Subject: RE: [nemo] Re: BU adds routes

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 12 Nov 2002 08:44:59 -0000

Hi:

I'm getting a bit anxious about this discussion... My 3 cents of €:

1) I believe it's great to have this discussion (and Alex's draft) for people to understand the dynamics of the protocols, but I hope this effort is not meant to lead to something in a standard document that would say if and how the routes are set up in the home link and the home AS - unless Nemo *needs* a new routing protocol, I mean. I believe that operators should be free to use static routes when they see fit, and a routing protocol when it covers their needs better.

2) I've read the 's' word ...scaling. Now, consider a home network with 10, 100, 1000, potentially 10000 or 100000 Mobile Routers. Why not? A home network could be a large community. I suspect that the routing fabric of the home AS may suffer some if routes are injected each time a MR binds, unbinds, leaves or returns home.

3) Routing protocols on the MRHA tunnel expect at least a keep alive form of traffic. When the only available connectivity is mobile phone, like GSM data (paid by the duration) or GPRS (paid by the bytes transported), then this approach may be a bit costly for the user.  

With Nemo, we may see arise a new form of routers. In one hand, some will be thin, low power, mass produced - not unlike mobile phones, and may not have routing protocol capabilities. On the other hand, Nemo may help companies manage (outsource, move physically) their production networks of traditional, large routers. 

Pascal

---

From: Mattias Pettersson <[email-masked]>
Date: Tue, 12 Nov 2002 12:13:19 +0100

Hi Pascal,

Thanks for your comments.

"Pascal Thubert (pthubert)" wrote:
> 
> Hi:
> 
> I'm getting a bit anxious about this discussion... My 3 cents of ˆ:
> 

Yes, I think we need support for both static and dynamic routing. I was
just focusing on the dynamic parts in my previous mails and comments.

> 2) I've read the 's' word ...scaling. Now, consider a home network with 10, 100, 1000, potentially 10000 or 100000 Mobile Routers. Why not? A home network could be a large community. I suspect that…

Yes. What operators need is the freedom to choose the properties of the
protocol. We can supply a number of alternatives.

Does the MRs come home often?
Routing protocols become more useful the more routers and subnets you
have. Previously we had manual configuration as the only alternative,
which is not interesting when the number of routers grow. Now a third
alternative is to not run traditional routing protocols but let MIPv6
manage the routes.

> 3) Routing protocols on the MRHA tunnel expect at least a keep alive form of traffic. When the only available connectivity is mobile phone, like GSM data (paid by the duration) or GPRS (paid by the…

It's up to the operator to decide. We can provide mechanisms. There will
always be some amount of control traffic going on.

/Mattias

---

From: Alexandru Petrescu<[email-masked]>
Date: 12 Nov 2002 17:26:47 +0100

"Pascal Thubert (pthubert)" <[email-masked]> writes:

> I'm getting a bit anxious about this discussion... My 3 cents of
> \210:

Is that \210 an euro? :-)

> 1) I believe it's great to have this discussion (and Alex's draft)
> for people to understand the dynamics of the protocols, but I hope
> this effort is not meant to lead to something in a standard document
> that would say if and how the routes are set up in the home link and
> the home AS - unless Nemo *needs* a new routing protocol, I mean. I
> believe that operators should be free to use static routes when they
> see fit, and a routing protocol when it covers their needs better.

Yes, exactly.  The discussion can be interpreted as effective as long
as for example it led to a proposal of a requirement (which is
in-scope right now).

Also, as the draft abstracts, I think there's a point to be made about
what goes into a BU.

> 2) I've read the 's' word ...scaling. Now, consider a home network
> with 10, 100, 1000, potentially 10000 or 100000 Mobile Routers.

Yes, sure; all 100000 cases are possible and all should be taken into
account (the 1 as the 100000).

Alex

---

From: Alexandru Petrescu<[email-masked]>
Date: 12 Nov 2002 17:33:15 +0100

Mattias Pettersson <[email-masked]> writes:
> Routing protocols become more useful the more routers and subnets
> you have. Previously we had manual configuration as the only
> alternative, which is not interesting when the number of routers
> grow. Now a third alternative is to not run traditional routing
> protocols but let MIPv6 manage the routes.

The story is nice.  I've problems digesting the end though :-) I'm not
against this end, I'm just figuring that maybe many people will have
many things to say about it.  Or maybe it's just me.

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 12 Nov 2002 10:46:40 -0800

hi Pascal,

"Pascal Thubert (pthubert)" wrote:
> 
> Hi:
> 
> I'm getting a bit anxious about this discussion... My 3 cents of ^:
> 
> 1) I believe it's great to have this discussion (and Alex's draft) for people to 
> understand the dynamics of the protocols, but I hope this effort is not meant to
> lead to something in a standard document that would say if and how the routes are
> set up in the home link and the home AS - unless Nemo *needs* a new routing
> protocol, I mean. I believe that operators should be free to use static routes
> when they see fit, and a routing protocol when it covers their needs better.

you are right that the operators should be given freedom
to do what they want.

on the other hand, we need to nail down the details for the
basic case. it is not enough to say use a bi-directional
tunnel between the MR and the HA. I think this discussion 
is a good start.

regards
Vijay

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 13 Nov 2002 19:17:37 +0900 (JST)

Let me try to see if I understand things right:

MR at home:
  HA------BR
      |
      MR

MR away:
  HA------BR
  |  <- tunnel looks like a link
  MR

If MR runs a routing protocol:

1. At home, BR and MR are neighbors, so are HA and MR
2. MR moves and obtains CoA
3. Bidirectional tunnel established between MR and HA. 
   - The bidirectional tunnel looks like a link between MR and HA
   - A route to MR with high timeout is added in the routing table of the HA
   - MR and BR are not neighbors anymore, but MR and HA still are
   - MR sends UNFREQUENT RUs over the tunnel (before routing entry times out)
   - HA sends UNFREQUENT RUs
     (i.e. it does NOT relay RUs sent by BR)
4. Binding Cache at the HA:
   - MR sends MIPv6 BU containing CoA
   - HA add entry in the BC
   - MR keeps sending BUs with current CoA REGULARLY (before BC entry times out)
   - HA updates BC
5. If MR is shutoff no more than routing_table_timeout, BC entry is
   removed but routing entry is maintained in the home network. HA
   drop packets since no BC entry.

If MR does not run a routing protocol:
- tunnel is established permanently (high timer)
- do not send RUs over the tunnel in either directions

-> the only thing we need to do is to specify how the tunnel should be
   established (in a secure way) maintained, and deleted. MIPv6 does
   not need to be changed. 

   Can we use existing mechanisms to set up the tunnel ? How ?

Thierry

---

From: Mattias Pettersson <[email-masked]>
Date: Thu, 14 Nov 2002 09:55:29 +0100

Hi Thierry,

>    drop packets since no BC entry.

HA will drop packets to HoA of MR.
Packets to MNNs will be tunneled to CoA (where there is nobody to
receive them). They don't depend on the BC, only the routing table.

BUT: the tunnel between HA and MR is installed because the MR sent a BU.
If the corresponding BC entry in HA times out, the tunnel must go of
course. So, packets to MNNs will be dropped as well.

>    Can we use existing mechanisms to set up the tunnel ? How ?

I would prefer to reuse the tunnel that ordinary MIPv6 sets up. The
outer addresses are known: HA and CoA. The inner addresses can be
anything (global or link-local addresses of HA or MN, global addresses
of MNNs or CNs).

MIPv6 installs the tunnel. If we use routing protocols the HA will learn
that the mobile prefix is reachable through the tunnel and install a
route to it. If we don't use routing protocols, a static route has to be
installed on HA saying the same thing.

/Mattias