Subject: RE: [nemo] MR definition

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 12 Dec 2002 07:37:37 -0000

Is that fair from all this discussion to consider that for basic support, Pekka's summary is correct? For one, this seems to work fine, and second this saves a lot of text in basic support doc by simple inheritence from knell-known models. 
 
Still for basic support, I suppose we need to extend Pekka for some MIPv6 support as well. On the egress interface the basic support for Nemo would include Mobile Node (RO and CN excluded). And MIPv6 support by all routers should be present on all ingress interfaces, correct?
 
Pascal

-----Original Message-----
From: Pekka Pääkkönen [mailto:[email-masked]] 
Sent: lundi 9 décembre 2002 11:52
To: [email-masked]
Subject: [nemo] MR definition

Hi all,
 
Please correct me if I have understood the definition of MR wrong.
 
MR is :
 
A router as defined in RFC 2460 : "a node that forwards IPv6 packets not explicitly addressed to itself."
 
In addition to this MR's relation to Neighbor Discovery (ND) is (RFC 2461):
 
- MR has host specific Neighbor Discovery behaviour in one or more interfaces as defined in RFC 2461. (MR's egress interfaces)
- MR has router specific Neighbor Discovery behaviour in one or more interfaces as defined in RFC 2461. (MR's ingress interfaces)
 
This would mean that MR would have different ND behaviour depending on the 
interface.

---

From: Alexandru Petrescu<[email-masked]>
Date: 13 Dec 2002 09:50:24 +0100

"Pascal Thubert (pthubert)" <[email-masked]> writes:
> Is that fair from all this discussion to consider that for basic
> support, Pekka's summary is correct? For one, this seems to work
> fine, and second this saves a lot of text in basic support doc by
> simple inheritence from knell-known models.

YEs, I see PEkka's summary as correct and good paragraph beginning.

> Still for basic support, I suppose we need to extend Pekka for some
> MIPv6 support as well. On the egress interface the basic support for
> Nemo would include Mobile Node (RO and CN excluded). And MIPv6
> support by all routers should be present on all ingress interfaces,
> correct?

I do not understand what you mean?  Not all routers will need to
support NEMO, only the mobile routers and the HAs, right?

Alex