Subject: RE: Source Address Selection (was Re: [nemo] crossover tunnel....)

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 1 Sep 2003 16:14:49 +0100

Hi again Vijay

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: mercredi 20 août 2003 00:24
> To: Pascal Thubert (pthubert)
> Cc: Jongkeun Na; [email-masked]
> Subject: Source Address Selection (was Re: [nemo] crossover tunnel....)
> 
> "Pascal Thubert (pthubert)" wrote:
> 
> 
> > When a MR joins a new link, there's more that happens than we actually described.
> >
> > I suggest to insert a 5.7 chapter: SAS for mobile router
> >
> >         In the process of Source Address Selection, the MRHA tunnel is considered as
> >         any other link, with the restriction that only a global address may be selected.
> 
> this is not necessarily true. link local addresses can be
> used as source and destination address in the inner IPv6
> header. infact link local address are used, for example,
> if DHCPv6 messages are exchanged over the MR-HA tunnel.
> the outer IPv6 header ofcourse will contain MR's CoA and
> HA's address.
> 
> >         So when the MR is not at Home, the Home Address will be selected as source
> >         address when and only when the destination is reached via the MRHA tunnel.
> 
> right.
> 
> >
> >         The MR has a set of connected routes for its attached MNPs. It may also
> >         have some static routes and a set of routes obtained from a routing protocol.
> >         For all these routes, SAS takes place normally and if the MRHA tunnel is not
> >         the link to the next hop, the best scoped global address on that link should
> >         be preferred, avoiding the MIP encapsulation and the need for global connectivity.
> 
> I am not sure what you mean by global connectivity here?
> the rest of the paragraph makes sense.

I meant that the connectivity to the infrastructure may not be there and yet SAS allows internal connectivity. Example between a VMN and a LFN in a mobile network when the MR that owns the mobile network is not bound to its HA and there's no MRHA tunnel.

> 
> >         In particular, when a MR forms a CoA from a visited prefix, it inserts a
> >         connected route to that prefix, over the associated egress interface, in
> >         its routing table. So when the MR initiates a socket to a node on that link,
> >         SAS will select the CareOf address as source.
> 
> why? the MR may want to use Route Optimization with the
> node on the visited link. in this case, the MR-HA tunnel
> wouldnt be outgoing interface. the application on the
> MR may initiate a socket with the home address and depend
> on the kernel to add the Home Address option. when the
> packet is actually sent out on the visited link, the
> source address would be the CoA with the home address in
> the Home Address Option.
> 
> but I agree with the general idea in your text. and I think
> it can be simplified.
> 
>     For any packet, if the interface through which the packet
>     is sent out is the MR-HA tunnel, then the Home Address must
>     be selected as the source address. The source must be set
>     to the link local address, if the destination of the packet
>     is a link local address. The Mobile Router MUST NOT set the
>     source address to Home Address if the packets are sent to
>     the visited link.
> 

I agree with that text, but there's something missing to the last sentence. The Mobile Router may have other routes than via the MRHA tunnel. For instance running a routing protocol locally in the visited network. For all these routes, the interface out will not he the MRHA tunnel, and SAS must select the appropriate address as it does normally as if Nemo was not there. This is all normal SAS, considering that the global address on the MRHA is the home address. Can you please reword the last sentence? 

Pascal

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 01 Sep 2003 19:24:34 -0700

Jongkeun Na wrote:
> 
> Hi Pascal and Vijay,
> 
> I have a question. When does MR want to use SAS for what connectivity?
> It's not clear to me. Some cases that I can understand are as follows:
> 1) The connectivity between any node on visited link and MR
> itself(acting as MN)

we are discussing only case 1 here.

Vijay

> 2) The connectivity between any node on visited link and LFN/VMN in
> Mobile Network.
>
> In this case, I've just considered Mobile Network as a simple type with
> one egress and one ingress interface. Is there any other case?
> And, SAS can describe case 1), but not about case 2). I wondering if
> case 2) can be concerned in our discussion. If case 2) is possible
> without any route optimization, it'd be good because many of
> applications no longer depend on their MRHA tunnel for local
> connectivity.
> 
> Regards,
> /Jongkeun

---

From: "Jongkeun Na" <[email-masked]>
Date: Tue, 2 Sep 2003 11:17:06 +0900

Hi Pascal and Vijay,

Regards,
/Jongkeun

> From: Pascal Thubert (pthubert) [mailto:[email-masked]]
> Sent: Tuesday, September 02, 2003 12:15 AM
> To: Vijay Devarapalli
> Subject: RE: Source Address Selection (was Re: [nemo] crossover
tunnel....)
> > > When a MR joins a new link, there's more that happens than we
actually
> described.
> > >         In the process of Source Address Selection, the MRHA
tunnel is
> considered as
> > >         any other link, with the restriction that only a global
address may be
> selected.
> > >         So when the MR is not at Home, the Home Address will be
selected
> as source
> > >         address when and only when the destination is reached via
the
> MRHA tunnel.
> >
> > right.
> >
> > >
> > >         The MR has a set of connected routes for its attached
MNPs. It may
> also
> > >         have some static routes and a set of routes obtained from
a routing
> protocol.
> > >         For all these routes, SAS takes place normally and if the
MRHA
> tunnel is not
> > >         the link to the next hop, the best scoped global address
on that link
> should
> > >         be preferred, avoiding the MIP encapsulation and the need
for
> global connectivity.
> I meant that the connectivity to the infrastructure may not be there
and yet SAS
> allows internal connectivity. Example between a VMN and a LFN in a
mobile
> network when the MR that owns the mobile network is not bound to its
HA and
> there's no MRHA tunnel.
> 
> 
> >
> > >         In particular, when a MR forms a CoA from a visited
prefix, it inserts
> a
> > >         connected route to that prefix, over the associated egress
interface,
> in
> > >         its routing table. So when the MR initiates a socket to a
node on
> that link,
> I agree with that text, but there's something missing to the last
sentence. The
> Mobile Router may have other routes than via the MRHA tunnel. For
instance
> running a routing protocol locally in the visited network. For all
these routes, the
> interface out will not he the MRHA tunnel, and SAS must select the
appropriate
> address as it does normally as if Nemo was not there. This is all
normal SAS,
> considering that the global address on the MRHA is the home address.
Can you
> please reword the last sentence?
> 
> 
> Pascal

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 01 Sep 2003 19:24:34 -0700

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 01 Sep 2003 13:16:30 -0700

"Pascal Thubert (pthubert)" wrote:

> I agree with that text, but there's something missing to the last sentence. The Mobile
> Router may have other routes than via the MRHA tunnel. 

ofcourse.

> For instance running a routing
> protocol locally in the visited network. For all these routes, the interface out will not
> he the MRHA tunnel, and SAS must select the appropriate address as it does normally as if
> Nemo was not there. 

right. the CoA should be used.

> This is all normal SAS, considering that the global address on the
> MRHA is the home address. Can you please reword the last sentence?

what specific text are you looking for? I am not sure I understood 
that from your email. we just want to place restriction on the use 
of home address when the MR is on a visited link, which the 
paragraph I proposed above does.

Vijay

---

From: "Jongkeun Na" <[email-masked]>
Date: Tue, 2 Sep 2003 11:17:06 +0900

Hi Pascal and Vijay,

Regards,
/Jongkeun

tunnel....)
actually
tunnel is
address may be
selected
the
MNPs. It may
a routing
MRHA
on that link
for
and yet SAS
mobile
HA and
prefix, it inserts
interface,
node on
sentence. The
instance
these routes, the
appropriate
normal SAS,
Can you

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 01 Sep 2003 13:16:30 -0700

ofcourse.

Vijay