Subject: [nemo] I-D ACTION:draft-ietf-nemo-basic-support-01.txt

From: [email-masked]
Date: Mon, 29 Sep 2003 15:38:06 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Mobility Working Group of the IETF.

	Title		: Nemo Basic Support Protocol
	Author(s)	: V. Devarapalli et al.
	Filename	: draft-ietf-nemo-basic-support-01.txt
	Pages		: 33
	Date		: 2003-9-29
	
This document describes the Nemo Basic Support protocol to support
network mobility as the mobile network attaches to different points
in the Internet.  The protocol is based on extensions to Mobile
IPv6 and allows for session continuity for every node in the mobile
network as the network moves.  It also allows every node in the
mobile network to be reachable while moving around.  The Mobile
Router, which connects the network to the Internet, runs the NEMO
Basic Support protocol with its Home Agent.  The protocol is designed
in such a way that network mobility is transparent to the nodes
inside the mobile network.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nemo-basic-support-01.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-nemo-basic-support-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-nemo-basic-support-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Jung-Hoon Cheon" <[email-masked]>
Date: Tue, 30 Sep 2003 16:02:16 +0900

Hi all,

I read a new version of NEMO Basic support protocol.

I appreciate an effort of the design team.

I have a question as following.

Prefix table is an optional data structure and used only for explicit mode.

I think that if HA implicitly has a pre-configured routes to the mobile network,

the pre-configured routes looks like as a prefix table.

For example, when CN sends a packet destined for mobile network, HA intercepts the packet.

At that time, the HA can do by serching the BCE or associated prefixes.

usually NEMO performs in implicit mode since the MNP is associated with home address of mobile router.

Anyway, we assum that pre-configured routes used in implicit mode has a conceptual structure,

because of manual configuration at the Home Agent mapping the Mobile Router's home address 

to the information required for setting up forwarding for the Mobile Network.

Is that right? 

Maybe it will be an implementation issue.

Also, HA MUST support all modes and SHOULD use Prefix Table only for verification in explicit mode.

still prefix table is an optional structure? 

Best Regards.
Jung-Hoon Cheon

---

From: "Jung-Hoon Cheon" <[email-masked]>
Date: Tue, 30 Sep 2003 16:02:16 +0900

Hi all,

Is that right? 

Best Regards.
Jung-Hoon Cheon

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 30 Sep 2003 10:24:12 -0700

>the pre-configured routes looks like as a prefix table.

yes it could. Prefix Table could be one of the ways for storing per MR
configuration information at the HA. see issue 12.

>Also, HA MUST support all modes and SHOULD use Prefix Table only for verification in explicit mode.
the HA MAY use Prefix Table for verification in explicit mode.
I dont think the draft says SHOULD anywhere.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 30 Sep 2003 10:24:12 -0700

Vijay