Subject: RE: [nemo] RE: about the Home Network Models WG item

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 7 Jan 2005 10:24:44 +0100

I agree with you on the virtual case.

On the aggregated case, we could by construction reserve some address space in the aggregation that we would not dedicate to any MNP, and, again by construction, we could enforce that the MR HoA be taken from that reserved space. This would allow a real DAD process by the Home Agent, but it seems a bit unnatural to my taste. Can/should we word that something looks more natural then something else? That requires a consensus in the WG.

To my personal taste, it is natural to take the Home Address from the Home Link in extended mode and from the MNP in aggregated mode. But in both cases, the alternate is possible. Specific support by the HA might be needed to enforce the related policies, and that is not in the scope of basic. Should we leave that to the products or is there something we should standardize? 

Pascal

| -----Original Message-----
| From: BINET David RD-CORE-CAE [mailto:[email-masked]]
| Sent: Friday, January 07, 2005 10:00 AM
| To: Pascal Thubert (pthubert); Daniel Shell (dshell); Alexandru Petrescu
| Cc: [email-masked]
| Subject: RE: [nemo] RE: about the Home Network Models WG item
| 
| From the draft, I understand that the question about the configuration of
| Home Address is only valid in extended mode. In aggregated mode and
| virtual mode, there is no specific Home subnet and Home Address will be
| configured on any MNP.
| I think it could be useful to distinguish both modes in current "extended
| mode", one if the Home Address is taken from Home Net (basic one) and one
| if the home address is taken from Mobile Net (extended one).
| 
| David
| 
| -----Message d'origine-----
| De : [email-masked] [mailto:[email-masked]] De la part de
| Pascal Thubert (pthubert)
| Envoyé : jeudi 6 janvier 2005 18:16
| À : Daniel Shell (dshell); Alexandru Petrescu
| Cc : [email-masked]
| Objet : RE: [nemo] RE: about the Home Network Models WG item
| 
| In fact, extended means versus the MIP Home Agent which is the 'basic'.
| In all modes, we can take the Home Address from a Mobile Network. But I
| agree with Alex it's a bit complex (actually almost against nature :) to
| do it with extended mode. OTOH, it seems to me that it's the preferred
| mode in the aggregated case. Comments anybody?
| 
| My suggestion to fix this issue is:
| 
| 1) to explain better that extended is versus MIP Home at the beginning of
| that section
| 
| 2) to describe better the case where the Home Address is taken from the
| Home Link in extended and say it's the preferred mode, and explain why
| 
| 3) in aggregated, say that the address is taken from the MNP and explain
| why (DAD related).
| 
| Once we agree no the approach we can start proposing text :)
| 
| Pascal
| 
| | -----Original Message-----
| | From: Daniel Shell (dshell)
| | Sent: Wednesday, January 05, 2005 7:24 PM
| | To: Alexandru Petrescu
| | Cc: Pascal Thubert (pthubert); [email-masked]
| | Subject: Re: [nemo] RE: about the Home Network Models WG item
| |
| | Sounds good to have the sections labelled
| |
| | Basic
| | Extended
| | Aggregated
| | Virtual
| |
| | Would like to see what Pascal says though.
| |
| |
| |
| |
| | At 06:58 PM 1/5/2005 +0100, Alexandru Petrescu wrote:
| | >Pascal Thubert (pthubert) wrote:
| | >[...]
| | >>please present on this list at this time, and if you get enough
| support,
| | >>I'll do the changes as required.
| | >
| | >I do not think in the simplest Home Network configuration the MR may
| use
| | >a Home Address derived from the prefix assigned on its moving network
| | >link, the MNP.  In the simplest cases, the MR Home Address is derived
| | >from the prefix valid on the Home Link.
| | >
| | >Or, section 4.1 Extended Home Network configuration has a last item
| | saying:
| | >>Alternatively, a Mobile Router could also form a Home Address from
| | >>one of its prefixes and use it to register[...]
| | >
| | >I think this kind of item should belong to other more complex Home
| | Network
| | >configurations.
| | >
| | >Besides, I think that a useful informational document on the types of
| | home
| | >networks should describe several such networks - in the order of
| | >simplicity - starting first from the most simple and basic and
| obvious
| | and
| | >only later to the most exotic.
| | >
| | >Or, while the current document does describe three such networks,
| there
| | >does not seem to be an order from basic to complex.  The first
| described
| | >is already "Extended" and the other two are "Aggregated" and
| | >"Virtual".  The "Aggregated" is a little more complex than the
| "Extended"
| | >in that the MR looks up its MNNs via ND on the Home Link, which is a
| | >little exotic feature.  The "Virtual" model is the most exotic in
| that
| | >there is no returning home procedure for example.
| | >
| | >So, I understand there is a form of scale on differentiation, from
| the
| | >most basic up to the most complex, but the most basic is still called
| | >"Extended" and allows MR HoA from MNP.
| | >
| | >Hence my proposal to call the basic model just "Basic Home Network"
| and
| | >this model not to use MR Home Address from the MNP.  Alternatively, I
| | >propose to introduce a 4th model, called "Basic Home Network Model",
| that
| | >would come before the other three models, and in which MR would only
| | >construct its Home Address from the prefix on the home link, that
| would
| | >perform ND for that address, that would implement the NEMO Returning
| Home
| | >procedure and for which address the HA performs proxy ND when MR not
| at
| | >home, according to Mobile IPv6.
| | >
| | >What do you think Pascal?  What do the others think?
| | >
| | >Alex
| |
| | Dan Shell
| | Government Service Unit
| | CISCO Systems
| | IP mobility/Wireless/Satellite
| | 440 331 5663

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 07 Jan 2005 14:17:08 +0100

Pascal Thubert (pthubert) wrote:
> To my personal taste, it is natural to take the Home Address from the
>  Home Link in extended mode

I'm ok with this; but just don't call it "extended" IMHO, call it 
"normal basic".  Or maybe "NEMO-extended MIP Home mode", but that's a 
bit clumsy. IMHO.

> and from the MNP in aggregated mode.

Pascal, the idea of having the HoA from MNP has an initial motivation
different than building aggregated Home Networks.

In my understanding from verbal explanations, the idea of having HoA
from MNP comes from ease of implementing a certain RO feature.  That is
not mentioned in the draft.

> But in both cases, the alternate is possible.

Let's get a feeling of why it is good to have a HoA from MNP, and not
try to put HoA from MNP in all modes (simple, extended, aggregated,
virtual) just because it is possible to have it.

> Specific support by the HA might be needed to enforce the related 
> policies, and that is not in the scope of basic.

Do we have an idea whether the NEMO Basic Support supports all modes
described in the NEMO Home Network Models?

> Should we leave that to the products or is there something we should
>  standardize?

I think that if you know about a product that specifically supports (or
plans to support) a certain Home Network Model then please mention it, 
it is very important.

When you're asking on whether there is something to be standardized.  I
think standard is better to have because inter-operability it
facilitates.  At the same time this draft being targeted as
INFORMATIONAL, its scope is supposedly (1) to advice network deployers
about how to do a Home Network that works with the NEMO Basic Support.
Or probably it aims to (2) describe existing deployments, positive 
experiences.  Or probably it (3) gives just "seed" ideas about 
directions of thinking of what a potential Home Network _could_ look
like with no engagement of actual implementation support, just providing
new ideas for future protocol development.  These are three different
goals IMHO.  But even so numerous be they, I do not think this draft
proposes anything about inter-operability, standardization.

This is my understanding of the draft currently, but you may know better
about the intent.

Alex