Subject: RE: [nemo] issue 2 diffs

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 12 Jan 2005 10:43:35 +0100

| -----Original Message-----
| From: Vijay Devarapalli [mailto:[email-masked]]
| Sent: Wednesday, January 12, 2005 1:09 AM
| To: Pascal Thubert (pthubert)
| Cc: [email-masked]
| Subject: Re: [nemo] issue 2 diffs
| 
| Pascal,
| 
| the following is already covered in the Basic Support spec.
| 
| > In that case, the Home Address does not match the Home Link
| > Prefix, and there is a need to configure the HA in a specific
| > mode with the support for the extended Home Network and the
| > range of the Mobile Network Prefixes.
| 
| section 6.2
| 
|      -  Mobile IPv6 specification [1] requires that the Home Address
in
|         the Binding Update should be configured from a prefix
advertised
|         on the home link.  Otherwise the Binding Update is rejected
|         with status value 132 [1].  This specification relaxes this
|         requirement so that the Home Agent rejects the Binding Update
|         only if Home Address does not belong to the prefix that the
Home
|         Agent is configured to serve.
| 
| so the following limitation does not exist.
| 
| > But if an implementation is simply derived from that of MIP,
| > then this capability might not exist, and the HA will not be
| > able to accept a Home Address based on the MNP.

Interesting... so you are saying that any NEMO HA SHOULD have a specific
configuration to express the extended Home Network Prefix? 

I did not interpret that text that way. Like a could or something, for
an advanced feature It's good for the HA to know specifically the
aggregation in order to automatically inject the route into the IGP. But
it can be done indirectly as a static route for instance.

So I was saying make sure your implementation has it if you want to
derive the Home Address from MNP. I agree it's moot iff it's a MUST or a
SHOULD by NEMO terms but I do not understand that it is. Maybe it's a
problem against 3963, then, but I do not even think so, because the
current text leaves the possibility for some simple implementations with
limited features and other, richer. I do not see that this creates an
interoperability issue, does it?

What do you think?

Pascal

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 12 Jan 2005 13:45:10 -0800

> configuration to express the extended Home Network Prefix? 

any NEMO HA should be configured with the prefix of the home
network that is configured to serve. one has to make sure
the prefix includes all the prefixes given out to the Mobile
Routers.

this is what the basic support spec says.

so the question of a MIP HA supporting a HoA from the MNP does
not exist. I dont know what it means when you say "But if an
implementation is simply derived from that of MIP....". a
HA that suports Mobile Routers is not just a simple MIP HA.
it is already configured to serve the MNPs given out to the
Mobile Routers.

> SHOULD by NEMO terms but I do not understand that it is. 

my understanding is that section 6.2 in the Basic Support
spec already says this.

> Maybe it's a

nope it does not. just pointing that the limitation you
describe does not exist, IMO.

> What do you think?

its fine to emphasize it again in the Home Networks model
draft.

Vijay