Subject: RE: [nemo] RE: about the Home Network Models WG item

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 5 Jan 2005 09:01:12 +0100

Hi: 

Please note that the issue list for this draft is hosted at:

http://mobilenetworks.org/~pthubert/draft-ietf-nemo-home-network-models-
issues.html

Pascal
| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] On Behalf
Of
| Pascal Thubert (pthubert)
| Sent: Wednesday, January 05, 2005 8:07 AM
| To: Alexandru Petrescu
| Cc: [email-masked]
| Subject: [nemo] RE: about the Home Network Models WG item
| 
| Hi Alex:
| 
| | Then, in the current description of the "Aggregated Home Network"
| | section 5, there are very many things unclear to me:
| |
| | section 5:
| | > A node on the Home Link computes that the Aggregated Home Network
is
| | > actually a subnet on the Home Link and may use it for
| | > autoconfiguration purposes.
| |
| | It would be more readable to say: "use the prefix on the Home Link
to
| | autoconfigure a Home Address".
| |
| 
| I agree with you here. I made the change as issue 1.
| 
| Pascal

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Thu, 6 Jan 2005 17:53:14 +0100

Hi:

I open this as issue 2, and I'll give my view on a separate message.

Pascal

| -----Original Message-----
| From: Alexandru Petrescu [mailto:[email-masked]]
| Sent: Wednesday, January 05, 2005 6:58 PM
| To: Pascal Thubert (pthubert)
| Cc: [email-masked]
| Subject: Re: [nemo] RE: about the Home Network Models WG item
| 
| Pascal Thubert (pthubert) wrote:
| [...]
| > please present on this list at this time, and if you get enough
| > support, I'll do the changes as required.
| 
| I do not think in the simplest Home Network configuration the MR may
use
| a Home Address derived from the prefix assigned on its moving network
| link, the MNP.  In the simplest cases, the MR Home Address is derived
| from the prefix valid on the Home Link.
| 
| Or, section 4.1 Extended Home Network configuration has a last item
| saying:
| > Alternatively, a Mobile Router could also form a Home Address from
| > one of its prefixes and use it to register[...]
| 
| I think this kind of item should belong to other more complex Home
| Network configurations.
| 
| Besides, I think that a useful informational document on the types of
| home networks should describe several such networks - in the order of
| simplicity - starting first from the most simple and basic and obvious
| and only later to the most exotic.
| 
| Or, while the current document does describe three such networks,
there
| does not seem to be an order from basic to complex.  The first
described
| is already "Extended" and the other two are "Aggregated" and
"Virtual".
|   The "Aggregated" is a little more complex than the "Extended" in
that
| the MR looks up its MNNs via ND on the Home Link, which is a little
| exotic feature.  The "Virtual" model is the most exotic in that there
is
| no returning home procedure for example.
| 
| So, I understand there is a form of scale on differentiation, from the
| most basic up to the most complex, but the most basic is still called
| "Extended" and allows MR HoA from MNP.
| 
| Hence my proposal to call the basic model just "Basic Home Network"
and
| this model not to use MR Home Address from the MNP.  Alternatively, I
| propose to introduce a 4th model, called "Basic Home Network Model",
| that would come before the other three models, and in which MR would
| only construct its Home Address from the prefix on the home link, that
| would perform ND for that address, that would implement the NEMO
| Returning Home procedure and for which address the HA performs proxy
ND
| when MR not at home, according to Mobile IPv6.
| 
| What do you think Pascal?  What do the others think?
| 
| Alex

---

From: "BINET David RD-CORE-CAE" <[email-masked]>
Date: Fri, 7 Jan 2005 15:09:36 +0100

Comments in the text

> -----Message d'origine-----
> De : Alexandru Petrescu [mailto:[email-masked]] 
> Envoyé : vendredi 7 janvier 2005 14:17
> À : Pascal Thubert (pthubert)
> Cc : BINET David RD-CORE-CAE; Daniel Shell (dshell); [email-masked]
> Objet : Re: [nemo] RE: about the Home Network Models WG item
> 
> Pascal Thubert (pthubert) wrote:
> > To my personal taste, it is natural to take the Home 
> Address from the  
> > Home Link in extended mode
> 
> I'm ok with this; but just don't call it "extended" IMHO, 
> call it "normal basic".  Or maybe "NEMO-extended MIP Home 
> mode", but that's a bit clumsy. IMHO.
> 
> > and from the MNP in aggregated mode.
> 
> Pascal, the idea of having the HoA from MNP has an initial 
> motivation different than building aggregated Home Networks.
> 
> In my understanding from verbal explanations, the idea of 
> having HoA from MNP comes from ease of implementing a certain 
> RO feature.  That is not mentioned in the draft.
> 
> > But in both cases, the alternate is possible.
> 
> Let's get a feeling of why it is good to have a HoA from MNP, 
> and not try to put HoA from MNP in all modes (simple, 
> extended, aggregated,
> virtual) just because it is possible to have it.
I think I agree with this. I do not think that we have to describe all the solutions in the document because it is tecchnically feasible. Even if the configuration of HoA from MNP is possible in all modes, it can be convenient to distinguish the different modes with some configuration support. If several solutions are possible and useful, maybe it could be good to give some reasons to implement one specific solution, according to RO deployment or traffic load or whatever. 
> 
> > Specific support by the HA might be needed to enforce the related 
> > policies, and that is not in the scope of basic.
> 
> Do we have an idea whether the NEMO Basic Support supports 
> all modes described in the NEMO Home Network Models?
> 
> > Should we leave that to the products or is there something 
> we should  
> > standardize?
> 
> I think that if you know about a product that specifically 
> supports (or plans to support) a certain Home Network Model 
> then please mention it, it is very important.
> 
> When you're asking on whether there is something to be 
> standardized.  I think standard is better to have because 
> inter-operability it facilitates.  At the same time this 
> draft being targeted as INFORMATIONAL, its scope is 
> supposedly (1) to advice network deployers about how to do a 
> Home Network that works with the NEMO Basic Support.
> Or probably it aims to (2) describe existing deployments, 
> positive experiences.  Or probably it (3) gives just "seed" 
> ideas about directions of thinking of what a potential Home 
> Network _could_ look like with no engagement of actual 
> implementation support, just providing new ideas for future 
> protocol development.  These are three different goals IMHO.  
> But even so numerous be they, I do not think this draft 
> proposes anything about inter-operability, standardization.
> 
> This is my understanding of the draft currently, but you may 
> know better about the intent.
> 
> Alex
David

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 7 Jan 2005 17:49:25 +0100

| > De : Pascal Thubert (pthubert) [mailto:[email-masked]]
| > Envoyé : vendredi 7 janvier 2005 10:25
| > À : BINET David RD-CORE-CAE; Daniel Shell (dshell); Alexandru Petrescu
| > Cc : [email-masked]
| > Objet : RE: [nemo] RE: about the Home Network Models WG item
| >
| > I agree with you on the virtual case.
| >
| > On the aggregated case, we could by construction reserve some
| > address space in the aggregation that we would not dedicate
| > to any MNP, and, again by construction, we could enforce that
| > the MR HoA be taken from that reserved space. This would
| > allow a real DAD process by the Home Agent, but it seems a
| > bit unnatural to my taste. Can/should we word that something
| > looks more natural then something else? That requires a
| > consensus in the WG.

| If you have a reserved address space in the aggregated home network, it
| looks like a specific prefix for home network and this solution is quite
| equivalent to extended mode. 

I would agree with that. 

| In the aggregated mode, MR HoA can be
| configured from any MNP and there is no mean, a priori, to enforce some
| HoA configuration.

I'm not sure I get what you mean here? 
NEMO basic says "  
	A Mobile Router has a unique Home Address through which it is
   reachable when it is registered with its Home Agent.  The Home
   Address is configured from a prefix aggregated and advertised by its
   Home Agent.  The prefix could be either the prefix advertised on the
   home link or the prefix delegated to the Mobile Router.  
"

But NEMO does not enforce any checking for this. I guess it's up to implementations. The NEMO words are open enough to allow both extended and aggregated modes.

| >
| > To my personal taste, it is natural to take the Home Address
| > from the Home Link in extended mode and from the MNP in
| > aggregated mode. But in both cases, the alternate is
| > possible. Specific support by the HA might be needed to
| > enforce the related policies, and that is not in the scope of
| > basic. Should we leave that to the products or is there
| > something we should standardize?

| If there can be some interoperability issues, I think it has to be
| specified. If two different modes (basic and extended) are described,
| implementations will support one or both modes and there will not be any
| problem with different extended implementations, with regard to HoA
| configuration.
| >

Agreed. I think it's more like some variations of the modes might not operate equivalently with all implementations. Like a HA might do checkings and another one might not. Or a MR might support bridging for aggregated mode or not. But I do not see any identified MR-HA interoperation problem. If someone did please raise your hand.

Pascal

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Mon, 10 Jan 2005 13:47:28 +0100

| > | Do we have an idea whether the NEMO Basic Support supports all
| > modes | described in the NEMO Home Network Models? This is a good
| > question. Applies to MR as well. The capability for MR to switch to
| > bridge mode in aggregated might not be there.
| 
| A router switching to bridge mode?  Can you be more specific on how
| could a router become a bridge and why would it do it?

Alex, sometimes I wonder how deeply you read the draft. This is all
written down, and I would agree that it is not obvious to understand
anyway, but I'm surprised that you do not know about it at all. Please
let us know if it is unclear.

Pascal

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Mon, 10 Jan 2005 13:48:21 +0100

I'm writing some text that I'll propose on the ML based on all these
suggestions.

Thank you all :)

Pascal

| -----Original Message-----
| From: Vijay Devarapalli [mailto:[email-masked]]
| Sent: Monday, January 10, 2005 5:44 AM
| To: Alexandru Petrescu
| Cc: Pascal Thubert (pthubert); [email-masked]
| Subject: Re: [nemo] RE: about the Home Network Models WG item
| 
| I have to disagree. this draft is primariy about Home Network
| Configuration. in every model (extended, aggregated and virtual),
| the Mobile Router is free to configure a HoA from the MNP at
| any time and use that for Home Registration. there is no way a
| Home Agent can force the Mobile Router to only use a HoA from
| the home link. lets assume a particular home link as configured
| as a "Basic Home Link" (as described by Alex below). if the MR
| chooses to configure a HoA from the MNP, the HA can't prevent
| it. and I dont think we need to provide a way for the HA to
| prevent it.
| 
| I dont see the need for a "Basic Home Link" model.
| 
| Vijay
| 
| Alexandru Petrescu wrote:
| > Pascal Thubert (pthubert) wrote:
| > [...]
| >
| >> please present on this list at this time, and if you get enough
| >> support, I'll do the changes as required.
| >
| >
| > I do not think in the simplest Home Network configuration the MR may
use
| > a Home Address derived from the prefix assigned on its moving
network
| > link, the MNP.  In the simplest cases, the MR Home Address is
derived
| > from the prefix valid on the Home Link.
| >
| > Or, section 4.1 Extended Home Network configuration has a last item
| saying:
| >
| >> Alternatively, a Mobile Router could also form a Home Address from
| >> one of its prefixes and use it to register[...]
| >
| >
| > I think this kind of item should belong to other more complex Home
| > Network configurations.
| >
| > Besides, I think that a useful informational document on the types
of
| > home networks should describe several such networks - in the order
of
| > simplicity - starting first from the most simple and basic and
obvious
| > and only later to the most exotic.
| >
| > Or, while the current document does describe three such networks,
there
| > does not seem to be an order from basic to complex.  The first
described
| > is already "Extended" and the other two are "Aggregated" and
"Virtual".
| >  The "Aggregated" is a little more complex than the "Extended" in
that
| > the MR looks up its MNNs via ND on the Home Link, which is a little
| > exotic feature.  The "Virtual" model is the most exotic in that
there is
| > no returning home procedure for example.
| >
| > So, I understand there is a form of scale on differentiation, from
the
| > most basic up to the most complex, but the most basic is still
called
| > "Extended" and allows MR HoA from MNP.
| >
| > Hence my proposal to call the basic model just "Basic Home Network"
and
| > this model not to use MR Home Address from the MNP.  Alternatively,
I
| > propose to introduce a 4th model, called "Basic Home Network Model",
| > that would come before the other three models, and in which MR would
| > only construct its Home Address from the prefix on the home link,
that
| > would perform ND for that address, that would implement the NEMO
| > Returning Home procedure and for which address the HA performs proxy
ND
| > when MR not at home, according to Mobile IPv6.
| >
| > What do you think Pascal?  What do the others think?
| >
| > Alex
| >

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Mon, 10 Jan 2005 18:45:56 +0100

| -----Original Message-----
| From: Alexandru Petrescu [mailto:[email-masked]]
| Sent: Monday, January 10, 2005 5:14 PM
| To: Pascal Thubert (pthubert)
| Cc: nemo
| Subject: Re: [nemo] RE: about the Home Network Models WG item
| 
| Pascal Thubert (pthubert) wrote:
| > | HA proxying for all addresses in all
| > | MNPs in its BC is something that can not be implemented.  Why?  At
| > least
| > | because proxy NA is sent periodically, becoming an overload.  Am I
| > | missing something?
| >
| > Note that I'm not a promoter of that model from the start :) I agree
| > that the HA can not send the async NA for all the range of suffixes
at
| > Home. It should just respond to NS. We can compare this with Dave
| > Thaler's work on spit networks. Alternatively, you can bar coming
Home
| > in Aggregated. Anyway, the process is nit mandated by NEMO or any
other
| > standard, so it would be a product specific support to get there.
| 
| If compared to other works (split networks) then it should be
referenced
| and made work with that model.  One thousand more lines make sure it's
| exactly the other work, is it worth the effort?
| 
| For hosts to autoconfigure addresses based on each MNP - who would
send
| RAs for each MNP on the home link?
| 
| > | What does "HA protects the MNP space from autoconfiguration by
| > | uncontrolled visitors on the Home Link" mean?
| >
| > MR binds MNP. Then, a node on the Home Link autoconfs an address
from
| > MNP. HA should defend the address at DAD time. The trouble with
| > aggregated is that the whole aggregation is supposedly on link. Do
you
| > have a rewording in mind?
| 
| I don't have a rewording in mind, sorry.  My only wording is that it
| can't scale.  You seem to say the same thing, so why re-wording it
when
| we could simply remove it.

Well, remove what? The whole aggregated model? The support of coming
Home in aggregated? I agree I can not specify MNP level proxying and
this is an informational draft anyway. All I can say is that if you wish
to do this (nodes at home connect to nodes on MNPs), than you need your
implementation to do that (HA ND proxies for nodes on MNP). I agree I
cannot say how this can be done. 

Personally, I believe it could be done, by passively answering NS. But
I'm not 100% sure there's no caveat in the process :( I favor the
extended home network vs. the aggregated.

Pascal