Subject: 答复: [nemo] Seeking help for VMN BUs

From: [email-masked]
Date: Thu, 17 Mar 2005 16:45:04 +0800

Hi Vijay;
I just read about the draft 
				Inter Home Agents Protocol (HAHA)
                  draft-wakikawa-mip6-nemo-haha-01.txt
it is expired:(
Do you all have some other updated version?

     I find that HAHA is matched the scenario of Multi-homing (Multi HA). But in HAHA-01 I do not find some path selection mechanism, do you consider it before?

     Have you got the idea about making the HA hierarchical? In different region has different grade. HA synchronization can been limited in one region and divides the BU cache into separate parts. When the closest HA for CN do not hit the CoA in its BU cache, it will do a Roaming based on the HA list it obtain by HAHA HA list Management. 
	Maybe it is useful for big ISP for large scale deployment. It is usable for centered but distributed AAA by hierarchical HA mechanism.
     BTW, do you think it is feasible here to use Anycast of IPv6 for Closest HA selection (path selection) ?

Yours 
Humphrey Gu

-----邮件原件-----
发件人: Vijay Devarapalli [mailto:[email-masked]] 
发送时间: 2005年3月17日 8:18
收件人: 研发 顾华平
抄送: [email-masked]
主题: Re: [nemo] Seeking help for VMN BUs

hello,

RFC 3963 keeps mobility transparent to the nodes in the
Mobile Network. the nodes in the mobile network always
see the mobile network prefixes. not the prefixes from
the visited network.

it is possible for the nodes in the mobile network to be
MIPv6 mobile nodes. that is allowed.

Vijay

[email-masked] wrote:
> Hi all NEMOers:
> According to RFC3963,there is no discussion on MN(VMN,LFN,LMN) operation. In RFC3963 there are only discussion on Mobile Router Operation(Section 5) and Home Agent Operation(Section 6).
> It seems that Basic NEMO need no modification on MN but I think it is impossible. For
> 1) VMN 
>  When one MN moved to the Mobile Network , it changes its attachment of network and should have a topologically correct CoA . Then how CNs outside the Mobile Network to communicate with him because CNs donot know the new CoA.
>  Maybe there also some other draft or similiar proposals talk about tis question. If it is, is anyone can told me where to find?
> 2) LFN,LN
>  There is similiar questions with minor difference(Maybe great).
>  
>  
>  I am a newer of NEMO, need some help on my studying. I think for VMN the process is as following:
>  
>  1)MR move to-->
>  	Foreign Network-->
>  		get a CoA for MR-->
>  			Register with MR's HA, using prefix-->
>  				HA forward packets destinated to VMN to MR, then to VMN
>  2)MN move to-->
>  	Mobile Network-->
>  		get a Coa-->
>  			Home Register with VMN's HA, by traditional MIPv6-->
>  				HA gets the CoA of VMN
>  3)CN send packet to VMN-->
>  	packet is intercepted by VMN's HA-->
>  		forward the packet to VMN's CoA-->
>  			HA of MR find the frefix match to the prefix of mobile network,then intercept the forwared packet and forward it to MR's CoA-->
>  				MR receive it, then send it to VMN.
>  
>   My Question(MQ):
>  
>  (MQ-1)I am not sure is the procedure above right?
>  
>  I also have some other question about NEMO, any comments is appreciated:)
>  
>  (MQ-2)When the MR move to a new network, do the nodes in the mobile network including(VMN,LFN,LFR,LMN) need to do a runumbering?
>  
>  (MQ-3)If MQ-2's answer is "YES", then does VMN need to do a new BU with its HA or other CNs will not know how to locate VMN?
>  
>  Maybe my question is very naive but it absolutely hovering on me. I know here are many experts of NEMO and is a wonderful place for me to find the answers.
>  Thousands of thanks in advance!
>  
>  Yours sincerely
>  Humphrey Gu
> 
>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 18 Mar 2005 11:50:49 +0900

Hello 

We now have two new documents for HAHA. 
draft-thubert-nemo-global-haha-00.txt  and draft-wakikawa-mip6-nemo-haha-spec-00.txt.

The draft-thubert may be matchehd for your questions.
Our concept is similar to anycast routing in terms of advertising
routes of the same aggregated home prefix from different sites.  

I will also send you a paper about HAHA in different mail.

regards,
ryuji

At Thu, 17 Mar 2005 16:45:04 +0800,
[email-masked] wrote:
> 
> [1  <text/plain (8bit)>]
> 
> Content analysis details:   (25.9 points, 13.0 required)
> 
>  pts rule name              description
> ---- ---------------------- --------------------------------------------------
>  0.3 NO_REAL_NAME           From: does not include a real name
>  5.0 THREAD_TOPIC           Thread-Topic: ...(Japanese Subject)...
>  5.0 THREAD_INDEX           thread-index: AcO7Y8iR61tzADqsRmmc5wNiFHEOig==
>   10 GB2312_CHARSET         GB2312 message
>  3.2 CHARSET_FARAWAY_HEADER A foreign language charset used in headers
>  2.5 MIME_CHARSET_FARAWAY   MIME character set indicates foreign language
> 
> 
> [2 original message before SpamAssassin <message/rfc822 (8bit)>]
> To: <[email-masked]>
> Cc: [email-masked]
> Subject: 答复: [nemo] Seeking help for VMN BUs
> From: [email-masked]
> Delivered-To: [email-masked]
> X-BrightmailFiltered: true
> X-Brightmail-Tracker: AAAAAQAAA+k=
> X-IronPort-AV: i="3.91,96,1110121200";    d="scan'208"; a="999620:sNHT45061104"
> content-class: urn:content-classes:message
> MIME-Version: 1.0
> X-MimeOLE: Produced By Microsoft Exchange V6.0.6487.1
> Date: Thu, 17 Mar 2005 16:45:04 +0800
> Message-ID: <[email-masked]>
> Thread-Topic: [nemo] Seeking help for VMN BUs
> Thread-Index: AcUqhsjbXD3cO2/tSLSwHG6nKHL/MgARGznw
> X-Spam-Score: 0.3 (/)
> X-Scan-Signature: 057ebe9b96adec30a7efb2aeda4c26a4
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.1.5
> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/nemo>,	<mailto:[email-masked]?subject=unsubscribe>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/nemo>,	<mailto:[email-masked]?subject=subscribe>
> Content-Transfer-Encoding: 8bit
> X-MIME-Autoconverted: from quoted-printable to 8bit by shaku.sfc.wide.ad.jp id j2H8lMFj005320
> 
> Hi Vijay;