Subject: Fwd: [nemo] draft-bagnulo-nemo-multi6-00.txt

From: marcelo bagnulo braun <[email-masked]>
Date: Sun, 6 Mar 2005 15:15:37 -0600

I think this message never made it to the list...

Inicio mensaje reenviado:

> De: marcelo bagnulo braun <[email-masked]>
> Fecha: 6 de marzo de 2005 06:47:57 GMT-06:00
> Para: Erik Nordmark <[email-masked]>
> Cc: Thierry Ernst <[email-masked]>, nemo <[email-masked]>
> Asunto: Re: [nemo] draft-bagnulo-nemo-multi6-00.txt
>
> Hi Erik,
>
> El 04/03/2005, a las 10:36, Erik Nordmark escribió:
>
>> Marcelo,
>>
>> Overall the draft is good.
>>
>
> thanks
>
>> But when I read the draft I was a bit confused because I think there 
>> are two end-to-ends to consider.
>
>> One is the CN to MNN, and the last case talks about that; one or both 
>> ends might have multiple addresses hence multi6 might be useful.
>>
>
> This is the case that the paper considers indeed
>
>> But there is also the HA to MR tunnel ends. If either or both ends 
>> have multiple addresses, then multi6 might be useful between those 
>> two endpoints, without any impact on the CN and MNN.
>>
>
> i haven't considered this case....
>
> But what do you have in mind?
> I mean multiple addresses between the HA and the MR are handled 
> through mip6 right?
> So mip6 could be enough for this?
> However, we could envision the usage of shim here:
> So the question is:
> Would it be useful to use shim below mip6?
> or the question would be:
> use only shim to manage multiple addresses between the MR and HA?
>
> I guess this second question is out of the scope of nemo, but, just to 
> clarify things...
>
> Regards, marcelo
>
>> Perhaps the draft can explore that space a bit more.
>>
>>    Erik
>>
>

---

From: Erik Nordmark <[email-masked]>
Date: Sun, 06 Mar 2005 14:05:11 -0800

> So mip6 could be enough for this?

People have been discussing MIP6 BU extensions that could carry multiple 
CoAs, but that is only one piece of the puzzle.
One would also need a mechanism to test which address pairs are working, 
and the multi6 protocol might be reusable here.
Also, nobody has discussed whether there is a need for a MR to find out 
multiple addresses of the HA; if there is, there can also be some reuse.

    Erik