Subject: [nemo] Seeking help for VMN BUs

From: [email-masked]
Date: Wed, 16 Mar 2005 19:34:49 +0800

Hi all NEMOers:
According to RFC3963,there is no discussion on MN(VMN,LFN,LMN) operation. In RFC3963 there are only discussion on Mobile Router Operation(Section 5) and Home Agent Operation(Section 6).
It seems that Basic NEMO need no modification on MN but I think it is impossible. For
1) VMN 
 When one MN moved to the Mobile Network , it changes its attachment of network and should have a topologically correct CoA . Then how CNs outside the Mobile Network to communicate with him because CNs donot know the new CoA.
 Maybe there also some other draft or similiar proposals talk about tis question. If it is, is anyone can told me where to find?
2) LFN,LN
 There is similiar questions with minor difference(Maybe great).

 I am a newer of NEMO, need some help on my studying. I think for VMN the process is as following:
 
 1)MR move to-->
 	Foreign Network-->
 		get a CoA for MR-->
 			Register with MR's HA, using prefix-->
 				HA forward packets destinated to VMN to MR, then to VMN
 2)MN move to-->
 	Mobile Network-->
 		get a Coa-->
 			Home Register with VMN's HA, by traditional MIPv6-->
 				HA gets the CoA of VMN
 3)CN send packet to VMN-->
 	packet is intercepted by VMN's HA-->
 		forward the packet to VMN's CoA-->
 			HA of MR find the frefix match to the prefix of mobile network,then intercept the forwared packet and forward it to MR's CoA-->
 				MR receive it, then send it to VMN.
 
  My Question(MQ):
 
 (MQ-1)I am not sure is the procedure above right?
 
 I also have some other question about NEMO, any comments is appreciated:)
 
 (MQ-2)When the MR move to a new network, do the nodes in the mobile network including(VMN,LFN,LFR,LMN) need to do a runumbering?
 
 (MQ-3)If MQ-2's answer is "YES", then does VMN need to do a new BU with its HA or other CNs will not know how to locate VMN?
 
 Maybe my question is very naive but it absolutely hovering on me. I know here are many experts of NEMO and is a wonderful place for me to find the answers.
 Thousands of thanks in advance!
 
 Yours sincerely
 Humphrey Gu

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 16 Mar 2005 13:50:03 +0100

Humphrey, is this a homework you're assigned?  If yes, please try to do
the homework properly.

[email-masked] wrote:
> Hi all NEMOers:
> According to RFC3963,there is no discussion on MN(VMN,LFN,LMN)
> operation. In RFC3963 there are only discussion on Mobile Router
> Operation(Section 5) and Home Agent Operation(Section 6). It seems
> that Basic NEMO need no modification on MN but I think it is
> impossible. For
> 1) VMN 

> When one MN moved to the Mobile Network , it changes its attachment
> of network and should have a topologically correct CoA . Then how CNs
> outside the Mobile Network to communicate with him because CNs donot
> know the new CoA.

Yes, CN does not know the CoA of MN, but CN does know the HoA (Home
Address) of MN, so CN continues sending packets to MN's HoA, that'll be
intercepted by MN's HA (Home Agent) and forwarded to the correct CoA.
This is basic MIP6 for MH operation, no NEMO difference.  Of course, the
paths are longer.

> Maybe there also some other draft or similiar proposals talk about
> tis question. If it is, is anyone can told me where to find?

Maybe something in this draft, please ask its authors:
http://www.mobilenetworks.org/nemo/drafts/draft-watari-nemo-nested-cn-01.txt

>  There is similiar questions with minor difference(Maybe great).

LFN does not implement MIP6 nor NEMO, by definition.  LFN does not move
out of the moving network.

>  (MQ-1)I am not sure is the procedure above right?

Somehow it is right, why do you think it is not right?

> (MQ-2)When the MR move to a new network, do the nodes in the mobile
> network including(VMN,LFN,LFR,LMN) need to do a runumbering?

No.

> (MQ-3)If MQ-2's answer is "YES", then does VMN need to do a new BU 
> with its HA or other CNs will not know how to locate VMN?
> 

> Maybe my question is very naive but it absolutely hovering on me.

What are you going to do when you have the answers?  Fill some
questionnaire?  Implement/code some stuff?  Do a little demo with some
mobility software?

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 16 Mar 2005 16:17:39 -0800

hello,

RFC 3963 keeps mobility transparent to the nodes in the
Mobile Network. the nodes in the mobile network always
see the mobile network prefixes. not the prefixes from
the visited network.

it is possible for the nodes in the mobile network to be
MIPv6 mobile nodes. that is allowed.

Vijay