Subject: 答复: [nemo] Seeking help for VMN BUs

From: [email-masked]
Date: Thu, 17 Mar 2005 13:43:57 +0800

Hi Vijay;
     Thanks for your explanation I got to know that in RFC3963 nodes in mobile network do nothing (they can be MIPv6 enabled or not) and all the modifications are on HA (section 5) , MR (section 6) and DHAAD between them (section 7).
     So, RFC 3963 do not discuss about the VMN, is my understanding right?
     
     If it is right, the IP address (I mean node identifier, not location identifier, because the mobility is transparent for inner nodes) assigned on nodes in mobile network will keep unchanged, all the communication between inner nodes and CN are proxyed by MR, so the mobile network turned in to a NAT-Sub-Network. The MR acts like a NAT server. I mean bi-direction NAT.
     Can somebody give me some comments on this? Is my understanding right?

Humphrey Gu

-----邮件原件-----
发件人: Vijay Devarapalli [mailto:[email-masked]] 
发送时间: 2005年3月17日 8:18
收件人: 研发 顾华平
抄送: [email-masked]
主题: Re: [nemo] Seeking help for VMN BUs

hello,

RFC 3963 keeps mobility transparent to the nodes in the
Mobile Network. the nodes in the mobile network always
see the mobile network prefixes. not the prefixes from
the visited network.

it is possible for the nodes in the mobile network to be
MIPv6 mobile nodes. that is allowed.

Vijay

[email-masked] wrote:
> Hi all NEMOers:
> According to RFC3963,there is no discussion on MN(VMN,LFN,LMN) operation. In RFC3963 there are only discussion on Mobile Router Operation(Section 5) and Home Agent Operation(Section 6).
> It seems that Basic NEMO need no modification on MN but I think it is impossible. For
> 1) VMN 
>  When one MN moved to the Mobile Network , it changes its attachment of network and should have a topologically correct CoA . Then how CNs outside the Mobile Network to communicate with him because CNs donot know the new CoA.
>  Maybe there also some other draft or similiar proposals talk about tis question. If it is, is anyone can told me where to find?
> 2) LFN,LN
>  There is similiar questions with minor difference(Maybe great).
>  
>  
>  I am a newer of NEMO, need some help on my studying. I think for VMN the process is as following:
>  
>  1)MR move to-->
>  	Foreign Network-->
>  		get a CoA for MR-->
>  			Register with MR's HA, using prefix-->
>  				HA forward packets destinated to VMN to MR, then to VMN
>  2)MN move to-->
>  	Mobile Network-->
>  		get a Coa-->
>  			Home Register with VMN's HA, by traditional MIPv6-->
>  				HA gets the CoA of VMN
>  3)CN send packet to VMN-->
>  	packet is intercepted by VMN's HA-->
>  		forward the packet to VMN's CoA-->
>  			HA of MR find the frefix match to the prefix of mobile network,then intercept the forwared packet and forward it to MR's CoA-->
>  				MR receive it, then send it to VMN.
>  
>   My Question(MQ):
>  
>  (MQ-1)I am not sure is the procedure above right?
>  
>  I also have some other question about NEMO, any comments is appreciated:)
>  
>  (MQ-2)When the MR move to a new network, do the nodes in the mobile network including(VMN,LFN,LFR,LMN) need to do a runumbering?
>  
>  (MQ-3)If MQ-2's answer is "YES", then does VMN need to do a new BU with its HA or other CNs will not know how to locate VMN?
>  
>  Maybe my question is very naive but it absolutely hovering on me. I know here are many experts of NEMO and is a wonderful place for me to find the answers.
>  Thousands of thanks in advance!
>  
>  Yours sincerely
>  Humphrey Gu
> 
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 17 Mar 2005 12:01:54 +0100

[email-masked] wrote:

> Hi Vijay; Thanks for your explanation I got to know that in RFC3963 
> nodes in mobile network do nothing (they can be MIPv6 enabled or not)
>  and all the modifications are on HA (section 5) , MR (section 6) and
>  DHAAD between them (section 7). So, RFC 3963 do not discuss about 
> the VMN, is my understanding right?

Yes, "VMN" is more like a concept of a MN that visits the moving network
and that usually has another HA than the MR.  VMN is usually belonging
to a different administrative domain than MR.

VMN implements Mobile IPv6 MN, no other need to specify anything for it,
unless the RO context is involved.  It is "visiting" because its HA is
not in the moving network - never.  VMN's HA is more probable to be
different than MR's HA, and less probable to be MR's HA.

> If it is right, the IP address (I mean node identifier, not location 
> identifier, because the mobility is transparent for inner nodes) 
> assigned on nodes in mobile network will keep unchanged, all the 
> communication between inner nodes and CN are proxyed by MR,

Yes, "proxied", hmmm, maybe "forwarded" better.  MR does not do "proxy"
ND and MR is not required to run any application-level proxy.

> so the mobile network turned in to a NAT-Sub-Network.

No, there's currently no NAT for v6.  MR does tunneling instead of NAT.

Alex