Subject: [nemo] Re: [Mip6] Consensus call on making ID draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

From: Sri Gundavelli <[email-masked]>
Date: Wed, 30 Mar 2005 14:38:46 -0800 (PST)

Hi Raj,
       In the last IETF nemo meeting, we raised some
issues on the approach chosen by this draft. We are
not convinced that the draft has explored and narrowed
down on the most common v4 traversal scenarios. The
basic assumption of the draft that the v6 Home Agent's
functionality is collapsed in to the transition gateway
is not valid and just addresses one scenario. The
requirement the draft imposes on having a V4 network
terminating on the v6 home agent is probably not
acceptible. Also, the draft's claim that they are
avoiding one extra encap layer is not true, the moment
you move the transition gateway from the home agent,
indeed an extra encap layer is needed.

There were some other proposals for solving this problem
and one being "draft-thubert-nemo-ipv4-traversal-01.txt",
we should look at this work as well. Before we agree on
a solution, we should atleast semantically agree on the
problem statement and the scope. I remember you words,
we should not boil the ocean in the process, Agreed !
But, atleast we should have some amount of discussions on
the problem scope. My 2c.

Regards
Sri

On Wed, 30 Mar 2005 [email-masked] wrote:

>
> One of the major barriers to the deployment of Mobile IPv6 today is
> the fact that most access networks are IPv4 only. A number of hosts
> are already dual-stack capable. While Mobile IPv6 works well in IPv6
> networks, it is essential that IPv6 mobility service continue to work
> even when the mobile host is attached to an IPv4 network. The same
> applies to a NEMO mobile router as well.
>
> A number of transition scenarios have been identified in IDs:
> 1. draft-larsson-v6ops-mip-scenarios-01
> 2. draft-tsirtsis-dsmip-problem-03
> While discussion of these scenarios in the larger scope makes sense,
> there is a need to focus on the most critical scenario that would
> address the MIP6 host and router problem. The problem in a single
> sentence can be stated as: "Mobile IPv6 hosts and routers (NEMO) need
> to be able to reach its (IPv6) home agent and services when roaming in
> and attached to an IPv4 access network."
> It makes sense to focus on just this one scenario and solve the
> problem immediately.
>
> The ID: draft-wakikawa-nemo-v4tunnel-01 solves the problem of a MIPv6
> mobile node or a NEMO mobile router roaming onto a IPv4 only access
> network in a simple manner.
> It is intended that the standardization of this solution in the IETFs
> MIP6 and/or NEMO working groups proceed. The working group chairs have
> reviewed and discussed this work item. It has also been presented at
> the MIP6 and NEMO WGs at IETF62.
>
> The chairs would like to hear your thoughts in order to see if there
> is consensus to make it a WG document and progress it as a standards
> track RFC. Comments should be sent to both the NEMO and MIP6 WGs.
>
> If we have consensus, then the document will be pursued as a dual WG
> item and called draft-ietf-mip6-nemo-v4tunnel-xx.txt
>
> Make I-D draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WG ID:
> 	For 		[  ]
> 	Against 	[  ]
>
>
> - MIP6 and NEMO WG chairs
>
>
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 30 Mar 2005 15:13:40 -0800

Sri,

Sri Gundavelli wrote:
> acceptible. 

if I understood you right, your concern is about how to make
an IPv6 HA with an IPv4 interface accesible through the IPv4
Internet. right?

> Also, the draft's claim that they are

we do want to keep it to just one level of encapsulation.

Vijay

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 30 Mar 2005 15:27:26 -0800 (PST)

Hi Vijay,

> an IPv6 HA with an IPv4 interface accesible through the IPv4

The question is not about configuring a v4 address on the
interface of v6 home agent, it about the termination point
of the v4 network and the placement of a v6 home agent. You
cannot expect the v6 home agent and the transition gateway
service to be co-located. The point is that we should identify
the practical deployment sceanarios and go from there.

> we do want to keep it to just one level of encapsulation.

Other way to say is we would not an extra encap layer, when
the home agent and the transition gateway functions are spread
out.

---

From: [email-masked]
Date: Wed, 30 Mar 2005 13:33:19 -0600

---

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 31 Mar 2005 14:45:33 +0900

Hello Sri

> the home agent and the transition gateway functions are spread

OK, but there is a problem,  "double tunneling".
Packets have, at least,  three IP headers when MN roams to v4 network.
Extra bits and processing costs are burden for MIP6/NEMO in IPv4.

regards,
ryuji

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 30 Mar 2005 22:21:04 -0800 (PST)

Hi Ryuji,
          Please see inline ...

> Extra bits and processing costs are burden for MIP6/NEMO in IPv4.

That is the cost for going over a transition gateway. The
transition solutions should not expect the networks to
overlap, they should provide a way for the network
administrators to systematically move the v4 network
out from the v6 cloud in a segmented approach. The solution
we are debating is about the tight coupling of the v4 and
v6 networks and requiring fundamental changes to the binding
cache entries for associating v4 addresses. If the solution
requires a v4 network all the way to the Home Agent,
a dual stacked Mobile Router, a modified home agent to
understand v4 address semantics, wonder why we can't go to
the next step of replacing the v6 home agent with a v4 home
agent. Clearly, the solution cannot disregard the problem
scenarios such as a home agent in a v6 cloud and disjointed
transition gateway to the v4 cloud.

All I'm saying is that we should agree up on the problem
scenarios, review the current solutions including doors and
work towards a solution.

Regards
Sri

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 30 Mar 2005 23:11:55 -0700

Hi Sri,

  Looking at things from an operational or deployment perspective:

  One requirement that I believe is highly desirable is the ease of
deployment of a solution that enables Mobile IPv6 traversal in IPv4
networks.  Additional network infrastructure and/or a complicated
protocol will take us further from the base MIPv6 protocol - which
impacts the ease of deployment and possible acceptance. 

   It would be highly desirable for operators and users not to have a
requirement that their Mobile IPv6 service be dependent on a separate
transition service.  

  Finally, co-existence of Mobile IPv6 (a feature of IPv6:) with IPv4
networks is a mandate that we must adhere to ASAP; otherwise, there will
be little acceptance to advance Mobile IPv6 adoption/deployment  [just
think if we waited for the core IPv6 specifications to become RFCs
before working on v6ops stuff - where would will be with IPv6 deployment
today].  draft-wakikawa-nemo-v4tunnel-01 limits the scope to what I
believe is the minimum scenario and requires little protocol changes.
Let's keep in mind the operator's perspective in the debate. 

   Carl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sri Gundavelli
Sent: Wednesday, March 30, 2005 4:27 PM
To: Vijay Devarapalli
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [nemo] Re: [Mip6] Consensus call on making ID
draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

Hi Vijay,

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 31 Mar 2005 09:53:54 -0800

Pekka Savola wrote:
> Why, exactly?

well, if its doable, dont we always want minimal encapsulation?
it is doable if the following assumptions from the draft are valid.

- HA has v4 and v6 interface
- MN is dual-stack
- HA's v4 address is reachable from the IPv4 Internet.

> There are existing mechanisms out there which have been deployed for 
> years, widely implemented, etc. to deal with exactly these issues.

I am not sure I understood. we are not defining any new tunneling
mechanisms. the idea is to use the existing tunneling mechanisms.

> 
> You're arguing we need to design protocol extensions to save 20 or 40 
> bytes.  Is it worth it ?

well, the protocol extension is only to bind an IPv4 CoA to IPv6
HoA. it is minor enough that we dont have to worry about it.

> A couple of quick comments on the ID:
>  - which encapsulation types are mandatory-to-implement?  There must be 
> at least one or a couple, to ensure interoperability.

right. we havent picked a mandatory-to-implement mechanism
yet. IPv6-in-UDP-over-IPv4 and IPv6-over-IPv4? suggestions are
welcome.

>  - you specify UDP encapsulation for NAT traversal, but no keepalive

okay. will fix this.

>  - I guess it should be possible to discover the v4 home agent address 
> without having to use (v6-only) DHAAD?

DNS is one mechanism to discover the v4 address of the home agent.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 31 Mar 2005 12:01:55 -0800

Henrik,

there is some mis-understanding regarding the relation
between draft-soliman and draft-wakikawa. both solve the
scenario of a v6 MN or MR accessing its v6 home agent from
a v4 only access network. draft-soliman talks about using a
IPv4 mapped IPv6 address to convey the IPv4 CoA to the
HA. draft-wakikawa uses a new mobility option to carry
the IPv4 CoA. I personally prefer carrying it in a separate
mobility option, because it makes processing on the HA easier.
we can debate the pros and cons of this later. but this *does*
not impact the scenario. both solve the same scenario.

there are other scenarios, but IMHO, they are not relevant.

regarding Sri's concerns, we do intend to address them. dont
worry about that. we have an assumption in the draft.

- the HA's IPv4 address is reachable through the IPv4 internet

Sri is questioning this assumption. he is claiming this is
not so easy. he doesnt want IPv4 routing inside his IPv6
network. the HA is deep inside in the IPv6 network. for the
HA's IPv4 address to be reachable, you might need a box in
the DMZ, which traps the packets for the HA's IPv4 address
and tunnels them to the HA deep in the IPv6 network. but here
we end with extra tunneling between the box sitting in the
DMZ and the HA deep in the IPv6 network. another option is to
place the HA in the DMZ. but he doesnt want to do that. I
will be discussing with him to see how we can come up with a
solution. Sri, let me know if I still dont understand the
issue you are bringing up.

Vijay

Henrik Levkowetz wrote:
> Hi,
> 
> On 2005-03-30 9:33 pm [email-masked] said the following:
> [...]
> 
> Given that there already exists at least 3 solution drafts in this area:
> 
>   draft-thubert-nemo-ipv4-traversal
>   draft-soliman-v4v6-mipv6
>   draft-wakikawa-nemo-v4tunnel
> 
> and Sri clearly indicates that there are requirements which these
> don't cover, I think it would be good to have a clear and agreed
> upon statement of what to achieve before adopting an approach and
> draft.  So I'm not for adopting draft-wakikawa before there is an
> agreed upon problem statement.
> 
> That said, I'm very much in favour of doing this work; and doing
> it by extensions to MIP6 (and MIP4) rather than trying to adapt
> any of the other approaches which would mix MIP6 with non-MIP tunnels,
> as listed in draft-larsson-v6ops-mip-scenarios-01.
> 
> If the decision is to write a problem statement, I'd be willing to
> work on such a draft, and I also have a potential co-editor who have
> indicated willingness.
> 
> 
> 	Not currently	[ X ]
> Henrik

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 31 Mar 2005 15:08:18 -0800 (PST)

Hi Vijay/Vidya,

> issue you are bringing up.

We need to agree on the most common scenarios that we need to
address and so we need a problem statement. That should be the
basis for defining a solution. Further, we need to have some
gap analysis on each of the three present solutions and
leverage some thing from them. I agree, we cannot afford to
spend too much on that, but at the same time adopting a
solution with out having an understanding of the deployment
models is not right either.

We have implementations based on draft-thubert-nemo-ipv4-traversal
and some good thinking went in to that proposal and it is
important that we review all these solutions in the context
of the agreed upon problem space.

Regards
Sri

---

From: Pekka Savola <[email-masked]>
Date: Thu, 31 Mar 2005 09:43:41 +0300 (EEST)

Why, exactly?

A couple of quick comments on the ID:
  - which encapsulation types are mandatory-to-implement?  There must 
be at least one or a couple, to ensure interoperability.
  - you specify UDP encapsulation for NAT traversal, but no keepalive
  - I guess it should be possible to discover the v4 home agent address 
without having to use (v6-only) DHAAD?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 31 Mar 2005 20:18:32 +0200

Hi,

	Not currently	[ X ]

Henrik

---

From: "James Kempf" <[email-masked]>
Date: Thu, 31 Mar 2005 10:45:15 -0800

I agree with Henrik. If we have multiple solution proposals, then I think it
makes sense to look at the problem more closely, see how the proposed
solutions do and don't address the problem, and try to come up with a
solution (or pick one) that best solves the problem.

            jak

----- Original Message ----- 
From: "Henrik Levkowetz" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Thursday, March 31, 2005 10:18 AM
Subject: Re: [Mip6] Consensus call on making ID
draft-wakikawa-nemo-v4tunnela MIP6/NEMO WGs document

---

From: Keiichi SHIMA <[email-masked]>
Date: Fri, 01 Apr 2005 11:10:50 +0900 (JST)

Hi all,

From: [email-masked]
Date: Wed, 30 Mar 2005 13:33:19 -0600

> track RFC. Comments should be sent to both the NEMO and MIP6 WGs. 

I agree that we need a mechanism for mobile hosts/routers to keep IPv6
mobility functions even if they jump into IPv4 network.

Personally, I am not sure if we need to save 40bytes instead of using
some other general tunneling mechanism.  But, I also personally feel
that we need much time if we wait for a general tunneling mechanism to
be defined, which we don't want to.  Defining a simple traversal
mechanism in MIP6/NEMO protocol makes sense to me.

The proposal (draft-wakikawa-nemo-v4tunnel) is simple enough and it
looks easy to implement from implementor's point of view.  It only
focuses IPv6 mobility which seems a good tradeoff to me.

However, I still don't fully understand the pros and cons between
draft-wakikawa-nemo-v4tunnel and draft-soliman-v4v6-mipv6.  I want to
see which is better for our purpose.

---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
KAME Project <[email-masked]>