Subject: RE: [nemo] carrying IPv4 traffic using MIP6/NEMO

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 9 Aug 2005 10:09:23 -0400

> > => That's no different to the IPv6 case.
 > 
 > Yes it is.  In v6 one gets the v6 Home Address from the DO, 
 > and that can
 > be different than the address and prefixlen that is in the BU.

=> And the DO can contain an IPv4-mapped IPv6 address. So again
there is no difference. It is only tricky if you have both
v4 and v6 addresses and need to contain more than one of those. 

 > >> I think giving v4 access to nodes in the moving network would best
 > >> be done by a NEMOv4 protocol.
 > > 
 > > => It's not about giving v4 access to those nodes, it's about 
 > > updating the MR's v4 home address/prefix to its current CoA. What
 > > happens inside the network is not in scope of transition 
 > mechanisms.
 > 
 > Is mip6trans doing a "transition mechanism"?  I don't get the above.

=> That's what "trans" stands for in "miptrans".

Hesham

 > Alex

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 09 Aug 2005 16:53:05 +0200

Soliman, Hesham wrote:
>> Yes it is.  In v6 one gets the v6 Home Address from the DO, and
>> that can be different than the address and prefixlen that is in the
>> BU.
> 
> => And the DO can contain an IPv4-mapped IPv6 address. So again there
> is no difference. It is only tricky if you have both v4 and v6
> addresses and need to contain more than one of those.

So it is acknowledged that this may become tricky.  I agree.

Alex