Subject: RE: [nemo] carrying IPv4 traffic using MIP6/NEMO

From: "Soliman, Hesham" <[email-masked]>
Date: Mon, 8 Aug 2005 13:37:32 -0400

Hi Ryuji, 

 > I thought you were opposed to support NEMOv4 during the 
 > discussion in  
 > DT.

=> I'm including my last email on that topic. What I was opposed
to was discussing injecting routes over the tunnel in the 
requirement because it's an orthogonal issue.

 > 
 > Are there any big differences between draft-soliman(w/prefixlen)
 > and draft-keiichi for NEMO support?

=> I haven't read draft-keiichi but if it only adds an IPv4 prefix
to the BU then there are differences, draft-soliman deals with 
IPv4 HoAs/prefix as well as IPv4 CoAs for MIP6 and nemo. 

Hesham

 > 
 > regards,
 > ryuji
 > 
 > On 2005/08/08, at 23:53, Soliman, Hesham wrote:
 > 
 > >>
 > >> Generally it looks like an interesting idea.  Why restraining the
 > >> binding to a fixed /32 full v4 address when binding a 
 > variable prefix
 > >> (1...32) could bring the benefit of giving v4 access to all
 > >> nodes in the
 > >> moving network (not only to the MR).  So this may look as 
 > an obvious
 > >> advantage.
 > >>
 > >> However, I was wondering how much would this addition extend
 > >> the current
 > >> scope of the DT work, whose goal was mainly to give v6 (not
 > >> v4) access
 > >> to MR and mobile nodes when MR connects to a v4 network.
 > >>
 > >> Giving continuous v4 access to mobile nodes in a moving
 > >> network whose MR
 > >> connects to a v4 access network can naturally be obtained 
 > by running
 > >> Mobile IPv4 on the MR, too.
 > >>
 > >> What does the DT think?
 > >>
 > >
 > > => We discussed this and I had extended draft-soliman to represent
 > > the IP address as : address/prefixlen, where prefixlen is 
 > anything up
 > > to 32. It's a useful feature that only adds another 5 mins 
 > of work  
 > > so why
 > > not.
 > >
 > > Hesham
 > >
 > > ===========================================================
 > > This email may contain confidential and privileged 
 > material for the  
 > > sole use
 > >  of the intended recipient.  Any review or distribution by others  
 > > is strictly
 > >  prohibited.  If you are not the intended recipient please 
 > contact  
 > > the sender
 > >  and delete all copies.
 > > ===========================================================
 > >
 > >
 > 
 > 

Subject: RE: [Mip6trans] Requirements 6 and 8
From: "Soliman, Hesham" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>, <[email-masked]>
Date: Fri, 22 Jul 2005 21:09:50 -0400

 > requirement 6 was about whether we should provide support
 > for IPv4 sessions initiated by the MN/MR without having
 > to use MIPv4. I guess everybody agrees that using MIPv4
 > and MIPv6 at the same time is not a good idea. so if a
 > MIPv6 MN or a NEMO MR, irrespective of whether it is on
 > an IPv4 or an IPv6 access network, wants to setup an IPv4
 > session with a CN we should enable it through our
 > mip6trans tunnel. the problem is described very clearly in
 > http://people.nokia.net/vijayd/mip6trans/relevant_drafts/draf
 > t-tsirtsis-dsmip-problem-01.txt
 > IMO, we should address requirement 6.

=> Sure.

 > 
 > requirement 8 is about extending this to the MNNs in the
 > mobile network, so that the MNNs can also setup IPv4
 > sessions with their CNs. this does not mean we are doing
 > a NEMO solution for IPv4, just using NEMO IPv6 solution
 > for IPv4 mobile networks too. currently NEMO assumes IPv6
 > mobile network prefix. for requirement 8, we assume there
 > is an IPv4 mobile network prefix in addition and we are
 > able to carry the IPv4 traffic from the MNN to its CN over
 > the tunnel between the MR and the HA.
 > 
 > we can address requirement 8 either here in this design
 > team or separately. I am tending towards doing it
 > separately.

=> Fine with me either way. My only comment was that the 
requirement should not take about injecting routes because
it's an orthogonal issue.

Hesham

 > 
 > Ryuji, Hesham, does this sound good?
 > 
 > Vijay
 > _______________________________________________
 > Mip6trans mailing list
 > [email-masked]
 > http://www.mobileip.jp/mailman/listinfo/mip6trans
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mip6trans mailing list
[email-masked]
http://www.mobileip.jp/mailman/listinfo/mip6trans

---

From: Keiichi SHIMA <[email-masked]>
Date: Tue, 09 Aug 2005 16:11:15 +0200 (CEST)

Hello Hesham,

From: "Soliman, Hesham" <[email-masked]>
Date: Mon, 8 Aug 2005 13:37:32 -0400

> IPv4 HoAs/prefix as well as IPv4 CoAs for MIP6 and nemo. 

The IPv4 CoAs are for IPv6 Mobility over IPv4 access networks, and the
IPv4 HoAs/Prefixes are for IPv4 Mobility over IPv6 networks, if I
understand correctly.

Then, the above two things are orthogonal and should be split into two
separate specifications?

Regards,
---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
KAME Project <[email-masked]>