Subject: Fw: [nemo] Split Networks:Query

From: Ranjitsinh Wable <[email-masked]>
Date: Mon, 22 Aug 2005 12:18:04 +0530

Hi Marcelo,

 Please see the inlined comments.

> ----- Original Message ----- 
> From: "marcelo bagnulo braun" <[email-masked]>
> To: "Sameer Kumar" <[email-masked]>
> Cc: "IETF NEMO WG" <[email-masked]>
> Sent: Thursday, August 18, 2005 6:43 PM
> Subject: Re: [nemo] Split Networks:Query
>
>
>
> El 18/08/2005, a las 14:31, Sameer Kumar escribió:
>>>                     MR1
>>>                   |  _  |
>>>                   |-|_|-|  _____
>>>                   | p<- |-|     |  _   |  _
>>>                _  |     | |     |-|_|--|-|_|HA
>>>            MNN|_|-|     | |     |  AR  |
>>>                   |  _  |-|_____|
>>>                   |-|_|-| INTERNET
>>>                   |p<-  |
>>>                     MR2
>>>           Figure 1: (n,1,1): Multiple MRs, 1 HA, 1 MNP
>>
>> The Figure 1. is easily possible in a wired scenario. It is a (n,1,1) "no
>> split" scenario. I just want to know how a similar configuration, as 
>> Figure
>> 1, will look like in a wireless scenario..with MR1, MR2, and one or more
>> Access Points in the diagram. And then how will split occur in a wireless
>> scenario.
>
> I am not sure why you think that a wired and a wireless scenario are so
> different... i mean, in the figure above the link between MR1, MR2 and
> MNN could perfectly be wireless or wired. I guess that from an IP layer
> perspective (that's where we are sitting on) there is no difference
> imho
> So if you assume that all the links above are wireless, then you have a
> wireless scenario, right?
> Then this scenario could simply split by breaking the link between MR1,
> MR2 and MNN i.e. for instance MR1 leaves and MR2 and MNN continues in
> the same link
>
> Regards, marcelo
 ==========>

 I would like to know how the MR1, MR2 and MNN can be on same link
 in wireless scenario?

 1) whether you want say that they all connected to the AR's wireless Link?
Again there may be a case that the MRs are connected to different ARs but
still advertise the same prefix without spilt.

 2) If not,  then whether the MNN have two interfaces to get in touch
 with both the MRs?

 I will try to put this problem in slightly different scenario:

 As per NEMO concept we can have two wireless networks

 1) Between the AR and the MR's
2) Between MR and MNN.

 Now suppose the MNN's are going to use the same prefix then
 there is no problem for the first network. As both the MRs are
 on same link of AR. Its normal AR-MR communication.

 Lets think about the second wireless scenario i.e. Between
MR-MNN. Lets says there are two MR's on Link of AR
MR1, MR2.

 Now one MNN can connect to either of the MR. Say
it connected to MR1. Lets say packet is comming for MNN
to MR2 as per load balancing at HA of MRs.

Now the question arieses is that how the packet will reach to MNN
via MR2?

 There can be some possiblities like

 1) MNN have two links and get connected to both MRs.
 (Sorry I know its not possible(feasible) but putting it to just give all
 options)

 2) MRs who share prefixes always send the packes on other link.
 (But its burden on the Wireless link (between AR and MRs))

 3) MRs keep update of the nodes under it and if
 packet is not destinied then only it forwards on other link.
 (Improved case 2 with intelligence at MR. )

 4) We can have Adhoc mode as explained by chan-Wah ng
 (I don't think that the NEMO talks about adhoc mode)

 If the Option 2 & 3 are the answer then, NEMO does not talk about this.
 So its hard to get the scenarion for anybody.

 Let me know your views on this.

Regards,

Wable R. U.

>>
>> Thanks and Regards,
>> Sameer Kumar.
>>
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> Masayuki Kumazawa
>> Sent: Thursday, August 18, 2005 8:23 AM
>> To: [email-masked]
>> Subject: Re: [nemo] Split Networks:Query
>>
>> Hello Sammer,
>>
>> <[email-masked]> From Sameer Kumar-san
>>> Hi all,
>>>
>>>      I have a doubt regarding the concept of "Split Networks" in NEMO.
>>> Split Networks comprise the case (n,1,1): Multiple MRs, Single HA, 
>>> Single
>>> MNP.
>>>
>>>   Figure 1. below depicts the Split Network scenario. No "split" has
>>> occured. MR1 and MR2 are together.
>>>
>>>                     MR1
>>>                   |  _  |
>>>                   |-|_|-|  _____
>>>                   | p<- |-|     |  _   |  _
>>>                _  |     | |     |-|_|--|-|_|HA
>>>            MNN|_|-|     | |     |  AR  |
>>>                   |  _  |-|_____|
>>>                   |-|_|-| INTERNET
>>>                   |p<-  |
>>>                     MR2
>>>           Figure 1: (n,1,1): Multiple MRs, 1 HA, 1 MNP
>>
>> In this case, split may occur in two ways.
>> One case is that MR2, which is a portable device like a cellular phone,
>> moves away from the network.
>>
>> The other case is that both of them are installed in different places but
>> they are configured with the same MNP.
>>
>> In the second case without additional mechanism, prefix table must be
>> configured more carefully, maybe manually.
>>
>>> In this case, HA can send packets destined to MNN via MR1, or MR2 (Load
>>> Balancing). The same situation in a wireless deployment is shown in 
>>> Figure
>>> 2. Here also, we consider the case when no "split" has occurred i.e. MR1
>> and
>>> MR2 are together.
>>>
>>>                       AP1   MR1
>>>                      _ _     _  |
>>>                     / |_|---|_|-|  _____
>>>                  _ /  p<-       |-|     |  _   |  _
>>>              MNN|_|             | |     |-|_|--|-|_|HA
>>>                                 | |     |  AR  |
>>>                        _     _  |-|_____|
>>>                       |_|---|_|-| INTERNET
>>>                      p<-        |
>>>                       AP2   MR2
>>>
>>>    Figure 2: (n,1,1) : Multiple MRs, 1 HA, 1 MNP in a Wireless Scenario
>>
>>> In Figure 2. MNN is currently attached to the Access Point (AP1) of MR1. 
>>> I
>>> have the following questions:
>>> a)If HA tries to send packets to MNN via MR2, how will these packets 
>>> reach
>>> MNN? Basically how is "Load Balancing"
>>>  possible for a case (n,1,1) in a practical wireless deployment?
>>
>>> b)Is it that the AP1 and AP2 are "physically connected"? If so, then 
>>> does
>>> the term "split" means a "physical split"?
>>
>> In the architecture of current major wireless technologies,
>> there is one AP in a BSS.
>>
>> So, as you pointed out, even if MR1 and MR2 are together,
>> AP1 and AP2 can't be connected phisically as Access Point.
>>
>> However, if AP2 behaves as a STA, MR1 and MR2 can be connected 
>> phisically.
>> In this configuration, all packets are forwarded via AP1, but load 
>> balancing
>>
>> between MR1 and MR2 seems possible.
>>
>> I'm not sure whether I understand your question, but I hope they will be
>> answer of your question.
>>
>> Best regards,
>> Masayuki
>> -----------
>> M.Kumazawa
>>
>>
>>
>>
>
>
>
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 22 Aug 2005 16:12:27 +0200

Hi Wable,

El 22/08/2005, a las 8:48, Ranjitsinh Wable escribió:

>> ----- Original Message ----- From: "marcelo bagnulo braun" 
>> <[email-masked]>

keeping the figure for reference...

First of all, i am really failing to understand what is so 
wireless-specific in any of those scenarios... i mean nemo is basically 
an IP layer protocol right? so why is it relevant that this is a 
wireless case? i mean, i think that exactly the same cases could be 
considered in a wired scenario... am i missing something? (i agree that 
splitting networks in a wired scenario is much less likely than in a 
wwireless scenario, but this would not change the solution behaviour 
imho)

Second, i am not sure i understand the actual cases we are 
discussing... i mean the draft tries to provide a description of the 
problem of split networks, and does not provides an actual solution to 
the problem. It is accepted that in some scenarios, where the nemo 
splits, there are problems yet unsolved.

As i see it we are in the point of understanding that there is a 
problem and we could consider solutions (i guess there are a few drafts 
proposing solutions)

So, in brief at this point the situation w.r.t. problem is that:
- splitting a nemo may result in communication disruption of some of 
the MNN with current nemo support
- additional tools/considerations/constraints are needed to support 
this scenario

Do we agree so far?

I mean, if you are arguing that splitting a nemo may cause problems, i 
agree

But before moving on to discussing solutions i would like to make sure 
that we have a common understanding about what the problem is (i.e. if 
you agree with the problem description included in the draft). In 
particular, i would like to understand if you consider that there are 
some wireless specific considerations in this problem (i guess so 
because of your mail) and which are those.

> 1) Between the AR and the MR's

right

> MR-MNN. Lets says there are two MR's on Link of AR

i don't understand what you mean here

in this second scenario, the link between MR1, MR2 and MNNs is 
wireless... not sure how does the AR fits in here. As i see it, the 
(wireless) link between MR1, MR2 and MNNs is a different wireless link 
that the one between the MRs and the ARs

> Now one MNN can connect to either of the MR.

Are you considering that the network is split?
If yes, then as i mentioned before we do may have problems.
If no, the MNNs are connected to the wireless link where both MR1 and 
MR2 are, what is the problem with this?

The options below are when the nemo is split of before splitting?

Again the same, if no split then no problem
If split we do may have issues that need additional tools

Regards, marcelo

>  Say
>>>> In Figure 2. MNN is currently attached to the Access Point (AP1) of 
>>>> MR1. I
>>>> a)If HA tries to send packets to MNN via MR2, how will these 
>>>> packets reach
>>>> b)Is it that the AP1 and AP2 are "physically connected"? If so, 
>>>> then does

---

From: Masayuki Kumazawa <[email-masked]>
Date: Tue, 23 Aug 2005 11:08:49 +0900

Hi Marcelo and all,

<[email-masked]> From marcelo bagnulo braun-san
>Hi Wable,
>
>El 22/08/2005, a las 8:48, Ranjitsinh Wable escribi・
>
>> Hi Marcelo,
>>
>>> El 18/08/2005, a las 14:31, Sameer Kumar escribi・
>>>>>                     MR1
>>>>>                   |  _  |
>>>>>                   |-|_|-|  _____
>>>>>                   | p<- |-|     |  _   |  _
>>>>>                _  |     | |     |-|_|--|-|_|HA
>>>>>            MNN|_|-|     | |     |  AR  |
>>>>>                   |  _  |-|_____|
>>>>>                   |-|_|-| INTERNET
>>>>>                   |p<-  |
>>>>>                     MR2

I assume that you mean the draft is draft-kumazawa-nemo-tbdnd-02.txt here.
If so, it does not provide an actual solution as you mentioned.

It provides only the way HA confirms whether split occurs or not.
And it does not provide any solution solving problems which 
will happen after split occurs.

This is because I guessed there were several different policies about 
addressing the problem.

To keep communications in both of mobile networks after split occurs,
renumbering of MRs may be needed.
Otherwise HA have only to reject a Binding Update to prohibit MRs' splitting.

However, I agree with you on the point that actual cases and problems
need to be clarified more before discussing solutions.

Best regards,
Masayuki

-----------
M.Kumazawa

---

From: Ranjitsinh Wable <[email-masked]>
Date: Tue, 23 Aug 2005 11:19:03 +0530

Hi Marcelo,

Kindly see the comments inlined

----- Original Message ----- 
From: "marcelo bagnulo braun" <[email-masked]>
To: "Ranjitsinh Wable" <[email-masked]>
Cc: "IETF NEMO WG" <[email-masked]>; "Sameer Kumar" <[email-masked]>
Sent: Monday, August 22, 2005 7:42 PM
Subject: Re: [nemo] Split Networks:Query

Hi Wable,

====>
This question about wireless scenarion arised bcoz we want to know
in wireless scenario how the sharing of the prefix works?(Problem before 
split).
May be its more related to Laye2 which L3 solution will not bother
but still we would like to know the practical implementation feasibility,
in current avialable wireless systems.

====>
This is not regarding the solution on split network but its regarding the
basic understading of existing cases. Sorry if we asking very basic 
questions.
But we are not clear about it.

Do we agree so far?
===>
Yes I  agree on your point.

right

====>>
I agree the link between AR and MR is different than the Link between
 MNN and MRs (same I stated above point 1) and 2)).

Basic question here is that how MR1, MR2 and MNN share one link.
(May be L2 related question but its basic requirement to share the perfixes)

Does MNN communicates with both MR1 and MR2?
May be different answers for Bluetooth and WLAN.

We tried to put the WLAN scenario with AP but as Chan-Wah said
and we also understand it is not possible. As suggested by Chan-Wah
WLAN adhoc mode can help in this regard. But we are not sure how
the link concept will be provided  by the adhoc WLAN. We may look
 into that option.

About bluetooth option provides mechanism to comminicate with more
than one router at a time (MR1, MR2 in above example) but again it
does not ptovide link concept as wired scenario.

Again the same, if no split then no problem
If split we do may have issues that need additional tools.

====>
We agree there are some issues in the split network which need to be 
addressed.
But this mail was for basic clarification of the actual implementation of 
sharing of
prefix on network.

Regards,

Wable R. U.

Regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 23 Aug 2005 15:52:22 +0200

> I assume that you mean the draft is draft-kumazawa-nemo-tbdnd-02.txt 

Well actually i was considering draft-ietf-nemo-multihoming-issues-03
sorry for the confusion,
regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 23 Aug 2005 19:15:53 +0200

El 23/08/2005, a las 7:49, Ranjitsinh Wable escribió:
> in wireless scenario how the sharing of the prefix works?(Problem 
> before split).

I am far from being a wireless expert, but it is my understanding that 
you can have multiple routers in the same WLAN. The next question then 
is whether those routers also behave as AP or as stations.
At this point, we would need to explore how would the different 
combinations of roles MR/AP/stations would work.

One case would be that all MRs are APs. In this case each station in 
the WLAN would connect to one of the MR/AP
 From what i understand this configuration would work, since the APs 
would forward packets addresses to stations connected to other AP to 
that AP

The other case would be that some MR are just stations. In that case, 
the network before split would work, but if the MR/station leaves, it 
wouldn't be able to take any other node with it, since there wouldn't 
be an AP in the part of the network

So, as i see it, there may be some considerations that need to be 
explored given a particular wireless technology, but my feeling is that 
the described scenario would be possible in some technologies, in 
particular in WLAN

> But we are not clear about it.

we are still not clear about it? what is missing?

> Basic question here is that how MR1, MR2 and MNN share one link.

I am not sure what is the problem with this... i think it is possible 
to have wireless lan networks with many many hosts and multiple routers 
and multiple ARs, isn't it?

> May be different answers for Bluetooth and WLAN.

agree, but for instance with WLAN, i think this would be possible, 
right?

> and we also understand it is not possible.

not sure what you mean by not possible here

regards, marcelo

>  As suggested by Chan-Wah
> But this mail was for basic clarification of the actual implementation 
> of sharing of
> prefix on network.
>
> Regards,
>
> Wable R. U.
>
> Regards, marcelo
>
>
>>  Say
>>>>> Balancing). The same situation in a wireless deployment is shown 
>>>>> in Figure
>>>>> In Figure 2. MNN is currently attached to the Access Point (AP1) 
>>>>> of MR1. I