Subject: Re: [nemo] Split Networks:Query

From: Masayuki Kumazawa <[email-masked]>
Date: Thu, 18 Aug 2005 11:52:38 +0900

Hello Sammer,

<[email-masked]> From Sameer Kumar-san
>Hi all,
>
>      I have a doubt regarding the concept of "Split Networks" in NEMO.
>Split Networks comprise the case (n,1,1): Multiple MRs, Single HA, Single
>MNP.
>
>   Figure 1. below depicts the Split Network scenario. No "split" has
>occured. MR1 and MR2 are together.
>
>                     MR1
>                   |  _  |
>                   |-|_|-|  _____  
>                   | p<- |-|     |  _   |  _
>                _  |     | |     |-|_|--|-|_|HA
>            MNN|_|-|     | |     |  AR  |
>                   |  _  |-|_____|
>                   |-|_|-| INTERNET  
>                   |p<-  |
>                     MR2
>           Figure 1: (n,1,1): Multiple MRs, 1 HA, 1 MNP

In this case, split may occur in two ways.
One case is that MR2, which is a portable device like a cellular phone, 
moves away from the network.

The other case is that both of them are installed in different places but
they are configured with the same MNP.

In the second case without additional mechanism, prefix table must be 
configured more carefully, maybe manually.

>In this case, HA can send packets destined to MNN via MR1, or MR2 (Load
>Balancing). The same situation in a wireless deployment is shown in Figure
>2. Here also, we consider the case when no "split" has occurred i.e. MR1 and
>MR2 are together.
>
>                       AP1   MR1
>                      _ _     _  |
>                     / |_|---|_|-|  _____  
>                  _ /  p<-       |-|     |  _   |  _
>              MNN|_|             | |     |-|_|--|-|_|HA
>                                 | |     |  AR  |
>                        _     _  |-|_____|
>                       |_|---|_|-| INTERNET  
>                      p<-        |
>                       AP2   MR2
>
>    Figure 2: (n,1,1) : Multiple MRs, 1 HA, 1 MNP in a Wireless Scenario

>In Figure 2. MNN is currently attached to the Access Point (AP1) of MR1. I
>have the following questions:
>a)If HA tries to send packets to MNN via MR2, how will these packets reach
>MNN? Basically how is "Load Balancing" 
>  possible for a case (n,1,1) in a practical wireless deployment?

>b)Is it that the AP1 and AP2 are "physically connected"? If so, then does
>the term "split" means a "physical split"?

In the architecture of current major wireless technologies, 
there is one AP in a BSS.

So, as you pointed out, even if MR1 and MR2 are together, 
AP1 and AP2 can't be connected phisically as Access Point.

However, if AP2 behaves as a STA, MR1 and MR2 can be connected phisically.
In this configuration, all packets are forwarded via AP1, but load balancing 
between MR1 and MR2 seems possible. 

I'm not sure whether I understand your question, but I hope they will be 
answer of your question.

Best regards,
Masayuki
-----------
M.Kumazawa

---

From: Sameer Kumar <[email-masked]>
Date: Thu, 18 Aug 2005 18:01:17 +0530

Hi all,
            Thanks for the replies. I still have some concerns regarding
(n,1,1) configuration in a wireless network..I mean, how does it look like.

>                       AP1   MR1
                         Figure 2.

I agree that the above network( Figure 2) is actually split. Consider the
>                     MR1

The Figure 1. is easily possible in a wired scenario. It is a (n,1,1) "no
split" scenario. I just want to know how a similar configuration, as Figure
1, will look like in a wireless scenario..with MR1, MR2, and one or more
Access Points in the diagram. And then how will split occur in a wireless
scenario.

Thanks and Regards,
Sameer Kumar.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Masayuki Kumazawa
Sent: Thursday, August 18, 2005 8:23 AM
To: [email-masked]
Subject: Re: [nemo] Split Networks:Query

Hello Sammer,

Best regards,
Masayuki
-----------
M.Kumazawa

---

From: Chan-Wah Ng <[email-masked]>
Date: Thu, 18 Aug 2005 21:20:17 +0800

On Thu, 2005-08-18 at 18:01 +0530, Sameer Kumar wrote:
> Access Points in the diagram.

With access point?  I don't know if its possible.  Perhaps this:
MR1 and MR2 connected to AP via Ethernet/Bluetooth, AP is a
WLAN-Ethernet or WLAN-Bluetooth bridge.  But I don't imagine why it will
split.

                            MR1
                          |  _  |
                     AP   |-|_|-|  _____  
                  _   _   |     |-|     |  _   |  _
              MNN|_|-|_|--|     | |     |-|_|--|-|_|HA
                          |     | |     |  AR  |
                          |  _  |-|_____|
                          |-|_|-| INTERNET  
                Ethernet->|     |
                            MR2

Alternatively, a more common scenario is the ad-hoc mode, then there is
no concept of AP, and it may split.  Here, MR1 has two interface. the
inner interface is in ad-hoc mode with MNN and MR2.

                       MR1
                      _ _ _  |
                     / |_|_|-|  _____  
                  _ /  p<-   |-|     |  _   |  _
                    \        | |     |  AR  |
                     \_ _ _  |-|_____|
                       |_|_|-| INTERNET  
                      p<-    |
                        MR2

/rgds
/cwng

>  And then how will split occur in a wireless
> scenario.
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 18 Aug 2005 15:13:58 +0200

> Access Points in the diagram. And then how will split occur in a 

I am not sure why you think that a wired and a wireless scenario are so 
different... i mean, in the figure above the link between MR1, MR2 and 
MNN could perfectly be wireless or wired. I guess that from an IP layer 
perspective (that's where we are sitting on) there is no difference 
imho
So if you assume that all the links above are wireless, then you have a 
wireless scenario, right?
Then this scenario could simply split by breaking the link between MR1, 
MR2 and MNN i.e. for instance MR1 leaves and MR2 and MNN continues in 
the same link

Regards, marcelo

>> 2. Here also, we consider the case when no "split" has occurred i.e. 
>> MR1
> and
>> MR2 are together.
>>
>>                       AP1   MR1
>>                      _ _     _  |
>>                     / |_|---|_|-|  _____
>>                  _ /  p<-       |-|     |  _   |  _

---

From: Ranjitsinh Wable <[email-masked]>
Date: Mon, 22 Aug 2005 11:54:25 +0530

Hi Marcelo,

See the inlined comments.

----- Original Message ----- 
From: "marcelo bagnulo braun" <[email-masked]>
To: "Sameer Kumar" <[email-masked]>
Cc: "IETF NEMO WG" <[email-masked]>
Sent: Thursday, August 18, 2005 6:43 PM
Subject: Re: [nemo] Split Networks:Query

Regards, marcelo
==========>

I would like to know how the MR1, MR2 and MNN can be on same link
in wireless scenario?

1) whether you say that they all connected to the AR's wireless Link?
2) If not,  then whether the MNN have two interfaces to get in touch
 with both the MRs?

I will try to put this problem in slightly different scenario:

As per NEMO concept we can have two wireless networks

1) Between the AR and the MR's
2) Between MR and MNN.

Now suppose the MNN's are going to use the same prefix then
there is no problem for the first network. As both the MRs are
on same link of AR. Its normal AR-MR communication.

Lets think about the second wireless scenario i.e. Between
MR-MNN. Lets says there are two MR's on Link of AR
MR1, MR2.

Now one MNN can connect to either of the MR. Say
it connected to MR1. Lets say packet is comming for MNN
to MR2 as per load balancing at HA of MRs.

Now the question arieses is that how the packet will reach to MNN
via MR2?

There can be some possiblities like

1) MNN have two links and get connected to both MRs.
(Sorry I know its not possible(feasible) but putting it to just give all 
options)

2) MRs who share prefixes always send the packes on other link.
(But its burden on the Wireless link (between AR and MRs))

3) MRs keep update of the nodes under it and if
packet is not destinied then only it forwards on other link.
(Improved case 2 with intelligence at MR. )

4) We can have Adhoc mode as explained by chan-Wah ng but
(I don't think that the NEMO talks about adhoc mode)

If the Option 2 & 3 are the answer then, NEMO does not talk about this.
So its hard to get the scenarion for anybody.

Let me know your views on this.

Thanks and Regards,

Wable R. U.

---

From: Chan-Wah Ng <[email-masked]>
Date: Mon, 22 Aug 2005 17:56:40 +0800

Hello all,

> (Sorry I know its not possible(feasible) but putting it to just give all 

this is possible, but this is two different NEMOs as we have already
explained in previous mails.

> (But its burden on the Wireless link (between AR and MRs))

Possible, but who would do that and why?

> (Improved case 2 with intelligence at MR. )

okay, the MR is also a bridge now. Possible, but again highly unlikely.
A more possible alternative to your Option 2&3 is the single AP bridge,
connected to two MR scenario.

> (I don't think that the NEMO talks about adhoc mode)

I must stress that this has nothing to do with MANET.  The ad-hoc mode I
am saying is a 802.11 mode, which get rids of the concept of AP.  So
don't understand what do you mean by "don't think ... NEMO talks about
adhoc mode".

The reason why there is an apparent difficulty in visualizing a scenario
where a mobile network with multiple MRs is because of the assumed
802.11 wireless LAN infrastructure-mode scenario.  First 3 of your above
4 options all assumed that.  If you throw away the concept of AP, you
can have a lot more options, eg Bluetooth WPAN network, etc.

> So its hard to get the scenarion for anybody.

I don't understand what you mean by the above statement "NEMO does not
talk about this".

In fact, NMEO shouldn't talk about any of this, because NEMO as a
layer-3 protocol, is supposed to be agnostic to whatever access
technology deployed for layer-2.  

/rgds
/cwng