Subject: RE: [Mip6] RE: [nemo] carrying IPv4 traffic using MIP6/NEMO

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 9 Aug 2005 10:14:25 -0400

> From: "Soliman, Hesham" <[email-masked]>
 > Date: Mon, 8 Aug 2005 13:37:32 -0400
 > 
 > >  > Are there any big differences between draft-soliman(w/prefixlen)
 > >  > and draft-keiichi for NEMO support?
 > > 
 > > => I haven't read draft-keiichi but if it only adds an IPv4 prefix
 > > to the BU then there are differences, draft-soliman deals with 
 > > IPv4 HoAs/prefix as well as IPv4 CoAs for MIP6 and nemo. 
 > 
 > The IPv4 CoAs are for IPv6 Mobility over IPv4 access 
 > networks, and the
 > IPv4 HoAs/Prefixes are for IPv4 Mobility over IPv6 networks, if I
 > understand correctly.

=> Not really. There is no need for that binding. If you have 
a HoA you always want to use it regardless of the access network
you are on. So if you have a v6 HoA you'll use it whether you're 
in an IPv4 or an IPv6 or dual stack access. The same goes for the 
v4 home address. 

 > 
 > Then, the above two things are orthogonal and should be 
 > split into two
 > separate specifications?

=> Not necessarily. It's one problem that the DT is trying to address.
There are different permutations depending on the scenario, but that
doesn't mean each permutation should be documented separately. That
would make life very complex.

Hesham

 > 
 > Regards,
 > ---
 > Keiichi SHIMA
 > IIJ Research Laboratory <[email-masked]>
 > KAME Project <[email-masked]>
 > 
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

---

From: Keiichi SHIMA <[email-masked]>
Date: Tue, 09 Aug 2005 16:31:44 +0200 (CEST)

Hi Hesham,

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 9 Aug 2005 10:14:25 -0400
> in an IPv4 or an IPv6 or dual stack access. The same goes for the 

I think I understand what you mean.  You are trying to provide the
mechanism Mobile IPv4 (network) over IPv4 access networks using
MIP6/NEMO signaling mechanisms, correct?

I thought that kind of configuration was not the scope of the DT team.
I even thought Mobile IPv4 over IPv6 was also out of scope, since I
though the DT team were discussing the mechanism to provide IPv6
mobility over IPv4 access networks.

Are such configurations are still in the v4traversal DT scope?

Regards,
---
Keiichi SHIMA