Subject: RE: [nemo] Preparing NEMO Slot for Vancouver

From: "Narayanan Vidya-CVN065" <[email-masked]>
Date: Fri, 21 Oct 2005 13:01:50 -0400

Hi Francis,

> 
>  In your previous mail you wrote:
> 
>    Hello, we'd like to request a 10min slot for presenting IPv4 NEMO.
>    
> => two questions:
>  - I believe that Mobile IPv4 already includes support for 
> mobile routers
>    (this is what is written in the specs and in my Mobility books)

RFC3344 contains a short mention of mobile routers, but it does not
define any extensions to the registration request to do prefix binding
explicitly with the HA. Also, it does not specify any details on how the
prefixes are maintained and managed by the HA, etc. This is required for
basic support and interoperability. 

>  - is IPv4 in the scope? (I've just look at the charter: it is)

I guess you've answered that question :) The charter never excluded v4 -
just that no one had done it so far. 

Regards,
Vidya

---

From: "Narayanan Vidya-CVN065" <[email-masked]>
Date: Mon, 24 Oct 2005 22:37:31 -0400

Among the list of documents on the NEMO page, the only document I can
see being applicable to having v4 basic support interoperability is
perhaps the MIB document. Debatably, the home network models may apply.
But then, a lot can be leveraged from the v6 document for that. 

Other than that, RO, prefix delegation, etc. are all topics that aren't
essential to basic support of the protocol itself.  RO doesn't even
apply to v4 (given that mip4 doesn't have RO, it doesn't make much sense
to talk about RO for nemov4). 

Am I missing something else that you have in mind? 

Vidya

> -----Original Message-----
> From: T.J. Kniveton [mailto:[email-masked]] 
> Sent: Monday, October 24, 2005 4:04 PM
> To: Narayanan Vidya-CVN065
> Cc: ml-nemo; Gopal Dommety
> Subject: Re: [nemo] Preparing NEMO Slot for Vancouver 
> 
> There would be additional documents. Take a look at the NEMO 
> home page and count the documents. There are many drafts 
> there related to NEMO (v6), and accordingly, there would be 
> more than one v4 document.  
> MIB, network models, security, ... whatever is needed to 
> describe how support works in a fully-baked way.
> 
> Many of the documents could be shared, so you wouldn't have 
> to repeat existing work, but some of them don't translate to v4.
> 
> TJ
> 
> On Oct 21, 2005, at 11:24 PM, Narayanan Vidya-CVN065 wrote:
> 
> > TJ,
> >
> >
> >> The key components, in my
> >> personal view, would be a core group of some people 
> willing to work 
> >> on all of the documents, and the consensus of the WG (and 
> ADs, etc) 
> >> that it's something that we want to keep in the charter and it's 
> >> proceeding in a reasonable way.
> >>
> >>
> >
> > What do you mean by "all of the documents"? If there is 
> consensus to 
> > work on basic support, without having to address other 
> topics that are 
> > not required for basic support, is that not (minimally) enough?
> >
> > Vidya
> >
> >
> 
>