Subject: RE: [nemo] Next steps in RO

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 4 Nov 2005 09:54:33 +0100

Hi Carlos :)

>
>Dear Pascal,
>
>
>> >(2) A mechanism for MRs to offer route optimization to LFNs.
>> >
>> >This is less important, but it's a mean to complete the entire RO
>> >process.  The mechanism above will allowed modified nodes (i.e. VMN) to
>> >achieve RO in a way compatible to the more "legacy" MIPv6 RO.  This
>> >mechanism, will allow RO to be achieved for unmodified LFNs.
>> >
>> [<PT>] If you meant doing between MRs what MIP6 does between MNs, then
>> I'd be with you. That is MRs locate each other, establish a tunnel and
>> exchange MNP routes over that tunnel, using a signaling that is close to
>> existing NEMO, directly or via MAPs, proxy HAs or such. I do think that
>> this is really important and that we have to consider it in NEMO; for
>> instance, 2) is the base for route projection.
>>
>> But if you mean MR doing some proxy MIP on behalf of LFN to be able to
>> do RO with MIP6 CN, then I see that as a next step for proxy-MIP as
>> opposed to a next step for NEMO, and I know of few scenarios that really
>> require it.
>
>	I disagree here. What about a NEMO in a train, bus, ... in which
>passengers switch on their laptops/PDAs, obtain an IPv6 address
>belonging to the MNP deployed in the NEMO (through stateless/stateful
>autoconfiguration) and start communicating using this IP address?. These
>nodes would be LFNs (since they are using addresses belonging to the
>NEMO and are not going to move from this network to a different one) and
>I clearly see the benefit from enabling the traffic of these nodes to be
>route optimised.
>
[<PT>] I guess that item 2) is very broad in its description. So it could cover the 2 approaches that I detailed. And RO for your user in the bus could be handled in both fashions.

What I believe is that the MR takes things up one step, placing things from the host based to the prefix based. So RO between MRs, or MR to CR makes more sense to me then spoofed MIP RO between LFN and CN.

In your bus case, if, say, the correspondent is in another bus or a train, then MR to MR RO will do the job. But MR to MR RO has a number of other applications: 

For instance, say a bunch of MRs establish a mesh of MRMR tunnels, and exchange MNP routes, using NEMO based RO; they end up forming a community, a form of dynamic VPN if you wish. If you couple that with a MIPTRANS type of solution, the encapsulation could be IPv4, and the backbone the current IPv4 infrastructure, while the 'VPN' is dual stack or IPv6 only.

Something like that changes the Internet Model from a common grid where you have your given position (your IPv4 address) to an infinite number of user or application centric on-demand networks, and you can scale to the sky. I think it's worth considering, even if the goal is a bit far-fetched...

Pascal

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Fri, 04 Nov 2005 11:16:26 +0100

Hi Pascal,

El vie, 04-11-2005 a las 09:54 +0100, Pascal Thubert (pthubert)
> [<PT>] I guess that item 2) is very broad in its description. So it could cover the 2 approaches that I detailed. And RO for your user in the bus could be handled in both fashions.

	RO can be handled in both fashions if the communication peers are both
attached to NEMOs. If one peer is an LFN and the other one is a video
streaming server in the fixed Internet, then only one of the both
approaches aforementioned is valid. And if you want not to change or add
any special support in the LFNs, then, as Chan-Wah said, the MR seems to
be the natural entity to put special functionality into.

> What I believe is that the MR takes things up one step, placing things from the host based to the prefix based. So RO between MRs, or MR to CR makes more sense to me then spoofed MIP RO between LFN…

	OK, agree if NEMO-to-NEMO communication takes place. Note that in my
example I was talking of NEMO-to-CN at fixed Internet communication.

> In your bus case, if, say, the correspondent is in another bus or a train, then MR to MR RO will do the job. But MR to MR RO has a number of other applications: 

	Agree.

	Kind Regards,

	Carlos J.

-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: BFF1 7C7A 6AA7 BCE3 885A  4DF1 ED0C 5952 BF89 B974