Subject: RE: [nemo] Rechartering: FMIPv6 for NEMO

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 9 Nov 2005 17:24:29 +0100

Hi Vijay :)

Well, the general idea of LMM is in HMIP, and that's not mine. My
mechanism is still LMM, but a bit different from HMIP because DHCPv6PD
gives you in a standard fashion a regional prefix whereas HMIP has to
define a mechanism to get a CoA from the MAP. When I have to describe
it, people understand much better when I say it's to NEMO what HMIP is
to MIP. 

And there are additional advantages in the NEMOized approach, since the
delegated prefix can be used to accept visitors in an anonymous fashion,
including MRs, which is the beginning of TIT-4-TAT in nested NEMO. The
mechanism could also be twisted to enable some Route Optimization for
the nested NEMO, to be discussed.

This might seem a bit cryptic for those who did not follow the NEMO
prefix delegation story. There is more in chapter 3.2 of the obsolete
version of the nemo DHCPv6PD draft:
http://mobilenetworks.org/nemo/drafts/draft-ietf-nemo-dhcpv6-pd-00.txt 

Pascal

>-----Original Message-----
>From: Vijay Devarapalli [mailto:[email-masked]]
>Sent: Wednesday, November 09, 2005 5:00 PM
>To: Pascal Thubert (pthubert)
>Cc: Thierry Ernst; ml-nemo
>Subject: Re: [nemo] Rechartering: FMIPv6 for NEMO
>
>Pascal Thubert (pthubert) wrote:
>> Actually, we could consider HMIP as well. We have shown in the past
that
>> HMIP for NEMO can be achieved using a regional NEMO prefix
delegation.
>> That text was removed from the working group document, but the
>> requirement is still there.
>
>Pascal, if I understand it right, you were proposing a new
>mechanism not extensions to HMIPv6.
>
>Vijay
>
>>
>> Pascal
>>
>>
>>>-----Original Message-----
>>>From: [email-masked] [mailto:[email-masked]] On Behalf
Of
>>
>> Thierry Ernst
>>
>>>Sent: Tuesday, November 08, 2005 11:50 PM
>>>To: ml-nemo
>>>Subject: [nemo] Rechartering: FMIPv6 for NEMO
>>>
>>>
>>>Dear all,
>>>
>>>Shouldn't we take a look at how FMIPv6 should work for NEMO Basic
>>>Support ? Isn't there any other protocol we need to fx ?
>>>
>>>Thierry
>>
>>

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 09 Nov 2005 08:51:20 -0800

> it, people understand much better when I say it's to NEMO what HMIP is

right. but the prefix delegation draft was the wrong
place to specify this new mechanim.

Vijay