Subject: RE: [nemo] Next steps in RO

From: "COMBES Jean-Michel RD-MAPS-ISS" <[email-masked]>
Date: Fri, 4 Nov 2005 15:24:25 +0100

Hi,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Pascal Thubert (pthubert)
> Sent: Friday, November 04, 2005 9:55 AM
> To: Carlos Jesús Bernardos Cano
> Cc: ml-nemo WG; T.J. Kniveton; Chan-Wah NG
> Subject: RE: [nemo] Next steps in RO
> 
> Hi Carlos :)
> 
> >
> >Dear Pascal,
> >
> >
> >> >(2) A mechanism for MRs to offer route optimization to LFNs.
> >> >
> >> >This is less important, but it's a mean to complete the entire RO 
> >> >process.  The mechanism above will allowed modified nodes 
> (i.e. VMN) 
> >> >to achieve RO in a way compatible to the more "legacy" MIPv6 RO.  
> >> >This mechanism, will allow RO to be achieved for unmodified LFNs.
> >> >
> >> [<PT>] If you meant doing between MRs what MIP6 does between MNs, 
> >> then I'd be with you. That is MRs locate each other, establish a 
> >> tunnel and exchange MNP routes over that tunnel, using a signaling 
> >> that is close to existing NEMO, directly or via MAPs, proxy HAs or 
> >> such. I do think that this is really important and that we have to 
> >> consider it in NEMO; for instance, 2) is the base for 
> route projection.
> >>
> >> But if you mean MR doing some proxy MIP on behalf of LFN 
> to be able 
> >> to do RO with MIP6 CN, then I see that as a next step for 
> proxy-MIP 
> >> as opposed to a next step for NEMO, and I know of few 
> scenarios that 
> >> really require it.
> >
> >	I disagree here. What about a NEMO in a train, bus, ... 
> in which 
> >passengers switch on their laptops/PDAs, obtain an IPv6 address 
> >belonging to the MNP deployed in the NEMO (through stateless/stateful
> >autoconfiguration) and start communicating using this IP address?. 
> >These nodes would be LFNs (since they are using addresses 
> belonging to 
> >the NEMO and are not going to move from this network to a different 
> >one) and I clearly see the benefit from enabling the traffic 
> of these 
> >nodes to be route optimised.
> >
> [<PT>] I guess that item 2) is very broad in its description. 
> So it could cover the 2 approaches that I detailed. And RO 
> for your user in the bus could be handled in both fashions.
> 
> What I believe is that the MR takes things up one step, 
> placing things from the host based to the prefix based. So RO 
> between MRs, or MR to CR makes more sense to me then spoofed 
> MIP RO between LFN and CN.

>From a security point of view, spoofing sets up always security issues (e.g. trustship between the "spoofer" and the "spoofed", how to control the rights of the "spoofer", how to give the security material to the "spoofer", etc.) ... So I prefer Pascal's ideas.

> 
> In your bus case, if, say, the correspondent is in another 
> bus or a train, then MR to MR RO will do the job. But MR to 
> MR RO has a number of other applications: 
> 
> For instance, say a bunch of MRs establish a mesh of MRMR 
> tunnels, and exchange MNP routes, using NEMO based RO; they 
> end up forming a community, a form of dynamic VPN if you 
> wish. If you couple that with a MIPTRANS type of solution, 
> the encapsulation could be IPv4, and the backbone the current 
> IPv4 infrastructure, while the 'VPN' is dual stack or IPv6 only.
> 
> Something like that changes the Internet Model from a common 
> grid where you have your given position (your IPv4 address) 
> to an infinite number of user or application centric 
> on-demand networks, and you can scale to the sky. I think 
> it's worth considering, even if the goal is a bit far-fetched...
> 
> Pascal
> 
> 
> 
> 
> 

Cheers.

JMC.

France Telecom - R&D Division - MAPS/NSS   
Jean-Michel COMBES, Internet/Intranet Security
E-Mail: [email-masked]
Phone: +33 (0)1 45 29 45 94
Fax: +33 (0)1 45 29 65 19
Mobile: +33 (0)6 07 29 30 16

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Fri, 04 Nov 2005 20:42:58 +0100

Dear Jean-Michel,

El vie, 04-11-2005 a las 15:24 +0100, COMBES Jean-Michel RD-MAPS-ISS
> From a security point of view, spoofing sets up always security issues (e.g. trustship between the "spoofer" and the "spoofed", how to control the rights of the "spoofer", how to give the security…

Mobile IPv6 does not protect against attackers in the path. Therefore,
NEMO RO approaches based on the MR performing the MIPv6 RO signalling on
behalf of the LFNs do not introduce new threads that cannot be performed
with MIPv6.

Kind regards,

Carlos J.

-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: BFF1 7C7A 6AA7 BCE3 885A  4DF1 ED0C 5952 BF89 B974

---

From: Jean-Michel COMBES <[email-masked]>
Date: Mon, 07 Nov 2005 02:19:29 +0100

Hi,

>El vie, 04-11-2005 a las 15:24 +0100, COMBES Jean-Michel RD-MAPS-ISS
[snip]

>behalf of the LFNs do not introduce new threads that cannot be performed
I am not speaking about the security on the path but on the fact that if 
this is the MR that will perform the RO on behalf of the LFNs, this will 
introduce security issues (e.g. trustship between the MR and the LFN, 
how to control the rights of the MR, how to give the security material 
to the MR, etc.).
And as far as I know, there is no such concept in MIPv6: this is the MN 
itself that is doing RO.

Regards.

JMC.

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Mon, 07 Nov 2005 11:04:49 +0100

Dear Jean-Michel,

> And as far as I know, there is no such concept in MIPv6: this is the MN 

	Yes, but the MR is taking care of the LFN's traffic anyway, so there is
an implicit delegation. The MR would be able to make the same kind of
attacks without performing RO. By the way, we have also analysed other
ways of performing RO taking into account delegation issues ([1]).

	Kind Regards,

	Carlos J.

[1] Securing Route Optimisation in NEMO
María Calderón, Carlos Jesús Bernardos, Marcelo Bagnulo, Ignacio Soto
Modeling and Optimization in Mobile, Ad Hoc, and Wireless Networks,
2005. WIOPT 2005. Third International Symposium on 
3-7 April 2005 Page(s): 248 - 254

---

From: Jean-Michel COMBES <[email-masked]>
Date: Mon, 07 Nov 2005 20:29:15 +0100

Hi,

Carlos Jesús Bernardos Cano a écrit :

>an implicit delegation.

Sorry, but I don't agree with you on the fact that a node which is 
linked with a Access Router, has always a strong trustship with it.

> The MR would be able to make the same kind of
>attacks without performing RO.
>
May you precise, please? Because I don't see which attacks you speak about.

> By the way, we have also analysed other
I tried to get the paper on WWW but I did'nt find it. May you send it to 
me, please? Thanks.

Best regards.

JMC.