Subject: [nemo] developing conformance tests and interoperability tests for NEMO

From: "K.Kawaguchi" <[email-masked]>
Date: Tue, 8 Nov 2005 10:16:12 +0900

Dear all,

We are researching and developing conformance tests and interoperability
tests for NEMO basic(RFC3963).  And we are requesting the opinion of the
tests under developing.

Please look for following URL if you are interested. 
Our Conformance tests and Scenario tests have been opened to the public.

http://www.tahi.org/nemo/

Best regards
---
Kiyoaki KAWAGUCHI [email-masked]

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 07 Nov 2005 22:05:06 -0800

> http://www.tahi.org/nemo/

Thanks for this announcement.

In the lab, we support the following NEMOv6 BU message formats, are they
part of the TAHI tests?

http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-mnp?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-mnpacoanonceauth?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-mnpaltcoa?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-mnpnonceauth?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-nmnp?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-nmnpaltcoa?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-nmnpaltcoanonceauth?rev=1.2&view=auto
http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-nmnpnonceauth?rev=1.2&view=auto

Thanks,

Alex

---

From: "K.Kawaguchi" <[email-masked]>
Date: Tue, 8 Nov 2005 17:33:19 +0900

Thank you for the answer immediately. 

> http://www.enrl.motlabs.com/cgi-bin/viewcvs.cgi/livsix/doc/bu-nmnpnonceauth?rev=1.2&view=auto

Isn't Mobile Network Prefix option unnecessary in Buindin update to CN ?

We show one standard packet format though we think that other patterns
like the arrangement of the option etc. exist, too.
Moreover, Conformance Test suite is inspected by using the packet of this
standard pattern. 

http://www.tahi.org/nemo/nemo_profile_v0_1_0.pdf
	"4. Packet formats"

I give one's views in the packet that you showed. 

mobility header, total message divisible by 8
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       | Payload Proto |  Header Len   |   MH Type     |   Reserved    |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |           Checksum            |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                               
binding update
                                       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                                       |          Sequence #           |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |A|H|L|K|M|R|    Reserved       |           Lifetime            |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                ^^^^ ** addition

padn
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |   Type = 1    |      0        |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
alternate care-of address, aligned 8n+6
                                       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                                       |   Type = 3    |  Length = 16  |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |                                                               |
       +                                                               +
       |                                                               |
       +                   Alternate Care-of Address                   +
       |                                                               |
       +                                                               +
       |                                                               |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
padn
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |   Type = 1    |    2          |     0    　   |    0          | 
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
mnp, aligned 8n+4
     ^^^^^^^^^^^^ ** adition
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |   Type = 6    |  Length = 18  |    Reserved   |Prefix Length  |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |                                                               |
       +                                                               +
       |                                                               |
       +                   Mobile Network Prefix		       +
       |                                                               |
       +                                                               +
       |                                                               |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Best regards
---