Subject: RE: [nemo] Distributing the Mobile Prefix in the visited network

From: "Roberto Baldessari" <[email-masked]>
Date: Thu, 17 Nov 2005 12:45:51 +0100

Hi Francis,

thank you for your answer.

I fully agree with the reasons behind the constraint, but I didn't find
any explicit "MUST NOT" in the RFC about distributing the MN prefix in
the visited network.
Am I wrong?
Is it planned to introduce such a restriction in the future steps? I
haven't had a look to the Route Optimization proposals yet.

Regards

Roberto

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Wednesday, November 16, 2005 6:49 PM
To: Roberto Baldessari
Cc: nemo
Subject: Re: [nemo] Distributing the Mobile Prefix in the visited
network 

 In your previous mail you wrote:

   I have a question related to the Basic NEMO Protocol.
   The RFC says:
   
   "  A Mobile Router does not distribute the
      Mobile Network routes to the infrastructure at its point of
      attachment (i.e., in the visited network) "
   
   How should this be inteded?

=> I can see two reasons for this constraint:
 - security: all the traffic for the Mobile Network is assumed to come
   through the HA-MR tunnel, in particular it always goes through the MR
 - handoff survivability: the short path has to be dismount when the MR
   leaves the visited network.
In fact, this is simply a special case of Routing Optimization which is
still in design and will address these two issues.

Regards

[email-masked]

---

From: "Davis, Terry L" <[email-masked]>
Date: Thu, 17 Nov 2005 09:11:47 -0800

Roberto/Francis

Just as an FYI, our commercial mobility implementation for aircraft in
IP-v4 does distribute its route at the ground station that it is
attached to.

Take care
Terry

-----Original Message-----
From: Roberto Baldessari [mailto:[email-masked]] 
Sent: Thursday, November 17, 2005 3:46 AM
To: [email-masked]
Cc: nemo
Subject: RE: [nemo] Distributing the Mobile Prefix in the visited
network 

Hi Francis,

Regards

Roberto

-----Original Message-----

   

Regards

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 18 Nov 2005 18:16:37 +0100

Hi Roberto:

There is a MANEMO list http://www.mobileip.jp/mailman/listinfo/manemo
But we did not start a BOF yet.

I guess it's a matter of raising interest and relating the effort with
NEMO. The more people show interest, the better off we are :)

Pascal

>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Roberto Baldessari
>Sent: Thursday, November 17, 2005 3:21 PM
>To: nemo
network
>
>
>Pascal,
>
>thank you. It seems like the MANEMO matches what we are interested in.
>How is the status of that? I didn't find material about.
>
>Regards
>
>Roberto
>
>
>From: Pascal Thubert (pthubert) [mailto:[email-masked]]
>Sent: Thursday, November 17, 2005 1:09 PM
>To: Roberto Baldessari; nemo
>>From: [email-masked] [mailto:[email-masked]] On Behalf
Of
>Roberto Baldessari
>>Sent: Wednesday, November 16, 2005 6:36 PM
>>To: nemo
>>Subject: [nemo] Distributing the Mobile Prefix in the visited network
>>
>>Hi all,
>>
>>I'm new of this mailing list.
>>How should this be inteded? In case a MR distributes the Mobile Prefix
>>in the visited network, in a way that the Mobile Network is routable
>>directly from the visited network, is the MR non-standard?
>>
>[<PT>] The goal in NEMO was to move prefix around without any route
>injection in the infrastructure. But there is no MUST or MUST NOT the
>text you mention.
>
>Francis provided good reasons why this is not done, in general. The
spec
>does not provide the means for doing it, does not discuss the risks and
>the consequences if this is done. It's just completely out of scope.
>
>But it does not say, never to do it, either. An example where you might
>do it is MANEMO, when MRs form a MANET for such purposes as route
>optimization.
>
>Pascal

---

From: "Roberto Baldessari" <[email-masked]>
Date: Fri, 18 Nov 2005 19:02:12 +0100

Thanks Pascal,

I have already subscribed the list and had a look to the mail archive.
It seems like you are searching for concrete scenarios, and you already
mentioned what we also are dealing with, i.e. car to car communication.
We are considering different strategies and we could contribute to this
starting group. But first we need to gather some information more.
Actually we are not interested in routing protocols, because we assume
the MANET already provided with that.

Best regrards.

Roberto

-----Original Message-----
From: Pascal Thubert (pthubert) [mailto:[email-masked]] 
Sent: Friday, November 18, 2005 6:17 PM
To: Roberto Baldessari; nemo
Subject: RE: [nemo] Distributing the Mobile Prefix in the visited
network

Hi Roberto:

Pascal

Roberto Baldessari
network
Of

spec

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Tue, 22 Nov 2005 15:31:07 +0100

Hi Roberto. 

You're welcome in :)

It seems that you can at least help in securing the requirements and
writing a charter, to make sure that your interests are covered. For
instance, you expect the MANET to be there, but which properties do you
assume in the MANET?

Pascal
Roberto Baldessari
>Sent: Friday, November 18, 2005 7:02 PM
>To: nemo
network
Of

---

From: "Roberto Baldessari" <[email-masked]>
Date: Wed, 23 Nov 2005 18:08:08 +0100

Alexandru,

thanks for your feedback.
The dhcpv6 prefix delegation doesn't seem to match our needs.
This draft relies on the MR-HA tunnel to exchange dhcp packets.

We are considering the case the MR doesn't have continuosly access to
the infrastructure, but is continuosly member of a MANET. We don't
consider Mobile Network Prefix' changes.

Best regards

Roberto

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]] 
Sent: Friday, November 18, 2005 6:27 PM
To: Roberto Baldessari
Cc: nemo
Subject: Re: [nemo] Distributing the Mobile Prefix in the visited
network

> How is the status of that? I didn't find material about.

Would dhcpv6-pd draft-ietf-nemo-dhcpv6-pd-00.txt match the interest?
The draft has text in it about AR distributing prefixes to a moving MR.
 It's not clear though whether session continuity is required.

Are you interested in session continuity at LFN when MR gets a new
prefix?

Alex