Subject: RE: Sub-optimal Terminology (was Re: [nemo]Re: I-D ACTION:draft-ietf-nemo-ro-problem-statement-01.txt)

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Tue, 8 Nov 2005 15:15:46 +0100

There is a topological view, where pinball routing and multi-angular are
contenders, and there is a tunnel view, for which we'd need a term like
telescopic or something. Any idea?

Pascal

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alexandru Petrescu
>Sent: Tuesday, November 08, 2005 3:17 AM
>To: Masafumi Watari
>Cc: IETF NEMO WG; T.J. Kniveton
>Subject: Re: Sub-optimal Terminology (was Re: [nemo]Re: I-D
ACTION:draft-ietf-nemo-ro-problem-
>statement-01.txt)
>
>Masafumi Watari wrote:
>
>> Hi,
>>
>> Alex, thanks for your comments.  Overall, I agree about making it
>> clear on what the problem is.
>>
>> Some comments about the terminology below.
>>
>> On 2005/11/05 7:10, T.J. Kniveton wrote:
>>
>>> On Nov 4, 2005, at 3:41 AM, Chan-Wah Ng wrote:
>>>
>>>> Thanks for the suggestions.  However, I do have a concern over the
>>>> choice of words.  It might suggest that perhaps a terminology is
needed
>>>> for the phenomenon where the routing path is anchored at the home
>>>> agent(s).
>>>>
>>>> In MIPv6, I recall it used to be called "triangular
>>>> routing" (traditionally though, I doubt it is used in RFC3775).
>>>>
>>>> You seems to favour the generalization of this term into "multi-
angular
>>>> routing".  Logical, since with multiple HAs, there would be more
than
>>>> three vertexes.
>>>
>>>
>>> Multi-angular makes less sense to me than triangular.
>>
>>
>> I agree.
>>
>>>>
>>>> In some of the NEMO-related individual drafts (eg.
>>>> draft-thubert-nemo-ro-taxonomy), there have been instances on the
>>>> use of
>>>> "dog-leg routing" and "pinball routing".
>>>
>>>
>>> dog-leg routing is sometimes used to be roughly synonymous to
>>> triangular routing. Pinball routing is a term which describes the
>>> route getting bounced back and forth like a pinball. I don't know
>>> whether it's used in other places in routing literature; I hadn't
>>> heard it before.
>>>
>>>>
>>>> In draft-ietf-nemo-ro-problem-statement, however, we have sticked
to
>>>> the
>>>> very general term "sub-optimal routing".
>>>
>>>
>>>
>>> Sub-optimal routing, as you mentioned, is very general. In fact,
>>> whereas pinball, triangular and dog-leg routing describe routing
>>> phenomena in certain circumstances, sub-optimal routing describes a
>>> general quality, not a specific scenario. It could mean almost
>>> anything other than shortest / cheapest path.
>>
>>
>> In keeping the document at a generic level, I don't see any problem
>> using sub-optimal routing.  I mean with nested-NEMO, you could draw
>> lines that look like a star for example...
>
>A star pictured as a hexagon is "multi-angular" still :-)
>
>I agree with you.  I could live with "sub-optimal" too.
>
>Alex

---

From: Christophe Janneteau <[email-masked]>
Date: Tue, 08 Nov 2005 17:07:32 +0100

Hi,

Is the term "nested tunnels" not the one we used to use?

Christophe