Subject: [nemo] Distributing the Mobile Prefix in the visited network

From: "Roberto Baldessari" <[email-masked]>
Date: Wed, 16 Nov 2005 18:35:38 +0100

Hi all,

I'm new of this mailing list.
I have a question related to the Basic NEMO Protocol.
The RFC says:

"  A Mobile Router does not distribute the
   Mobile Network routes to the infrastructure at its point of
   attachment (i.e., in the visited network) "

How should this be inteded? In case a MR distributes the Mobile Prefix
in the visited network, in a way that the Mobile Network is routable
directly from the visited network, is the MR non-standard?

Thanks in advance.

Roberto

============================================
Roberto Baldessari
Research Staff Member
Network Laboratories, NEC Europe Ltd.
Kurfuerstenanlage 36, D-69115 Heidelberg
Tel.     +49 (0)6221 90511-67
Fax:     +49 (0)6221 90511-55
e-mail:  [email-masked]
============================================

---

From: Francis Dupont <[email-masked]>
Date: Wed, 16 Nov 2005 18:49:17 +0100

In your previous mail you wrote:

   
   How should this be inteded?

=> I can see two reasons for this constraint:
 - security: all the traffic for the Mobile Network is assumed to come
   through the HA-MR tunnel, in particular it always goes through the MR
 - handoff survivability: the short path has to be dismount when the MR
   leaves the visited network.
In fact, this is simply a special case of Routing Optimization which is
still in design and will address these two issues.

Regards

[email-masked]