Subject: RE: [nemo] Extensions to NEMOv4 base for the Charter.

From: "Tsirtsis, George" <[email-masked]>
Date: Thu, 18 May 2006 07:43:00 -0700

Ryuji,

The draft will be available before the deadline for this IETF. Remember
that NEMOv4 base protocol is already done in the context of this working
group. The new draft just proposes some extensions to it.

George

> -----Original Message-----
> From: Ryuji Wakikawa [mailto:[email-masked]]
> Sent: Thursday, May 18, 2006 7:19 AM
> To: Vijay Devarapalli
> Cc: [email-masked]; Thierry Ernst
> Subject: Re: [nemo] Extensions to NEMOv4 base for the Charter.
> 
> I agree, too.
> We should proceed this re-charter right away.
> 
> I have a question on IPv4 only work.
> Are there any ID for FA support and prefix allocation?
> I only saw the discussion whether we need these or not, but not
> requirements, solutions, i.e. technical stuff.
> IPv4 folks can work on this in NEMO WG  and chairs and WG can decide
> whether we really need this specification as RFC in this WG, later.
> If there are only a few arguments on this IPv4 related stuff, maybe
> these items should be discussed in MIP4 or IPv4-NEMO WG.
> 
> regards,
> ryuji
> 
> 
> 
> On 2006/05/18, at 3:34, Vijay Devarapalli wrote:
> 
> > Thierry Ernst wrote:
> >
> >> Discussion is fine, but IMHO agreeing and sending a new charter to
> >> the
> >> IESG is too early at this point of time since there are divergent
> >> point
> >> of views on what we should do or not.  I would rather see this
really
> >> happening for next-next IETF (November). In the meantime, we can
> >> discuss
> >> the deployment requirements (see the other thread) so that we
really
> >> know what is needed.
> >
> > I don't think it is a good idea to put off re-chartering
> > for this long. you can infact re-charter once more in
> > November if you want once we have a clearer picture of
> > what solutions are needed. working on the requirements
> > could be part of the new charter and we can send the
> > charter to the IESG right away. we shouldn't let other
> > items  proposed items in the charter suffer because we
> > want to gather "deployment requirements".
> >
> > Vijay
> >
>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 19 May 2006 01:02:58 +0900

George

Well, NEMO is an extension to MIP6 :-)
We always had enough discussions on how to proceed an extension to  
some work.

I recommend you to publish a draft which has PS and Requirement and  
maybe Solution.

You understand why you need this work because you are working on this,
but most of members are unaware of this necessity and work overhead,  
etc.

Since it's obvious that only few member express interests to v4  
related topic,
it's too early to decide this as NEMO WG topic.
However, it does not mean we exclude this work from NEMO WG forever.
We can move forward whenever the work becomes ready in terms of  
discussion and I-D.

ryuji

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 May 2006 18:46:13 +0200

Ryuji Wakikawa wrote:
> George
> 
> Well, NEMO is an extension to MIP6 :-) We always had enough
> discussions on how to proceed an extension to some work.

I agree.

> I recommend you to publish a draft which has PS and Requirement and 

NEMOv4 draft has a short section 3 on problem statement and
requirements.  It mainly points to 3344 not supporting moving networks
and requires a solution to do both explicit and implicit, not modify the
3344 FAs for NEMOv4 to work and support various mobile entities.

For NEMOv4 FA support this could be extended to say that if FAs are
enhanced from 3344 to NEMOv4 then certain advantages could be obtained.

I could help writing such Problem Statement and Reqs draft, would you
review?

> You understand why you need this work because you are working on
> this, but most of members are unaware of this necessity and work
> overhead, etc.
> 
> related topic, it's too early to decide this as NEMO WG topic. 

Ok,

Alex