Subject: RE: [nemo] Potential conflict on NEMOv4 Type and FA-ERR Type

From: "Tsirtsis, George" <[email-masked]>
Date: Fri, 19 May 2006 11:32:28 -0700

Yes, I think Vijay is right. It is up to IANA and implementations need
to be ready to change to the assigned numbers when the IANA decides. In
the mean time I-D authors can suggest reasonable values just in case
they get it right and so they do not have to change ;-)

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: Friday, May 19, 2006 2:21 PM
> To: Alexandru Petrescu
> Cc: ml-nemo WG
> Subject: Re: [nemo] Potential conflict on NEMOv4 Type and FA-ERR Type
> 
> Alexandru Petrescu wrote:
> > I've been pointed that there seems to be a potential conflict on
NEMOv4
> > Mobile Network Extension Type and FA-Err Type.
> >
> > NEMOv4 uses a new Type (to be assigned by IANA) in Mobile Network
> > Extension.  We suggested in the draft that it be 45.
> >
> > FA-ERR draft-ietf-mip4-faerr-02.txt uses Type 45 for FA Error
Extension
> > (already assigned by IANA).  The draft does not specify 45, just
says
> > TBA by IANA.  IANA seems to have assigned it, see
> > http://www.iana.org/assignments/mobileip-numbers.
> >
> > draft-ietf-mobileip-gen-key-01.txt implemented in dynamics 0.8.1
uses 45
> > too, but I think this can be ignored, because  I think this work has
> > been evolved into draft-rfc3012bis which uses Type 24.
> >
> > To solve the issue between NEMOv4 and FA-ERR I suggest that we use
Type
> > 46 - and not 45 - in NEMOv4 implementation, until IANA assigns a
Type
> > for NEMOv4 Mobile Network Extension.
> >
> > What do you think?
> 
> IMO, you should leave it to be assigned by the IANA.
> not suggest any value at all. IANA will just pick
> the next available one.
> 
> Vijay

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 23 May 2006 11:22:37 +0200

Hi George,

> they get it right and so they do not have to change ;-)

No, please don't do this.  Instead, as I just mentioned in my note to
Vidya, please use the values assigned for experimental work, and leave
the value in the draft as TBA.

Regards,

	Henrik