Subject: RE: [nemo] RE: comments on draft-ietf-nemo-prefix-delegation-00.txt

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Thu, 14 Dec 2006 18:16:23 +0100

I thought I answered this but somehow the mail got lost.

I agree with Vijay's lifetime proposal. 

In fact, the draft lets the MR ask for a prefix length - for instance if
it has multiple interfaces, it can ask for a /60. In a similar fashion,
the MR could ask for a given lifetime.

A - very - temporary prefix might indeed be useful for privacy for,
within or outside NEMO...

What do you think?
 
Pascal

>-----Original Message-----
>From: Vijay Devarapalli [mailto:[email-masked]]
>Sent: Thursday, December 14, 2006 8:31 AM
>To: T.J. Kniveton
>Cc: Pascal Thubert (pthubert); [email-masked]
>Subject: Re: [nemo] RE: comments on
draft-ietf-nemo-prefix-delegation-00.txt
>
>T.J. Kniveton wrote:
>> Sounds like you want to have a method to assign a very temporary MP.
We
>> were thinkFrom [email-masked] Thu Dec 14 12:16:39 2006
Content-class: urn:content-classes:message
Subject: RE: [nemo] RE: comments on draft-ietf-nemo-prefix-delegation-00.txt
Date: Thu, 14 Dec 2006 18:16:23 +0100
From: "Pascal Thubert \(pthubert\)" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>,
	"T.J. Kniveton" <[email-masked]>
Cc: [email-masked]

I thought I answered this but somehow the mail got lost.

I agree with Vijay's lifetime proposal. 

In fact, the draft lets the MR ask for a prefix length - for instance if
it has multiple interfaces, it can ask for a /60. In a similar fashion,
the MR could ask for a given lifetime.

A - very - temporary prefix might indeed be useful for privacy for,
within or outside NEMO...

What do you think?
 
Pascal

>-----Original Message-----
>From: Vijay Devarapalli [mailto:[email-masked]]
>Sent: Thursday, December 14, 2006 8:31 AM
>To: T.J. Kniveton
>Cc: Pascal Thubert (pthubert); [email-masked]
>Subject: Re: [nemo] RE: comments on
draft-ietf-nemo-prefix-delegation-00.txt
>
>T.J. Kniveton wrote:
>> Sounds like you want to have a method to assign a very temporary MP.
We
>> were thinking more about requesting a longer-term MP. I don't really
>> have an opinion about whether one or the other should be preferred,
but
>> usually granting of something like a prefix would be more
longer-term..
>
>Just add a lifetime field to the option. A 32 bit
>lifetime field gives you 136 years of lifetime for
>the mobile network prefix. That should be long
>enough.
>
>This was one of the options I had suggested in my
>earlier mail.
>
>Vijay
>
>>
>> On Dec 12, 2006, at 8:59 PM, Vijay Devarapalli wrote:
>>
>>> I think we can still keep the protocol simple.
>>>
>>> T.J. Kniveton wrote:
>>>> Vijay,
>>>> The draft was intended to be simple, but there is more signaling
info
>>>> that is needed other than just "request and assign" a prefix. For
>>>> instance, how long is the prefix supposed to last for? Is it
permanent?
>>>
>>> Two options.
>>>
>>> 1. Make it last as long the mobile router has a binding
>>> cache entry at the home agent. The prefix after all was
>>> obtained through a Binding Update/Binding Ack exchange
>>> that created the binding cache entry.
>>>
>>> 2. Add a lifetime field to the option which carries the
>>> prefix.
>>>
>>>> How do I negotiate the length of the prefix?
>>>
>>> There is no negotiation. The Home Agent always tells the
>>> MR what the prefix length is. Anyway if the prefix is
>>> going to be assigned to the subnet which corresponds to
>>> the mobile network, it has to be /64.
>>>
>>>> How do I know, if the request fails,
>>>
>>> No response from the HA in the binding ack.
>>>
>>>> why it failed
>>>
>>> Does it matter to the mobile router? The mobile router
>>> just needs to know that the HA can't assign it any
>>> prefix.
>>>
>>>> and what I should do about it?
>>>
>>> Try another Home Agent? If that fails too bail out?
>>>
>>> Vijay
>>>
>>

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Thu, 14 Dec 2006 18:16:20 +0100

but
longer-term..
info
permanent?

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Thu, 14 Dec 2006 18:16:20 +0100

Please do; we need to make sure that they are aware before last call.

As of the exercise, a new attribute for the MNP seems an obvious
requirement.

If the MR uses SeND over the Mobile Network, it needs some ownership
certificate as well. 

What else?

Pascal

>From: Vijay Devarapalli [mailto:[email-masked]]
>Sent: Thursday, December 14, 2006 6:04 PM
>To: Pascal Thubert (pthubert)
>Cc: [email-masked]; [email-masked]
>
>Pascal Thubert (pthubert) wrote:
>> Makes sense...
>>
>> Did you get in touch with the authors already?
>
>I could bring it up. In fact it might be a good exercise
>in the NEMO WG to figure out what all needs to be added
>between the HA and the AAAH for NEMOv6 to work. Then we
>can extend those documents.
>
>Vijay
>
>>
>> Pascal
>>
>>> Sent: Thursday, December 14, 2006 5:57 PM
>>> To: Pascal Thubert (pthubert)
>>> Cc: [email-masked]; [email-masked]
>>> Pascal Thubert (pthubert) wrote:
>>>
>>>> On the constructive side, I'd say that the radius attributes for
NEMO
>> (:
>>>> the protocol, not the user :) are still to be defined - maybe
>> extending
>>>> RFC 2868 for NEMO tunnels? If someone is interested in moving
forward
>>>> with that effort, please raise your hand!
>>> Nope. We should be extending the following drafts.
>>> http://www.ietf.org/internet-drafts/draft-ietf-mip6-radius-01.txt
>>>
http://www.ietf.org/internet-drafts/draft-ietf-dime-mip6-split-01.txt
>>> Vijay

3A [nemo] RE: comments on draft-ietf-nemo-pref
	ix-delegation-00.txt |Sender: ;
	bh=5jOUFzAWaUctc2cB0J9C07V/Ug7Qn7/AJh9trQBRbAg=;
	b=Mq3y8SBd7TiNmPyEwcx0DLhC7Ha7HbrcXE1NaPcnpFvOCmqURiCY/EbZZeNcba/hGapt3j6X
	IXEwGp29agdtui2/FlXMyuSrHWoqYzifQ/Wf+xXkAIraqX9Syu4FB6j5;
Cc: [email-masked], [email-masked]

Please do; we need to make sure that they are aware before last call.

As of the exercise, a new attribute for the MNP seems an obvious
requirement.

If the MR uses SeND over the Mobile Network, it needs some ownership
certificate as well. 

What else?

Pascal

>From: Vijay Devarapalli [mailto:[email-masked]]
>Sent: Thursday, December 14, 2006 6:04 PM
>To: Pascal Thubert (pthubert)
>Cc: [email-masked]; [email-masked]
>
>Pascal Thubert (pthubert) wrote:
>> Makes sense...
>>
>> Did you get in touch with the authors already?
>
>I could bring it up. In fact it might be a good exercise
>in the NEMO WG to figure out what all needs to be added
>between the HA and the AAAH for NEMOv6 to work. Then we
>can extend those documents.
>
>Vijay
>
>>
>> Pascal
>>
>>> Sent: Thursday, December 14, 2006 5:57 PM
>>> To: Pascal Thubert (pthubert)
>>> Cc: [email-masked]; [email-masked]
>>> Pascal Thubert (pthubert) wrote:
>>>
>>>> On the constructive side, I'd say that the radius attributes for
NEMO
>> (:
>>>> the protocol, not the user :) are still to be defined - maybe
>> extending
>>>> RFC 2868 for NEMO tunnels? If someone is interested in moving
forward
>>>> with that effort, please raise your hand!
>>> Nope. We should be extending the following drafts.
>>> http://www.ietf.org/internet-drafts/draft-ietf-mip6-radius-01.txt
>>>
http://www.ietf.org/internet-drafts/draft-ietf-dime-mip6-split-01.txt