Subject: [MEXT] Query on Binding Revocation Procedure for Proxy Mobile IPv6

From: "Magesh Shanmugam" <[email-masked]>
Date: Tue, 29 Jul 2008 20:53:04 +0530

Ahmad

Since the Binding Revocation proceudre (i.e. exchange of BRI & BRA)
can be triggered by any node in Proxy Mobile IPv6, is it possible that
both MAG & LMA can trigger BRI message simultaneously (due to some
adminstrative reasons)

i.e. MAG sends a BRI with G bit set (i.e. bulk revocation of PMIPv6
bindings) and LMA sends a BRI with either one PMIPv6 binding
revocation or G bit set for bulk PMIPv6 binding revocation.  Both the
BRI messages does not set the A bit in BRI, hence won't wait for ACK.

What should be the behavior at MAG & LMA.

Thanks
S Magesh
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 30 Jul 2008 01:06:46 -0500

Magesh,

Let me try to address in the following way:

1. From administrative prospective, it is sometimes hard to imagine that
the administrative decision would come through the two different nodes,
but I agree this could be looked at from a race condition where the
administrative reasons are different, but possible.

2. This case needs to be addressed as a race condition and should be
handled as follows:
2.1. In case of Global revocation, we MUST mandate that the node which
send a BRI with the 'G' bit is set MUST also set the A bit, since this
BRI is related to many sessions not a single one.

2.2. Even if the A bit is not set in the BRI, if the BRI is
authenticated and securely protected, the receiving node must process
the BRI and delete the session, if the session is already deleted, then
the receiving node does not need to do any thing extra.

Hope this address your concern.

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Magesh Shanmugam
> Sent: Tuesday, July 29, 2008 4:23 PM
> To: [email-masked]
> Subject: [MEXT] Query on Binding Revocation Procedure for 
> Proxy Mobile IPv6
> 
> Ahmad
> 
> Since the Binding Revocation proceudre (i.e. exchange of BRI 
> & BRA) can be triggered by any node in Proxy Mobile IPv6, is 
> it possible that both MAG & LMA can trigger BRI message 
> simultaneously (due to some adminstrative reasons)
> 
> revocation or G bit set for bulk PMIPv6 binding revocation.  
> Both the BRI messages does not set the A bit in BRI, hence 
> won't wait for ACK.
>

---

From: "Magesh Shanmugam" <[email-masked]>
Date: Wed, 30 Jul 2008 11:50:51 +0530

Ahmad

Thanks for your explanation.

My query here is that when MAG sends a BRI with G bit set, but not A
bit, then immediately after sending the BRI it will clean up its
resources (i.e. Binding Update List and other related resources), but
at the LMA side if the cleaning up of resource is partial success
(i.e. not all the resources are cleaned-up), then what should be the
behavior at MAG, since it might have cleaned up all the resources.

Regards
S Magesh

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 30 Jul 2008 01:27:23 -0500

Magesh,

As I said, we will mandate the A bit when the G bit is set. 
On the other hand, I understand your concern as the MAG cleaned all
sessions, e.g. 1-10. sine the A bit is not set. The LMA received BRI to
clean 10 sessions but it already cleaned 1. right?

The LMA needs to clean the remaining 9. that is it.
The MAG already cleaned the session indicated in the LMA BRI and 9 more.
Nothing else should be done.

Now: As a follow up to the new behavior, i.e. G bit is set then A bit is
always set, In case the same scenario happened, then the LMA will send a
BRA with status code "success" since all session have been deleted
anyway.

Regards,
Ahmad

> From: Magesh Shanmugam [mailto:[email-masked]] 
> Sent: Wednesday, July 30, 2008 7:21 AM
> To: Muhanna, Ahmad (RICH1:2H10); [email-masked]
> Subject: Re: [MEXT] Query on Binding Revocation Procedure for 
> Proxy Mobile IPv6
> 
> Ahmad
> 
> My query here is that when MAG sends a BRI with G bit set, 
> but not A bit, then immediately after sending the BRI it will 
> clean up its resources (i.e. Binding Update List and other 
> related resources), but at the LMA side if the cleaning up of 
> resource is partial success (i.e. not all the resources are 
> cleaned-up), then what should be the behavior at MAG, since 
> it might have cleaned up all the resources.
> 
> Regards
> S Magesh
> 
> 
> > 1. From administrative prospective, it is sometimes hard to imagine 
> > that the administrative decision would come through the two 
> different 
> > nodes, but I agree this could be looked at from a race 
> condition where 
> > the administrative reasons are different, but possible.
> >
> > the BRI and delete the session, if the session is already deleted, 
> > then the receiving node does not need to do any thing extra.
> >
> > > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > > Of Magesh Shanmugam
> > > Subject: [MEXT] Query on Binding Revocation Procedure for Proxy 
> > > Mobile IPv6
> > >
> > > Ahmad
> > >
> > > can be triggered by any node in Proxy Mobile IPv6, is it possible 
> > > that both MAG & LMA can trigger BRI message 
> simultaneously (due to 
> > > Both the BRI messages does not set the A bit in BRI, hence won't 
> > > wait for ACK.
> > >

---

From: "Magesh Shanmugam" <[email-masked]>
Date: Wed, 30 Jul 2008 12:37:31 +0530

Ahmad

I'm fine mandating A bit, when either MAG or LMA triggers BRI with G bit set.

Thanks
S Magesh

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 30 Jul 2008 06:06:48 -0400

Hi Ahmad,

A related question. Why don't we set the 'A' bit all the time? It seems
to me that it is a good idea to get a confirmation any time you revoke a
binding.

Vijay 

> Behalf Of Ahmad Muhanna
> Sent: Tuesday, July 29, 2008 11:27 PM
> To: Magesh Shanmugam; [email-masked]
> Proxy MobileIPv6

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 30 Jul 2008 06:54:48 -0500

Hi Vijay,

That is not a bad idea. If people on the list think that the 'A' bit
needs to be set all the times, then I can update the document
accordingly.

My personal opinion, the famous 'should' will give the needed
flexibility while we mandate the obvious behavior, i.e. in global
revocation.

Regards,
Ahmad

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Wednesday, July 30, 2008 11:07 AM
> To: Muhanna, Ahmad (RICH1:2H10); Magesh Shanmugam; [email-masked]
> Subject: RE: [MEXT] Query on Binding Revocation Procedure for 
> Proxy MobileIPv6
> 
> Hi Ahmad,
> 
> A related question. Why don't we set the 'A' bit all the 
> time? It seems to me that it is a good idea to get a 
> confirmation any time you revoke a binding.
> 
> Vijay 
> 
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of Ahmad Muhanna
> > Subject: Re: [MEXT] Query on Binding Revocation Procedure for Proxy 
> > MobileIPv6
> > 
> > Magesh,
> > 
> > sessions, e.g. 1-10. sine the A bit is not set. The LMA 
> received BRI 
> > to clean 10 sessions but it already cleaned 1. right?
> > 
> > Now: As a follow up to the new behavior, i.e. G bit is set 
> then A bit 
> > is always set, In case the same scenario happened, then the 
> LMA will 
> > send a BRA with status code "success" since all session have been 
> > deleted anyway.
> > 
> > 
> > Regards,
> > Ahmad
> >  
> >