Subject: Re: [MEXT] A comment on draft-ietf-monami6-multiplecoa-09.txt

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 5 Nov 2008 14:24:22 -0500

Hi Juan, 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Juan A. Ternero
> Sent: Thursday, October 23, 2008 10:59 AM
> To: [email-masked]
> Subject: [MEXT] A comment on draft-ietf-monami6-multiplecoa-09.txt
> 
> Dear members:
> Length field in Binding Identifier Mobility Option is explained
> as follows:
> "Length
> 
> 8-bit unsigned integer.  Length of the option, in octets,
> excluding the Type and Length fields.  It MUST be set to either 4,
> 12, or 20 depending on the care-of address field.  When the
> care-of address is not carried by this option, the length value
> MUST be set to 4.  If the IPv4 care-of address is stored in the
> care-of address field, the length MUST be 12.  Otherwise, the
> Length value MUST be set to 20 for IPv6 care-of address."
> 
> According to that, possible values of length field are only 4-12-20
> (4=No_CoA, 12=IPv4_CoA, 20=IPv6_CoA).
> 
> I have read last versions of the draft and I have detected that
> possible values of this field changed from 4-8-20 in version 06
> to 4-12-20 in version 07.
> I think the correct ones are 4-8-20, because an IPv4 address only
> adds 4 bytes to the option.
> 
> In that case, alignment should be modified from:
> 
> "The Binding Identifier Mobility Option has an alignment requirement
> of 2n if the Care-of Address field is not present. Otherwise, it has
> the alignment requirement of 8n + 2."
> 
> to
> 
> "The Binding Identifier Mobility Option has an alignment requirement
> of 2n if the Care-of Address field is not present, 4n+2 if the Care-of
> Address field stores an IPv4 address, an 8n+2 if the Care-of Address
> field stores an IPv6 address."

Thanks for catching this. Will be fixed in the next version.

Vijay
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 08 Nov 2008 13:20:03 +0900

Hi Juan,

Thanks for your review.
We will fix your point in the next revision.

thanks
ryuji

At Wed, 5 Nov 2008 14:24:22 -0500,