Subject: [MEXT] A few findings on the binding revocation draft

From: Teemu Rinta-aho <[email-masked]>
Date: Mon, 3 Nov 2008 12:26:43 +0200 (EET)

Hi all,

here are some newcomer's findings on the
binding revocation draft -01:

1) In Fig 2 and 3 there is a field "Cause" in BRA.
    Where is it defined in more detail?

2) In 9.1.1. it is stated that "The Global (G) bit MUST
    be set and..." without any conditions. However, in the
    next bullet, it is stated that "Whenever the Global (G)
    bit is set", implying that it does not always need to
    be set. These texts are controversial and should be fixed.

Some typos found:

3.4.3: "LMA may only supports IPv4" -> "LMA may only support IPv4"

8.2: "the home SHOULD examine" -> "the home agent SHOULD examine"

      "the home agent delete" -> "the home agent deletes"

9.1.1: "anchor send a" -> "anchor sends a"

        "LMA MUST sends a" -> "LMA MUST send a"

Best regards,
Teemu Rinta-aho

--
Teemu Rinta-aho                    Tel: +358 9 299 3078
NomadicLab, Ericsson Research      Fax: +358 9 299 3535
Oy L M Ericsson Ab                 Mobile: +358 40 562 3066
FIN-02420 Jorvas, Finland          E-mail: [email-masked]
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 3 Nov 2008 11:02:46 -0600

Hi Teemu,

Thanks for the comments. Please see inline.

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Teemu Rinta-aho
> Sent: Monday, November 03, 2008 4:27 AM
> To: [email-masked]
> Subject: [MEXT] A few findings on the binding revocation draft
> 
> Hi all,
> 
> here are some newcomer's findings on the binding revocation draft -01:
> 

[Ahmad]
Thanks. This needs to be corrected and replaced by "Status"

>     be set. These texts are controversial and should be fixed.

[Ahmad]
I do not think that there is any contradiction in there. In the first
bullet, if you continue reading you find the following: ".... to request
the mobile access gateway to remove all Per-Peer bindings that are
registered with the LMA and hosted at this MAG."

We could rearrange the bullet to read as follows:

In case of revoking all Per-Peer bindings, the Global (G) bit MUST be
set and the Revocation Trigger MUST contain a value of "Per-Peer Policy"
in the Binding Revocation Indication to request the mobile access
gateway to remove all Per-
Peer bindings that are registered with the LMA and hosted at this MAG.

Would that makes it clearer?

>         "LMA MUST sends a" -> "LMA MUST send a"

[Ahmad]
Thanks. Will take care of them.

---

From: Julien Laganier <[email-masked]>
Date: Tue, 4 Nov 2008 09:17:37 +0100

Hello Ahmad,

Another finding in 9.1.1. Sending Binding Revocation Indication:

   When the mobile node is registered with an IPv4 proxy home address in
   addition to the Home Network Prefix where both of the IPv4 pHoA and
   HNP are bound to the same proxy CoA, the local mobility anchor MAY
   revoke the mobile node IPv4 proxy HoA binding to the current mobile
   node proxy CoA while maintaining the mobile node binding of the HNP
   to its current pCoA as part of the mobile node BCE.  In this case, if
   the LMA decides to revoke the mobile node IPv4 proxy HoA ONLY, the
   LMA MUST sends a BRI message following the procedure in Section 7.1
   and the following rules:

   o  The Acknowledge (A) bit MUST be set in the BRI to request the MAG
      to send a BRA message.

   o  The Revocation Trigger field MUST be set to "IPv4 HoA Binding
      ONLY".

But the "IPv4 HoA Binding ONLY" revocation trigger isn't listed in 6.1.  
Binding Revocation Indication Message:

   Revocation Trigger

      8-bit unsigned integer indicting the event which triggered the
      revoking node to send the BRI message.  The following Revocation
      Trigger values are currently defined:

          0  Reserved.
          1  Unspecified.
          2  Administrative Reason.
          3  Inter-MAG Handoff - same Access Types.
          4  Inter-MAG Handoff - different Access Types.
          5  Inter-MAG - Unknown Handoff.
          6  Per-Peer Policy.
          7  Revoking Node Local Policy.
          8  User Initiated Session(s) Termination.
          9  Access Network Session(s) Termination.
          10  Possible Out-of Sync BCE State.
          250-255 Reserved For Testing Purposes only.
          All other values are Reserved.

Cheers,

--julien

On Monday 03 November 2008, Ahmad Muhanna wrote:
> bullet, if you continue reading you find the following: ".... to
> request the mobile access gateway to remove all Per-Peer bindings
> that are registered with the LMA and hosted at this MAG."
>
> set and the Revocation Trigger MUST contain a value of "Per-Peer
> Policy" in the Binding Revocation Indication to request the mobile
> access gateway to remove all Per-

-- 
--julien

[ New email address: [email-masked] ]
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Teemu Rinta-aho <[email-masked]>
Date: Tue, 04 Nov 2008 12:08:55 +0200

Hi Ahmad,

> Peer bindings that are registered with the LMA and hosted at this MAG.

maybe it was not a critical problem, but I think this version
is clearer and should be used to replace the current version.
Thanks!

Best regards,
Teemu

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 4 Nov 2008 07:41:48 -0600

Hi Julien,
Yes, that was an oversight and will be fixed in the next revision.

We will publish a new revision with all of the identified
comments/correction after the IETF-73 discussion/meeting hoping that
revision will be ready for a wg Last Call.

Regards,
Ahmad

> From: Julien Laganier [mailto:[email-masked]] 
> Sent: Tuesday, November 04, 2008 2:18 AM
> To: [email-masked]
> Cc: Muhanna, Ahmad (RICH1:2H10); Teemu Rinta-aho
> Subject: Re: [MEXT] A few findings on the binding revocation draft
> 
> Hello Ahmad,
> 
> > > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > > Of Teemu Rinta-aho
> > request the mobile access gateway to remove all Per-Peer 
> bindings that 
> > are registered with the LMA and hosted at this MAG."
> >
> > access gateway to remove all Per- Peer bindings that are registered 
> > with the LMA and hosted at this MAG.
> >