Subject: Re: [MEXT] Issue #11: De-registration when returning home

From: "Giaretta, Gerardo" <[email-masked]>
Date: Sat, 1 Nov 2008 21:09:52 -0700

Hi Vijay, 

this is fine to me

Thanks
Gerardo

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Vijay Devarapalli [[email-masked]]
Sent: Friday, October 31, 2008 3:56 PM
To: Charles E. Perkins; [email-masked]
Subject: Re: [MEXT] Issue #11: De-registration when returning home

Hi Charlie,

In the previous discussions on this issue (July 2008), we had almost
concluded on the following text.

   A mobile node detects that it has returned to its home link through
   the movement detection algorithm in use (Section 11.5.1), when the
   mobile node detects that its home subnet prefix is again on-link.
   To be able to send and receive packets using its home address from
   the home link, the mobile node MUST send a Binding Update to its
   home agent to instruct its home agent to no longer intercept or
   tunnel packets for it. Until the mobile node sends a de-registration
   Binding Update, it will not be able to send and receive packets
   using its home address from the home link. The home agent will
   continue to intercept all packets sent to the mobile's home address
   and tunnel to the previously registered care-of address.

Only Sri had an objection to this text. He was objecting to the last two
sentences.

   Until the mobile node sends a de-registration
   Binding Update, it will not be able to send and receive packets
   using its home address from the home link. The home agent will
   continue to intercept all packets sent to the mobile's home address
   and tunnel to the previously registered care-of address.

For the last sentences, we can replace the text with what you proposed
in your email. So the final text would be

   A mobile node detects that it has returned to its home link through
   the movement detection algorithm in use (Section 11.5.1), when the
   mobile node detects that its home subnet prefix is again on-link.
   To be able to send and receive packets using its home address from
   the home link, the mobile node MUST send a Binding Update to its
   home agent to instruct its home agent to no longer intercept or
   tunnel packets for it. Until the mobile node sends such a
   de-registration Binding Update, it MUST NOT attempt to send and
   receive packets using its home address from the home link. The home
   agent will continue to intercept all packets sent to the mobile's
   home address and tunnel to the previously registered care-of address.

Is this acceptable?

Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Charles E. Perkins
> Sent: Wednesday, October 01, 2008 11:51 AM
> To: [email-masked]
> Subject: [MEXT] Issue #11: De-registration when returning home
>
>
> Hello folks,
>
> Perhaps this issue is ready to be closed.
>
> I suggest we use the text offered by George
> Tsirtsis, but with one additional change:
>
>
>
> OLD Text:
>
> 11.5.5.  Returning Home
>
>    A mobile node detects that it has returned to its home link through
>    the movement detection algorithm in use (Section 11.5.2).
> The mobile
>    node SHOULD then send a Binding Update to its home agent,
> to instruct
>    its home agent to no longer intercept or tunnel packets for it.
>
>
>
> George's Text:
>
> 11.5.5.  Returning Home
>
>    A mobile node detects that it has returned to its home link through
>    the movement detection algorithm in use (Section 11.5.2), when the
>    mobile node detects that its home subnet prefix is again on-link.
>    The mobile node SHOULD then send a Binding Update to its
> home agent,
>    to instruct its home agent to no longer intercept or tunnel packets
>    for it.  Until the mobile node sends a de-registration
> Binding Update,
>    it will not be able to send and receive packets using its
> home address
>    from the home link. The home agent will continue to intercept all
>    packets sent to the mobile's home address and tunnel to
> the previously
>    registered care-of address.
>
>
>
> A slightly amended version of George's Text:
>
> 11.5.5.  Returning Home
>
>    A mobile node detects that it has returned to its home link through
>    the movement detection algorithm in use (Section 11.5.2), when the
>    mobile node detects that its home subnet prefix is again on-link.
>    The mobile node SHOULD then send a Binding Update to its
> home agent,
>    to instruct its home agent to no longer intercept or tunnel packets
>    for it.  Until the mobile node sends such a de-registration Binding
>    Update, it MUST NOT attempt to send and receive packets using its
>    home address from the home link. The home agent will continue to
>    intercept all packets sent to the mobile's home address and tunnel
>    to the previously registered care-of address.
>
> ==================================================
>
> Regards,
> Charlie P.
>
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext
>
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 8 Nov 2008 13:48:53 +0900

Hi Charlie and VIjay,

If MN knows that HA no longer holds the binding for MN,
there is no reason to send deregistration BU.
Two examples.
- MN returns home after its binding is expired.
- MN bootstraps from the home link.

If the above two cases are not equivalent to "returning home",
I am fine with your text.

thanks,
ryuji

---

From: "Giaretta, Gerardo" <[email-masked]>
Date: Fri, 7 Nov 2008 21:13:23 -0800

Hi Ryuji,

I agree with you on the points below but I think those scenarios are not part of the case described in this section. In the first case there is no entry in the BUL of the MN so the MN has no state to clear at the HA. The second case implies a home link detection procedure of the MN which is different from a returning home scenario

Thanks
Gerardo
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ryuji Wakikawa [[email-masked]]
Sent: Friday, November 07, 2008 8:48 PM
To: Vijay Devarapalli
Cc: [email-masked]
Subject: Re: [MEXT] Issue #11: De-registration when returning home

Hi Charlie and VIjay,

thanks,
ryuji

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 10 Nov 2008 17:54:17 +0900

Hi Gerardo,

Thanks for clarification :-)

ryuji

On 2008/11/08, at 14:13, Giaretta, Gerardo wrote:

> Hi Ryuji,
>
> I agree with you on the points below but I think those scenarios are  
> not part of the case described in this section.
> In the first case there is no entry in the BUL of the MN so the MN  
> has no state to clear at the HA.
> The second case implies a home link detection procedure of the MN  
> which is different from a returning home scenario
>
> Thanks
> Gerardo
> From: [email-masked] [[email-masked]] On Behalf Of  
> Ryuji Wakikawa [[email-masked]]