Subject: RE: interim meeting - clarifications

From: "Hector Trevino \(htrevino\)" <[email-masked]>
Date: Wed, 6 Sep 2006 08:27:39 -0700

Just to make sure... are you suggesting this to be included in the
notifications draft or some new document to be done at a later time.

> -----Original Message-----
> From: Andy Bierman [mailto:[email-masked]] 
> Sent: Wednesday, September 06, 2006 8:46 AM
> To: Hector Trevino (htrevino)
> Cc: [email-masked]
> Subject: Re: interim meeting - clarifications
> 
> Hector Trevino (htrevino) wrote:
> >  
> > Andy,
> >  
> >  
> >  
> >  From meeting minutes
> > 
> > 5.4) Filtering
> > 
> >  
> > 
> > The use of POSIX regular expressions is planned for this
> > 
> > feature.  There are still a lot of details that need to
> > 
> > be written down before an interoperable filtering
> > 
> > mechanism (i.e., same NETCONF behavior across agents)
> > 
> > is fully defined.
> > 
> >  
> > 
> > It was noted that the function library of XPATH 2.0 supports
> > 
> > regular expressions in the function library. XPATH 1.0 does
> > 
> > not have something like that.
> > 
> >  
> > 
> > The authors will propose some text in the next revision of
> > 
> > the Notifications I-D.
> > 
> >  
> > Question: The current notifications draft uses the same filtering 
> > mechanism as those identified in the netconf protocol doc. 
> Wouldn't it 
> > be more appropriate to add this information (i.e. filtering using 
> > XPATH 2.0 reg exp) to the main protocol document after it 
> becomes an 
> > RFC? By doing this we maintain the two docs in sync wrt 
> filtering features.
> > thanks
> > 
> 
> IMO, it would be more appropriate to put this new filtering 
> in a separate document, with its own capability.  The base 
> protocol doesn't need to change to add a new capability.
> 
> 
> > Hector Trevino
> 
> Andy
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 06 Sep 2006 09:14:00 -0700

> notifications draft or some new document to be done at a later time.

I don't know:
  - how much text this capability needs
  - what the WG wants

I think it would be fine to put it in the next Notifications
draft, and after the WG reads it, this decision can be made
by the WG.

Andy