Subject: Re: [Netconf] [netmod] leaf encoding rules

From: Balazs Lengyel <[email-masked]>
Date: Fri, 08 Aug 2008 11:18:14 +0200

Martin Bjorklund wrote:
>>     A NETCONF server that replies to a <get> or <get-config> request MAY
>>     choose not to send the leaf element if its value is the default
>>     value.  Thus, a client that receives an <rpc-reply> for a <get> or
>>     <get-config> request, must be prepared to handle the case that a leaf
>>     node with a default value is not present in the XML.  In this case,
>>     the value used by the server is known to be the default value.
>>
>>
>> I strongly object to this paragraph.
>> It has no place in the YANG specification.
>> If you want to modify the NETCONF operations,
>> then do it in the NETCONF WG.
> 
> I don't agree that the NETCONF operation is changed.  rfc4741 does not
> say one way or the other re. defaults.  NETCONF has no concept of
> default values.
> 
> The intention of this paragraph is to allow a capability such as
> 'with-defaults' to control if defaults are sent or not.  IMO it is
> better to keep this paragraph - if we remove it people will not know
> if defaults should always be sent or what the intention of YANG was.
> Esp. since there is no standard 'with-defaults' capability, and it
> does not seem that it will get standardized any time soon.
> 

Maybe we should get with-defaults standardized.

I hereby ask the NETCONF/NETMOD community and specially the chairs of NETCONF if they would 
accept as a new NETCONF work item a small draft adding a with-defaults option to Netconf as a 
capability. As my Partial locking draft seems to wind down (Is this wishful thinking :-) I 
might even volunteer to write a draft on with-defaults.

Opinions? Good idea? Feasible idea?

Balazs
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 08 Aug 2008 11:18:14 +0200

Balazs

---

From: Andy Bierman <[email-masked]>
Date: Fri, 08 Aug 2008 02:48:54 -0700

Balazs Lengyel wrote:
>> does not seem that it wiFrom [email-masked]  Fri Aug  8 02:55:39 2008
Date: Fri, 08 Aug 2008 02:48:54 -0700
From: Andy Bierman <[email-masked]>
To: Balazs Lengyel <[email-masked]>
Cc: [email-masked], netconf mailing list <[email-masked]>
Subject: Re: [Netconf] [netmod] leaf encoding rules
Sender: [email-masked]

Balazs Lengyel wrote:
>> does not seem thatll get standardized any time soon.
>>
> 
> I hereby ask the NETCONF/NETMOD community and specially the chairs of 
> NETCONF if they would accept as a new NETCONF work item a small draft 
> adding a with-defaults option to Netconf as a capability. As my Partial 
> locking draft seems to wind down (Is this wishful thinking :-) I might 
> even volunteer to write a draft on with-defaults.
> 

You mean something like this:

http://tools.ietf.org/html/draft-bierman-ncx-ext-00

I would be interested in pulling out just the with-defaults
and republishing this draft.  IMO, a capability is overkill,
but if an agent wants to suppress defaults unless explicitly
requested to send them, that should be OK, as long
as there is a status flag the manager can retrieve that
indicates this is how the agent works.

> Opinions? Good idea? Feasible idea?

Andy

 it will get standardized any time soon.
> I hereby ask the NETCONF/NETMOD community and specially the chairs of 
> NETCONF if they would accept as a new NETCONF work item a small draft 
> adding a with-defaults option to Netconf as a capability. As my Partial 
> locking draft seems to wind down (Is this wishful thinking :-) I might 
> even volunteer to write a draft on with-defaults.
> 

You mean something like this:

http://tools.ietf.org/html/draft-bierman-ncx-ext-00

I would be interested in pulling out just the with-defaults
and republishing this draft.  IMO, a capability is overkill,
but if an agent wants to suppress defaults unless explicitly
requested to send them, that should be OK, as long
as there is a status flag the manager can retrieve that
indicates this is how the agent works.

> Opinions? Good idea? Feasible idea?

Andy

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 08 Aug 2008 12:12:15 +0200

Andy Bierman wrote:
>> adding a with-defaults option to Netconf as a capability. As my 
>> Partial locking draft seems to wind down (Is this wishful thinking :-) 
>> I might even volunteer to write a draft on with-defaults.
>>
> 
I think that would be splendid. The flag you mention could go into the Netconf Monitoring model 
Scott is working on (timing, extensibility of that model). On the other hand some might argue, 
that if we already have one method to indicate optional behavior (capabilities) why invent a 
second one (flags).

If you do this yourself good. if you think I should help or do it myself say so.
Balazs
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 08 Aug 2008 12:12:15 +0200

---

From: Phil Shafer <[email-masked]>
Date: Fri, 08 Aug 2008 14:15:28 -0400

>http://tools.ietf.org/html/draft-bierman-ncx-ext-00

Two comments:
(a) with-defaults shouldn't be an attribute on <rpc>.  It should be
an element on the appropriate RPCs (get-config).
(b) Having a mechanism to learn default values is fine, but since
defaults will increase the size of configurations by several orders
of magnitude, making this the base behavior is a Very Bad Idea.  It
should be an option.

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Fri, 08 Aug 2008 14:15:28 -0400

Two comments:

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Fri, 08 Aug 2008 15:06:46 -0700

> an element on the appropriate RPCs (get-config).

IMO, it is easier and more consistent to use the XML attribute
mechanism already defined for the <rpc> element. The same mechanism works
for all standard and vendor RPC methods.

> of magnitude, making this the base behavior is a Very Bad Idea.  It

agreed.

A read-only leaf in the netconf-state spec is fine.

But if you support the (separate) 'with-defaults' capability,
then you must return these default leafs when 'with-defaults'
is set to true.

It is OK to make this a marketing decision, similar to
retrieving all the YANG, XSD, or RNG files directly
from the agent.  IMO, NE devices will continue to get smarter,
and 1 way to do that is to help the operator quickly get
out of a jam with instant, context-sensitive documentation.

Andy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinFrom [email-masked]  Fri Aug  8 15:13:30 2008
Date: Fri, 08 Aug 2008 15:06:46 -0700
From: Andy Bierman <[email-masked]>
To: Phil Shafer <[email-masked]>
Cc: netconf mailing list <[email-masked]>, [email-masked]
Subject: Re: [Netconf] [netmod] leaf encoding rules
Sender: [email-masked]

> an element on the appropriate RPCs (get-config).

IMO, it is easier and more consistent to use the XML attribute
mechanism already defined for the <rpc> element. The same mechanism works
for all standard and vendor RPC methods.

> of magnitude, making this the base behavior is a Very Bad Idea.  It

agreed.

A read-only leaf in the netconf-state spec is fine.

But if you support the (separate) 'with-defaults' capability,
then you must return these default leafs when 'with-defaults'
is set to true.

It is OK to make this a marketing decision, similar to
retrieving all the YANG, XSD, or RNG files directly
from the agent.  IMO, NE devices will continue to get smarter,
and 1 way to do that is to help the operator quickly get
out of a jam with instant, context-sensitive documentation.

Andy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/fo/netconf

listinfo/netconf

---

From: Phil Shafer <[email-masked]>
Date: Sat, 09 Aug 2008 17:11:44 -0400

>for all standard and vendor RPC methods.

"works" != "makes sense".  with-defaults makes no sense for many
RPCs.  It should only be defined for those RPCs where it makes sense.
Imagine if we allow this as a general concept and everyone starts
stuffing all their cruft in <rpc> because is "easier".

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Sat, 09 Aug 2008 17:11:44 -0400

Thanks,
 Phil