Subject: [Netconf] continue-on-error

From: Andy Bierman <[email-masked]>
Date: Tue, 19 Aug 2008 14:05:37 -0700

Hi,

RFC 4741 is fairly vague on what exactly happens when
continue-on-error is given as the edit-config error-option.
(The test-option test-then-set is just as vague).

It would be nice if an agent using YANG data models
behaved in a deterministic manner for this knob.

Is there any scoping that can be standardized, for example?

I interpret continue-on-error to mean continue to
the next child of <config> (i.e., top-level element
in an XML namespace).  This is rather conservative,
and maybe a finer granularity could be defined.

But first, does anybody implement continue-on-error,
and if so, what does it really mean in your agent?

thanks,
Andy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 20 Aug 2008 00:12:32 +0200 (CEST)

> (The test-option test-then-set is just as vague).

Yes, the "continue" part is unclear, and also the "error" part is
unclear.

> Is there any scoping that can be standardized, for example?

The motivation for this that I've been told is to support something
like when you upload an old cli backup file, and some commands are now
obsolete, and you just want to ignore them.

For this particular use case, I think it could make sense to define
"continue" to mean skip the faulty XML element, and "error" to occur
when an unknown element is encountered.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 20 Aug 2008 00:12:32 +0200 (CEST)

/martin

---

From: Phil Shafer <[email-masked]>
Date: Wed, 20 Aug 2008 17:34:21 -0400

>and if so, what does it really mean in your agent?

"continue-on-error" means "do your best to keep going".
"your best" can't be defined easily, since you're
facing input that contains errors.

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Wed, 20 Aug 2008 17:34:21 -0400

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Fri, 22 Aug 2008 15:29:36 -0700

> facing input that contains errors.

pretty vague.
I used to think it meant there are no errors
detected in syntax or constraints, but if
an error occurred trying to apply the <edit-config>
(e.g., malloc failed), then try to continue.

Clearly this is the intent if test-option 'test-then-set' is true.
(It actually requires more -- a <validate> must succeed too.)

But for my internal <load-config> operation, using the
same infrastructure as <edit-config>, I want to
skip over syntax errors in one subtree if another subtree
is good.

You are suggesting that even for <edit-config>, skipping
over invalid well-formed XML is OK for 'continue-on-error'.
Seems fine to me, since the spec doesn't really say.

Andy

---

From: Andy Bierman <[email-masked]>
Date: Fri, 22 Aug 2008 15:29:36 -0700

pretty vague.

Andy

---

From: "tom.petch" <[email-masked]>
Date: Thu, 28 Aug 2008 13:50:52 +0200

----- Original Message -----
From: "Andy Bierman" <[email-masked]>
To: "Phil Shafer" <[email-masked]>
Cc: "NETCONF" <[email-masked]>
Sent: Saturday, August 23, 2008 12:29 AM
Subject: Re: [Netconf] continue-on-error

> Seems fine to me, since the spec doesn't really say.
'continue-on-error' is what (almost?) every HTML browser does.  Look at the
source for web sites and many if not most is invalid, at least in the sense of
using mismatched start and end tags, eg for <DIV> <SPAN> <P> <LI> etc so there
seems a general implementation rule that if a </...> is missing, supply it.

Easier to do for syntax errors than for misspelt QNaems.

The better systems I am used to have a classification of errors - eg minor,
severe, catastrophic - with different actions specifiable for each.  The systems
I dislike most are the ones that continue on catastrophic errors thus generating
hundreds or thousands of error messages for one typo (something I see with SMI
checkers:-(

Tom Petch

---

From: "tom.petch" <[email-masked]>
Date: Thu, 28 Aug 2008 13:50:52 +0200

----- Original Message -----
From: "Andy Bierman" <[email-masked]>
To: "Phil Shafer" <[email-masked]>
Cc: "NETCONF" <[email-masked]>
Sent: Saturday, August 23, 2008 12:29 AM
Subject: Re: [Netconf] continue-on-error

Tom Petch