Subject: Re: [Netconf] FW: I-D Action:draft-ietf-netconf-monitoring-13.txt

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 1 Jun 2010 10:49:22 +0200

Hi All,

IIRC we agreed in the past not to be dependent on 4741bis and I 
also believe it makes sense that other documents (like 4741bis) don't 
have to import basic netconf-types from monitoring doc. 
4741bis or an other document can define a generic (to be imported 
by other modules) set of netconf-types. If we then do a monitoring-bis 
later this can be imported.

I would suggest to use uint32 in the monitoring draft and NOT to 
define a specific type.

As I see on ML there seems to be already an agreement on this. 
So, I would like to ask the editors to make this very last change and 
to submit a final revision.

Mehmet
(document shepherd)

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Martin Bjorklund
> Sent: Monday, May 31, 2010 8:34 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Netconf] FW: I-D 
> Action:draft-ietf-netconf-monitoring-13.txt
> 
> Andy Bierman <[email-masked]> wrote:
> > Romascanu, Dan (Dan) wrote:
> > >  
> > >
> > >   
> > >> -----Original Message-----
> > >> From: [email-masked] 
> > >> [mailto:[email-masked]] On Behalf Of Andy Bierman
> > >>     
> > >
> > >   
> > >> I prefer to have all the common NETCONF typedefs in the 
> > >> draft-ietf-netmod-types draft.  (e.g., session-id, 
> datastore-type).
> > >> That is the correct engineering solution.  That would also 
> > >> get published before 4741bis, so ietf-netconf and 
> > >> ietf-netconf-monitoring can import from a module in this draft.
> > >>
> > >>     
> > >
> > > This looks cleaner and can be done in theory right now 
> with the cost of
> > > delaying draft-ietf-netmod-types which hangs on the 
> clearing of a last
> > > DISCUSS before being approved by the IESG. However I am 
> wondering if
> > > this is not a futile effort. This will not be the last 
> typedef that will
> > > be needed, and in the future we shall not update each 
> time that RFC when
> > > we need to add one or a few new typedefs. Or shall we? 
> > >   
> > 
> > Another solution is to not use any typedef
> > in ietf-netconf-monitoring.  Just use uint32
> > instead.
> 
> I think this is a reasonable way forward.  We should remove the two
> session-id types from monitoring, and just use unit32.
> 
> > IMO, we should add
> > the ietf-netconf-types module to 4741bis now, and start
> > with the session-id-type in ietf-netconf.yang.
> 
> Why can't we just define those types in ietf-netconf?  Why do we need
> a separate module for the types?  Do you expect that module to be
> revised more often than ietf-netconf?
> 
> 
> /martin
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "t.petch" <[email-masked]>
Date: Tue, 1 Jun 2010 10:15:03 +0200

----- Original Message ----- 
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: <[email-masked]>; "Martin Bjorklund" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, May 31, 2010 6:32 PM
> > draft-ietf-netmod-types draft.  (e.g., session-id, datastore-type).
> This looks cleaner and can be done in theory right now with the cost of
> delaying draft-ietf-netmod-types which hangs on the clearing of a last
> DISCUSS before being approved by the IESG. However I am wondering if
> this is not a futile effort. This will not be the last typedef that will
> be needed, and in the future we shall not update each time that RFC when

Or do as we did with Another Language and place such definitions under
IANA control and use Standards Track RFC to amend the IANA definitions

Tom Petch

> Dan
> (speaking as a contributor)