Subject: [Netconf] bug in ietf-netconf-monitoring.yang

From: Andy Bierman <[email-masked]>
Date: Fri, 25 Jun 2010 12:28:49 -0700

Hi,

Please use the correct data type from ietf-yang-types,
since that module is already imported anyway:

/netconf-state/datastores/datastore/locks/lock-type/partial-locks/partial-locks/select

      leaf-list select {
         type string;
              ^^^^^^
         min-elements 1;
          description
            "The xpath expression which was used to request
             the lock.  The select expression indicates the
             original intended scope of the lock.";
         }

s/string/yang:xpath1.0/

Tools need to be aware of QNames in the content.

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 27 Jun 2010 12:12:12 +0200

Should this edit be included in the RFC Editor notes? 

Were all the other current RFC Editor notes made redundant by the new
version and can they be deleted? 

(Questions for the editors and document shepherd)

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Friday, June 25, 2010 10:29 PM
> To: NETCONF
> Subject: [Netconf] bug in ietf-netconf-monitoring.yang
> 
> Hi,
> 
> Please use the correct data type from ietf-yang-types, since 
> that module is already imported anyway:
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 27 Jun 2010 15:00:09 +0200

I think we should include this into the RFC 
editors notes with OLD/NEW text but don't 
want to talk for the authors.

Current RFC editors notes can be deleted as 
they have been incorporated into the v15 draft.

Cheers,
Mehmet

> [mailto:[email-masked]] On Behalf Of ext Romascanu, 
> Dan (Dan)
> Sent: Sunday, June 27, 2010 12:12 PM
> To: [email-masked]; NETCONF
> Subject: Re: [Netconf] bug in ietf-netconf-monitoring.yang
>

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 28 Jun 2010 11:05:37 +0200 (CEST)

Hi,

> want to talk for the authors.

I agree that we should make this change:

OLD:

               leaf-list select {
                 type string;
                 min-elements 1;

NEW:

               leaf-list select {
                 type yang:xpath1.0;
                 min-elements 1;

> they have been incorporated into the v15 draft.

Yes.

/martin

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 28 Jun 2010 12:42:10 +0200

I believe this change is minimal from the IESG point of  view, but I
would like to make sure that the WG has consensus about it. Mehmet, can
you confirm this? 

Thanks and Regards,

Dan

> From: Martin Bjorklund [mailto:[email-masked]] 
> Sent: Monday, June 28, 2010 12:06 PM
> To: [email-masked]
> Cc: Romascanu, Dan (Dan); [email-masked]; [email-masked]
> > I think we should include this into the RFC editors notes 
> with OLD/NEW 
> > text but don't want to talk for the authors.
> 
> > Current RFC editors notes can be deleted as they have been 
> > incorporated into the v15 draft.
> 
> Yes.
> 
> 
> /martin
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 28 Jun 2010 14:27:51 +0200

Dear NETCONF WG,

NETCONF Monitoring draft passed the IESG review.

Though there is one small issue left. Andy proposed to
use "yang:xpath1.0" instead of "string" for the type 
statement in the definition of "leaf-list select" 
(see attached mail and OLD/NEW text below). 

The draft authors and myself (as the document shepherd)
support this change.

If there are no strong objections by June 30, 2010, EOB 
we are going to change the text as proposed and will ask 
Dan to consider to bring the draft to the next step. 

Many thanks to the authors to bring the Monitoring draft 
to this stage and all who contributed to the development. 

Cheers,
Mehmet

> From: ext Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: Monday, June 28, 2010 12:42 PM
> To: Martin Bjorklund; Ersue, Mehmet (NSN - DE/Munich)
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Netconf] bug in ietf-netconf-monitoring.yang
> 

Subject: [Netconf] bug in ietf-netconf-monitoring.yang
From: "ext Andy Bierman" <[email-masked]>
To: "NETCONF" <[email-masked]>
Date: Fri, 25 Jun 2010 21:28:49 +0200

Hi,

      leaf-list select {
         type string;
              ^^^^^^
         min-elements 1;
          description

s/string/yang:xpath1.0/

Andy