Subject: Re: [Netconf] Status WGLC RFC4742bis WAS:FW: status WGLC RFC4741bis

From: Phil Shafer <[email-masked]>
Date: Thu, 21 Oct 2010 22:27:58 -0400

Andy Bierman writes:
>I have not heard a proposal for an acceptable solution.

Lada has suggested using a truly illegal character (<0x20).  I
suggested a "chunked" approach, where a block of data is prefaced
by the length and an indication of whether it's the final chunk.
Either solution is reasonable.

Thanks,
 Phil

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 22 Oct 2010 10:46:45 +0200

> Either solution is reasonable.

And Per suggested the bit stuffing. Each of the methods has its pros and
cons but each will also solve the issue in a clean way. As it is now,
there are valid NETCONF messages that the SSH transport fails to deliver
as valid messages to the opposite end, hence the transport protocol is
broken.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C