Subject: Re: [Netconf] Status WGLC RFC4742bis WAS:FW: status WGLC RFC4741bis

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 21 Oct 2010 22:15:05 +0200

On Čt, 2010-10-21 at 15:21 -0400, Phil Shafer wrote:
> Andy Bierman writes:
> >I would like to hear evidence that this EOM sequence is causing problems
> >for operators using NETCONF.  Is this really a concern to operators?
> 
> It's not an issue for operators, but increases the complexity for
> implementors and decreases the robustness of NETCONF.  It mixes the
> parsing of message boundaries with the parsing of the XML itself.
> I consider this a more significant issue than many of the issues
> addressed by the current netconf-1.1 draft.

Me too. SSH is the required transport in 4741bis, so 4741bis and
4742bis have to be considered together. Now, we have this EOM issue that
has security implications, which are however mentioned neither in
4741bis nor in 4742bis. This is IMO unacceptable.

Lada
 
> Thanks,
>  Phil

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Thu, 21 Oct 2010 15:11:10 -0700

Hi,

I don't agree that complexity is increased by any measurable amount.

I have not heard a proposal for an acceptable solution.
Requiring buffering in the server is not going to be implemented.
If it is a burden for a server to receive part of a list before the keys,
then it is a burden to buffer any part of the rpc-reply as well.

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ladislav Lhotka
Sent: Thursday, October 21, 2010 1:15 PM
To: Phil Shafer
Cc: Netconf
Subject: Re: [Netconf] Status WGLC RFC4742bis WAS:FW: status WGLC RFC4741bis

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf