Subject: [Netconf] YANG Patch Optional or Mandatory

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 6 Mar 2014 14:22:23 +0000

Dear NETCONF WG,

there was a discussion in the IETF #89 NETCONF session on whether YANG patch for the RESTCONF protocol should be optional or mandatory.
Although we heard different opinions there was no final conclusion.

The chairs would like to raise this discussion again to come to an agreement for the way forward.
Please state your opinion with pro and contra.

Thanks,
Mehmet

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 6 Mar 2014 15:35:50 +0100

> Please state your opinion with pro and contra.

I assume we talk about draft-bierman-netconf-yang-patch-00.txt. My
first question is this YANG module only for RESTCONF or is the idea
that NETCONF servers also implement this patch operation. The
introduction is not quite clear, it says things such as "A new RPC
operation can be defined to utilize YANG Patch in the NETCONF
protocol.". There is text further down in the document how it would
work with NETCONF but then I again read "For NETCONF, a YANG "rpc"
statement must be defined.". I like to understand where we are heading
regarding editing primitives in both NETCONF and RESTCONF. (Sorry that
I am not really addressing your question whether this should be
mandatory for RESTCONF.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 06 Mar 2014 15:57:33 +0100 (CET)

"Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]> wrote:
> Dear NETCONF WG,
> 
> there was a discussion in the IETF #89 NETCONF session on whether YANG patch
> for the RESTCONF protocol should be optional or mandatory.

I strongly believe that *some* mechanism to CRUD all YANG-defined
resources MUST be mandatory.  Whether it is YANG Patch or something
else I don't know.

For example, it is not clear to me why we should have different
edit-formats for NETCONF and RESTCONF.  Since the edit-config format
seems to work for NETCONF, it must be clarified why it doesn't work
for RESTCONF.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Thu, 6 Mar 2014 07:02:25 -0800

Hi,

It is designed to be used in NETCONF and RESTCONF.
The <edit2> operation in draft-bierman-netconf-efficiency-extensions-00
uses it.

As for YANG Patch being mandatory...
Martin convinced be it needs to be mandatory or removed.
The ability to change the appropriate data in 1 request is critical.
How it is done is not.

Andy

On Thursday, March 6, 2014, Juergen Schoenwaelder <
[email-masked]> wrote:

> > there was a discussion in the IETF #89 NETCONF session on whether YANG
> patch for the RESTCONF protocol should be optional or mandatory.
> _______________________________________________
> Netconf mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 6 Mar 2014 15:51:21 +0000

> The ability to change the appropriate data in 1 request is critical.

I agree that being able to have all updates in a single request is
critical, but can't a RESTCONF client PUT the entire configuration
in one request and achieve this too?

Thanks,
Kent

From:  Andy Bierman <[email-masked]>
Date:  Thursday, March 6, 2014 3:02 PM
To:  Juergen Schoenwaelder <[email-masked]>, "Ersue,
Mehmet (NSN - DE/Munich)" <[email-masked]>, NetConf
<[email-masked]>
Subject:  Re: [Netconf] YANG Patch Optional or Mandatory

Hi,

Andy

On Thursday, March 6, 2014, Juergen Schoenwaelder
<[email-masked]> wrote:

On Thu, Mar 06, 2014 at 02:22:23PM +0000, Ersue, Mehmet (NSN - DE/Munich)

/js

---

From: Andy Bierman <[email-masked]>
Date: Thu, 6 Mar 2014 08:06:00 -0800

> in one request and achieve this too?

This is a very heavyweight way to do a patch.
I am much more concerned with efficient NM than following all
The CLRs in HTTP.  The merge operation is mandatory in NETCONF
so it needs to be mandatory in RESTCONF.

Andy

>
> From:  Andy Bierman <[email-masked] <javascript:;>>
> To:  Juergen Schoenwaelder <[email-masked]<javascript:;>>,
> "Ersue,
> Mehmet (NSN - DE/Munich)" <[email-masked] <javascript:;>>, NetConf
> <[email-masked] <javascript:;>>
> <[email-masked] <javascript:;>> wrote:
>
> [email-masked] <javascript:;> <javascript:;>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 6 Mar 2014 16:29:12 +0000

> This is a very heavyweight way to do a patch.

It's not a PATCH, not even a poor-man's PATCH - it's a PUT, and for some devices, that may be all they want to support.  Again, I'm thinking about resource-constrained devices...

> I am much more concerned with efficient NM than following all the CLRs in HTTP.

Me too, but RESTCONF purports itself as being lightweight.   I don't want to make the same mistakes that drove us to want NETCONF Light - recall that edit-config was going to be optional, because copy-config could support the base case...

> The merge operation is mandatory in NETCONF

That was a mistake, do we want to double-down?

Thanks,
Kent

---

From: Andy Bierman <[email-masked]>
Date: Thu, 6 Mar 2014 08:40:05 -0800

On Thursday, March 6, 2014, Kent Watsen <[email-masked]> wrote:

>  It's not a PATCH, not even a poor-man's PATCH - it's a PUT, and for some
> devices, that may be all they want to support.  Again, I'm thinking about
> resource-constrained devices...
>
>
>  Me too, but RESTCONF purports itself as being lightweight.   I don't
> want to make the same mistakes that drove us to want NETCONF Light - recall
> that edit-config was going to be optional, because copy-config could
> support the base case...
>
>
I don't agree that is a mistake.
It is the most direct and efficient way to convey the intended
changes to the server implementation.

Andy

---

From: Kent Watsen <[email-masked]>
Date: Thu, 6 Mar 2014 17:18:34 +0000

> changes to the server implementation.

No argument that granular-updates are great - forcing all implementation to have to implement it is the mistake.  A more modular approach would've allowed implementation by more devices, as well as the creation of better adapters for those that don't.

BTW, recall that I was the one that pushed for PATCH to be added the RESTCONF - I'm a huge supporter, but I don't think it needs to be a MUST.

Thanks,
Kent