Subject: Re: [Netconf] NETCONF call home and new port assignment

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 3 Mar 2014 11:34:08 +0100 (CET)

On Tue, 25 Feb 2014, Reinaldo Penno (repenno) wrote:

> That does not seem the intention of the draft at all. Are we talking about
> http://tools.ietf.org/html/draft-kwatsen-netconf-zerotouch-01?
>
> My expectation of a call home mechanism is about solving the important
> problem of discovery decentralization.

Well, there are some of us who want to solve the simple call-home problem 
as well. We proposed this in a separate draft at IETF88, but now we're 
trying to merge it into a single draft that should solve both.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Mon, 3 Mar 2014 17:05:53 +0000

Hi Mikael,

what is the actual problem you are trying to solve that needs "call home" ? Is it NAT traversal issues where device is on the public side of NAT?

thanks,

________________________________________
From: Mikael Abrahamsson [[email-masked]]
Sent: Monday, March 03, 2014 2:34 AM
To: Reinaldo Penno (repenno)
Cc: Juergen Schoenwaelder; netconf
Subject: Re: [Netconf] NETCONF call home and new port assignment

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 3 Mar 2014 18:55:48 +0100 (CET)

On Mon, 3 Mar 2014, Reinaldo Penno (repenno) wrote:

> what is the actual problem you are trying to solve that needs "call 
> home" ? Is it NAT traversal issues where device is on the public side of 
> NAT?

The CPE does SLAAC for WAN IPv6 address so we have no idea what address to 
talk to it on.

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Mon, 3 Mar 2014 18:00:24 +0000

Interesting use-case. I believe this is the type of problem the draft
tries to tackle: installing devices without having to pre-provision IP
addresses on NMS/Netconf.