Subject: Re: [Netconf] comments on draft-kwatsen-netconf-server-00

From: Martin Bjorklund <[email-masked]>
Date: Mon, 03 Mar 2014 10:05:16 +0000 (GMT)

Dean Bogdanovic <[email-masked]> wrote:
> 
> On Feb 19, 2014, at 2:17 AM, Martin Bjorklund
> <[email-masked]<mailto:[email-masked]>> wrote:
> 
> 
> > Well, I still don't know if you are talking about TCP keep alives, TLS
> > heartbeats / SSH keep alives or NETCONF-layer keep alive (whatever
> > that is).  I think you mean TLS/SSH but it needs to be spelled out.
> > And as for SSH, is there even a standard for keep alives?
> 
> You can configure SSH server and client to keep the sessions
> open. There are two config options
> ServerAliveInterval
> and
> ClientAliveInterval

These are config parameters for one SSH implementation.  This document
needs to specify which SSH _mechanism_ is supposed to be used, so that
any SSH implementation can be utilized.

/martin

---

From: Dean Bogdanovic <[email-masked]>
Date: Mon, 3 Mar 2014 18:29:44 +0000

Martin,

Check out http://www.ietf.org/rfc/rfc4254.txt, section 4 can be used for SSH keep alive mechanism, so for SSH this RFC can be referenced.

Dean