Subject: Re: [Netconf] NETCONF call home and new port assignment

From: Joe Touch <[email-masked]>
Date: Tue, 04 Mar 2014 15:49:57 -0800

A well designed protocol needs one port.

What's the rationale for so many variants of the same service, and what 
happens if both run on the same machine and collide? (i.e., two 
independent ports could mean independent two servers).

Joe

On 2/25/2014 7:41 AM, Kent Watsen wrote:
>
> I believe that is the case as well, but note that we need two port
> assignments - one for reverse-SSH and another for reverse-TLS.
>
> Cheers!
> Kent
>
>
>
> On 2/25/14 6:31 AM, "Bert Wijnen (IETF)" <[email-masked]> wrote:
>
>> NETCONF WG participants,
>>
>> there has been quite some discussion about this topic on our mailing list.
>> We (WG chairs) have asked our AD (Benoit) to follow up in the IESG.
>>
>> Our current understanding is that if our WG has consensus on asking for
>> a new port, then we can do so and we should get one.
>>
>> We (WG chairs) belive we have (at least rough) consensus on this matter
>> and so we will ask for a new port.
>>
>> Bert and Mehmet
>>
>>
>> -------- Original Message --------
>> Subject: Re: NETCONF call home and new port assignment
>> Resent-To: [email-masked], [email-masked],,
>> [email-masked], [email-masked], [email-masked]
>> Date: Mon, 20 Jan 2014 15:58:52 +0100
>> From: Benoit Claise <[email-masked]>
>> CC: Joe Touch <[email-masked]>,        "[email-masked]"
>> <[email-masked]>,        "Romascanu, Dan (Dan)"
>> <[email-masked]>,        Lemon Ted <[email-masked]>,
>> "[email-masked]" <[email-masked]>,
>> Kent Watsen <[email-masked]>
>>
>> Dear all,
>>
>> We discussed the issue of potentially allocating a new port for the
>> NETCONF call home during our informal telechat last week.
>> Personally, I wanted a confirmation on the procedure.
>> Material:
>> http://www.iana.org/assignments/service-names-port-numbers/service-names-p
>> ort-numbers.xhtml
>> an
>>      RFC 6335
>>
>> Bottom line: The review of the port assignment via IETF standards
>> (consensus based) does not go to the port review
>>
>> There is strong consensus to allocate this port in the NETCONF WG.
>> - http://www.ietf.org/proceedings/88/minutes/minutes-88-netconf
>>    30 in favor, 0 against
>> - doublechecked on the mailing list
>> http://www.ietf.org/mail-archive/web/netconf/current/msg08445.html
>>
>> So we're good here, let's proceed with the new port design
>>
>> Regards, Benoit
>>
>>> Hi, Benoit,
>>>
>>> On 11/4/2013 10:30 AM, Benoit Claise wrote:
>>>> Hi Joe,
>>>>
>>>> Regarding the "NETCONF call home and new port assignment" discussion on
>>>> the NETCONF mailer, I'm wondering if your comments are made as the port
>>>> expert reviewer or as a contributor.
>>>
>>> The ports review team doesn't participate in that role on these
>>> discussions on the lists; we review requests and report directly to
>>> IANA. So I'm speaking as a contributor, but it's with the ports review
>>> in the back of my mind.
>>>
>>>> In the NETCONF WG, there is strong consensus that the new port is the
>>>> preferred way. We checked that today: by a show of hand, everybody
>>>> wanted a new port.
>>>
>>> Everyone always does.
>>>
>>>> I want to understand if there is a major flaw in requesting this port.
>>>
>>> There's often a case where the individual request makes sense, but in
>>> the broader context of "tragedy of the commons" it doesn't. That's my
>>> impression here. There should be other ways to accomplish this - the
>>> SYN attempt I recently saw looked like a good alternative that would
>>> scale to other assignments, e.g.
>>>
>>>> Note: I contacted it you directly, because I'm not sure how to reach
>>>> all
>>>> the expert reviewers at the same time.
>>>
>>> There's no official way to do that. We respond to requests for reviews
>>> from IANA, and report back to IANA directly. There's no "official"
>>> role for us in the IETF directly.
>>>
>>> Joe
>>>
>>>>
>>>> http://www.iana.org/assignments/service-names-port-numbers/service-names
>>>> -port-numbers.xhtml
>>>>
>>>> is not explicit
>>>>
>>>> Regards, Benoit (OPS AD)
>>> .
>>>
>>
>>
>>
>>
>> _______________________________________________
>> Netconf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netconf
>>
>>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 06 Mar 2014 10:45:24 +0000

Joe, it does not help if you try to re-open the discussion.
We have had the discussion The WG has concluded they want to ask for a new port,
We have asked our AD to check with the IESG if this is acceptable, and our (WG chairs)
understanding is that IF we as a WG want to ask for a port, we can do so.

Bert speaking as co-chair.

On 04/03/14 23:49, Joe Touch wrote:
> What's the rationale for so many variants of the same service, and what happens if both run on the same machine and collide? (i.e.,
> two independent ports could mean independent two servers).
>
> Joe
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 6 Mar 2014 11:45:38 +0000

Mehmet supports as the other co-chair.

As a matter of fact we see this discussion as concluded!

Cheers, 
Mehmet 

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of ext Bert
> Wijnen (IETF)
> Sent: Thursday, March 06, 2014 11:45 AM
> To: Joe Touch; Kent Watsen; netconf
> Subject: Re: [Netconf] NETCONF call home and new port assignment
> 
> > What's the rationale for so many variants of the same service, and
> what happens if both run on the same machine and collide? (i.e.,

---

From: Joe Touch <[email-masked]>
Date: Thu, 6 Mar 2014 07:39:34 -0800

> On Mar 6, 2014, at 2:45 AM, "Bert Wijnen (IETF)" <[email-masked]> wrote:
> 

That one new port has now doubled to two. That is a new issue. 

Joe