Subject: [Netconf] content match nodes - clarification

From: "Rajan Narayanan (rajann)" <[email-masked]>
Date: Fri, 30 Sep 2016 05:55:29 +0000

Hello IETF team

   ?Working on testing YangModels with Cisco devices. Trying some content match node testing.

1.   I couldn't get one of the constraint mentioned below

    (i.e) what is meant by Filtering of list content is not supported.

     Can someone please clarify with a simple example.

6.2.5<https://tools.ietf.org/html/rfc6241#section-6.2.5>.  Content Match Nodes

   A leaf node that contains simple content is called a "content match
   node".  It is used to select some or all of its sibling nodes for
   filter output, and it represents an exact-match filter on the leaf
   node element content.  The following constraints apply to content
   match nodes:

   o  A content match node MUST NOT contain nested elements.

   o  Multiple content match nodes (i.e., sibling nodes) are logically
      combined in an "AND" expression.

   o  Filtering of mixed content is not supported.

   o  Filtering of list content is not supported.

2.   Is the following a valid content match query?

     (i.e)more than one sub-filter with 4 containment node (<containerA>, <list>, <containerB> and <containerC>)

     and one content matching node. But the key value of the instance is not specified.

     I am in the assumption that, even though there is no content selection node,

     this query return's the key value of the all the list instance and the content match node in the resp.

     pls comment.

<rpc message-id="101 "xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">

<get>
<filter type="subtree">
<top xmlns="http://cisco.com/schema/oper?"> (pls ignore name space)
<containerA>

<list>
<containerB>
<containerC>
<node>match_val_a</node>
</containerC>
</containerB>
</list>

<list>
<containerB>
<containerC>
<node>match_val_b</node>
</containerC>
</containerB>
</list>

<list>
<containerB>
<containerC>
<node>match_val_c</node>
</containerC>
</containerB>
</list>

</containerA>
</top>
</filter>
</get>
</rpc>

Thx
Rajan

---

From: Andy Bierman <[email-masked]>
Date: Fri, 30 Sep 2016 08:59:05 -0700

Hi,

The text is referring to xsd:list, not YANG list.

Andy

On Thu, Sep 29, 2016 at 10:55 PM, Rajan Narayanan (rajann) <[email-masked]
> wrote:

>
> Hello IETF team
>
>
>    ​Working on testing YangModels with Cisco devices. Trying some content match node testing.
>
>
> 6.2.5 <https://tools.ietf.org/html/rfc6241#section-6.2.5>.  Content Match Nodes
>
> <top xmlns="http://cisco.com/schema/oper​"> (pls ignore name space)
> <containerA>
>
> <list>
> <containerB>
> <containerC>
> <node>match_val_a</node>
> </containerC>
> </containerB>
> </list>
>
> <list>
> <containerB>
> <containerC>
> <node>match_val_b</node>
> </containerC>
> </containerB>
> </list>
>
> <list>
> <containerB>
> <containerC>
> <node>match_val_c</node>
> </containerC>
> </containerB>
> </list>
>
> </containerA>
> </top>
> </filter>
> </get>
> </rpc>
>
>
> Thx
> Rajan
>
>
>
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>