Subject: [Netconf] RESTCONF yang-data media type change

From: Andy Bierman <[email-masked]>
Date: Thu, 22 Sep 2016 13:53:37 -0700

Hi,

After discussions with Mark Nottingham about RESTCONF-16,
the following changes are proposed:

The application/yang-data-xml data type will be changed
in draft-17 to be named application/yang-data+xml.

The Fragment identifier considerations section will be updated:

   Fragment identifier considerations: The fragment field in the
      request URI has no defined purpose.  All YANG data nodes are
      accessible as resources using the path in the request URI.

The application/yang-patch-xml media type will be renamed
to application/yang-patch+xml, in the YANG Patch draft.

Please send comments/objections to the WG mailing list
.

Andy

---

From: "Steve Truong (struong)" <[email-masked]>
Date: Thu, 22 Sep 2016 20:59:45 +0000

This meta type change makes sense.
I never understand the “+json/-xml” in draft 16.

steve

From: Netconf [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Thursday, September 22, 2016 1:54 PM
To: Netconf
Subject: [Netconf] RESTCONF yang-data media type change

Hi,

Andy

---

From: Sean Leonard <[email-masked]>
Date: Sat, 24 Sep 2016 05:45:42 -0700

Thumbs up. 👍

Sean