Subject: Re: [Netconf] Solicit comments on inline action capability for NETCONF

From: Qin Wu <[email-masked]>
Date: Thu, 19 Jul 2018 11:40:40 +0000

Hi, All:
-----邮件原件-----
发件人: Robert Wilton [mailto:[email-masked]] 
发送时间: 2018年7月17日 22:13
收件人: Robert Wilton <rwilton=[email-masked]>; Qin Wu <[email-masked]>; [email-masked]
主题: Re: [Netconf] Solicit comments on inline action capability for NETCONF

On 17/07/2018 09:25, Juergen Schoenwaelder wrote:
> On Tue, Jul 17, 2018 at 08:08:47AM -0400, Robert Wilton wrote:
>> Hi Qin,
>>
>> Having read this draft, I can understand what the draft is proposing, 
>> but I don't currently understand why this is useful. Specifically, I 
>> don't find the example that is in the draft as compelling.  If the 
>> desire is to set the MTU and enable the interface as one 
>> configuration operation, then wouldn't the client just configure both 
>> mtu and enabled leaves at the same time.  Why is a separate action required here to enable the interface?
>>
> I have asked myself the same question multiple times. ;-)
>
> If people want engineer transactions consisting of multiple 
> operations, then they should do this for combinations of _arbitrary_ 
> operations. At the end, edit-config is just an operation like 
> edit-data or any other operation.
I agree.

[Qin]: Good point, this is exactly what we propose to do. but in the current draft, we haven't made this clearly.
In addition, we think action is still a special operation, need to be handled in the different way from other operations.

> Personally, I do not think heavy weight transactions is the way to go 
> but if people want to engineer this, please make the solution at least 
> generic and not bound to edit-config or something like that.
I also agree to both points.

[Qin]: in our implementation practice,
The action can be also be applied to get-config, get-data, so you are right, our intention
Is to define it in the generic way.
Thanks,
Rob

> /js

---

From: Robert Wilton <[email-masked]>
Date: Thu, 19 Jul 2018 07:57:51 -0400

Hi Qin,

Can you please provide some concrete example of the problem that needs 
to be solved here, and that can't be solved by existing tools.

I agree that transactional chained operations could be done, but I'm not 
convinced that they should be done.  E.g. if the problem can be solved 
in a simpler way then that it better.  E.g. considering enabling an 
interface and clearing counters at the same time.  Obviously if the 
interface is disabled, then a client could clear the counters first, 
then enable the interface, no transaction is required.

The more stuff that we add to NETCONF/YANG, the more complex it becomes 
and more expensive it becomes to implement and use.

So, for me, I think that a compelling problem statement would help 
evaluate whether this enhancement is really required.

Thanks,
Rob

On 19/07/2018 07:40, Qin Wu wrote:
>> On Tue, Jul 17, 2018 at 08:08:47AM -0400, Robert Wilton wrote:Hi Qi
>>> Hi Qin,
>>>