Subject: Re: [Netconf] Solicit comments on inline action capability for NETCONF

From: Qin Wu <[email-masked]>
Date: Thu, 19 Jul 2018 11:51:48 +0000

Hi, Robert:

发件人: Robert Wilton [mailto:[email-masked]]
发送时间: 2018年7月17日 20:09
收件人: Qin Wu <[email-masked]>; [email-masked]
抄送: Eric Voit (evoit) <[email-masked]>
主题: Re: [Netconf] Solicit comments on inline action capability for NETCONF

Hi Qin,

Having read this draft, I can understand what the draft is proposing, but I don't currently understand why this is useful.  Specifically, I don't find the example that is in the draft as compelling.  If the desire is to set the MTU and enable the interface as one configuration operation, then wouldn't the client just configure both mtu and enabled leaves at the same time.  Why is a separate action required here to enable the interface?

So I'm struggling to think of actions that apply to configuration datastores where the same behaviour cannot just be achieved via a simple configuration manipulation.  One use case could be wanting to repeat the same configuration on many interfaces at the same time, but for this, I think that a configuration templating solution would be preferable rather than using actions, and a templating would probably just reused edit-config/edit-data.  So, if you have some other more concrete examples of actions that apply to configuration datastores, that might be helpful.

[Qin]: Good point, but I am not sure action and configuration templating can always exchangeable and serve the same purpose.

Another question (which I think is similar to the one that Eric has also asked) is whether to have transactions that mix configuration operations and action operations on <operational>.  E.g. perhaps enable an interface and reset the counters at the same time, or perform some config change and establish a dynamic subscription at the same time.  But I question how robust this would end up being (I'm not generally a fan of distributed transactions - they never seem to be as robust as they claim to be).  Perhaps one for future thought and discussion.

[Qin]: we are not looking for complicating transaction, we are not looking for multiple operations leading to unexpected consequence. The case we are focusing on is when action can be used with other operation in the compatible way,

The idea will be close to workflow handling. Operation can be arranged in sequence. Maybe have other cases.

Thanks,
Rob

On 03/07/2018 22:01, Qin Wu wrote:
Hi, Folks:
We have posted inline action capability draft on Jun 28:
https://www.ietf.org/mail-archive/web/netconf/current/msg14823.html

One comment we received from the list is:

https://www.ietf.org/mail-archive/web/netconf/current/msg14863.html

The v-(01) is uploaded to address this comment.
Therefore we would like to draw you attention again on this draft

https://tools.ietf.org/html/draft-zheng-netconf-inline-action-capability-01
We would like to receive more review and feedback on this draft, thanks.

-Qin

_______________________________________________

Netconf mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/netconf

---

From: Robert Wilton <[email-masked]>
Date: Thu, 19 Jul 2018 08:06:55 -0400

Hi Qin,

On 19/07/2018 07:51, Qin Wu wrote:
>
> Hi, Robert:
>
> *发件人:*Robert Wilton [mailto:[email-masked]]
> *发送时间:*2018年7月17日20:09
> *收件人:*Qin Wu <[email-masked]>; [email-masked]
> *抄送:*Eric Voit (evoit) <[email-masked]>
> *主题:*Re: [Netconf] Solicit comments on inline action capability for 
> NETCONF
>
> Hi Qin,
>
> Having read this draft, I can understand what the draft is proposing, 
> but I don't currently understand why this is useful.  Specifically, I 
> don't find the example that is in the draft as compelling.  If the 
> desire is to set the MTU and enable the interface as one configuration 
> operation, then wouldn't the client just configure both mtu and 
> enabled leaves at the same time.  Why is a separate action required 
> here to enable the interface?
>
> So I'm struggling to think of actions that apply to configuration 
> datastores where the same behaviour cannot just be achieved via a 
> simple configuration manipulation.  One use case could be wanting to 
> repeat the same configuration on many interfaces at the same time, but 
> for this, I think that a configuration templating solution would be 
> preferable rather than using actions, and a templating would probably 
> just reused edit-config/edit-data.  So, if you have some other more 
> concrete examples of actions that apply to configuration datastores, 
> that might be helpful.
>
> [Qin]: Good point, but I am not sure action and configuration 
> templating can always exchangeable and serve the same purpose.
>
Sure, so please can you provide the example of where it isn't 
exchangeable, so that can be discussed/evaluated.

> Another question (which I think is similar to the one that Eric has 
> also asked) is whether to have transactions that mix configuration 
> operations and action operations on <operational>.  E.g. perhaps 
> enable an interface and reset the counters at the same time, or 
> perform some config change and establish a dynamic subscription at the 
> same time.  But I question how robust this would end up being (I'm not 
> generally a fan of distributed transactions - they never seem to be as 
> robust as they claim to be).  Perhaps one for future thought and 
> discussion.
>
> [Qin]: we are not looking for complicating transaction, we are not 
> looking for multiple operations leading to unexpected consequence. The 
> case we are focusing on is when action can be used with other 
> operation in the compatible way,
>
So, why can't the NMS or controller just sequence these actions?

> in sequence. Maybe have other cases.
OK, but please can you concrete examples of what is not working today.  
E.g. what actual system operation is being performed that either doesn't 
work today, or is not reliable, or is too complex, and would benefit 
from this.

Thanks,
Rob

>     [email-masked] <mailto:[email-masked]>
>