Subject: [Netconf] [Editorial Errata Reported] RFC6241 (5443)

From: RFC Errata System <[email-masked]>
Date: Fri, 27 Jul 2018 08:36:28 -0700 (PDT)

The following errata report has been submitted for RFC6241,
"Network Configuration Protocol (NETCONF)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5443

--------------------------------------
Type: Editorial
Reported by: Jonathan Natale <[email-masked]>

Section: 4.4

Original Text
-------------
The <ok> element is sent in <rpc-reply> messages if no errors or
warnings occurred during the processing of an <rpc> request, and no
data was returned from the operation.

Corrected Text
--------------
The <ok> element is sent in <rpc-reply> messages if
and only if
no errors or
warnings occurred during the processing of an <rpc> request, and no
data was returned from the operation.

Notes
-----
I have been informed that an <ok> element should not include any errors or warnings, even in the event of the associated operation completing because the error's severity was only at warning level).

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6241 (draft-ietf-netconf-4741bis-10)
--------------------------------------
Title               : Network Configuration Protocol (NETCONF)
Publication Date    : June 2011
Author(s)           : R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed.
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Andy Bierman <[email-masked]>
Date: Fri, 27 Jul 2018 08:45:28 -0700

Hi,

The addition of the words "and only if" do not seem to change the semantics.
The XSD (page 83) makes it clear that <ok/> and (<rpc-error>, data) cannot
both be present.

Andy

On Fri, Jul 27, 2018 at 8:36 AM, RFC Errata System <
[email-masked]> wrote:

> I have been informed that an <ok> element should not include any errors or
> warnings, even in the event of the associated operation completing because
> the error's severity was only at warning level).
>
> Instructions:
> -------------