Subject: [Netconf] Review of draft-zheng-netconf-inline-action-capability-00

From: "Wubo (lana)" <[email-masked]>
Date: Mon, 2 Jul 2018 02:10:07 +0000

Hi,all
I like this proposal and add missing piece in NETCONF 2.0 on how to handle action operation together with other NC operations. A few quick comments as follows:

1.How do we identify ifstatenable within <config> as action operation?
<config>
<ifstatenable xc:operation="action">
<enable>true<enable>
</ifstatenable>
</config>

2.How do you prevent action operation from conflicting with other sub-operation within <edit-config> and <edit-data>?
3.I think inline action operation can also be applied to other NC/RC operations such as <get>,<get-config>,<get-data>?

Best regards.

Bo

---

From: Qin Wu <[email-masked]>
Date: Mon, 2 Jul 2018 02:18:17 +0000

Thanks Bo, please see reply line.
发件人: Netconf [mailto:[email-masked]] 代表 Wubo (lana)
发送时间: 2018年7月2日 10:10
收件人: [email-masked]
主题: [Netconf] Review of draft-zheng-netconf-inline-action-capability-00

Hi,all

[Qin]: Good catch, I think we should ifstatenable element should be include within <action>element and use action element to identify action operation data.

[Qin]:Good point, we should make sure action operation and other operation to be executed together will not generate unexpected result.

[Qin]: Yes, that’s correct, at this stage, we like to start from <edit-config> and <edit-data> cases. We will cover other NC/RC operations in the later version after
action operation within <edit-config> and <edit-data> operation are well specified.

Best regards.

Bo

---

From: "Aijun Wang" <[email-masked]>
Date: Wed, 4 Jul 2018 12:02:58 +0800

Hi, Qin and Walker:

https://tools.ietf.org/html/rfc7950#section-7.15 states the following
contents: “An action MUST NOT be defined within an rpc, another action, or
a notification, i.e., an action node MUST NOT have an rpc, action, or a
notification node as one of its ancestors in the schema tree.  For example,
this means that it is an error if a grouping that contains an action
somewhere in its node hierarchy is used in a notification definition. ”,
but the proposal within this draft requires the combination operations
within one transaction. 
 
How about define one new statement that is parallel with the existing ”
action” statement, but can be defined within an rpc? Doing so can lower the
confusion for the associated procedures.
And if we doing the above thing, we should clarify the following things:
1.       What is the order to handle this new statement within other NC
operations?
2.       Can this new statement coexist with other NC operations besides the
“edit-config” and “edit-data” that proposed within the current draft?
3.       Should provide more examples for the usage of this new statement.

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

发件人: Qin Wu [mailto:[email-masked]] 
发送时间: 2018年7月2日 10:18
收件人: Wubo (lana); [email-masked]
主题: Re: [Netconf] Review of
draft-zheng-netconf-inline-action-capability-00

Hi,all

I like this proposal and add missing piece in NETCONF 2.0 on how to handle
action operation together with other NC operations. A few quick comments as
follows:

[Qin]: Good catch, I think we should ifstatenable element should be include
within <action>element and use action element to identify action operation
data.

2.How do you prevent action operation from conflicting with other
sub-operation within <edit-config> and <edit-data>?

[Qin]:Good point, we should make sure action operation and other operation
to be executed together will not generate unexpected result.

3.I think inline action operation can also be applied to other NC/RC
operations such as <get>,<get-config>,<get-data>?

[Qin]: Yes, that’s correct, at this stage, we like to start from
<edit-config> and <edit-data> cases. We will cover other NC/RC operations in
the later version after 

action operation within <edit-config> and <edit-data> operation are well
specified.

Best regards.

Bo

---

From: Qin Wu <[email-masked]>
Date: Wed, 4 Jul 2018 06:11:40 +0000

Thanks Aijun for valuable comments, please see my reply inline below.

-Qin
发件人: Aijun Wang [mailto:[email-masked]]
发送时间: 2018年7月4日 12:03
收件人: Qin Wu; Wubo (lana); [email-masked]
主题: 答复: [Netconf] Review of draft-zheng-netconf-inline-action-capability-00

Hi, Qin and Walker:

https://tools.ietf.org/html/rfc7950#section-7.15 states the following contents: “An action MUST NOT be defined within an rpc, another action, or a notification, i.e., an action node MUST NOT have an rpc, action, or a notification node as one of its ancestors in the schema tree.  For example, this means that it is an error if a grouping that contains an action somewhere in its node hierarchy is used in a notification definition. ”, but the proposal within this draft requires the combination operations within one transaction.

[Qin]: I am not worried about your quoted statement, since this statement is only applied to all user defined rpc, action and notification. kernel state RPC such as <edit-config>,<copy-config><get><get-data> are all kenernel state operations and should not be restricted by this statement.

How about define one new statement that is parallel with the existing ”action” statement, but can be defined within an rpc? Doing so can lower the confusion for the associated procedures.

[Qin]: See the above argument.

1.       What is the order to handle this new statement within other NC operations?

[Qin]: The order of different sub-operation doesn’t matter, since 2 phase commit transaction will take care of this.

2.       Can this new statement coexist with other NC operations besides the “edit-config” and “edit-data” that proposed within the current draft?

[Qin]: Yes, I think this operation can coexist with <copy-config><validate> as well.

3.       Should provide more examples for the usage of this new statement.
[Qin]: We have one example in the draft right now, yes, we can provide additional examples if needed.
Best Regards.

Aijun Wang
Network R&D and Operation Support Department
China Telecom Corporation Limited Beijing Research Institute,Beijing, China.
发件人: Qin Wu [mailto:[email-masked]]
发送时间: 2018年7月2日 10:18
收件人: Wubo (lana); [email-masked]<mailto:[email-masked]>
主题: Re: [Netconf] Review of draft-zheng-netconf-inline-action-capability-00

Thanks Bo, please see reply line.
发件人: Netconf [mailto:[email-masked]] 代表 Wubo (lana)
发送时间: 2018年7月2日 10:10
收件人: [email-masked]<mailto:[email-masked]>
主题: [Netconf] Review of draft-zheng-netconf-inline-action-capability-00

Hi,all

Best regards.

Bo