Subject: [Netconf] FW: New Version Notification for draft-ietf-netconf-yang-push-19.txt

From: "Alexander Clemm" <[email-masked]>
Date: Fri, 21 Sep 2018 22:29:51 -0700

Hi,

Just FYI, we just posted a new revision which has the WGLC incorporated, per the mail threads.  Thank you for all the valuable input!

--- Alex

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Friday, September 21, 2018 10:28 PM
To: Alberto Gonzalez Prieto <[email-masked]>; Andy Bierman <[email-masked]>; Alexander Clemm <[email-masked]>; Balazs Lengyel <[email-masked]>; Alberto Prieto <[email-masked]>; Ambika Tripathy <[email-masked]>; Eric Voit <[email-masked]>; Ambika Prasad Tripathy <[email-masked]>; Einar Nilsen-Nygaard <[email-masked]>
Subject: New Version Notification for draft-ietf-netconf-yang-push-19.txt

A new version of I-D, draft-ietf-netconf-yang-push-19.txt
has been successfully submitted by Alexander Clemm and posted to the IETF repository.

Name:		draft-ietf-netconf-yang-push
Revision:	19
Title:		YANG Datastore Subscription
Document date:	2018-09-21
Group:		netconf
Pages:		57
URL:            https://www.ietf.org/internet-drafts/draft-ietf-netconf-yang-push-19.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-push/
Htmlized:       https://tools.ietf.org/html/draft-ietf-netconf-yang-push-19
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netconf-yang-push
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-yang-push-19

Abstract:
   Via the mechanism described in this document, subscriber applications
   may request a continuous, customized stream of updates from a YANG
   datastore.  Providing such visibility into updates enables new
   capabilities based on the remote mirroring and monitoring of
   configuration and operational state.

   Via the mechanism described in this document, subscriber applications
   may request a continuous, customized stream of updates from a YANG
   datastore.  Providing such visibility into updates enables new
   capabilities based on the remote mirroring and monitoring of
   configuration and operational state.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 24 Sep 2018 09:38:54 +0200 (CEST)

Hi,

Thanks for this update.  I checked the new version with my comments.
Technically, all my comments are addressed, but there are some mostly
editorial issues left:

o  In the abstract, the same paragraph occurs twice.

o  Figure 2:

  OLD:

     <yang-patch urn:ietf:params:xml:ns:yang:ietf-yang-patch>

  NEW:

       <yang-patch>

o  Figure 6:

  OLD:

          |  +--ro ypatch:yang-patch
          |     +--ro patch-id        string
          |     +--ro ypatch:comment?    string
          |     +--ro ypatch:edit* [edit-id]
          |        +--ro ypatch:edit-id      string
          |        +--ro ypatch:operation    enumeration
          |        +--ro ypatch:target       target-resource-offset
          |        +--ro ypatch:point?       target-resource-offset
          |        +--ro ypatch:where?       enumeration
          |        +--ro ypatch:value?

  NEW:

          |  +--ro yang-patch
          |     +--ro patch-id        string
          |     +--ro comment?        string
          |     +--ro edit* [edit-id]
          |        +--ro edit-id      string
          |        +--ro operation    enumeration
          |        +--ro target       target-resource-offset
          |        +--ro point?       target-resource-offset
          |        +--ro where?       enumeration
          |        +--ro value?

o  Section 3.1

  OLD

         +  No sync on start: defines whether or not a complete push-

  NEWL

         +  Sync on start: defines whether or not a complete push-

o  Section 3.9

  The text says:

   In addition, a publisher MAY choose
   to terminate a dynamic subscription or suspend a configured receiver
   when the authorization privileges of a receiver change, or the access
   controls for subscribed objects change.  In that case, the publisher
   SHOULD include the error identity "unchanging-selection" as reason
   when sending the "subscription-terminated" notification.

 The first sentence says that a publisher can (i) terminate or (ii)
 suspend.  The second sentence details what to do for case (i), but
 not case (ii).

 In my original comment on this issue in my WGLC review for -17 I
 suggested:

   Maybe you meant that the error identity "unchanging-selection"
   SHOULD be sent in an "subscription-terminated" notification or
   "subscription-suspended" notification, respectively.

   If so, the "unchanging-selection" identity should probably also
   derive from "sn:subscription-suspended-reason".

o  Section 3.11.1

  s/the the/the/

o  Section 4.4.1

  In my previous review, I asked you to remove the error-app-tag, but
  this was wrong.  See
  https://mailarchive.ietf.org/arch/msg/netconf/cDeV6YFfVvCMxgHTZdeFqas04b8.

  So, please put back the text about error-app-tag, so that YP aligns
  with SN.

  (Ditto for 4.4.2)

o  Section 5

  The YANG module is not consistently indented.  Before sending this
  to the RFC editor, I suggest you run the module through pyang -f
  yang --keep-comments.  Also, I suggest you run the result through
  pyang --max-line-length 69.  This simplifies the job of the RFC
  editor.

o  General

  I think you might have changed "identifier" to "id" a bit
  aggressively in the document.   For example you changed:

      leaf filter-id {
        type string;
        description
          "An identifier to differentiate between selection filters.";

  to

      leaf filter-id {
        type string;
        description
          "An id to differentiate between selection filters.";

 There are a few of these.

/martin

"Alexander Clemm" <[email-masked]> wrote:
> Hi,
> 
> Just FYI, we just posted a new revision which has the WGLC
> incorporated, per the mail threads.  Thank you for all the valuable
> input!
> 
> --- Alex
> 
> To: Alberto Gonzalez Prieto <[email-masked]>; Andy Bierman
> <[email-masked]>; Alexander Clemm <[email-masked]>; Balazs
> Lengyel <[email-masked]>; Alberto Prieto
> <[email-masked]>; Ambika Tripathy <[email-masked]>; Eric
> Voit <[email-masked]>; Ambika Prasad Tripathy <[email-masked]>;
> Einar Nilsen-Nygaard <[email-masked]>
> URL:
> https://www.ietf.org/internet-drafts/draft-ietf-netconf-yang-push-19.txt
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-yang-push
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-yang-push-19
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>