Subject: [Netconf] IPR and known implementation (Was Re: WG LC for zerotouch)

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 11 Sep 2018 18:44:06 -0700

> On Sep 25, 2017, at 6:45 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> The last round of WG LC on Zerotouch draft <https://tools.ietf.org/html/draft-ietf-netconf-zerotouch-17> resulted in lot comments being posted about the draft. Kent has since then updated the document to address all those comments and posted -17 version of the draft.
> 
> We believe the document is now ready for a re-run of that call. This starts a two-week WG LC on the draft. Please indicate your support if you believe the document is now ready for LC. We need affirmation of support for the LC to succeed. Unfortunately, silence is not affirmation. If you believe the document is still not ready, please indicate why. The LC will conclude on Oct. 9.
> 
> Authors, please indicate if you are aware of any IPRs related to the document. Also, please indicate if there are any known implementations of the draft.

This thread devolved into a review of the draft, where the two questions on IPR and known implementations got lost. And while there exists one IPR disclosure, this question is still pertinent. Please note that a response is required from ALL the authors or contributors to this e-mail. Without it, the document cannot be advanced. 

Are the authors or contributors to the draft aware of any IPRs related to the draft? Please state either:

"No, I'm not aware of any IPR that applies to this draft"
or
"Yes, I'm aware of IPR that applies to this draft”

If so, has this IPR been disclosed in compliance with IETF IPR rules (see RFCs 3669, 5378 and 8179 for more details)?

If yes to the above, please state either:

"Yes, the IPR has been disclosed in compliance with IETF IPR rules"
or
"No, the IPR has not been disclosed"

If you answer no, please provide any additional details you think appropriate.

If you are on the WG mailing list and/or attend WG meetings, it is your obligation under the IPR rules to notify IETF.

For more information, please see RFCs 3669, 5378, 8179 and
http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty <http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty>.

Finally, if you are aware of any implementations of this draft, please let us know.

> Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 12 Sep 2018 08:31:59 +0200 (CEST)

After reading the IPR disclosures done for the draft, I can say:

The only IPR I am aware of is the one Juniper has filed in

https://datatracker.ietf.org/ipr/2581/

I can't judge if that's done according to the rules, but from my knowledge 
it looks ok.

So:

I am not aware of any unfiled IPR against this draft.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: [email-masked]
Date: Wed, 12 Sep 2018 13:44:23 +0200

Hi Mahesh,

No, I am not aware of any IPR that applies to this draft which hasn’t already been filed. I’m also not aware of any implementations.

Thanks,
Ian

> On 12. Sep 2018, at 03:44, Mahesh Jethanandani <[email-masked]> wrote:
> 
> 
> 
>> On Sep 25, 2017, at 6:45 PM, Mahesh Jethanandani <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Kent Watsen <[email-masked]>
Date: Wed, 12 Sep 2018 17:24:12 +0000

Yes, I'm aware of IPR that applies to this draft.
Yes, the IPR has been disclosed in compliance with IETF IPR rules.
https://datatracker.ietf.org/ipr/2581.

Kent // co-author

On 9/11/18, 9:44 PM, "Netconf on behalf of Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

On Sep 25, 2017, at 6:45 PM, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>> wrote:

The last round of WG LC on Zerotouch draft<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dnetconf-2Dzerotouch-2D17&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=YJdPBnzAm0aSx5BROP7pdBnrkHTOFr7cw5zN9lviQvg&s=-G-ItBJZflabvDPnNzeGGBZTG1nXWiD8ntm0JY8im9w&e=> resulted in lot comments being posted about the draft. Kent has since then updated the document to address all those comments and posted -17 version of the draft.

For more information, please see RFCs 3669, 5378, 8179 and
http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty<https://urldefense.proofpoint.com/v2/url?u=http-3A__trac.tools.ietf.org_group_iesg_trac_wiki_IntellectualProperty&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=YJdPBnzAm0aSx5BROP7pdBnrkHTOFr7cw5zN9lviQvg&s=tmQAYt024S49q0feexLWPMtBPuTSKvEbLKCoO1iIGf4&e=>.

Thanks.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 12 Sep 2018 17:27:23 +0000

As for implementations, most everything has been implemented in unit tests, and parts have been implemented in production.

Kent

On 9/12/18, 1:24 PM, "Netconf on behalf of Kent Watsen" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Kent // co-author

Thanks.

Mahesh Jethanandani