Subject: [Netconf] Last Call on subscribed-notifications-16

From: Kent Watsen <[email-masked]>
Date: Wed, 5 Sep 2018 23:31:31 +0000

This message starts a Last Call on draft-ietf-netconf-subscribed-notifications-16:

  https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notifications-16

This marks the second of the last calls on the yang push suite of drafts.
As explained before, given the size and number of documents, the chairs
decided to break the reviews up into pieces so as to get focus on each
in turn.  We are choosing to go top-down, starting with yang-push and
ending with the "notif" drafts.  We plan to submit the drafts for 
publication when they are ready as a collective.  The goal is to do 
all this prior to IETF 103.

While it's always nice to receive messages of support, at this time, the
question isn't so much if the working group supports the work than if
the document is ready to progress.  The chairs need to see reviews that
indicate thorough end-to-end reading of the text.  Of course, if there
are any objections, these should be brought forward now as well.

The current version (-16) of this draft was published on Aug 15th, about
three weeks after IETF 102.  The datatracker page for the draft is here:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications.

Thanks,
Kent (and Mahesh)

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 13 Sep 2018 18:07:47 +0200

Hello,

I have reviewed the latest changes. In my view the document is ready to 
progress.

regards Balazs

On 9/6/2018 1:31 AM, Kent Watsen wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909              email: [email-masked]

---

From: Kent Watsen <[email-masked]>
Date: Thu, 27 Sep 2018 21:43:48 +0000

This message successfully concludes the Last Call on subscribed-notifications
started on Sep 5th. The draft received significant reviews from Tim, Martin, 
and Andy, and received passing reviews from others.  Thank you all for that.
 
Authors, please be sure close any remaining active threads, and then post a
-17 for shepherd review.  Please also ensure that -17 passes all validation
tools (e.g., idnits, yang validators, instance document validators) and that
the tree diagrams are correct.

Thanks,
Kent (and Mahesh)

-----Original Message-----

Thanks,
Kent (and Mahesh)

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 28 Sep 2018 21:06:47 +0000

Posted.    (Note that 5 YANG errors appear due to a long-outstanding bug within yanglint.  Details on that bug below.)

I will post the NETCONF-Notif update which includes comments from the SN review as soon as instance validations are done on the examples.

Eric

-----Original Message-----
From: Eric Voit (evoit) 
Sent: Friday, January 19, 2018 4:58 PM
To: [email-masked]
Subject: RE: FW: [Netconf] Updates to subscription drafts posted

Hi Radek,

When do you think a fix might be available?

Eric

> From: Benoit Claise (bclaise)
> Sent: Tuesday, January 9, 2018 2:32 AM
> To: Eric Voit (evoit) <[email-masked]>
> Cc: Martin Bjorklund <[email-masked]>; Einar Nilsen-Nygaard (einarnn) 
> <[email-masked]>; [email-masked]; Benoit Claise (bclaise) 
> <[email-masked]>
> Subject: Re: FW: [Netconf] Updates to subscription drafts posted
> 
> Including Radek for yanglint.
> 
> Regards, B.
> > Hi Benoit,
> >
> > Attached is a YANG file showing a bug in yanglint.   The error is that
> yanglint reports "The leafref leaf is config but refers to a non-config leaf".
> This occurs even though the leaf is marked "require-instance false".
> >
> > Note this error only appears when the leafref is defined within a grouping.
> It does not occur when the leafref is defined directly within a data node.
> >
> > Where do we get these issue addressed?   I suspect I can't upload a new
> subscribed-notifications draft without this being fixed.
> >
> > Eric
> >

> From: Netconf <[email-masked]> On Behalf Of Kent Watsen
> Sent: Thursday, September 27, 2018 5:44 PM
> To: [email-masked]
> Subject: Re: [Netconf] Last Call on subscribed-notifications-16
> 
> -17 for shepherd review.  Please also ensure that -17 passes all validation tools
> (e.g., idnits, yang validators, instance document validators) and that the tree
> diagrams are correct.
> 
> Thanks,
> Kent (and Mahesh)
> 
> 
> decided to break the reviews up into pieces so as to get focus on each in turn.
> We are choosing to go top-down, starting with yang-push and ending with the
> "notif" drafts.  We plan to submit the drafts for publication when they are
> ready as a collective.  The goal is to do all this prior to IETF 103.
> 
> While it's always nice to receive messages of support, at this time, the question
> isn't so much if the working group supports the work than if the document is
> ready to progress.  The chairs need to see reviews that indicate thorough end-
> to-end reading of the text.  Of course, if there are any objections, these should
> be brought forward now as well.
> 
> The current version (-16) of this draft was published on Aug 15th, about three
> weeks after IETF 102.  The datatracker page for the draft is here: