Subject: Re: [netconf] YANG attributes in a datastore

From: Qin Wu <[email-masked]>
Date: Wed, 11 Dec 2019 01:46:36 +0000

Kent:
How “enable” attribute is different from if-feature statement?

-Qin
发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2019年12月11日 0:20
收件人: Ladislav Lhotka <[email-masked]>
抄送: [email-masked]
主题: Re: [netconf] YANG attributes in a datastore

A typical example is a "comment" annotation - you want to permit it basically
everywhere but don't want to clutter the schema with "comment" leaves.

These are what I refer to as "cross-cutting" metadata attributes.  Another example
is the "enabled" attribute defined in draft-kwatsen-conditional-enablement.

Kent // contributor

---

From: Kent Watsen <[email-masked]>
Date: Wed, 11 Dec 2019 19:15:31 +0000

Hi Qin,

Quite different.   One is in the YANG model while the other is in the data defined by the YANG model.

Kent

> On Dec 10, 2019, at 8:46 PM, Qin Wu <[email-masked]> wrote:
> 
> Kent: