Subject: [netconf] FW: New Version Notification for draft-ietf-netconf-notification-capabilities-08.txt

From: Balázs Lengyel <[email-masked]>
Date: Mon, 9 Dec 2019 15:14:33 +0000

Hello,
We updated the draft to include support for generic capabilities as the issue received quite a bit of support in the group.
   v07 - v08

   o  Prepared the YANG model to include other non-YANG-Push related
      capabilities.

   o  Renamed the top level container to system-capabilities

   o  Added a container subscription-capabilities to the grouping
      subscription-capabilities to contain all subscription related
      capabilities

   o  Updated examples according to draft-ietf-netmod-yang-instance-
      file-format-06.
Regards Balazs

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 2019. december 9., hétfő 16:07
To: Benoit Claise <[email-masked]>; Alexander Clemm <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: New Version Notification for draft-ietf-netconf-notification-capabilities-08.txt

A new version of I-D, draft-ietf-netconf-notification-capabilities-08.txt
has been successfully submitted by Balazs Lengyel and posted to the IETF repository.

Name:		draft-ietf-netconf-notification-capabilities
Revision:	08
Title:		YANG-Push Notification Capabilities
Document date:	2019-12-09
Group:		netconf
Pages:		21
URL:            https://www.ietf.org/internet-drafts/draft-ietf-netconf-notification-capabilities-08.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-netconf-notification-capabilities/
Htmlized:       https://tools.ietf.org/html/draft-ietf-netconf-notification-capabilities-08
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-netconf-notification-capabilities
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-notification-capabilities-08

Abstract:
   This document proposes a YANG module that allows a publisher to
   specify capabilities related to "Subscription to YANG Datastores"
   (YANG-Push).  It proposes to use YANG Instance Data to document this
   information and make it already available at implementation-time, but
   also allow it to be reported at run-time.

   The YANG module is also prepared to contain other system
   capabilities, for future augmentations.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Balázs Lengyel <[email-masked]>
Date: Mon, 9 Dec 2019 15:17:17 +0000

Hello Chairs,
This draft has been through WGLC, but following the discussions about generic capabilities we made some updates. What is the procedure now? New WGLC ? Simplified WGLC?
Please advise us. Best regards Balazs

-----Original Message-----
From: Balázs Lengyel 
Sent: 2019. december 9., hétfő 16:15
To: [email-masked]
Subject: FW: New Version Notification for draft-ietf-netconf-notification-capabilities-08.txt

Hello,

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 2019. december 9., hétfő 16:07
To: Benoit Claise <[email-masked]>; Alexander Clemm <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: New Version Notification for draft-ietf-netconf-notification-capabilities-08.txt

Abstract:

The IETF Secretariat

---

From: Kent Watsen <[email-masked]>
Date: Mon, 16 Dec 2019 22:47:00 +0000

Hi Balazs,

Mahesh and I discussed.   We believe that another LC is needed, which we will issue shortly.

We support the idea of extending the model to enable other capabilities to be augmented-in over time.  However, we're unsure if the current layout is best suited for this purpose.  We're hoping to use the LC in order to suss this detail out.

Kent and Mahesh

> On Dec 9, 2019, at 10:17 AM, Balázs Lengyel <balazs.lengyel=[email-masked]> wrote:
> 
> Hello Chairs,
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf