Subject: [netconf] https-notif: concern w/ YANG module

From: Kent Watsen <[email-masked]>
Date: Mon, 9 Aug 2021 23:12:34 +0000

Hiya Folks,

The 111 discussed again the idea of using an IANA-maintained module (i.e., derived from an IANA registry).  Pictorially:

	Current:  strings --> IANA registry
	Proposed: strings --> IANA registry --> IANA-maintained module

The value of using a YANG module is, presumably, to enable finer syntactic validation (e.g., "type identityref” vs. "type string”), but by whom and why?

  - Receivers validating their messages before transmission to Publishers may occur in development, but is typically disabled in production.

  - Publishers validating messages received from Receivers is common.   But the draft says that Publishers should ignore any unknown capabilities.  However, YANG-validation would produce a validation error, which seems worse.  Yes, the validation error could be examined and, in case only due to an unknown identityref, ignored, but does it make sense to do this?

At this point, the CONs seem to outweigh the PROs.  We’re considering to abandon the YANG-module…comments?

Kent and Mahesh (as authors)

---

From: Kent Watsen <[email-masked]>
Date: Tue, 24 Aug 2021 21:44:09 +0000

There has been no response in two weeks.   Mahesh and I feel that the WG is okay with not adding a module defining identities.  Thusly the current draft does not need any changes.

Kent and Mahesh (as co-authors)

> On Aug 9, 2021, at 7:12 PM, Kent Watsen <[email-masked]> wrote:
> 
> Hiya Folks,
> 
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf