Subject: [netconf] Encoding Type field in draft-ietf-netconf-udp-notif-04

From: Andy Bierman <[email-masked]>
Date: Wed, 27 Oct 2021 09:59:08 -0700

Hi,

The ET field is under-specified and needs clarification.
References are needed.

 *  ET is a 4 bit identifier to indicate the encoding type used for
      the Notification Message. 16 types of encoding can be expressed.
      When the S bit is unset, the following values apply:

      -  0: Reserved;

      -  1: JSON;

      -  2: XML;

      -  3: CBOR;

      -  others are reserved.

JSON: Does this mean RFC 7951 encoding or something else?

CBOR: Does this mean application/cbor defined in RFC 8949?
Does it mean application/yang-data+cbor defined
in draft-ietf-core-yang-cbor-17?
Does it mean application/yang-data+cbor; id=name?
Does it mean  application/yang-data+cbor; id=sid?

Andy

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 28 Oct 2021 11:12:09 +0000

Hi Andy,

Thanks for your comments. Your perspective is correct.
Please see in line.

Cheers,
Tianran

From: netconf [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Thursday, October 28, 2021 12:59 AM
To: Netconf <[email-masked]>
Subject: [netconf] Encoding Type field in draft-ietf-netconf-udp-notif-04

Hi,

      -  0: Reserved;

      -  1: JSON;

      -  2: XML;

      -  3: CBOR;

      -  others are reserved.

ZTR> Yes. We will add this reference.

CBOR: Does this mean application/cbor defined in RFC 8949?
Does it mean application/yang-data+cbor defined in draft-ietf-core-yang-cbor-17?
Does it mean application/yang-data+cbor; id=name?
Does it mean  application/yang-data+cbor; id=sid?

ZTR> My thought was RFC8949. But I think you are right. It should be like RFC7951, should be a YANG related cbor encoding. I have no idea about draft-ietf-core-yang-cbor-17. I will check it. Do you have any hint on the difference to RFC8949?
Thanks.
Andy

---

From: Andy Bierman <[email-masked]>
Date: Thu, 28 Oct 2021 10:16:12 -0700

On Thu, Oct 28, 2021 at 4:12 AM Tianran Zhou <[email-masked]> wrote:

> *From:* netconf [mailto:[email-masked]] *On Behalf Of *Andy
> Bierman
> *Sent:* Thursday, October 28, 2021 12:59 AM
> *To:* Netconf <[email-masked]>
> *Subject:* [netconf] Encoding Type field in
> draft-ietf-netconf-udp-notif-04
>
>
>
> Hi,
>
>
>
> ZTR> My thought was RFC8949. But I think you are right. It should be like
> RFC7951, should be a YANG related cbor encoding. I have no idea about
> draft-ietf-core-yang-cbor-17. I will check it. Do you have any hint on the
> difference to RFC8949?
>

It is very much like the CBOR version of RFC7951.
Except way better because it has delta-SID encoding.
The node names can be encoded as small integers,

In both cases (JSON and CBOR) the YANG version is fully compliant to the
base encoding.
Perhaps application/json+yang or application/cbor+yang would be more
accurate but
that's not what was defined.

Thanks.

Andy

---

From: Tianran Zhou <[email-masked]>
Date: Sat, 30 Oct 2021 07:25:00 +0000

Thanks Andy for your further explanation.
We will add the YANG version encodings to the reference.

Cheers,
Tianran

From: Andy Bierman [mailto:[email-masked]]
Sent: Friday, October 29, 2021 1:16 AM
To: Tianran Zhou <[email-masked]>
Cc: Netconf <[email-masked]>
Subject: Re: [netconf] Encoding Type field in draft-ietf-netconf-udp-notif-04

On Thu, Oct 28, 2021 at 4:12 AM Tianran Zhou <[email-masked]<mailto:[email-masked]>> wrote:
Hi Andy,

Cheers,
Tianran

From: netconf [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Andy Bierman
Sent: Thursday, October 28, 2021 12:59 AM
To: Netconf <[email-masked]<mailto:[email-masked]>>
Subject: [netconf] Encoding Type field in draft-ietf-netconf-udp-notif-04

Hi,

      -  0: Reserved;

      -  1: JSON;

      -  2: XML;

      -  3: CBOR;

      -  others are reserved.

In both cases (JSON and CBOR) the YANG version is fully compliant to the base encoding.
Perhaps application/json+yang or application/cbor+yang would be more accurate but
that's not what was defined.

Thanks.
Andy

Andy