Subject: Re: [netlmm] Comments on draft-krishnan-netlmm-pmip-sel-00

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 10 Jul 2007 07:54:57 -0700 (PDT)

Hi Suresh,
  See inline.

Regards,

Behcet
----- Original Message ----
From: Suresh Krishnan <[email-masked]>
To: Frank Xia <[email-masked]>
Cc: [email-masked]
Sent: Monday, July 9, 2007 5:34:49 PM
Subject: Re: [netlmm] Comments on draft-krishnan-netlmm-pmip-sel-00

Hi Frank,
  Thanks for the comments. Please see responses inline.

Frank Xia wrote:
> Hi all
>  
> 1) Different service means different accounting policy, priority,QoS and 
> so on.
>    How to corelate them?

The proposed mechanism is just for denoting a preference for a given
mobility mechanism. I believe that the considerations you have mentioned
are orthogonal to the mobility mechanism.

> 2) In PMIPv6 IPv4 support scenario, there is no any RS/RA support

Check RFC1256. The concepts illustrated in the draft can equally apply
to update the IPv4 RS/RA messages.

> 3) In this document , MN can signal to the PMIPv6 network whether it
>    would like to make use of the Proxy Mobility service or not.
>    In fact , we can list other service, such as, ipv4 support Proxy Mobile,
>    while IPv6 is only simple IP.

You are talking more about capability exchange/negotiation rather than a
simple selection. I believe what you want to solve is a valid problem.
It is just not the same problem I was trying to address.

behcet>> Sure.
>  
> 4)We have proposed a solution using EAP expansion. Probably it is helpful.
>   
> http://tools.ietf.org/wg/netlmm/draft-xia-netlmm-service-negotiation-00.txt

Not all link layers use EAP originating at the MN for authentication
:-). How do we solve this problem for those?

behcet>>In the draft we did not assume such a thing. What we assume is the execution of any EAP method and we added the negotiation there. So there is in fact no problem to solve. We assume MN will be authenticated using EAP as PMIPv6 does.

Cheers
Suresh

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 10 Jul 2007 11:30:11 -0400

Hi Behcet,
   Removing things we agree on.

Behcet Sarikaya wrote:

> behcet>>In the draft we did not assume such a thing. What we assume is 
> the execution of any EAP method and we added the negotiation there. So 
> there is in fact no problem to solve. We assume MN will be authenticated 
> using EAP as PMIPv6 does.

I don't think PMIPv6 assumes that EAP will be used as the authentication 
mechanism. PMIPv6 just assumes that some form of access authentication 
is used to trigger the PMIP process.

Cheers
Suresh