Subject: Re: [netlmm] Today's discussion about multihomed MNs

From: Ashutosh Dutta <[email-masked]>
Date: Tue, 24 Jul 2007 23:19:06 -0400

Hesham,
         I agree if you would like to use both the interfaces (interface 
anchored at MAG1 and interface 2 anchored with MAG2) at the same time 
when the mobile is static, this is a typical problem. But then LMA has 
to maintain binding with both the MAGs (similar to simultaneous binding 
update). In normal case, LMA should overwrite the existing binding with 
MAG1 and replace it with the binding with MAG2.

	The following is the make-before-break scenario I had in mind:

Assume that the mobile has two interfaces, 802.11 and CDMA. While under 
MAG1 mobile is using WiFi Interface, LMA sends traffic via MAG1, and the 
mobile is about to move out of WiFi hotspot and makes a move to CDMA 
access that is controlled by MAG2. So, while the mobile is still using 
WiFi access, it can start the PMIP procedure using the second interface 
(CDMA interface) with MAG2 (assuming the mobile is under CDMA coverage). 
Depending upon when the address gets configured on the second interface, 
there maybe potentially an overlap of time when both the interfaces can 
have the same addresses momentarily. If MN's address does not get 
configured on CDMA interface, until the Proxy Binding Update from MAG2 
is complete,  this problem maybe avoided by some smart algorithm at the 
mobile end.

Thanks
Ashutosh

Hesham Soliman wrote:
>  > 
>  > As discussed during the base draft specification, I think this is a 
>  > general problem with multi-homed case when the mobile uses a 
>  > make-before-break scenario during handover between two MAGs, as the 
>  > mobile may end up having two same IP addresses on the mobile's two 
>  > interfaces for a while.
> 
> => I don't think that happens in a make-before-break case that I've seen. 
> Please explain how this happens in your scenario. Also note that I wasn't
> talking about a handover, this node can be still for hours. 
> 
> Hesham
> 
>  > 	However, in case of PMIP-PMIP handover, both MAG1 and 
>  > MAG2 having the 
>  > ownership MN's binding may not be an issue, as PBU through MAG2 will 
>  > effectively annul the binding at MAG1, as the LMA will be 
>  > updated and 
>  > will forward the traffic to MAG2 destined for interface 2 instead of 
>  > forwarding the data traffic destined for interface 1 via 
>  > MAG1 before the 
>  > handover.
>  > 
>  > Thanks
>  > Ashutosh
>  > 
>  > 
>  > Hesham Soliman wrote:
>  > > Hi, 
>  > > 
>  > > I didn't get a chance to explain this at the mic so here's 
>  > a followup.
>  > > 
>  > > One of the problems I see with using the home prefix in 
>  > NETLMM (i.e.
>  > > scenario C in the 
>  > > PMIP-MIP interaction draft) is the case where the MN is 
>  > multihomed. If you
>  > > have to allocate the same prefix in the local domain (i.e. 
>  > the permanent
>  > > home prefix) then we end up with a problem where MAG1 and 
>  > MAG2 both want to
>  > > own the MN's binding. This is obviously a broken scenario. 
>  > I don't know how
>  > > this can be solved.
>  > > 
>  > > Hesham
>  > > 
>  > > 
>  > > 
>  > > _______________________________________________
>  > > netlmm mailing list
>  > > [email-masked]
>  > > https://www1.ietf.org/mailman/listinfo/netlmm
>  > 
> 
> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Hesham Soliman" <[email-masked]>
Date: Thu, 26 Jul 2007 02:06:55 +1000

> when the mobile is static, this is a typical problem. 

=> Good, so we agree. 

   But 
 > then LMA has 

=> I don't know how the LMA would know how to do that since neither MAG can
know that the MN wants to maintain both connections without explicit
signalling from the MN. So I don't think it's a simultaneous bindings issue.

Hesham

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Thu, 26 Jul 2007 03:32:15 +0900

Dear Colleagues.

> then LMA has to maintain binding with both the MAGs (similar to
> simultaneous binding update). In normal case, LMA should overwrite the
existing
> binding with MAG1 and replace it with the binding with MAG2.

>> I don't know how the LMA would know how to do that since neither MAG can

Well, according to the current PMIPv6 specification, LMA will change the
tunnel endpoint to MAG2. So, I think there would be addition works for
multihomed MNs. As Soliman mentioned, LMA wouldn't know how to manage the
tunnel for multihomed MNs without explicit signallings from MAG or MN.

Cheers.

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://www.hurryon.org
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Ashutosh Dutta <[email-masked]>
Date: Wed, 25 Jul 2007 15:28:33 -0400

Agreed, we need to think about if any additional work is needed to 
support the multi-homed mobile and avoid such issues. These issues could 
  probably be covered in the base protocol document as raised during the 
meeting.

Thanks
Ashutosh

Jong-Hyouk Lee wrote:
>  > simultaneous binding update). In normal case, LMA should overwrite 
> the existing

> multihomed MNs. As Soliman mentioned, LMA wouldn't know how to manage 
> the tunnel for multihomed MNs without explicit signallings from MAG or MN.
> 
> Cheers.
> 
> 
> 
> On 7/26/07, *Hesham Soliman* <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
> 
>      > Hesham,
>      > >  > > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Sri Gundavelli" <[email-masked]>
Date: Wed, 25 Jul 2007 13:38:22 -0700

Hi Ashutosh/Jong-Hyouk,

This scenario of mobile node attaching to multiple 
access links, simultaneously, is an advanced issue.
This is not in the scope of the base document. These
scenario of simultaneous multi-access for PMIP should
be solved in a separate document and its a logical
extension to the base document. Also:

- It introduces some challenges from the host perspective,
  two interfaces being on the same home network prefix.
  Some host stacks may not be able to handle the same 
  address configuration over multiple interfaces. 

- There were some proposals in 3GPP on defining some virtual
  interface to handle such scenario's. It requires some
  investigation and a solution, it may require some changes
  to the host stack as well.

Bottom line, this requires some work and if the WG decides
to bring this into the charter, it should be solved in a 
separate document. 

Sri

> -----Original Message-----
> From: Ashutosh Dutta [mailto:[email-masked]] 
> Sent: Wednesday, July 25, 2007 12:29 PM
> To: Jong-Hyouk Lee
> Cc: [email-masked]
> Subject: Re: [netlmm] Today's discussion about multihomed MNs
> 
> >     => I don't know how the LMA would know how to do that 
> since neither
> >     MAG can

---

From: Ashutosh Dutta <[email-masked]>
Date: Wed, 25 Jul 2007 16:42:31 -0400

Sri, thanks for the clarification. Is it possible to include some 
statement involving scenarios for multi-homed clients under PMIP 
operating environment in the base document?

Thanks
Ashutosh

---

From: "Sri Gundavelli" <[email-masked]>
Date: Wed, 25 Jul 2007 13:56:21 -0700

Hi Ashutosh,

We can probably state that we do not support this scenario,
but, the solution doc, for this issue may very well cover
the whole problem and the solution. I do not know, if this
helps explaining this scenario in the base doc. I'd think,
we should just defer exploring this scenario.

Sri 

> Sent: Wednesday, July 25, 2007 1:43 PM
> To: Sri Gundavelli
> Cc: 'Jong-Hyouk Lee'; [email-masked]
> >>>      > configured on CDMA interface, until the Proxy 
> Binding Update
> >>>      > from MAG2
> >>>      > >  > will forward the traffic to MAG2 destined for 
> interface
> >>>      > 2 instead of

---

From: RYUJI WAKIKAWA <[email-masked]>
Date: Wed, 25 Jul 2007 16:08:00 -0500

Hi Sri,

If PMIP cannot run without MN's policy profile, MN should enable  
policy profile for single interface all the time.
MAG cannot initiate PBU for the other interfaces.
It may useful to have some flag indicating active/inactive in policy  
profile.

ryuji

---

From: "Sri Gundavelli" <[email-masked]>
Date: Wed, 25 Jul 2007 14:21:28 -0700

Hi Ryuji,

Just to clarify, we dont define any profile on the MN.

If each of the MN's interfaces are anchored to different
MAG's, any one of those MAG's cannot predictably identify which
one is the active interface. We can certainly support roaming
across multi-access, i.e a mobile using WiFI on MAG1 and
later moving to MAG2 over WiMAX. We cannot just specify one type
in the profile. So, enforcing single access thru policy profile
might be difficult. We just require the MN to use one active
interface at a time for the connectivity.

Sri

> From: RYUJI WAKIKAWA [mailto:[email-masked]] 
> Sent: Wednesday, July 25, 2007 2:08 PM
> To: Sri Gundavelli
> Cc: 'Ashutosh Dutta'; [email-masked]

---

From: RYUJI WAKIKAWA <[email-masked]>
Date: Wed, 25 Jul 2007 17:04:08 -0500

Hi Sri,

thanks for clarification. sorry I was confused.
ryuji

---

From: <[email-masked]>
Date: Thu, 26 Jul 2007 01:11:18 +0200

I support Sri's view. Keep the base spec as simple as possible.

I also have one question for my clarification.. If there is no
DHCP available, then a MN would configure a different MN-HoA for
a new interface after a handover even if the MN-HNP remained the
same, right? Or are folks assuming that we could somehow use the
same interface identifier on all interfaces (could be doable over
GPRS and any PPP link at least..)?

My 0.0145732€,
	Jouni

> From: Sri Gundavelli [mailto:[email-masked]] 
> Sent: 25. heinäkuuta 2007 23:38
> To: 'Ashutosh Dutta'; 'Jong-Hyouk Lee'
> Cc: [email-masked]
> Subject: RE: [netlmm] Today's discussion about multihomed MNs
> 
> 
> Hi Ashutosh/Jong-Hyouk,
> 
> This scenario of mobile node attaching to multiple access 
> links, simultaneously, is an advanced issue.
> This is not in the scope of the base document. These scenario 
> of simultaneous multi-access for PMIP should be solved in a 
> separate document and its a logical extension to the base 
> document. Also:
> 
> Bottom line, this requires some work and if the WG decides to 
> bring this into the charter, it should be solved in a 
> separate document. 
> 
> Sri
> 
> 
> >   probably be covered in the base protocol document as 
> raised during 
> > the meeting.
> > 
> > Thanks
> > Ashutosh
> > 
> > 
> > Jong-Hyouk Lee wrote:
> > > Dear Colleagues.
> > >

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Thu, 26 Jul 2007 13:09:20 +0900

Dear Jouni.

> I support Sri's view. Keep the base spec as simple as possible.

I agree. The base document would be a simple - only define base operations
and scenario, then other documents would solve such advanced or special
issues.

> GPRS and any PPP link at least..)?

In case of statless auto-configuration, a mobile node (MN) will have
addresses for each interface. As I know, however, the communication
interface is one used for binding with MAG (Actually, MAG or LMA maintains
MN-id information to allow PMIP service or not. Thus, it depends on how to
define that on MAG or LMA).

If I have wrong with this, please, pointing out.

Cheers.

---

From: "Kalin Getov" <[email-masked]>
Date: Thu, 26 Jul 2007 10:56:21 +0200

Hi all,

-------- Original-Nachricht --------
Datum: Thu, 26 Jul 2007 01:11:18 +0200
Von: [email-masked]
An: [email-masked], [email-masked], [email-masked]
CC: [email-masked]
Betreff: RE: [netlmm] Today\'s discussion about multihomed MNs

> GPRS and any PPP link at least..)?

  Same question, according to goal#2 in RFC 4831, if the address stays unchanged by handover within the pmip domain(even if changing interface by vertical handover), would reduce much of the signaling overhead...is this doable?

Thanks...

-- 
******************************************
Best Regards
Kalin Getov

[email-masked]
******************************************

Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kanns mit allen: http://www.gmx.net/de/go/multimessenger

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Sat, 28 Jul 2007 22:51:12 +0300

Hello everybody,

<chair hat off>

I agree with Sri and Jouni. I don't think the advanced multihoming 
scenario should be brought to the base spec - at least not in its 
completeness. Some text to indicate that if you do this you should 
better be sure that you handle the consequences.

I think if some system would, however, like to use PMIP for 
inter-technology handovers it should not be explicitly forbidden. How 
that would work and what changes are needed to the MN stack should be 
for them to investigate and not for us - at least for now.

Remember, this mail was sent as a participant and not as a chair.

</chair hat on>

Cheers,

Jonne.
ext [email-masked] wrote:
>>>>  > then LMA has to maintain binding with both the MAGs 
>>>>         
>> (similar to  
>>     
>>>>> simultaneous binding update). In normal case, LMA should
>>>>>           
>>> overwrite
>>>       
>>>> the existing
>>>>  >> I don't know how the LMA would know how to do that
>>>>         
>>> since neither MAG can
>>>       
>>>>  >> know that the MN wants to maintain both connections
>>>>         
>>> without explicit
>>>       
>>>> Well, according to the current PMIPv6 specification, LMA
>>>>         
>>> will change the
>>>       
>>>> tunnel endpoint to MAG2. So, I think there would be
>>>>         
>>> addition works for
>>>       
>>>> multihomed MNs. As Soliman mentioned, LMA wouldn't know how
>>>>         
>>> to manage
>>>       
>>>> the tunnel for multihomed MNs without explicit signallings
>>>>         
>>> from MAG or MN.
>>>       
>>>> Cheers.
>>>>
>>>>
>>>>
>>>>     know that the MN wants to maintain both connections
>>>>         
>>> without explicit
>>>       
>>>>      >      The following is the make-before-break scenario 
>>>>         
>>> I had in mind:
>>>       
>>>>      >
>>>>      > mobile is about to move out of WiFi hotspot and
>>>>         
>>> makes a move to CDMA
>>>       
>>>>      > have the same addresses momentarily. If MN's address
>>>>         
>>> does not get
>>>       
>>>>      > >  > general problem with multi-homed case when the
>>>>         
>>> mobile uses a
>>>       
>>>>      > > talking about a handover, this node can be still 
>>>>         
>> for hours.
>>     
>>>>      > >
>>>>      > > Hesham
>>>>      > >
>>>>      > >  >         However, in case of PMIP-PMIP handover, 
>>>>         
>>> both MAG1 and
>>>       
>>>>      > >  > MAG2 having the
>>>>      > >  > effectively annul the binding at MAG1, as the
>>>>         
>>> LMA will be
>>>       
>>>>      > >  > updated and
>>>>      > >  > forwarding the data traffic destined for 
>>>>         
>> interface 1 via
>>     
>>>>      > >  > MAG1 before the
>>>>      > >  > handover.
>>>>      > >  >
>>>>      > >  > Thanks
>>>>      > >  > Ashutosh
>>>>      > >  >
>>>>      > >  >
>>>>      > >  > Hesham Soliman wrote:
>>>>      > >  > > Hi,
>>>>      > >  > >
>>>>      > >  > > I didn't get a chance to explain this at the
>>>>         
>>> mic so here's
>>>       
>>>>      > >  > a followup.
>>>>      > >  > >
>>>>      > >  > > One of the problems I see with using the home
>>>>         
>>> prefix in
>>>       
>>>>      > >  > NETLMM (i.e.
>>>>      > >  > > scenario C in the
>>>>      > >  > > PMIP-MIP interaction draft) is the case where
>>>>         
>>> the MN is
>>>       
>>>>      > >  > multihomed. If you
>>>>      > >  > > have to allocate the same prefix in the local
>>>>         
>>> domain (i.e.
>>>       
>>>>      > >  > the permanent
>>>>      > >  > > home prefix) then we end up with a problem
>>>>         
>>> where MAG1 and
>>>       
>>>>      > >  > MAG2 both want to
>>>>      > >  > > own the MN's binding. This is obviously a
>>>>         
>>> broken scenario.
>>>       
>>>>      > >  > I don't know how
>>>>      > >  > > this can be solved.
>>>>      > >  > >
>>>>      > >  > > Hesham
>>>>      > >  > >
>>>>      > >  > >
>>>>      > >  > >
>> ------------------------------------------------------------------------
>>

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Sat, 28 Jul 2007 22:54:55 +0300

Oh,

maybe our issue tracker watch-dog could open an issue for this. That way 
we have the issue and the decision documented - whatever the final 
decision is...

Cheers,

Jonne.

---

From: "Dutta, Ashutosh" <[email-masked]>
Date: Sun, 29 Jul 2007 20:05:04 -0400

I think it is a good idea to add this into the issue list. There will be deployment instances where a multi-homed mobile may make movement between different access technologies  (e.g., WiFi and CDMA or WiMAX) while using PMIP as the mobility protocol. It would be interesting to see what are the real issues in such a deployment for the multi-homed environment such as, do we need a new MN-HoA  in the 2nd interface or will end up using the same one as assigned to the first one.
 
   As pointed out by Jouni, home prefix maybe same, but it all depends upon what interface identifier one would use to generate the IP address  for either interface in case of Stateless Address Autoconfiguration.
 
Thanks
Ashutosh

________________________________

From: Soininen Jonne (NSN - FI/Espoo) [mailto:[email-masked]]
Sent: Sat 7/28/2007 3:54 PM
To: ext [email-masked]
Cc: [email-masked]
Subject: Re: [netlmm] Today's discussion about multihomed MNs

Oh,

Cheers,

Jonne.
ext [email-masked] wrote:
> My 0.0145732EUR,
>>>> #webpage: http://www.hurryon.org <http://www.hurryon.org/> 
>>>>

---

From: "Hesham Soliman" <[email-masked]>
Date: Mon, 30 Jul 2007 12:00:22 +1000

Hi Jonne,  

 > completeness. 

=> Not only do I agree, I'd go further than that. I don't think we should be allowing this scenario. This scenario is not a problem because the MN is multihomed. It's a problem because people want to allocate the same prefix to more than one link. That's what we should not allow. 

Hesham

Some text to indicate that if you do this you should 
 > >>> support the multi-homed mobile and avoid such issues. 
 > These issues 
 > >>> could
 > >>>>  >> signalling from the MN. So I don't think it's a 
 > simultaneous 
 > >>>> bindings issue.
 > >>>>  
 > >>>>         
 > >>>       
 > >>>>      > anchored at MAG1 and interface 2 anchored with 
 > MAG2) at the
 > >>>>      > same time
 > >>>>      > update). In normal case, LMA should overwrite 
 > the existing
 > >>>>      > binding with
 > >>>>      > Assume that the mobile has two interfaces, 
 > 802.11 and CDMA.
 > >>>>      > While under
 > >>>>      > MAG1 mobile is using WiFi Interface, LMA sends 
 > traffic via
 > >>>>      > MAG1, and the
 > >>>>      > access that is controlled by MAG2. So, while the 
 > mobile is
 > >>>>      > still using
 > >>>>      > >  > make-before-break scenario during handover 
 > between two
 > >>>>      > MAGs, as the
 > >>>>      > >  > mobile may end up having two same IP 
 > addresses on the
 > >>>>      > mobile's two
 > >>>>      > >  > interfaces for a while.
 > >>>>      > >
 > >>>>      > > => I don't think that happens in a 
 > make-before-break case
 > >>>>      > that I've seen.