Subject: Re: [netlmm] Comments on draft-krishnan-netlmm-pmip-sel-00

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 11 Jul 2007 12:31:37 -0700 (PDT)

Hi Suresh,
  I am trying to understand why? Is there a fundamental restriction in EAP?
  In fact if you look at fig. 1 in draft-xia-netlmm-service-negotiation-00.txt, EAP does start from the authenticator. However it should also work if EAP started from MN, in fact, 802.1X allows the authentication to be initiated by MN.

Regards,

Behcet
----- Original Message ----
From: Suresh Krishnan <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, July 10, 2007 5:23:16 PM
Subject: Re: [netlmm] Comments on draft-krishnan-netlmm-pmip-sel-00

Hi Behcet,

Behcet Sarikaya wrote:
>   In your previous mail you said EAP can not start from the MN, now you 
> are saying no EAP?

If EAP does not originate from the MN, the mechanism in draft-xia cannot 
be used, since the MN has no way of indicating its preference for PMIP 
or non-PMIP service.

>   PMIPv6 says MN will perform access authentication during network entry 
> and in managed networks the current technology is to use EAP. 

Not all of them.

> Draft-xia-netlmm-service-negotiation adds PMIP service negotiation to 
> EAP exchange. That's it.

I got that part. I just said there are non EAP authentication mechanisms 
out there.

Cheers
Suresh

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 11 Jul 2007 15:38:13 -0400

Hi Behcet,

>   I am trying to understand why? Is there a fundamental restriction in EAP?

Nope. There isn't. But EAP is not the ONLY authentication protocol 
around. My question was, what happens when EAP is not used? How does the 
PMIP selection take place?

>   In fact if you look at fig. 1 in 
> draft-xia-netlmm-service-negotiation-00.txt, EAP does start from the 
> authenticator. However it should also work if EAP started from MN, in 
> fact, 802.1X allows the authentication to be initiated by MN.

No disagreement here.

Cheers
Suresh

---

From: Frank Xia <[email-masked]>
Date: Wed, 11 Jul 2007 16:04:55 -0500

Hi Suresh

Please see my inline comments.

BR
Frank

----- Original Message ----- 
From: "Suresh Krishnan" <[email-masked]>
To: "Behcet Sarikaya" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, July 11, 2007 2:38 PM
Subject: Re: [netlmm] Comments on draft-krishnan-netlmm-pmip-sel-00

> PMIP selection take place?

In fact, It hard for us find panacea for every scenario.  We just try to find optimal
solution in most common scenario.

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 12 Jul 2007 11:51:08 -0400

Hi Frank,

> solution in most common scenario.

Sure. But even if I agree that EAP is the most common scenario (I don't) 
we still need to solve the problem for the non-EAP case, right? Or do we 
want to sweep non-EAP under the rug and pretend it does not exist?

Cheers
Suresh

---

From: Frank Xia <[email-masked]>
Date: Thu, 12 Jul 2007 11:48:56 -0500

Hi Suresh

BR
Frank

----- Original Message ----- 
From: "Suresh Krishnan" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: <[email-masked]>; "Behcet Sarikaya" <[email-masked]>
Sent: Thursday, July 12, 2007 10:51 AM
Subject: Re: [netlmm] Comments on draft-krishnan-netlmm-pmip-sel-00

> want to sweep non-EAP under the rug and pretend it does not exist?

In fact , our main points are
1) mobility service negotiation is perferable to be done in access authentication stage.
    If there are some protocols adopted  other than EAP ,  extenstion
    should be done similary as EAP's. 
2)mobility sevice negotiation is service provided by operators,  and it is related  with
   accounting policy  and so on.