Subject: [netlmm] Today's discussion about multihomed MNs

From: "Hesham Soliman" <[email-masked]>
Date: Wed, 25 Jul 2007 05:34:44 +1000

Hi, 

I didn't get a chance to explain this at the mic so here's a followup.

One of the problems I see with using the home prefix in NETLMM (i.e.
scenario C in the 
PMIP-MIP interaction draft) is the case where the MN is multihomed. If you
have to allocate the same prefix in the local domain (i.e. the permanent
home prefix) then we end up with a problem where MAG1 and MAG2 both want to
own the MN's binding. This is obviously a broken scenario. I don't know how
this can be solved.

Hesham

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Mon, 30 Jul 2007 18:53:36 +0800

Hi Sri,

My name is Mohana and working for panasonic and interested in
multi-interface MN in a PMIP domain. My views are in-line for your
previous mail:
>-----Original Message-----
>From: Sri Gundavelli [mailto:[email-masked]] 
>Sent: Thursday, July 26, 2007 4:38 AM
>To: 'Ashutosh Dutta'; 'Jong-Hyouk Lee'
>Cc: [email-masked]
>Subject: RE: [netlmm] Today's discussion about multihomed MNs

>Hi Ashutosh/Jong-Hyouk,

- >It introduces some challenges from the host perspective,
  >two interfaces being on the same home network prefix.

In PMIP domain if there is a multi-interface MN present, each interface
will receive the same prefix(per MN-prefix). I don't see an issue here,
because the prefixes(same prefix) are unicasted to each interface of MN
via different MAGs. Thus as far as routing is concerned, there is no
issue because different MAGs will have a routing state to the same MN
prefix tied to different link-layer address of MN interface. Of course,
the LMA needs some multihoming support to maintain the same prefix
binding for the MN pointing to different MAGs (multi-homing support). 

>Some host stacks may not be able to handle the same
>address configuration over multiple interfaces. 
I think whether to configure same address for MN interfaces in PMIP
needs to be looked into in detail. Keeping the same address when
switching interface when roaming from one access technology to another
access technology may reduce vertical hand-off latency in PMIP. But,
when configuring same address for both interfaces, benefits needs to be
explored. Also, again in my opinion, having the same address for both
interfaces may not be a problem in PMIP domain, bcos interfaces are
attached to different MAGs and the routing state at MAG is such that it
binds MNs unique prefix to the link layer address of MN's interface. 
BR,
Mohana

> -----Original Message-----
> From: Ashutosh Dutta [mailto:[email-masked]]
> Sent: Wednesday, July 25, 2007 12:29 PM
> To: Jong-Hyouk Lee
> Cc: [email-masked]
> Subject: Re: [netlmm] Today's discussion about multihomed MNs
> 
> Agreed, we need to think about if any additional work is needed to 
> support the multi-homed mobile and avoid such issues. These issues 
> could
>   probably be covered in the base protocol document as raised during 
> the meeting.
> 
> Thanks
> Ashutosh
> 
> 
> Jong-Hyouk Lee wrote:
> > Dear Colleagues.
> >  
> >  > then LMA has to maintain binding with both the MAGs (similar to  
> > > simultaneous binding update). In normal case, LMA should
> overwrite
> > the existing
> >  > binding with MAG1 and replace it with the binding with MAG2.
> > 
> >  >> I don't know how the LMA would know how to do that
> since neither MAG can
> >  >> know that the MN wants to maintain both connections
> without explicit
> >  >> signalling from the MN. So I don't think it's a simultaneous 
> > bindings issue.
> >  
> 
> 
> > Well, according to the current PMIPv6 specification, LMA
> will change the
> > tunnel endpoint to MAG2. So, I think there would be
> addition works for
> > multihomed MNs. As Soliman mentioned, LMA wouldn't know how
> to manage
> > the tunnel for multihomed MNs without explicit signallings
> from MAG or MN.
> > 
> > Cheers.
> > 
> > 
> > 
> > On 7/26/07, *Hesham Soliman* <[email-masked] 
> > <mailto:[email-masked]>> wrote:
> > 
> > 
> > 
> >      > Hesham,
> >      >          I agree if you would like to use both the
> >      > interfaces (interface
> >      > anchored at MAG1 and interface 2 anchored with MAG2) at the
> >      > same time
> >      > when the mobile is static, this is a typical problem.
> > 
> >     => Good, so we agree.
> > 
> >       But
> >      > then LMA has
> >      > to maintain binding with both the MAGs (similar to
> >      > simultaneous binding
> >      > update). In normal case, LMA should overwrite the existing
> >      > binding with
> >      > MAG1 and replace it with the binding with MAG2.
> > 
> >     => I don't know how the LMA would know how to do that
> since neither
> >     MAG can
> >     know that the MN wants to maintain both connections
> without explicit
> >     signalling from the MN. So I don't think it's a simultaneous
> >     bindings issue.
> > 
> > 
> >     Hesham
> > 
> >      >
> >      >      The following is the make-before-break scenario 
> I had in mind:
> >      >
> >      > Assume that the mobile has two interfaces, 802.11 and CDMA.
> >      > While under
> >      > MAG1 mobile is using WiFi Interface, LMA sends traffic via
> >      > MAG1, and the
> >      > mobile is about to move out of WiFi hotspot and
> makes a move to CDMA
> >      > access that is controlled by MAG2. So, while the mobile is
> >      > still using
> >      > WiFi access, it can start the PMIP procedure using the
> >      > second interface
> >      > (CDMA interface) with MAG2 (assuming the mobile is under
> >      > CDMA coverage).
> >      > Depending upon when the address gets configured on the
> >      > second interface,
> >      > there maybe potentially an overlap of time when both the
> >      > interfaces can
> >      > have the same addresses momentarily. If MN's address
> does not get
> >      > configured on CDMA interface, until the Proxy Binding Update
> >      > from MAG2
> >      > is complete,  this problem maybe avoided by some smart
> >      > algorithm at the
> >      > mobile end.
> >      >
> >      > Thanks
> >      > Ashutosh
> >      >
> >      >
> >      >
> >      > Hesham Soliman wrote:
> >      > >  >
> >      > >  > As discussed during the base draft specification, I
> >      > think this is a
> >      > >  > general problem with multi-homed case when the
> mobile uses a
> >      > >  > make-before-break scenario during handover between two
> >      > MAGs, as the
> >      > >  > mobile may end up having two same IP addresses on the
> >      > mobile's two
> >      > >  > interfaces for a while.
> >      > >
> >      > > => I don't think that happens in a make-before-break case
> >      > that I've seen.
> >      > > Please explain how this happens in your scenario. Also
> >      > note that I wasn't
> >      > > talking about a handover, this node can be still for hours.
> >      > >
> >      > > Hesham
> >      > >
> >      > >  >         However, in case of PMIP-PMIP handover, 
> both MAG1 and
> >      > >  > MAG2 having the
> >      > >  > ownership MN's binding may not be an issue, as PBU
> >      > through MAG2 will
> >      > >  > effectively annul the binding at MAG1, as the
> LMA will be
> >      > >  > updated and
> >      > >  > will forward the traffic to MAG2 destined for interface
> >      > 2 instead of
> >      > >  > forwarding the data traffic destined for interface 1 via
> >      > >  > MAG1 before the
> >      > >  > handover.
> >      > >  >
> >      > >  > Thanks
> >      > >  > Ashutosh
> >      > >  >
> >      > >  >
> >      > >  > Hesham Soliman wrote:
> >      > >  > > Hi,
> >      > >  > >
> >      > >  > > I didn't get a chance to explain this at the
> mic so here's
> >      > >  > a followup.
> >      > >  > >
> >      > >  > > One of the problems I see with using the home
> prefix in
> >      > >  > NETLMM (i.e.
> >      > >  > > scenario C in the
> >      > >  > > PMIP-MIP interaction draft) is the case where
> the MN is
> >      > >  > multihomed. If you
> >      > >  > > have to allocate the same prefix in the local
> domain (i.e.
> >      > >  > the permanent
> >      > >  > > home prefix) then we end up with a problem
> where MAG1 and
> >      > >  > MAG2 both want to
> >      > >  > > own the MN's binding. This is obviously a
> broken scenario.
> >      > >  > I don't know how
> >      > >  > > this can be solved.
> >      > >  > >
> >      > >  > > Hesham
> >      > >  > >
> >      > >  > >
> >      > >  > >
> >      > >  > > [email-masked] <mailto:[email-masked]>
> >     [email-masked] <mailto:[email-masked]>
> > --
> > Internet Management Technology Lab, Sungkyunkwan University.
> > Jong-Hyouk Lee.
> > 
> > #email: jonghyouk (at) gmail (dot) com
> > #webpage: http://www.hurryon.org
>

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Tue, 31 Jul 2007 09:19:46 +0800

Hi Sri,

Thanks for your detailed answer. Yes, I agree if an IPv6 node needs to
maintain same addresses in both interfaces, then there needs to be
changes as pointed out by you at the host side. Both stateless and
satteful address configuration mechansims may end up yielding different
addresses for the interfaces. 

You mentioned about bicasting from LMA to both interfaces. This is a
"may" I guess. LMA can choose different alternate interfaces (or MAG
addresses) to tunnel.

The problem here is that, according to netlmm goals (RFC 4831) the
changes to legacy IPv6 should be avoided. Yeah, got your point thanks.
Mohana

>Sent: Monday, July 30, 2007 10:34 PM
>To: Mohana Jeyatharan
>Cc: [email-masked]

>Hi Mohana,

> In PMIP domain if there is a multi-interface MN present, each 
> interface will receive the same prefix(per MN-prefix). I don't see an 
> issue here, because the prefixes(same prefix) are unicasted to each 
> interface of MN via different MAGs. Thus as far as routing is 
> concerned, there is no issue because different MAGs will have a 
> routing state to the same MN prefix tied to different link-layer 
> address of MN interface.
> Of course,
> >Some host stacks may not be able to handle the same address 
> >configuration over multiple interfaces.

> when configuring same address for both interfaces, benefits needs to 
> be explored. Also, again in my opinion, having the same address for 
> both interfaces may not be a problem in PMIP domain, bcos interfaces 
> are attached to different MAGs and the routing state at MAG is such 
> that it binds MNs unique prefix to the link layer address of MN's 
> interface.
> BR,
> Mohana
> 
> 

>My concerns are on the host side. For each of the address configuration
mechanisms, I do not see how the 
>host will end up configuring the same identifier on both the interfaces
and further how the routing table 
>will look in such scenario.

>I do not know if there is a config option in Linux 2.6 kernel, that
allows the host to access the LAN over >multiple interfaces and with the
same L3 address configuration.

>Autoconf:>
>If the interface identifiers are based on EUI-64, the generated
addresses will be different on each of the >interfaces, as the MAC
addresses are different.

>DHCPv6:>
>The DHCP server will allocate a unique address for each of the
interfaces, for each of the DHCP query.

>Packet Duplicates:>
>The LMA may choose to bicast the packets over each of the tunnel, but
the host will receive duplicate >>packet for every packet that it
receives.

>Default Gateway:>
>The host needs to maintain multiple default gateways over multiple
interfaces.
>May not be an issue. But, needs to verify the behavior of the current
IPv6 stacks for this configuration.

>I think, changes will be required on the host stack to achieve this.
>Otherwise,
>no issue.
>Sri