Subject: [newtrk] rethinking "after stage one": perhaps a different kind of document?

From: Larry Masinter <[email-masked]>
Date: Sat, 10 Jul 2004 19:26:48 -0700

This isn't entirely coherent, but bear with me...

While earlier I argued for "keep three stages", I'm starting
to lean more toward "one stage for documents plus some
other formal specifications".

I've been thinking that perhaps "after Proposed Standard"
requires a different kind of document.

For Proposed Standard, it is common for the Internet Drafts
and RFCs not to be "whole protocols", but rather pieces;
e.g., there's a document for HTTP, another one for HTTP
authentication, another one for cookies, another one for
MIME types, another one for the text/html media type, etc.

An implementor has to look at a lot of different
specifications to see what to implement. More importantly,
the notion of "independent interoperable implementations"
should (even though it doesn't currently) span the suite
of specifications that are necessary to implement an
application.

So perhaps "after Proposed Standard" documents should be
different, in that they should be a pointer to the suite
of RFCs and referenced documents that are necessary for
the complete implementations that are tested...

Larry
-- 
http://larry.masinter.net

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Aaron Falk <[email-masked]>
Date: Mon, 12 Jul 2004 15:16:31 -0400

> the complete implementations that are tested...

Larry-

Take a look at draft-duke-tcp-roadmap-00.txt and see if that's the kind 
of thing you have in mind.

--aaron

.

---

From: John C Klensin <[email-masked]>
Date: Mon, 12 Jul 2004 21:58:09 -0400

> the complete implementations that are tested...

Please have a look at
draft-klensin-newtrk-std-repurposing-00.txt and see if that
mechanism -- which involves documents independent of RFCs that
can be used to document relationships, implementation status,
etc. and that starts at (not after) "Proposed" -- would suit
your purposes.

     john

.

---

From: Alex Rousskov <[email-masked]>
Date: Tue, 13 Jul 2004 01:52:37 -0600 (MDT)

On Sat, 10 Jul 2004, Larry Masinter wrote:

> So perhaps "after Proposed Standard" documents should be different,
> in that they should be a pointer to the suite of RFCs and referenced
> documents that are necessary for the complete implementations that
> are tested...

While describing related specs in one coherent document is often quite
useful (wasn't there are recent draft about how to do it?), I am not
sure there are enough reasons for doing that "after" the first stage.
Such descriptions can exist independently of RFC stages and can even
talk about perceived RFC stability and such, in case of a single-stage
track.

Alex.
.