Subject: Re: [newtrk] List of Old Standards to be retired

From: Bob Braden <[email-masked]>
Date: Thu, 16 Dec 2004 09:31:02 -0800 (PST)

*> From [email-masked]  Thu Dec 16 05:23:25 2004
  *> Mime-Version: 1.0
  *> Date: Thu, 16 Dec 2004 08:02:44 -0500
  *> To: Eliot Lear <[email-masked]>, IETF Discussion <[email-masked]>
  *> From: Margaret Wasserman <[email-masked]>
  *> X-Spam-Score: 0.1 (/)
  *> X-Scan-Signature: ffa9dfbbe7cc58b3fa6b8ae3e57b0aa3
  *> Cc: "[email-masked]'" <[email-masked]>,
  *>    [email-masked]
  *> Subject: Re: [newtrk] List of Old Standards to be retired
  *> List-Id: IETF-Discussion <ietf.ietf.org>
  *> X-ISI-4-32-5-MailScanner: Found to be clean
  *> X-ISI-4-30-3-MailScanner: Found to be clean
  *> X-Spam-Status: No, hits=-4.9 required=5.0 tests=AWL,BAYES_00 autolearn=ham
  *> 	version=2.64
  *>
  *>
  *> >RFC0885       Telnet end of record option
  *>
  *> This option was, at least at one time, used for telnet clients that
  *> connected to IBM mainframes...  It was used to indicate the end of a
  *> 3270 datastream.  I don't know if it is still used in that fashion,
  *> but Bob Moskowitz might know.
  *>

I don't see that usage matters in the least. The EOR option provides a
function that was useful at one time and may be useful again.  It is
not technically unsound.  I don't see any excuse to change the category
of this document.

Bob Braden  (speaking for himself)
.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 Dec 2004 22:09:41 -0500

--On Thursday, 16 December, 2004 09:31 -0800 Bob Braden
<[email-masked]> wrote:

>...
>   *> This option was, at least at one time, used for telnet
> clients that   *> connected to IBM mainframes...  It was used
> to indicate the end of a   *> 3270 datastream.  I don't know
> if it is still used in that fashion,   *> but Bob Moskowitz
> might know.
>   *>
> 
> I don't see that usage matters in the least. The EOR option
> provides a function that was useful at one time and may be
> useful again.  It is not technically unsound.  I don't see any
> excuse to change the category of this document.
> 

Let me reinforce this.  If one is going to use Telnet, one can
transmit and, where appropriate, expect echoing, 

	* one character at a time
	* one line at a time
	* one block of stuff at a time.

Each is well-defined, each is functional, each has value in some
circumstances.  There is neither value nor other reason to try
to deprecate any of them.

If there is really a crusade against the number of outstanding
telnet options around, the solution is SUPDUP, which is based on
a much stronger and featureful virtual terminal model.
Unfortunately, there are few contemporary implementations of
SUPDUP and it is more appropriately on the hit list than
(almost?) any of the telnet options.

    john

.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 17 Dec 2004 12:51:33 +0100

[reply limited to newtrk, since it's that group's debate]

> not technically unsound.  I don't see any excuse to change the category

Bob,

just a reminder: You have stated an opinion on this that is different from 
the consensus of the NEWTRK working group so far - that we should NOT 
follow the RFC 2026 mandate to move things to historic that do not advance.

While it's a perfectly reasonable position to take, I don't think the 
old-standards team should take that into consideration when doing 
evaluation of individual documents against the criteria that NEWTRK agreed 
that the old-standards group should be doing.

                 Harald

.