Subject: RE: [newtrk] one size fits all vs two-step

From: <[email-masked]>
Date: Mon, 1 Aug 2005 10:45:32 +0300

Pekka,

> On Mon, 1 Aug 2005 [email-masked] wrote:
> >> I read both draft-loughney-newtrk-one-size-fits-all-00.txt and
> >> draft-carpenter-newtrk-twostep-00.txt.
> >>
> >> I like twostep much more, because it still includes a notion that obtaining
> >> interoperability information is important, and if a spec has
> >> knobs which aren't used or or implemented, at least the fact should be
> >> documented if those can't be reasonably removed.
> >
> > For the one-step, the process for handling this would be to simply revise
> > the spec.  It is entirely reasonable to revise specs in order to remove
> > knobs.
> 
> Indeed.  Howeve, why I liked two-step was that specs that have 
> bothered to do that step will be able to get special status.  Maybe 
> this would encourage folks to go through that step.

So, if I can summarize, you like being able to designate RFCs with some notion
of the status of the document.  

I'm not sure there is really any evidence that the status provides any
motivation for progressing the documents up the 3 stage process right now,
so I'm not sure that the motivation is there to progress it up a 2 stage
process.

YMMV,
John

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: <[email-masked]>
Date: Wed, 3 Aug 2005 17:11:47 +0300

Bruce,

> Sure, and there may be some scope for minor reform of 2026 to assist
> (see separate message in response to Sam's "in support of Larry's
> proposal" message) WGs to plan for advancement and in so doing to
> simplify review.  On the other hand, if the IESG disbands WGs before
> they *can* request PS-DS status change (minimum 6 months after PS),
> it's inappropriate to blame the WGs.  And the IESG has been disbanding
> WGs.

I'd even go one step further - the IESG charters WGs that have charters
that end at 'Submit x for proposed standard' - so that could be 
interpreted that the IESG is only planning for WGs to produce PS documents
and then go out of business ....

John L.

.

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Wed, 3 Aug 2005 16:39:38 +0200

> I'd even go one step further - the IESG charters WGs that 
> have charters that end at 'Submit x for proposed standard'
> - so that could be interpreted that the IESG is only planning
> for WGs to produce PS documents and then go out of business ....
> 
> John L.

Well, the IESG approves the charters, but there is usually a
dialog with others during that process. Also, when the charter
is getting close to completion, I see it as one of our duties
as WG chairs to suggest how to proceed (close WG or add new
items such as PS->DS advancement). IMHO, it would be wrong to
include PS->DS advancement as a milestone when the work item
is originally included in the charter. 

/L-E

.

---

From: <[email-masked]>
Date: Wed, 3 Aug 2005 19:08:58 +0300

Lars-Erik,

> is originally included in the charter. 

Why?  My assumption, as WG chair, is that closing is the default 
condition.  Some WGs do have progressing drafts onwards & upwards,
so that could be at least stated, even if there are not explicit
deadlines for this.

John

.

---

From: "Robert Snively" <[email-masked]>
Date: Wed, 3 Aug 2005 10:04:48 -0700

The point is that the compliance and interoperability program
should be separated from the standards process, not embedded
in the standards development path.

Addressing only the interoperability path, the IETF
interoperability reports are interesting in that they
show that certain implementations have
been tested. However, that does not necessarily show how to demonstrate
the likely interoperability of future implementations.

For your review, here are three practical examples
of test specifications that have been used in the preparation
of interoperability testing programs.  Note that test specification  
development is not in the standards development path, but there is some
mechanism of feedback into the standards development path. 

IEEE publishes for many significant standards a document
or clause within a document called a Protocol Implementation 
Conformance Statement (PICS).  Such statements can be used
by any third party to create a pretty effective interoperability
screening test.  For examples of PICS, see http://standards.ieee.org/
and search on "PICS".  In many cases, the IEEE develops these
in parallel with the standards development process, providing 
a check on the standard development as well.

The FCIA publishes for key Fibre Channel standards a set of
documents called SANMark tests.  These are developed by the
trade organization with very strong liaison with the standards
committee.  For an example of a SANMark test, see 
http://www.fibrechannel.org/products/SCD-3001vB.pdf.
The actual testing uses third party implementations of the 
tests to verify proper behavior.

SNIA has created a conformance testing program for the
SMI-S management programs.  This is described at
http://www.snia.org/ctp/ctp_process_smi, but the text
of the test plan documents is available only to SNIA members.
This work is often prepared in parallel with the
standard as part of the mechanism for verifying the
correctness of the standard.

The legal statements associated with these tests or the
related testing programs have the same
kind of wishy-washy wording that the IETF would also use in
creating or encouraging the creation of such tests.  Lawyers
and insurance should not be any more necessary than they
are already.  The tests do not guarantee interoperability, but 
devices that pass the tests have a high probability of 
successfully interoperating, since all normal and many
abnormal states are thoroughly investigated.

Robert Snively
+1 408 333 8135
[email-masked] 

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, August 03, 2005 5:27 AM
> To: Robert Snively
> Cc: Spencer Dawkins; [email-masked]; [email-masked]
> Subject: Re: [newtrk] one size fits all vs two-step
> 
> 
> I think you'll find that the interop reports posted
> at http://www.ietf.org/IESG/implementation.html often
> do derive from such efforts. But the IETF itself doesn't
> get into the certification or conformance business. We
> don't have enough lawyers or insurance for that.
> 
>     Brian
> 
> Robert Snively wrote:
> > Interoperability is related to the clarity and completeness of
> > a specification/RFC/standard.  However, it is even more dependent
> > on the faithful implementation of that standard.  It seems to me
> > that interoperability would be more effectively achieved by taking
> > advantage of certification and testing mechanisms separate from the 
> > path of standards development rather than using a two-step 
> > standards creation process.
> > 
> > One example would be the development of standards and specifications
> > specifying conformance testing procedures, either from within
> > IETF or as part of the work product of IETF product 
> marketing organizations.
> > 
> > Another example would be the use of monitored independent 
> plugfests, such as
> > those held by the University of New Hampshire's 
> Interoperability Laboratory
> > (http://www.iol.unh.edu/).
> > 
> > Since long-term stability and back compatibility of the internet
> > is clearly very important, that would be a key subject of such
> > monitored plugfests.
> > 
> > Clearly, such work will lead to the identification of mistakes and
> > unclear text in the standards, but that (as pointed out by
> > John Loughney) is easily remedied by revisions to the standard.
> > 
> > The overhauled website suggested by Bruce Lilly is an 
> obvious mechanism
> > to maintain current information about the status of standards 
> > and the existence of on-going efforts to improve and revise
> > those standards that need revision.  It would also be the place that
> > would document the status and content of new standards 
> being developed.
> > 
> > 
> > Robert Snively
> > +1 408 333 8135
> > [email-masked] 
> > 
> > 
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked]
> >>[mailto:[email-masked]]On Behalf Of Spencer Dawkins
> >>Sent: Monday, August 01, 2005 12:45 AM
> >>To: [email-masked]
> >>Subject: Re: [newtrk] one size fits all vs two-step
> >>
> >>
> >>
> >>>knobs which aren't used or or implemented, at least the 
> fact should 
> >>>be
> >>This would not be unreasonable, if we made more effort to 
> obtain and 
> >>document interoperability information.
> >>
> >>My problem with the current process is that it is 
> engineered for the 
> >>case which is not the common case - count PS, count DS and 
> count IS, 
> >>for a proof of this.
> >>
> >>We could change the current process in more than one way - I've 
> >>proposed three versions so far, since 2003. Meanwhile, 2026 
> >>still says 
> >>what it says.
> >>
> >>I would really like to change it to what we are actually doing, 
> >>whatever that is. If we change it to what we WILL be doing in the 
> >>future, that could be lovely, too.
> >>
> >>Spencer
> >>
> >>
> >>
> >>.
> >>newtrk 
> resources:_____________________________________________________
> >>mhonarc archive: 
> http://darkwing.uoregon.edu/~llynch/newtrk/index.html
> >>
> >>
> > 
> > 
> > .
> > newtrk 
> resources:_____________________________________________________
> > mhonarc archive: 
> http://darkwing.uoregon.edu/~llynch/newtrk/index.html
> > 
> 
> 
> 

.