Subject: RE: [newtrk] RE: Interoperability Testing Format

From: <[email-masked]>
Date: Tue, 9 Aug 2005 06:16:29 +0300

I think you summed-up my worries about interoperability reports nicely,
Harold.  Doing a good interop report probably will incur as much work
as any other the other meta-docs we're talking about here.

John

> --On 8. august 2005 10:15 -0700 Larry Masinter <[email-masked]> wrote:
> 
> > After the meeting, I asked people to review existing 
> interoperability
> > reports and give their opinion about whether they were good
> > or bad, so we could start working on guidelines for what made
> > a "good" interoperability report, and understanding what the
> > evaluation criteria might be.
> 
> My absolute favourite implementation report of all time:
> 
> <http://www.ietf.org/IESG/Implementations/SMTP-PIPELINE-implem
> entation>
> 
> The "more serious-looking" version for Standard, not much longer:
> 
> <http://www.ietf.org/IESG/Implementations/SMTP-PIPELINING-Stan
> dard-implementation>
> 
> Let's make sure we don't REQUIRE anything much longer.
> 
>                   Harald
> 
> .
> newtrk resources:_____________________________________________________
> web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
> mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html
> 

.
newtrk resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/newtrk.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/newtrk/index.html

---

From: Larry Masinter <[email-masked]>
Date: Mon, 08 Aug 2005 23:03:45 -0700

> as any other the other meta-docs we're talking about here.

I don't disagree, but I think that's not so bad. Getting the schema
right -- identifying which RFCs are needed as a total, and creating
the feature list -- is probably as much or even a more work
 than writing an ISD or a SRD.

However, I think 

* the result is more useful
   You can use the interop schema and report to aid in
   standards track progression, as well as understand the
   relationship between multiple RFCs.

* there are likely different people motivated to work on it
   Technical specs are generally written by 'product management'
   and 'software engineering', but test specs are frequently
   written/reviewed by 'quality engineering'
* the net added work is less
   Writing an ISD is totally new work; we don't generally write them.
   Writing implementation/interoperability testing schemas is
   something that many IETF efforts already do, as part of
   interop testing.

Larry
-- 
http://larry.masinter.net

.