Subject: Re: NFS MIB ideas

From: Mike Eisler <[email-masked]>
Date: Thu, 15 Mar 2001 18:33:52 -0800 (PST)

> Venkat Rangan wrote:
> > 
> 
> > I created a very early version of the MIB which covers the following areas:
> > 
> > - Error counters that count the number of occurrences of almost all errors
> > 
> > - Statistical counters for all the NFS v4 operations
> > 
> > - Table of current locks and their owners
> 
> I'm a neophyte to MIB design, but it seems that you should design
> a MIB so that it provides access to data that an NFS administrator needs.
> 
> I'm an NFSv4 engineer, so error and operations counts would
> be lovely, but it doesn't seem all that useful to an NFS sysadmin
> no matter how much you process the data.
> 
> My guess is that admins would be interested in higher-level
> statistics, e.g. which filesystems are hot? which clients
> are beating on my server? what's the average call processing
> time? How many bytes/sec are being read/written?

I think errors that would help an NFSv4 customer support engineer debug
a customer's problem are useful.

	-mre

---

From: Gordon W Waidhofer <[email-masked]>
Date: Thu, 15 Mar 2001 18:54:21 -0800

For what it's worth, which probably ain't much....

2790 Host Resources MIB. S. Waldbusser, P. Grillo. March 2000.
     (Format: TXT=95807 bytes) (Obsoletes RFC1514) (Status: DRAFT
     STANDARD)

    http://www.ietf.org/rfc/rfc2790.txt