Subject: RE: OPEN4_RESULT_LOCKTYPE_POSIX

From: "Noveck, Dave" <[email-masked]>
Date: Tue, 3 Sep 2002 10:41:07 -0700

Stevan Steve Allen: 
> Requesting clarification as to what OPEN4_RESULT_LOCKTYPE_POSIX represents:
> (new open return flag added in July draft)
> 
> o Server supports the complete set of posix locking techniques i.e.
> subrange unlock & promotion.

This is my understanding of what it means.

> o Caution, Server implementation supports an unspecified subset of posix
> locking techniques.

What could a client do with this information, if you can call it
information?  "I might support it.  I might not not." doesn't help
the client much.

> o Caution, Server implementation only supports a minimal set of posix
> locking techniques.

No idea what a minimal set might be.

---

From: Mike Eisler <[email-masked]>
Date: Wed, 04 Sep 2002 18:55:01 -0700

I agree with everything Dave says here. OPEN4_RESULT_LOCKTYPE_POSIX can only
mean the complete set of posix locking semantics.

	-mre