Subject: file_id

From: "Eric Sedlar" <[email-masked]>
Date: Wed, 27 Nov 2002 18:28:55 -0800

How important is it to support file_id?  Our filesystem has a 16 byte GUID, and the file_id attribute is fixed at 8 bytes.  Is there some reason it wasn't variable length?

--Eric

---

From: "Gordon Waidhofer" <[email-masked]>
Date: Wed, 27 Nov 2002 21:32:08 -0800

The APIs (ala POSIX), especially stat(2).
The fileid is mapped to 'ino_t st_ino'.
Most systems use a 32 bit ino_t, some support 64 bit.
Some programs use st_ino for identity, like cmp(1)
and cp(1). For example, cp(1) uses st_ino to
prevent 'cp x x'. Is it important? It's sorta
a judgement call. I'd urge heroics on this one.
If taken lightly, you could encounter weird
problems in the field that are awkward to explain.
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Eric Sedlar
  Sent: Wednesday, November 27, 2002 6:29 PM
  To: [email-masked]
  Subject: file_id

  How important is it to support file_id?  Our filesystem has a 16 byte
GUID, and the file_id attribute is fixed at 8 bytes.  Is there some reason
it wasn't variable length?

  --Eric