Subject: OPEN_CONFIRM implementation issues

From: Mike Eisler <[email-masked]>
Date: Fri, 8 Nov 2002 12:54:57 -0800 (PST)

My interpretation of OPEN_CONFIRM is that since
the server solicits it, the client MUST NOT send it
when it is unsolicited. I agree with Dave N that
we are somewhat ambiguous. Server's are certainly
free to be forgiving, but I would think that in
our tight little community here, we could get the
client implementors on board. Sending an OPEN_CONFIRM
only when the server solicits is the simplest implementation,
so why not just do that?

So what are Sun, Hummingbird, and CITI going to do in
their clients?

	-mre

---

From: eric kustarz <[email-masked]>
Date: Mon, 11 Nov 2002 11:18:35 -0800

> So what are Sun, Hummingbird, and CITI going to do in

Our (SUN) client only sends an OPEN_CONFIRM when the server request it
(which means only after sending an OPEN) because that's the only thing
that makes sense.

It does seem simpler for the server to return an error for unsolicited
OPEN_CONFIRM, is it too late to change the spec?

eric