Subject: [nfsv4] Fw: email bounced to nfsv4-wg alias

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 14 Mar 2003 11:50:18 -0800

Hi -

Done.  Enough hoops already.  I guess I'll wait till it comes up in IETF last call.

Randy

> From: "Spencer Shepler" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Thursday, March 13, 2003 1:13 PM
> Subject: Re: email bounced to nfsv4-wg alias
>
> The WG alias has moved to [email-masked].  If you send mail to that
> alias, I will approve the post so you do not have to subscribe.
>
> It would be great if you raised this issue directliy on the list in
> case there is follow up discussion.
>
> Spencer
>
> On Wed, Randy Presuhn wrote:
> > Hi -
> >
> > The I-D's discussion of strings limited to ASCII (at the very least it
> > should have a reference so it's clear whether it's 7-bit or one of the
> > 8-bit variants from ISO) is at odds with RFC 2277.
> > UTF-8 might merit a look.
> >
> > Randy
> >
> > > From: "Spencer Shepler" <[email-masked]>
> > > To: "Randy Presuhn" <[email-masked]>
> > > Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
> > > Sent: Wednesday, March 05, 2003 3:44 AM
> > > Subject: Re: email bounced to nfsv4-wg alias
> > >
> > > Unfortunately, I do not have a copy of your comments any longer.
> > > Please resend to me and I will forward to the WG, etc.
> > >
> > > On Tue, Randy Presuhn wrote:
> > > > Hi -
> > > >
> > > > I am not interested in subscribing to this working group mailing list.
> > > > I would, however, like my comments forwarded to the mailing list
> > > > since they pertain to WG chartered work's compliance with RFC 2277.
> > > >
> > > > Randy
> > > >
> > > > ----- Original Message -----
> > > > From: "Spencer Shepler" <[email-masked]>
> > > > To: <[email-masked]>
> > > > Sent: Tuesday, March 04, 2003 12:13 AM
> > > > Subject: email bounced to nfsv4-wg alias
> > > >
> > > >
> > > > >
> > > > > Your email bounced because of non-member submission.  You are welcome
> > > > > to subscribe to [email-masked] and repost.
> > > > > [email-masked] will accept your submission request.
> > > > >
> > > > > --
> > > > > Spencer
> > > > >
> > > > >
> > > >
> > > >
> > >
> > > --
> > > Spencer
> > >
> >
> >
>
> --
> Spencer
>

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Mike Eisler <[email-masked]>
Date: Fri, 14 Mar 2003 13:00:06 -0800

Randy,

Spencer tells me that your issue is with the XDR i-d.

Yes, the string typdef is limited to 7 bit ASCII. Since this
i-d documents a widely used existing standard, we can't
change this.

We could consider the addition of a  utf-8 typdef support to XDR.
In my opinion that should be a separate standards track document.

It is possible IESG will insist that for XDR to advance to Standard, it
needs to support utf-8. That would be disappointing, but if that's
the case, then I'm sure Rob or Brian will find a document
editor for it if the wg thinks advancing XDR is important. Best
of luck to the wg achieving consensus.

Note that the NFSv4 specification attempted to add a utf-8
type, and it's been nothing but misery on this alias
ever since. There are dozen or so conflicting opinions about
normalization and other processing. So I wish
the future xdr-utf-8 doc editor a lot of luck,
and my sympathy.

    -mre