Subject: [nfsv4] callbacks via TCP

From: [email-masked]
Date: Thu, 17 Jul 2003 15:25:11 -0400 (EDT)

This is going to sound like a dumb one, but I can't find it spelled out
in the RFC, so here goes...

For a callback via TCP, is the server expected to
#1 -  do a "connect" to the client at the specified address
OR
#2 - is it expected to find that one of the connections that already
	exists from client->server has the specified address as the other end

(Since I had done callbacks "in-band" on the
same TCP virtual circuit way back when I did NQNFS, I was thinking #2,
but I now realize the RFC probably means #1.)

So, is it door #1 or door #2?

Thanks again, rick

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 17 Jul 2003 14:44:59 -0500

> So, is it door #1 or door #2?

The RFC selects Door #1.

We would like to get to Door #2 in a future minor revision (or
something like it).

-- 
Spencer