Subject: RE: [nfsv4] Client disk cache

From: Mike Eisler <[email-masked]>
Date: Mon, 18 Aug 2003 10:38:56 -0700

> -----Original Message-----
 > From: Wim Glassee [mailto:[email-masked]]
 > Sent: Thursday, August 14, 2003 6:03 AM
 > To: [email-masked]
 > Subject: [nfsv4] Client disk cache
 >
 >
 > Hi all,
 >
 > At the moment I'm using AFS mainly because of it's client disk cache
 > possibilities. However, for my needs (a linux cluster setup),
 > I have the
 > feeling AFS is a bit overkill. I don't need extreme security
 > measures or
 > such, just an easy to work with (and big) client disk cache.
 >
 > Can NFSv4 do this for me? Or will it ever?

Disk caching and the file access protocol, and the version
of the file access protocol are largely orthogonal ... Solaris has had
cachefs for over 10 years starting back in the NFSv2-only days.
Of course delegations in NFSv4 could make cachefs "cleaner".

That Linux doesn't have a cachefs after all these years doesn't
bode well for it having one in the near future. There is an
interesting and relevant discussion in
http://www.ussg.iu.edu/hypermail/linux/kernel/0306.1/0271.html but 
unfortunately
no resolution to actually do anything.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: 18 Aug 2003 14:20:19 -0700

>>>>> " " == Mike Eisler <[email-masked]> writes:

     > http://www.ussg.iu.edu/hypermail/linux/kernel/0306.1/0271.html
     > but unfortunately

Relax Mike...

     http://cvs.infradead.org/cgi-bin/cvsweb.cgi/afs/

The cachefs there is quite general-purpose (not AFS-specific).

Cheers,
   Trond

---

From: Mike Eisler <[email-masked]>
Date: Mon, 18 Aug 2003 14:41:07 -0700

> http://cvs.infradead.org/cgi-bin/cvsweb.cgi/afs/

Not my fault that google showed the June discussion before the July
discussion. :-) Anyway, I'm glad my prediction is profoundly
wrong.

> The cachefs there is quite general-purpose (not AFS-specific).

Looks very promising. The Linux kernel mail archives shows that a patch 
request for
2.6 was submitted last month ... is this going to be accepted?

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 18 Aug 2003 15:43:19 -0700

> Looks very promising. The Linux kernel mail archives shows that
     > a patch request for

Linus has said he is pretty happy with it, but that since it was
submitted after the 2.6.0-test code slush came into effect, it would
have to be put on hold.

I would be surprised, though, if it doesn't get merged into the main
tree some time during the stable 2.6.x cycle. A *lot* of people have
been waiting for this...

Cheers,
  Trond