Subject: RE: [nfsv4] draft-ietf-nfsv4-acl-mapping-00: mapping of posix to NFSv4 access mask bits

From: Mike Eisler <[email-masked]>
Date: Wed, 20 Aug 2003 16:13:40 -0700

> As a side issue, I have not been able to find any discussion
 > of attributes
 > like immutable, append only, etc, in the archive, and their
 > absence any

I can't find "append only" or "immutable" in RFC3530. Are
you asking why those aren't among the list of attributes?
In the past, if there's no existence proof of an client-side
API for an attribute, then the working group consensus has been
to not include them. I don't believe POSIX has these attributes;
is there an operating environment that does?

 > discussion any where in the SPEC (even as standardized named
 > attributes)
 > is interesting.

In NFSv4 there are no standarized named attributes. :-)

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Richard Sharpe <[email-masked]>
Date: Thu, 21 Aug 2003 16:03:45 -0700 (PDT)

> is there an operating environment that does?

They are not POSIX attributes, but then, neither are HIDDEN, SYSTEM and 
ARCHIVE (yes, I know that that attribute is deprecated in at least the 
latest version of NFSv4. Nor are NFSv4 ACLs.

FreeBSD defines UF_IMMUTABLE and UF_APPEND as bits in the st_flags field 
on its stat structure, while Linux seems to keep them in inodes and has 
special attribute calls to retrieve these attributes.

In some sense, READONLY is equivalent to IMMUTABLE.

I guess my pet peeve at this point is that HIDDEN, SYSTEM, and ARCHIVE 
made it into the standard, but READONLY didn't.
 
> In NFSv4 there are no standarized named attributes. :-)

Regards
-----
Richard Sharpe, rsharpe[at]ns.aus.com, rsharpe[at]samba.org, 
sharpe[at]ethereal.com, http://www.richardsharpe.com

---

From: Mike Eisler <[email-masked]>
Date: Fri, 22 Aug 2003 14:46:55 -0700

> latest version of NFSv4. Nor are NFSv4 ACLs.

Windows/DOS environments motivated the appearance of those attributes, 
including NFSv4
ACLs. I can't remember why, if ARCHIVE was deprecated in favor of
TIME_BACKUP,  why we didn't kill it. Perhaps because Windows only has
one bit? Dunno, not a Windows guru.

> made it into the standard, but READONLY didn't.

I don't recall anyone asking for them. If you want them,
why not write up a personal i-d describing them and let
the WG know when it is posted at ietf.org. I'm
sure it will get consideration for NFSv4.1.

    -mre