Subject: RE: [nfsv4] Re: Delegation recall and delay

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 7 Aug 2003 14:21:35 -0700

I don't think that's correct.  You can't have a file
open for write when you have a read delegation.  Read
delegations only allow you to have files open for read.

It seems that what you are doing here is silently 
turning a read delegation into a write delegation and
that would only work if clients were prepared for that.
I think we could have defined a way for an open  
response to contain an indication of a delegation
traded-up from read to write, if we'd thought of it.
This might be a reasonable thing to add for 4.1.
The existing handling of a single client reading a 
file, getting a read delegation and then opening
it for write is pretty clumsy, even apart from the
DELAY issue and allowing the server to do the trade-
up and tell you about it would fix that.   

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Thursday, August 07, 2003 5:15 PM
To: [email-masked]
Subject: [nfsv4] Re: Delegation recall and delay

> 	client				server
> 	------				------
> 	<assume same openowner for all ops>
> 
> (1) OPEN(ACCESS_READ) ->
> (2) 				<-	OPEN is okay; provides READ delegation
> (3) CLOSE of OPEN in (1) ->
> (4)				<-	CLOSE is okay
> (5) local open for read
> (6) local open for write
> (7) OPEN(ACCESS_WRITE) ->
> (8)				<-	CB_RECALL of delegation from (2)
> (9) OPEN(ACCESS_READ) ***
> 
> 
> *** The client is attempting to OPEN the file as a result of the
>     delegation recall processing (ensuring all open state is at the
>     server)

Would another correct solution be for the server to issue the Open with
write_access at (9), but no new delegation and just leave the Read
delegation valid? (At this point, my server only recalls delegations
when there is a conflict and it only considers it a conflict if the
open request is from a different client.)

In other words, the server avoids the Recall, but doesn't issue a
Write Delegation.

Does this sound ok? rick

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 7 Aug 2003 17:12:22 -0500

> delegations only allow you to have files open for read.

I agree.  It is not appropriate for the server to do an upgrade.
Mainly because it is not allowed.  I am unable to find the text in the
RFC currently but I thought this situation had been addressed (see
below).

> up and tell you about it would fix that.   

The issue had been discussed during the final updates to the spec at
last year's bakeathon in August.  It was decided at that point that
the functionality was too late for the updates.  That was fine.

I agree that defining an upgrade path for read -> write delegations is
something to consider for a minor version.

Spencer