Subject: [nfsv4] Name Mappings for NFSv4 in Active Directory

From: "Wachdorf, Daniel R" <[email-masked]>
Date: Wed, 8 Oct 2003 15:34:57 -0600

I have been working with CITI on finding a way to use Active Directory to
use map NFSv4 names into active directory user accounts.
I wrote a document that describes a scheme to map NFSv4 names and
authentication principals into an Active Directory Domain.  
I would be interested in what the members of the list thought.  Thanks.

-dan

--------------------------------------
Daniel Wachdorf
[email-masked]
Sandia National Laboratories
System Security Research and Integration
505-284-8060

---

From: Nicolas Williams <[email-masked]>
Date: Wed, 8 Oct 2003 14:49:52 -0700

Please see:

http://www.ietf.org/internet-drafts/draft-williams-nfsv4-ace-mapping-01.txt

This draft describes:

 - how to map user|group@domain names from multiple domains to UIDs/GIDs
   in one domain

    - including how to deal with foreign domain name reuse

 - how to do this on demand (as opposed to having to have meta-directory
   style synchronization)

 - how to make such mappings consistent to any of: a single host, a
   cluster of hosts, an entire domain

 - a new Kerberos V authorization data type that lists a principal's
   NFSv4-style user@domain and group@domain name lists

Cheers,

Nico

> I would be interested in what the members of the list thought.  Thanks.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Nicolas Williams <[email-masked]>
Date: Wed, 8 Oct 2003 14:56:13 -0700

Is your document an I-D?  Will you submit it as an I-D?