Subject: [nfsv4] Question On the seq_window field in a context creation response of the RPCSEC_GSS Protocol( RFC 2203)

From: Kaukab Uddin <[email-masked]>
Date: Tue, 13 Apr 2004 12:20:10 -0700

We would like to validate our interpretation and understanding of the
definition of a context sequence window
(as represented by the seq_window field in a context creation response).

We interpret this to mean the maximum number that could possibly be
supported on a security context and not
necessarily the exact number that needs to be supported on a security
context.

So for example:

1) If seq_window returned by the server  is 'n'.

2) If the client increments its sequence number by '1' for its requests,
then the effective number
    of simultaneous requests supported on this context would in fact be
'n'.

3) However if the client has a sequence number algorithm, that increments
the sequence number
    by more than '1', then the effective number of simultaneous requests
supported on this context
    would actually be less than 'n'

 Is our understanding here correct?

Regards;
Kaukab

---

From: Mike Eisler <[email-masked]>
Date: Tue, 13 Apr 2004 14:39:30 -0700

If sequence number in the post establishment phase were
uniformly 2 or more greater than the previous then your
interpretation is correct. Otherwise, in general, your
interpretation is not correct, as this example
illustrates.

seq_window = 10

-> client request w/ sequence number

^ window range on server

A server accepts
D server discards

-> 11  A ^  2 ... 11
->  3  A ^  2 ... 11
->  5  A ^  2 ... 11
->  7  A ^  2 ... 11
->  2  A ^  2 ... 11
->  8  A ^  2 ... 11
-> 10  A ^  2 ... 11
->  9  A ^  2 ... 11
->  6  A ^  2 ... 11
->  4  A ^  2 ... 11

The above shows a seemingly random generation of sequence
numbers, and yet the entire window of 10 is available.

The above might be a consequence of multithreading in
some client operating environments.

-----Original Message-----
From: Kaukab Uddin [mailto:[email-masked]]
Sent: Tuesday, April 13, 2004 12:20 PM
To: [email-masked]
Subject: [nfsv4] Question On the seq_window field in a context creation response of the RPCSEC_GSS Protocol( RFC 2203)

We would like to validate our interpretation and understanding of the definition of a context sequence window
(as represented by the seq_window field in a context creation response).

We interpret this to mean the maximum number that could possibly be supported on a security context and not
necessarily the exact number that needs to be supported on a security context.

So for example:

2) If the client increments its sequence number by '1' for its requests, then the effective number
of simultaneous requests supported on this context would in fact be 'n'.

3) However if the client has a sequence number algorithm, that increments the sequence number
by more than '1', then the effective number of simultaneous requests supported on this context
would actually be less than 'n'

Regards;
Kaukab

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4