Subject: [nfsv4] Basic client delegation code ready for testing...

From: Trond Myklebust <[email-masked]>
Date: Mon, 12 Apr 2004 18:08:50 -0700

Grab the latest Bitkeeper release (as of right now), and apply the new
2.6.6-pre1 NFS4_ALL patch from the usual site...

As of yet, there are no actual caching optimizations implemented, but
the basic delegation management code (and callback server) should all be
there.

IOW:
  - SETCLIENTID advertises the callback server
  - CB_GETATTR & CB_RECALL are both implemented on the callback server.

  - OPEN now deals with setting up READ/WRITE delegation state.
  - READs and WRITEs should now use the delegation stateid if we've got
one.
  - DELEGRETURN is implemented.

Cheers,
  Trond

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 12 Apr 2004 18:20:03 -0700

Argh... Late in the afternoon, and I'm messing up my list aliases...
This message was supposed to go to CITI's private NFSv4 list..

Apologies to everyone for the noise...
  Trond