Subject: [nfsv4] Minor Versioning.

From: Robert Gordon <[email-masked]>
Date: Mon, 31 Jan 2005 17:22:09 -0600

I've been pondering the following :-
	 a server may advertise support for a minor version but may not
	(if the feature is classified as recommended) actually implement
	one (or any) of the 'minor version' features.

It has occurred to me that in 4.1 we should recommend a mechanism to
query the server of it's capabilities and then make that mechanism
mandatory in 4.2; This way it should be easy for a client to figure
out if a server can handle sessions, pnfs etc...

Eg:
	/* Operation values */
	OP_GET_CAPABILITIES  = 40

	struct SUPPORTED_OPS {
		bitmap4		ops; 	/* ops is a bitmap of nfs_opnum4 */
	};

	struct SUPPORTEDOPargs {
		/* allows client to query multiple minor vers in one compound */
		uint32_t	minor_version;
	};

	struct SUPPORTEDOPSresok {
		uint32_t		minor_version;
		SUPPORTEDOPS	supported;
	};

	union SUPPORTEDOPSres switch (nfsstat4 status) {
		case NFS4_OK:
			SUPPORTEDOPSresok so;

		case NFS4ERR_NOTSUPP:
		default:
			void;
	};

--
Robert..

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 31 Jan 2005 16:21:17 -0800

> out if a server can handle sessions, pnfs etc...

Why is the existing NFS4ERR_NOTSUPP insufficient for these purposes?

Cheers,
  Trond

-- 
Trond Myklebust <[email-masked]>

---

From: Robert Gordon <[email-masked]>
Date: Mon, 31 Jan 2005 19:25:00 -0600

> Why is the existing NFS4ERR_NOTSUPP insufficient for these purposes?

The proposal allows for a succinct up-front mechanism to ascertain
the operations supported by the server in one round-trip. One could
also figure out the minor versions supported by the server if the
supported operations in the reply was zero.

I don't see how one could achieve the same with NFS4ERR_NOTSUPP,
maybe i'm missing something..

--
Robert..