Subject: Re: [nfsv4] SET_PRIORITY: new op proposal

From: Trond Myklebust <[email-masked]>
Date: Thu, 01 Mar 2007 00:15:41 -0500

On Wed, 2007-02-28 at 14:49 +0200, Benny Halevy wrote:
> Trond Myklebust wrote:
> <snip>
> > If the client wants clever scheduling of
> > metadata operations, it can do so all by itself without having to
> > introduce new state for the server to carry around.
> > 
> >   Trond
> > 
> 
> There a couple of shortcomings with this approach:
> First, the client can't schedule its operations with respect to
> other clients' work

If you really want to do this, then it will require administrator
intervention anyway, since there is no way for a user to specify the
scheduling priority for individual filesystem ops. At that point, why
not have said administrator just do it on the server?

>  and second, if the prioritization is done
> only on the client side it will be very hard for the client
> to achieve low latency for metadata ops while keeping the server
> busy with a pipeline full of data I/O operations. Sending
> metadata ops over a high priority session can allow the op
> to pass I/O operations waiting in the server queues.

The client that cares can easily trunk the metadata ops into a separate
channel. When will we need more fine grained control?

Trond

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Thu, 1 Mar 2007 19:27:04 -0500

> not have said administrator just do it on the server?

Giving a certain client higher priority for every single operation seems
like kind of a big hammer; I can imagine it might be more useful if you
could instead say "trust this client to raise the priority on certain
operations."

--b.