Subject: [nfsv4] NFS V4 share - user level permission control.

From: <[email-masked]>
Date: Sun, 20 Feb 2011 04:13:07 -0500

Hi all,
  I read NFS V4 supports authentication  with krb5 .

so far I know NFS controls share access with ip address   to make ro or rw.

how it supports the user level access control for a NFS share ?.

just like  in samba for share  "sambashare" I can set user1 has read only , user2 has readwrite irrespective of the ip adress.I can modify the smb.conf read list and write list for a particular share   to make that happen.

is it possible to this on NFS v4?.  any doc on this how to do?.

anticipating your reply

Thanks
Suresh

---

From: "Mike Eisler" <[email-masked]>
Date: Sun, 20 Feb 2011 07:40:24 -0800

That's a server implementation choice. It has nothing to do with the NFS
protocol.
On Sun, February 20, 2011 1:13 am, [email-masked] wrote:
> just like  in samba for share  "sambashare" I can set user1 has read only
> , user2 has readwrite irrespective of the ip adress.I can modify the
> smb.conf read list and write list for a particular share   to make that
> happen.
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/