Subject: [nfsv4] Agenda for interim NFSv4 meeting (version 0.4)

From: Spencer Shepler <[email-masked]>
Date: Wed, 9 Feb 2011 17:29:36 +0000

NFS version 4 - Interim meeting
Fri/Sat, Feb 18-19, 2011
Sunnyvale, CA - Netapp
Aragorn conference room - Building 4

------------------------------------
(version 0.4)

Intro/Blue Sheets

WG Administrivia

NFS Version 4 bis                                       (Haynes)  30 minutes
    - courtesy locks
    - others?

NFSv4.1 pNFS open issues                                (Noveck)  2 hours
        - forgetfulness
        - return-on-close
        - CB_LAYOUTRECALL
        - state seqid
        - LAYOUTCOMMIT

rfc5664 pNFS errata                                     (Halevy) 20 minutes

pNFS LAYOUTCOMMIT optimizations                         (Pranoop) 20 minutes

Simple and Efficient Read Support for Sparse Files      (Hildebrand)
draft-hildebrand-nfsv4-read-sparse-02.txt

User ID translation in AUTH_SYS environments            (Haynes)
        
LEASED_MOVED error handling                             (Haynes)

FedFS Domain Roots                                      (Lever) 20 minutes

Server-side copy implementation experience              (Pranoop) 20 minutes
NFSv4.2 Structure and Content                           (All)
[new functionality that is not NFSv4.2]
        - integration of proposals
        - prioritization of content
        - resource and proposed timeline

pNFS file servers implementation strategy               (Sorin)
pNFS over IPv6                                          (Sorin)
Performance related issues of NFSv4.1/pNFS              (Sorin)
Secure NFS in 4.x                                       (Sorin)
Multi-layout pNFS server support                        (Sorin)
FedFS imlementation issues                              (Sorin)
Discussion on our general testing strategy and new test suite (Sorin)

---

From: James Lentini <[email-masked]>
Date: Wed, 9 Feb 2011 15:56:09 -0500 (EST)

> Aragorn conference room - Building 4

What time will the meeting end on Saturday?

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 9 Feb 2011 21:46:43 +0000

> -----Original Message-----
> From: James Lentini [mailto:[email-masked]]
> Sent: Wednesday, February 09, 2011 12:56 PM
> To: Spencer Shepler
> Cc: [email-masked]
> Subject: Re: [nfsv4] Agenda for interim NFSv4 meeting (version 0.4)
> 
> 

Given the current agenda, it appears that
we will be done between 2-3pm on Saturday.

Spencer