Subject: [nfsv4] [3530bis] nfs4_client_id4

From: Thomas Haynes <[email-masked]>
Date: Tue, 15 Feb 2011 14:49:27 -0800

9.1.1 states:

>    The second field, id is a variable length string that uniquely
>    defines the client.
> 
>    There are several considerations for how the client generates the id
>    string:
> 
>    o  The string should be unique so that multiple clients do not
>       present the same string.  The consequences of two clients
>       presenting the same string range from one client getting an error
>       to one client having its leased state abruptly and unexpectedly
>       canceled.
> 
>    o  The string should be selected so the subsequent incarnations
>       (e.g., reboots) of the same client cause the client to present the
>       same string.

It then mentions for userland clients:

>    o  For a user level NFS version 4 client, it should contain
>       additional information to distinguish the client from other user
>       level clients running on the same host, such as a process id or
>       other unique sequence.
> 

How is recording the pid unique across client reboots?

I'm going to propose changing the text to:

   o  For a user level NFS version 4 client, it should contain
      additional information to distinguish the client from other user
      level clients running on the same host.

Has anyone got any implementation experience on userland clients
that they want to share here?

Thanks

---

From: Tigran Mkrtchyan <[email-masked]>
Date: Wed, 16 Feb 2011 07:43:57 +0100

> that they want to share here?
I use UUID in my Java client.

Tigran.

> Thanks
>
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>