Subject: [nfsv4] [NFSv4.2] No meeting for 06/02/11

From: Thomas Haynes <[email-masked]>
Date: Thu, 2 Jun 2011 10:58:27 -0500

The up and coming issues were the security implications
for COPY and the fadvise incorporation. As both David and
Dean are out, those issues would be off of the agenda.

Also, as the 06/26 meeting is during the BAT, I am going
to cancel that one as well.

I am reformatting the draft to be more along the lines of
5661 (concepts and then operations) instead of several
proposals tacked together. I'll be pushing out a new copy
and asking reviewers to provide feedback.

We can kick that all off on the WG alias.

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 2 Jun 2011 16:01:30 +0000

Thanks, Tom.

As a reminder, we have a working group meeting coming up.
Please send me your agenda items.  I need to submit a draft
agenda by the first of next week and would like to have
as much of our work identified by then.

Spencer

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Thomas Haynes
> Sent: Thursday, June 02, 2011 8:58 AM
> To: [email-masked]
> Subject: [nfsv4] [NFSv4.2] No meeting for 06/02/11
> 
> The up and coming issues were the security implications for COPY and the
> fadvise incorporation. As both David and Dean are out, those issues would
> be off of the agenda.
> 
> Also, as the 06/26 meeting is during the BAT, I am going to cancel that
> one as well.
> 
> 5661 (concepts and then operations) instead of several proposals tacked
> together. I'll be pushing out a new copy and asking reviewers to provide
> feedback.
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Thomas Haynes <[email-masked]>
Date: Thu, 2 Jun 2011 11:48:24 -0500

Peter won the prize in finding the one mistake, I am canceling
the 06/16 meeting. We are still not meeting on the 26th as
it is a Sunday.

---

From: sfaibish <[email-masked]>
Date: Thu, 02 Jun 2011 13:48:21 -0400

Assuming that others will join me I have a couple of items as I travel  
next week:
1. RPCSEC_GSS3 dependencies for 4.2 features
2. LNFS discussion, assuming the latest state of the I-D, for inclusion in  
4.2
3. Disk Protection for block layout.

/Sorin

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: sfaibish <[email-masked]>
Date: Thu, 02 Jun 2011 13:45:16 -0400

Really? I didn't want to insult you this is why I didn't send corection.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Thomas Haynes <[email-masked]>
Date: Thu, 2 Jun 2011 14:01:39 -0500

On Jun 2, 2011, at 12:48 PM, sfaibish wrote:

> Assuming that others will join me I have a couple of items as I travel next week:

Besides COPY depending on it, what else is there to discuss? I am trying
to understand issues here to make sure we cover them for you.

And please feel free to start a thread of discussion in the alias on this subject.

> 2. LNFS discussion, assuming the latest state of the I-D, for inclusion in 4.2

One of the cliches I do not like about promotion is your manager telling
you that you will get to N+1 once everyone already sees you doing N+1
work and not N level work.

It happens to apply here - we should not focus on work getting LNFS
accepted into NFSv4.2. Instead, we should focus on getting the
LNFS work as complete as it can be. We need to identify and fix
issues, we need to focus on the parts that are relevant to this
WG.

We've been doing that in the meetings and on the WG alias - 

1) Incorporating  use cases from business.
2) LNFS and pNFS
3) How many labels can be stored against a file?
4) How will the CB mechanism work?

We've been working all along with the assumption that we are
able to bring things into NFSv4.2 as we need, i.e., we have
set no deadline on when we will stop considering things. But
as time goes on, items up for consideration need to be further
developed and ready to drop in.

Or as I've been saying, we need to focus on making sure LNFS
is ready to ship.

> 3. Disk Protection for block layout.

Besides the issue of whether this belongs in the NFSv4.2 draft or not,
(i.e., are we going to keep it focused on file-based layouts), there is
the issue of energy for this item.

Could you either keep it fresh by driving discussions on it on the WG
alias or by asking for some agenda time for the next 4.2 meeting?

> /Sorin
> 
> On Thu, 02 Jun 2011 12:01:30 -0400, Spencer Shepler <[email-masked]> wrote:
> 
>> 
>> Thanks, Tom.
>>

---

From: sfaibish <[email-masked]>
Date: Thu, 02 Jun 2011 17:49:10 -0400

> And please feel free to start a thread of discussion in the alias on  
This is what we both understand but I think we should still have
a discussion about v3 and LNFS dependencies within the WG at large
as not all were involved in the calls we had so far.

> issues, we need to focus on the parts that are relevant to this
Well my intention was just to stick to the promise to Spencer to have
a viable I-D for LNFS and discuss if it is ready for inclusion
in 4.2. This was the plan after Praha and this is why I proposed the
discussion. Maybe I spell it wrong but this was the intent. Sorry
if you felt I am pushing you; not my intention.

> alias or by asking for some agenda time for the next 4.2 meeting?
I am waiting for Dave Black to review it and then I will post the I-D.
The intention is to discuss if it should be a WG item or a 4.2 or an errata
for 5663 or a BIS. The energy behind is me and I am commited to finish
what I started.

/Sorin

-- 
Best Regards

Sorin Faibish

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 2 Jun 2011 22:30:07 +0000

> for 5663 or a BIS. The energy behind is me and I am commited to finish

I believe the way we left this was the work would be 
a standalone I-D with a target of informational RFC.

This is based on the pre-discussed content.  This can change
if the content of the I-D warrants but I have not seen anything
yet that would change the direction.

So, an agenda item to review/discuss the forthcoming I-D and
to confirm the next steps for the work.  Sounds good.

Spencer

> sfaibish
> Sent: Thursday, June 02, 2011 2:49 PM
> To: Thomas Haynes
> Cc: [email-masked]
> Subject: Re: [nfsv4] [NFSv4.2] No meeting for 06/02/11
>

---

From: "Sorin Faibish" <[email-masked]>
Date: Thu, 02 Jun 2011 20:04:49 -0400

> to confirm the next steps for the work.  Sounds good.
This is correct except that after we update the I-D I would like to
validate that this is the right option. We will add the usage for
layout validation and it might change the scope. So, I want to have
this discussion, 15 min should suffice.

/Sorin

>> >> 2. LNFS discussion, assuming the latest state of the I-D, for  
>> inclusion
>> >> in 4.2
>> >
>> >
>> >>>> The up and coming issues were the security implications for COPY  
>> and
>> >>>> the

        EMC²
where information lives

Phone: 508-435-1000 x 48545
Cellphone: 617-510-0422
Email : [email-masked]