Subject: Re: [nfsv4] rfc3530bis: parallel opens in 4.0

From: "Myklebust, Trond" <[email-masked]>
Date: Mon, 29 Aug 2011 20:17:01 -0400

4.0 doesn't support sessions, so your argument does not apply to rfc3530bis.

You don't need multiple sessions to do this in 4.1: just use different slots.

Trond

"Welch, Brent" <[email-masked]> wrote:

Sessions give you the ability to send multiple commands in parallel, and manage the reply caches separately and reliably.  So, if you want to launch multiple operations to the server, you need multiple RPC sessions.
	Brent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of J. Bruce Fields
Sent: Monday, August 29, 2011 3:34 PM
To: Trond Myklebust
Cc: [email-masked]
Subject: Re: [nfsv4] rfc3530bis: parallel opens in 4.0

On Mon, Aug 29, 2011 at 06:29:23PM -0400, Trond Myklebust wrote:
> On Mon, 2011-08-29 at 17:17 -0400, J. Bruce Fields wrote: 
> > I thought one of the points of seqid's was that they allowed you to send
> > multiple operations in parallel.  (Just send them all off, without
> > waiting, in the right order, and in the (hopefully rare) case where they
> > get reordered the server errors tell you what you need to know to
> > retry and recover.)
> 
> Yes, you're confused.
> 
> What if one of the replies gets lost and you have to try to replay it?
> You can't do that if you have already sent off a request with the next
> seqid.

Doh--yes, you're right, of course, thanks.

--b.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Welch, Brent" <[email-masked]>
Date: Tue, 30 Aug 2011 00:47:12 +0000

Erf - sorry I wasn't paying attention to the "4.0" in the subject line, and yes, I meant "slots" not "sessions" for the 4.1 mechanism.
	Brent

-----Original Message-----
From: Myklebust, Trond [mailto:[email-masked]] 
Sent: Monday, August 29, 2011 5:17 PM
To: Welch, Brent; J. Bruce Fields
Cc: [email-masked]
Subject: RE: [nfsv4] rfc3530bis: parallel opens in 4.0

Trond

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of J. Bruce Fields
Sent: Monday, August 29, 2011 3:34 PM
To: Trond Myklebust
Cc: [email-masked]
Subject: Re: [nfsv4] rfc3530bis: parallel opens in 4.0

--b.