Subject: Re: [nfsv4] connectathon.org

From: "J. Bruce Fields" <[email-masked]>
Date: Fri, 26 Aug 2011 22:06:44 -0400

On Sat, Jul 23, 2011 at 09:48:34AM -0400, Jim Rees wrote:
> J. Bruce Fields wrote:
> 
>   On Wed, Jul 13, 2011 at 11:49:21AM -0400, bfields wrote:
>   > I don't seem to be able to resolve www.connectathon.org.  Anyone know
>   > what's up?
>   
>   Still not working for me.  Does anyone have a mirror of the
>   presentations?
> 
> It's in the Internet Wayback but the last crawl was May 2009:
> http://web.archive.org/web/20090505173902/http://www.connectathon.org/

Thanks!  I got the one thing I wanted off of it.

The wayback machine doesn't seem friendly to wget -r, so I couldn't get
a copy of the whole archive.  Probably somebody should.

--b.

---

From: Thomas Haynes <[email-masked]>
Date: Fri, 26 Aug 2011 22:36:39 -0500

> a copy of the whole archive.  Probably somebody should.

I have a copy of everything from the 2010 event (and all of the prior presentations).

I have some of the 2011 presentations, but not the NDA. :->

I don't know the legalities of hosting it on a vanity site....

> --b.
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Jim Rees <[email-masked]>
Date: Sat, 27 Aug 2011 10:33:30 -0400

Thomas Haynes wrote:

  

I'd have to ask, but I think CITI would be willing to host the content, if
it's legal.

---

From: Trond Myklebust <[email-masked]>
Date: Sat, 27 Aug 2011 13:15:06 -0400

> I'd have to ask, but I think CITI would be willing to host the content, if

We could also host a mirror at linux-nfs.org, again subject to legality
concerns...

Cheers
  Trond
-- 
Trond Myklebust
Linux NFS client maintainer

NetApp
[email-masked]
www.netapp.com

---

From: "J. Bruce Fields" <[email-masked]>
Date: Sat, 27 Aug 2011 14:38:14 -0400

> We could also host a mirror at linux-nfs.org, again subject to legality

I think the best we could do would be to send mail to the alias saying
something like:

	"Some time ago you gave us connectathon presentation materials
	to post publicly at connectathon.org.  We're assuming that you
	would also be willing to have the identical identical materials
	posted at $site.  If that isn't true, please let $email know and
	we will take your materials down immediately."

For extra credit, also mail it to any individual presenter addresses we
can find.

Much more than that would be harder than just getting connectathon.org
up again, I'd think.  Which probably somebody will still do soon anyway?

--b.

---

From: Trond Myklebust <[email-masked]>
Date: Sat, 27 Aug 2011 15:19:24 -0400

> up again, I'd think.  Which probably somebody will still do soon anyway?

A lot of the original presenters no longer work for the same company
and/or a lot of the companies have died over the past 25ish years...

Even if those presenters consent, if they no longer work for the same
company then their consent may be meaningless (depending on who owns the
copyrights for the presentation).

IOW: life is hard.

Trond

NetApp

---

From: Trond Myklebust <[email-masked]>
Date: Sat, 27 Aug 2011 15:43:59 -0400

> copyrights for the presentation).

Let me rather correct that to: "life may be hard". It all depends on
what kind of licence connectathon.org had for publishing the
presentations in the first place.

Trond

NetApp

---

From: Chuck Lever <[email-masked]>
Date: Sat, 27 Aug 2011 19:49:37 -0400

> presentations in the first place.

The presentations are made to the public at each connectathon event, and are made available on a public web site afterwards.  How much license encumbrance could there possibly be?

-- 
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: "J. Bruce Fields" <[email-masked]>
Date: Sat, 27 Aug 2011 23:53:17 -0400

> copyrights for the presentation).

Sure.  But I think the above would more than meet any reasonable
objections.

If you want an airtight defense against all the unreasonable objections
too, then the project becomes too tedious to be worthwhile.

If we've made an effort to be fair then I suspect we're fine.  None of
this is important enough for anyone to put up a big fight over anyway.

--b.

---

From: Tom Haynes <[email-masked]>
Date: Tue, 30 Aug 2011 13:22:59 -0500

> this is important enough for anyone to put up a big fight over anyway.

Okay, I'll bite:

 "Some time ago you gave us connectathon presentation materials
 to post publicly at connectathon.org.  We're assuming that you
 would also be willing to have the identical identical materials
 posted at nfsv4bat.org.  If that isn't true, please let [email-masked]
 know and we will take your materials down immediately."

I'm interested in having a well known site for BakeAThons, etc. One
intent is for people to know what events are upcoming.

I'm also willing to cache other NFSv4 documentation and/or
presentations.

http://www.nfsv4bat.org

-- 
Tom Haynes
ex-cfb

---

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 30 Aug 2011 17:57:45 -0400

> I'm also willing to cache other NFSv4 documentation and/or

Thanks!

--b