Subject: [nfsv4] Proposal to remove LIPKEY from rfc3530bis

From: Spencer Shepler <[email-masked]>
Date: Thu, 11 Aug 2011 03:02:20 +0000

I would like to propose that we remove LIPKEY use from NFSv4.0
through the update of rfc3530bis.  We have set precedence for
ourselves by removing its use in NFSv4.1.  The justification
given for that decision was the lack of implementation and
deployment issues and that was based on NFSv4.0 non-use.

I don't believe the LIPKEY use for NFSv4.0 has changed since
we made that decision for NFSv4.1.

The bis update seems like an appropriate time to do this.

Anyone willing to present the contrary position that LIPKEY
should stay in as one of the security mechanisms for NFSv4.0?

Spencer

---

From: Rick Macklem <[email-masked]>
Date: Thu, 11 Aug 2011 09:51:16 -0400 (EDT)

> should stay in as one of the security mechanisms for NFSv4.0?
Not me. Can I assume that SPKM3 goes away too?
(Btw, RFC5661 says that they are "not required", which isn't
 quite the same as "remove", although I have no problem with "remove".)

rick

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 11 Aug 2011 16:35:37 +0000

Yes, SPKM3/LIPKEY.  "remove" would be appropriate document
editing to have equivalent language to 5661.

Spencer

> -----Original Message-----
> From: Rick Macklem [mailto:[email-masked]]
> Sent: Thursday, August 11, 2011 6:51 AM
> To: Spencer Shepler
> Cc: [email-masked]
> Subject: Re: [nfsv4] Proposal to remove LIPKEY from rfc3530bis
> 
> Spencer Shepler wrote:
> > I would like to propose that we remove LIPKEY use from NFSv4.0 through
> > the update of rfc3530bis. We have set precedence for ourselves by
> > removing its use in NFSv4.1. The justification given for that decision
> > was the lack of implementation and deployment issues and that was
> > based on NFSv4.0 non-use.
> >
> > I don't believe the LIPKEY use for NFSv4.0 has changed since we made
> > that decision for NFSv4.1.
> >
> > Anyone willing to present the contrary position that LIPKEY should
> > stay in as one of the security mechanisms for NFSv4.0?
> >
> (Btw, RFC5661 says that they are "not required", which isn't  quite the
> same as "remove", although I have no problem with "remove".)
> 
> rick
>

---

From: <[email-masked]>
Date: Fri, 12 Aug 2011 20:05:12 -0400

> Btw, RFC5661 says that they are "not required", which isn't
>  quite the same as "remove",

In the context it has the same effect.  You are not required to implement 
LIPKEY and SPKM3 and you are not prohibited from doing so.  It is the same
for any unmentioned existing or potential future  security mechanism.  You may 
use it if you want to.  Normally, you signify that state of affairs by not mentioning
it.

5661 has specific language to this effect only because RFC3530 mentions it and that 
fact might confuse people if it were simply not mentioned.

BTW, once RFC3530bis is published, things would be different, so that if we eventually
publish RFC5661bis, it too should not mention SPKM3 or LIPKEY.  So eventually, we would
have two equivalent (empty :-) strings in both specs regarding these.       

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rick Macklem
Sent: Thursday, August 11, 2011 9:51 AM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] Proposal to remove LIPKEY from rfc3530bis

rick

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4