Subject: [nfsv4] rfc3530bis: parallel opens in 4.0

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 29 Aug 2011 17:17:22 -0400

I thought one of the points of seqid's was that they allowed you to send
multiple operations in parallel.  (Just send them all off, without
waiting, in the right order, and in the (hopefully rare) case where they
get reordered the server errors tell you what you need to know to
retry and recover.)

But maybe I'm confused....

--b.

diff --git a/nfsv4_middle_file_locking.xml b/nfsv4_middle_file_locking.xml
index e2b8df7..f839657 100644
--- a/nfsv4_middle_file_locking.xml
+++ b/nfsv4_middle_file_locking.xml
@@ -926,11 +926,6 @@
       </t>
 
       <t>
-        Note that for requests that contain a sequence number, for each
-        state-owner, there should be no more than one outstanding request.
-      </t>
-
-      <t>
         If a request (r) with a previous sequence number (r &lt;
         L) is received, it is rejected with the return of error
         NFS4ERR_BAD_SEQID.  Given a properly-functioning client, the

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 29 Aug 2011 18:29:23 -0400

> get reordered the server errors tell you what you need to know to

Yes, you're confused.

What if one of the replies gets lost and you have to try to replay it?
You can't do that if you have already sent off a request with the next
seqid.

Trond
-- 
Trond Myklebust
Linux NFS client maintainer

NetApp
[email-masked]
www.netapp.com

---

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 29 Aug 2011 18:34:18 -0400

> You can't do that if you have already sent off a request with the next

Doh--yes, you're right, of course, thanks.

--b.

---

From: "Welch, Brent" <[email-masked]>
Date: Mon, 29 Aug 2011 23:49:57 +0000

Sessions give you the ability to send multiple commands in parallel, and manage the reply caches separately and reliably.  So, if you want to launch multiple operations to the server, you need multiple RPC sessions.
	Brent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of J. Bruce Fields
Sent: Monday, August 29, 2011 3:34 PM
To: Trond Myklebust
Cc: [email-masked]
Subject: Re: [nfsv4] rfc3530bis: parallel opens in 4.0

--b.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4