Subject: [nfsv4] [help]why showmount and exportfs command result is different ?

From: "hujun_hotmail" <[email-masked]>
Date: Mon, 12 Mar 2012 09:54:00 +0800

Hello experts:
    I met a strange problem: showmount  and exportfs  command result  is different? why? which is the question's root cause?

gd10000_fs3_1:~ # rcnfsserver status
Checking for kernel based NFS server:                                 running
gd10000_fs3_1:~ # rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100024    1   udp  41140  status
    100021    1   udp  41140  nlockmgr
    100021    3   udp  41140  nlockmgr
    100021    4   udp  41140  nlockmgr
    100024    1   tcp  50125  status
    100021    1   tcp  50125  nlockmgr
    100021    3   tcp  50125  nlockmgr
    100021    4   tcp  50125  nlockmgr
    100005    1   udp    888  mountd
    100005    1   tcp    889  mountd
    100005    2   udp    888  mountd
    100005    2   tcp    889  mountd
    100005    3   udp    888  mountd
    100005    3   tcp    889  mountd
gd10000_fs3_1:~ # showmount -e
Export list for gd10000_fs3_1:
/share9  *
/share10 *
/share14 *
/share13 *
/share12 *
/share11 *
gd10000_fs3_1:~ # exportfs
/share10        <world>
/share14        <world>
/share13        <world>
/share12        <world>
/share11        <world>
/share8         <world>
/share9         <world>

gd10000_fs3_1:~ # showmount -e
Export list for gd10000_fs3_1:
/share9  *
/share10 *
/share14 *
/share13 *
/share12 *
/share11 *

gd10000_fs3_1:~ # exportfs -v
/share10        <world>(rw,async,wdelay,root_squash)
/share14        <world>(rw,async,wdelay,root_squash)
/share13        <world>(rw,async,wdelay,root_squash)
/share12        <world>(rw,async,wdelay,root_squash)
/share11        <world>(rw,async,wdelay,root_squash)
/share8         <world>(rw,async,wdelay,root_squash)
/share9         <world>(rw,async,wdelay,root_squash)

messages contain nfs info like this:

Installing knfsd (copyright (C) 1996 [email-masked]).
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: starting 90-second grace period

---

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 12 Mar 2012 09:00:07 -0400

>     I met a strange problem: showmount  and exportfs  command result  is different? why? which is the question's root cause?

Huh.  So showmount isn't seeing share8?

Would it be possible to get a network trace showing this?

(So, run something like "tcpdump -s0 -wmtp.pcap", then run showmount,
then send us tmp.pcap.)

What version of nfs-utils are you using?

--b.

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4