Subject: [nfsv4] Scribe 5/24

From: "Reyes-Ortiz, Talia" <[email-masked]>
Date: Thu, 24 May 2012 22:34:03 +0000

Tom, Talia, Bruce, Trond, Bryan, Bandi, Mike Eisler, Chuck, Manjunath, Pranoop

Note-well agreement.

START CHAPTER 2, NFS Server-side Copy - Line 379

405-409 - Bruce: Sentences can be deleted

452-476 - Trond and Mike: would like us to see us talk about the authentication model rather than the pull-
base model

768 - Trond: Remove sentence

776 - Trond: Remove the minor version restriction.

774-792 & 794-835 - Bruce: Remove subsection 2.3.2  AI: Discuss in working group alias

846 - Rewrite paragraph to point to section 13

848 - Dave: What does this OPTIONAL mean, and a table needs to be added for inter and intra implementation; what the client and server must implement (has to be able to support both)

856 - Trond: Discussion of COPY_ABORT operation in terms of state protection that rsc5661 implements as part of the EXCHANGE_ID operation

910 - Chuck: Need a discussion on server reboot recovery, in the event of A and network partition

924-933 - Mike: change "document" to "chapter" throughout 2.4

932 - Mike: "The" is repeated twice

981- AI: Make it clear that the end to end authentication is required by the server implementation and trust based that the sever to server copy is optional

Cheers!
Talia Reyes-Ortiz
Program Manager
CTO Office
NetApp Inc.
408.822.1566 Direct Phone
[email-masked]
[Description: http://media.netapp.com/images/esigs-innovative-company-480x75.png]<http://www.forbes.com/special-features/innovative-companies.html>

---

From: "Haynes, Tom" <[email-masked]>
Date: Tue, 29 May 2012 13:23:13 -0500

> 452-476 - Trond and Mike: would like us to see us talk about the authentication model rather than the pull-

How about this:

git diff nfsv42_middle_copy.xml
diff --git a/nfsv42_middle_copy.xml b/nfsv42_middle_copy.xml
index 8798803..c473d82 100644
--- a/nfsv42_middle_copy.xml
+++ b/nfsv42_middle_copy.xml
@@ -69,45 +69,14 @@
     </t>
 
     <t>
-      For the inter-server copy protocol, the operations are defined
-      to be compatible with a server-to-server copy protocol in which
-      the destination server reads the file data from the source server.
-      This model in which the file data is pulled from the source by the
-      destination has a number of advantages over a model in which the
-      source pushes the file data to the destination. The advantages
-      of the pull model include:
+      For the inter-server copy, the operations are defined
+      to be compatible with the traditional copy authentication approach.
+      The client and user are authorized at the source for reading. Then
+      they are authorized at the destination for writing.
     </t>
 
     <t>
-      <list style="symbols">
-        <t>
-          The pull model only requires a remote server (i.e., the destination
-          server) to be granted read access. A push model requires a
-          remote server (i.e., the source server) to be granted write
-          access, which is more privileged.
-        </t>
-
-        <t>
-          The pull model allows the destination server to stop reading
-          if it has run out of space. In a push model, the destination
-          server must flow control the source server in this situation.
-        </t>
-
-        <t>
-          The pull model allows the destination server to easily flow
-          control the data stream by adjusting the size of its read
-          operations. In a push model, the destination server does not
-          have this ability. The source server in a push model is capable
-          of writing chunks larger than the destination server has
-          requested in attributes and session parameters. In theory, the
-          destination server could perform a "short" write in this situation,
-          but this approach is known to behave poorly in practice.
-        </t>
-      </list>
-    </t>
-
-    <t>
-      The following operations are provided to support server-side copy:
+      The following operations are described in detail in <xref target="operations" />.
     </t>
 
     <t>
@@ -144,12 +113,6 @@
       </list>
     </t>
 
-    <t>
-      These operations are described in detail in <xref target="operations" />.
-      This section provides an overview of how these operations are used
-      to perform server-side copies.
-    </t>
-
     <section title="Intra-Server Copy">
       <t>
         To copy a file on a single server, the client uses a COPY operation.

-- 
Tom Haynes - ex-cfb