Subject: [nfsv4] [PATCH 5661] maxread, maxwrite are per-filesystem

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 4 Dec 2012 09:44:05 -0500

Both these attributes are listed as per-filesystem, but the descriptions
are written as though they were per-filesystem object.
---
 nfsv41_middle_fileattributes.xml |    9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/nfsv41_middle_fileattributes.xml b/nfsv41_middle_fileattributes.xml
index a708541..c7e6c80 100644
--- a/nfsv41_middle_fileattributes.xml
+++ b/nfsv41_middle_fileattributes.xml
@@ -764,15 +764,16 @@
 
       <section toc='exclude' anchor="ss:file_attributes:A3m" title="Attribute 30: maxread">
         <t>
-          Maximum amount of data the READ operation will return for this
-          object.
+          Maximum amount of data the READ operation will return for
+          objects in this filesystem.
         </t>
       </section>
 
       <section toc='exclude' anchor="ss:file_attributes:A3m1" title="Attribute 31: maxwrite">
         <t>
-          Maximum amount of data the WRITE operation will accept for this
-          object.  This attribute SHOULD be supported if the file is writable.
+          Maximum amount of data the WRITE operation will accept for
+          objects in this filesystem.  This attribute SHOULD be supported
+          if any objects in the filesystem are writeable.
           Lack of this attribute can lead to the client either wasting
           bandwidth or not receiving the best performance.
         </t>
-- 
1.7.9.5

---

From: "J. Bruce Fields" <[email-masked]>
Date: Tue, 4 Dec 2012 09:45:34 -0500

Both these attributes are listed as per-filesystem, but the descriptions
are written as though they were per-filesystem object.
---
 nfsv4_middle_fileattributes.xml |   11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/nfsv4_middle_fileattributes.xml b/nfsv4_middle_fileattributes.xml
index c098877..2c56357 100644
--- a/nfsv4_middle_fileattributes.xml
+++ b/nfsv4_middle_fileattributes.xml
@@ -898,18 +898,17 @@
     <section toc="exclude" anchor="attrdef_maxread"
              title="Attribute 30: maxread">
       <t>
-        Maximum amount of data the READ operation will return for this
-        object.
+        Maximum amount of data the READ operation will return for
+        objects in this filesystem.
       </t>
     </section>
 
     <section toc="exclude" anchor="attrdef_maxwrite"
              title="Attribute 31: maxwrite">
       <t>
-        Maximum amount of data the WRITE operation will accept for this
-        object.  This attribute SHOULD be supported if the file is writable.
-        Lack of this attribute can lead to the client either wasting
-        bandwidth or not receiving the best performance.
+        Maximum amount of data the WRITE operation will accept for
+        objects in this filesystem.  This attribute SHOULD be supported
+        if any objects in the filesystem are writeable.
       </t>
     </section>
 
-- 
1.7.9.5