Subject: [nfsv4] rfc5666bis and rpcrdma-bidirection progress update

From: Chuck Lever <[email-masked]>
Date: Tue, 25 Oct 2016 11:06:44 -0400

Hi Spencer-

Trying to ascertain the status of rfc5666bis and friends. They've
been in "Waiting for Write-up" for some time now, according to the
datatracker.

The NFSv4.2 documents, RPCGSSv3, and the multi-domain doc are all on
the edge of publication, but they've been waiting there for over
half a year. GSSv3 in particular has been in AUTH48 for quite some
time. I assume my docs are waiting behind those.

Please let me know if there's anything I can do to help move this
process forward. Thanks!

--
Chuck Lever

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 25 Oct 2016 16:48:55 +0000

Chuck,

The GSSv3 has been going through changes because of the addition of a new IANA registry.  See the email below that Spencer Dawkins sent last Friday to the IETF for feedback on the changes made to the GSSv3 I-D.

For the I-Ds that are "waiting for write-up", those are on my to-do list and will be out in the next week.

For the I-Ds that are awaiting working-group last call - will start those to run concurrently in the next day or two:

draft-ietf-nfsv4-umask-02 Allowing inheritable NFSv4 ACLs to override the umask
draft-ietf-nfsv4-versioning-07  Rules for NFSv4 Extensions and Minor Versions.
draft-ietf-nfsv4-xattrs-03 File System Extended Attributes in NFSv4

-----Original Message-----
From: Chuck Lever [mailto:[email-masked]] 
Sent: Tuesday, October 25, 2016 8:07 AM
To: Spencer Shepler <[email-masked]>
Cc: NFSv4 <[email-masked]>
Subject: rfc5666bis and rpcrdma-bidirection progress update

Hi Spencer-

Trying to ascertain the status of rfc5666bis and friends. They've been in "Waiting for Write-up" for some time now, according to the datatracker.

The NFSv4.2 documents, RPCGSSv3, and the multi-domain doc are all on the edge of publication, but they've been waiting there for over half a year. GSSv3 in particular has been in AUTH48 for quite some time. I assume my docs are waiting behind those.

Please let me know if there's anything I can do to help move this process forward. Thanks!

--
Chuck Lever

[Spencer] -------
[Spencer] 
From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, Oct 21, 2016 at 12:54 PM
Subject: Checking for objections - adding an IANA registry to draft-ietf-nfsv4-rpcsec-gssv3
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, [email-masked]

To the IETF community,

draft-ietf-nfsv4-rpcsec-gssv3 is in the RFC Editor queue, in AUTH48.

During AUTH48 discussions between the authors, they convinced each other, the document shepherd, and me, that this document needed a new registry for "RPCSEC_GSS Structured Privilege Names" that were being defined in the document, and they added one, as Section 5.2.

Here's the diff that shows you the new Section 5.2:

    https://www.rfc-editor.org/authors/rfc7861-lastdiff.html

The working group has seen the change, and the working group chairs believe the working group has consensus to make the change.

IANA has reviewed the proposed registry instructions and provided comments, and now has no more questions.

I believe this is the Right Thing To Do.

This is a post-IESG evaluation technical change to draft-ietf-nfsv4-rpcsec-gssv3, so I've discussed this with the rest of the IESG, and they agreed that that IETF community should see this change before publication as an RFC.

I plan to approve this document with the RFC Editor on October 28, one week from today, unless I hear objections from the community. 

Feedback can be sent to [email-masked], or directly to me. 

Spencer

---

From: Chuck Lever <[email-masked]>
Date: Tue, 25 Oct 2016 12:59:38 -0400

Thanks for the update! Good to see a constructive outcome for RPCGSSv3.

Authors should plan accordingly: A reminder that the I-D submission tool
will close on Oct 31, 2016 before IETF 97 next week. This might make it
challenging to immediately address requested changes to I-Ds in WGLC
until the tool opens again.

> On Oct 25, 2016, at 12:48 PM, Spencer Shepler <[email-masked]> wrote:
> 
> 
> Chuck,
> 

--
Chuck Lever