Subject: Re: [nfsv4] request last call for draft-ietf-nfsv4-umask-01.txt

From: "J. Bruce Fields" <[email-masked]>
Date: Mon, 3 Oct 2016 10:35:30 -0400

On Fri, Sep 30, 2016 at 01:06:06PM -0400, bfields wrote:
> Could we start a last call for this?
> 
> Compared to -00, this just has some minor language tweaks.

But, it was in the wrong category: it should be standards-track, not
informational.  I've posted an -02, could you take that instead?

Thanks to Dave Noveck for catching that so quickly.

--b.

> 
> --b.
> 
> On Fri, Sep 30, 2016 at 09:13:59AM -0700, [email-masked] wrote:
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> > This draft is a work item of the Network File System Version 4 of the IETF.
> > 
> >         Title           : Allowing inheritable NFSv4 ACLs to override the umask 
> >         Authors         : J. Bruce Fields
> >                           Andreas Gruenbacher
> > 	Filename        : draft-ietf-nfsv4-umask-01.txt
> > 	Pages           : 5
> > 	Date            : 2016-09-30
> > 
> > Abstract:
> >    In some environments, inheritable NFSv4 ACLs can be rendered
> >    ineffective by the application of the per-process umask.  This is
> >    easily worked around by transmitting the umask and create mode
> >    separately, to allow servers to make more intelligent decisions about
> >    the new mode of a file.
> > 
> > 
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-nfsv4-umask/
> > 
> > There's also a htmlized version available at:
> > https://tools.ietf.org/html/draft-ietf-nfsv4-umask-01
> > 
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-umask-01
> > 
> > 
> > Please note that it may take a couple of minutes from the time of submission
> > until the htmlized version and diff are available at tools.ietf.org.
> > 
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> > 
> > _______________________________________________
> > nfsv4 mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/nfsv4

---

From: David Noveck <[email-masked]>
Date: Thu, 13 Oct 2016 13:00:33 -0400

Given that it has been  ten days since Bruce requested last call on
draft-ietf-nfsv4-umask-02, I suspect that his request has been lost
somehow.  It may have been that the quick succession of nearly identical
versions contributed to this.

Nevertheless, his request was appropriately made and I see no reason to
delay starting WGLC on this document further.   In any case, I am
anticipating submitting draft-ietf-nfsv4-versioning-07 in the next week and
will be requesting WGLC on that.  The two documents would probably be ready
for IESG consideration at about the same time, as discussed at IETF96.

Although the authors have not yet requested WGLC on
draft-ietf-nfsv4-xattrs-03, I understand the document is ready and might
well be considered as part of the same package.

---

From: Manoj Naik <[email-masked]>
Date: Thu, 13 Oct 2016 17:02:36 +0000

Perhaps it got lost somehow too, but please consider this a request for WGLC on draft-ietf-nfsv4-xattrs-03 as well.

Manoj.

From: nfsv4 <[email-masked]> on behalf of David Noveck <[email-masked]>
Date: Thursday, October 13, 2016 at 10:00 AM
To: Spencer Shepler <[email-masked]>
Cc: "J. Bruce Fields" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [nfsv4] request last call for draft-ietf-nfsv4-umask-01.txt

Given that it has been  ten days since Bruce requested last call on draft-ietf-nfsv4-umask-02, I suspect that his request has been lost somehow.  It may have been that the quick succession of nearly identical versions contributed to this.

Nevertheless, his request was appropriately made and I see no reason to delay starting WGLC on this document further.   In any case, I am anticipating submitting draft-ietf-nfsv4-versioning-07 in the next week and will be requesting WGLC on that.  The two documents would probably be ready for IESG consideration at about the same time, as discussed at IETF96.

Although the authors have not yet requested WGLC on draft-ietf-nfsv4-xattrs-03, I understand the document is ready and might well be considered as part of the same package.

---

From: "J. Bruce Fields" <[email-masked]>
Date: Fri, 14 Oct 2016 09:44:58 -0400

> for IESG consideration at about the same time, as discussed at IETF96.

Thanks for keeping on top of this!

--b.