Subject: [nfsv4] Working group recharter

From: David Noveck <[email-masked]>
Date: Sun, 23 Jul 2017 07:23:41 -0400

We discussed this at the working group meeting at IETF99.  In the meeting
materials you can find:

   - Ietf99CharterDiscuss which are the slides I presented about the effort.
   - Ietf99CharterMateials which had the latest draft charter and milestone
   proposals, both converted to a powerpoint form.

With regard to the draft charter there were only very minor changes made,
which are reflected in the attached file NearFinalCharterDraft.

I'd like people to look at the current draft and send mail to the list
about any issues they see.  Even though there was broad agreement
at the working group meeting, I don't think we can consider this draft as
final yet.  I think people who were not able to be in Prague or to
participate remotely given the meeting time (starting at 00:30 Pacific and
03:30 Eastern) should have the opportunity to comment before
we go forward on a re-charter effort.  I think a week is a reasonable time
so please offer any comments by 7/30.  In my presentation to the
working group, I stressed that we were looking for agreement on the basic
message and that minor corrections could wait.  Because we seem
to have  reached that basic agreement, I'd like everyone think about any
worthwhile correction they might offer, whether they attended the
working group meeting or not.

With regard to the milestones, things are a little further off.  There is
only one milestone in the current draft.  While there is no minimum number,
we would like to have more.  David  Black suggested that
one-milestone-per-working-document was a good model, which makes sense.
The only
problem is that if you look at our current list of working group documents,
we seems to have a temporary shortage.

If you look at our current seven working group documents:

   - Three are past WGLC and waiting for various stages of IESG handling,
   which leaves them out as milestone candidates.  Creating milestones fr
   these would essentially be giving the IESG milestones and they might not
   like that.  The drafts in question are rfc5667bis, xattrs, and umask.
   - Two drafts, flex-file and layout-types., are now in a WGLC scheduled
   to end 8/11. which makes milestones for these kind of pointless.
   - The remaining draft, migration issues is the one that has an
   associated milestone.

I expect that, in the next several weeks we will be considering adding some
working group documents.  I'd like to ask those who will be making
proposals in this regard to give some thought to likely milestones and let
me know so I can update the draft milestones.  It's important to note
that Spencer D has indicated that such milestones will not be set in
stone.  We are looking for people's best estimates, which can be revised
if unanticipated issues arise.

---

From: Mike Kupfer <[email-masked]>
Date: Wed, 26 Jul 2017 15:24:49 -0700

David Noveck writes:

> about any issues they see.

I don't have any high-level concerns, just a couple editorial nits.

- General Section, 2nd bullet: maybe add a comma after "related ONC
  components".

- Extension Section, slide 1, 1st bullet: the wording is a bit awkward.
  How about

    The NFSv4 protocol is designed to allow extension by the definition
    of new operations, new attributes, and new pNFS layout types, as
    well as the creation of minor versions.

cheers,
mike

---

From: David Noveck <[email-masked]>
Date: Thu, 27 Jul 2017 10:32:19 -0400

Thanks.  Those changes will be in the final draft, which being sent out on
Monday.

On Wed, Jul 26, 2017 at 6:24 PM, Mike Kupfer <[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Chuck Lever <[email-masked]>
Date: Thu, 27 Jul 2017 12:11:02 -0400

> On Jul 23, 2017, at 7:23 AM, David Noveck <[email-masked]> wrote:
> 
> We discussed this at the working group meeting at IETF99.  In the meeting materials you can find:
> 	• Ietf99CharterDiscuss which are the slides I presented about the effort.
> 	• Ietf99CharterMateials which had the latest draft charter and milestone proposals, both converted to a powerpoint form.
> With regard to the draft charter there were only very minor changes made, which are reflected in the attached file NearFinalCharterDraft.
> 
> I'd like people to look at the current draft and send mail to the list about any issues they see.  Even though there was broad agreement 
> at the working group meeting, I don't think we can consider this draft as final yet.  I think people who were not able to be in Prague or to 
> participate remotely given the meeting time (starting at 00:30 Pacific and 03:30 Eastern) should have the opportunity to comment before
> we go forward on a re-charter effort.  I think a week is a reasonable time so please offer any comments by 7/30.  In my presentation to the
> working group, I stressed that we were looking for agreement on the basic message and that minor corrections could wait.  Because we seem 
> to have  reached that basic agreement, I'd like everyone think about any worthwhile correction they might offer, whether they attended the 

Maintenance section, slide one of two:

"The working group is chartered with the vetting of the issues
and determining correctness of submitted errata."

Not clear which "issues" are referred to in this sentence.
How about:

"The working group is chartered with vetting reported issues
and determining correctness of submitted errata."

Maintenance section, slide two of two:

"or to respond to changed IESG expectations with regard to
areas such as security."

How about:

"or to respond to evolving IESG expectations with regard to
areas such as security."

> With regard to the milestones, things are a little further off.  There is only one milestone in the current draft.  While there is no minimum number,
> we would like to have more.  David  Black suggested that one-milestone-per-working-document was a good model, which makes sense.  The only
> problem is that if you look at our current list of working group documents, we seems to have a temporary shortage.
> 
> 	• Three are past WGLC and waiting for various stages of IESG handling, which leaves them out as milestone candidates.  Creating milestones fr these would essentially be giving the IESG milestones and they might not like that.  The drafts in question are rfc5667bis, xattrs, and umask.
> 	• Two drafts, flex-file and layout-types., are now in a WGLC scheduled to end 8/11. which makes milestones for these kind of pointless.
> 	• The remaining draft, migration issues is the one that has an associated milestone.
> I expect that, in the next several weeks we will be considering adding some working group documents.  I'd like to ask those who will be making
> proposals in this regard to give some thought to likely milestones and let me know so I can update the draft milestones.  It's important to note
> that Spencer D has indicated that such milestones will not be set in stone.  We are looking for people's best estimates, which can be revised

One of the purposes of the "NFS/RDMA Next Steps" talk during
IETF 99 was to review the various personal drafts in the bull
pen and select which ones might be appropriate for promotion
to WG document. At the end of that talk, it was agreed that
there was not a quorum of working group members present to
make any final choices.

In particular, draft-cel-nfsv4-rpcrdma-cm-pvt-msg and
draft-cel-nfsv4-rpcrdma-version-two need some discussion to
resolve their paths to becoming WG documents. I will start a
thread on [email-masked] in a few days to start that
discussion.

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Thu, 27 Jul 2017 13:44:44 -0400

Thanks for your sugestions about the charter.  Will incorporate these in
the fnal draft.

> thread on [email-masked] in a few days to start that

One of the version two issues concerned the use of one-way messages and
the possible effect on credit logic.  I'll send some mail to the list about
this issue
in the next few days.

On Thu, Jul 27, 2017 at 12:11 PM, Chuck Lever <[email-masked]>
wrote:

> >       • Ietf99CharterMateials which had the latest draft charter and
> milestone proposals, both converted to a powerpoint form.
> > With regard to the draft charter there were only very minor changes
> made, which are reflected in the attached file NearFinalCharterDraft.
> >
> > at the working group meeting, I don't think we can consider this draft
> as final yet.  I think people who were not able to be in Prague or to
> > participate remotely given the meeting time (starting at 00:30 Pacific
> and 03:30 Eastern) should have the opportunity to comment before
> > we go forward on a re-charter effort.  I think a week is a reasonable
> time so please offer any comments by 7/30.  In my presentation to the
> > working group, I stressed that we were looking for agreement on the
> basic message and that minor corrections could wait.  Because we seem
> > With regard to the milestones, things are a little further off.  There
> is only one milestone in the current draft.  While there is no minimum
> number,
> > problem is that if you look at our current list of working group
> documents, we seems to have a temporary shortage.
> >
> >       • Three are past WGLC and waiting for various stages of IESG
> handling, which leaves them out as milestone candidates.  Creating
> milestones fr these would essentially be giving the IESG milestones and
> they might not like that.  The drafts in question are rfc5667bis, xattrs,
> and umask.
> >       • Two drafts, flex-file and layout-types., are now in a WGLC
> scheduled to end 8/11. which makes milestones for these kind of pointless.
> > I expect that, in the next several weeks we will be considering adding
> some working group documents.  I'd like to ask those who will be making
> > proposals in this regard to give some thought to likely milestones and
> let me know so I can update the draft milestones.  It's important to note