Subject: [nfsv4] Status of draft-ietf-nfsv4-mv0-trunking-update

From: David Noveck <[email-masked]>
Date: Wed, 10 Oct 2018 05:39:03 -0400

We need more information about the current status and future of this
document.  Since WGLC ended, we have not received status updates and the
datatracker entry appears out-of-date.

Here's a brief summary of what I know:

   - Working Group Last Call for this document started on 7/24 and was
   scheduled to end on 8/10.
   - On 8/16 Chuck indicated that no last call comments had been received
   and inqiuired as to next steps for the document.
   - On 8/19 you responded to Chuck, indicating that your vacation had
   caused an unavoidable brief delay and  that you intended to shepherd the
   document forward.   From this, I (and probably others) assumed that there
   was no question that working group consensus on the document had been
   achieved and that further steps to advance consideration of it would happen
   soon.
   - On 10/3. Chuck noticed that the document was still listed on the
   datatracker with a WG state of "I-D Exists".   Apparently, the state was
   never updated to reflect the start or end of working group last call or the
   fact that working group consensus had been achieved. Chuck inquired whether
   there was someting that you needed from him (as editor) or me (as
   co-author).

It is now two months since the end of last call and we have had no further
information about the status of the document. The authors need to know
about the current status and expected next steps for this document.  This
issue is of particular concern given that the target date for final
submission for this document is 11/2018 and further delay would make it
hard to achieve this date.  The authors are conerned about this issue and
others might be as well.

Some questions that I think need clear answers:

   - How is the lack of a transition to WGLC to be dealt with?  In the past
   this issue has ben dealt with simply by noting, after the fact, that the
   last-call took place but I'm not sure why that has not been done.  If that
   is still OK from a IETF/IESG perspctive it needs to be done, to keep the
   datatracker listing of wg document status in accord with reality.
   - Are we right in presuming that, in your judgment, working group
   consensus has been achieved?   Since the authors have received no indicaton
   of difficulties, one would normally assume so.  However, the fact that the
   document is still in "I-D exists" makes things confusing and uncertain.  We
   need to get a quick clarification about the document status.
   - Unfortunately, despite your indication that you would shpherd the
   document forward, according to the data tracker, there is no current
   shepherd assigned which is apparently in conflict with your statement to
   Chuck about proceeding to shepherd this document forward.  Again, we need
   clarification as to the status of this document.  Since the datatracker
   info is often unreliable, we need to get clarity on this point, to be sure
   if work on shepherding this document is proceeding and what we can expect
   in terms of schdule.

Authors and the rest of the working group need a realiable source of
information about the status of documents once thet are ready for working
group last call and the data tracker currently is not fulfilliing that
function. I'd like to make a couple of suggestions to improve the situation
in the future:

   - The WG status for documents needs to be updated in the data tracker
   whenever the status changes.   I realize that this kind of update might
   strike one as excessive and I agree that it can be annoying.  However, as
   the datatacker is the one available means to commmunicate this information
   to the working group members (and others), it makes sense to keep it
   accurate.
   - Given that we have target dates for many of our active documents,
   these should be noted on the data tracker.
   - When there is a substantial delay in proceeding to the next step of
   document processing (over a week), I suggest that there is a need to
   properly set expectations with the document authors (and the working group
   as a whole, if you so choose).

With regard to this specific document, I think it makes sense for you to
decide on a realistic plan to submit it for IESG consideration and share
that with the working group.
ReplyForward

---

From: spencer shepler <[email-masked]>
Date: Wed, 10 Oct 2018 09:22:15 -0700

Datatracker updated.  Shepherding to IESG forthcoming within the week.

On Wed, Oct 10, 2018 at 2:39 AM David Noveck <[email-masked]> wrote:

>    - How is the lack of a transition to WGLC to be dealt with?  In the
>    past this issue has ben dealt with simply by noting, after the fact, that
>    the last-call took place but I'm not sure why that has not been done.  If
>    that is still OK from a IETF/IESG perspctive it needs to be done, to keep
>    the datatracker listing of wg document status in accord with reality.

---

From: spencer shepler <[email-masked]>
Date: Sun, 21 Oct 2018 14:42:35 -0700

Document submitted to IESG for review (goes to AD/Spencer D. first).

Spencer

On Wed, Oct 10, 2018 at 9:22 AM spencer shepler <[email-masked]>
wrote:

>>    - On 8/16 Chuck indicated that no last call comments had been
>>    received and inqiuired as to next steps for the document.
>> It is now two months since the end of last call and we have had no
>> further information about the status of the document. The authors need to
>> know about the current status and expected next steps for this document.
>> This issue is of particular concern given that the target date for final

---

From: Chuck Lever <[email-masked]>
Date: Mon, 22 Oct 2018 10:08:37 -0400

Thanks, Spencer!

> On Oct 21, 2018, at 5:42 PM, spencer shepler <[email-masked]> wrote:
> 
> 
> On Wed, Oct 10, 2018 at 9:22 AM spencer shepler <[email-masked]> wrote:
> 
> We need more information about the current status and future of this document.  Since WGLC ended, we have not received status updates and the datatracker entry appears out-of-date.
> 
> 	• Working Group Last Call for this document started on 7/24 and was scheduled to end on 8/10.
> 	• On 8/16 Chuck indicated that no last call comments had been received and inqiuired as to next steps for the document.   
> 	• On 8/19 you responded to Chuck, indicating that your vacation had caused an unavoidable brief delay and  that you intended to shepherd the document forward.   From this, I (and probably others) assumed that there was no question that working group consensus on the document had been achieved and that further steps to advance consideration of it would happen soon.
> 	• On 10/3. Chuck noticed that the document was still listed on the datatracker with a WG state of "I-D Exists".   Apparently, the state was never updated to reflect the start or end of working group last call or the fact that working group consensus had been achieved. Chuck inquired whether there was someting that you needed from him (as editor) or me (as co-author).
> It is now two months since the end of last call and we have had no further information about the status of the document. The authors need to know about the current status and expected next steps for this document.  This issue is of particular concern given that the target date for final submission for this document is 11/2018 and further delay would make it hard to achieve this date.  The authors are conerned about this issue and others might be as well.
> 
> 	• How is the lack of a transition to WGLC to be dealt with?  In the past this issue has ben dealt with simply by noting, after the fact, that the last-call took place but I'm not sure why that has not been done.  If that is still OK from a IETF/IESG perspctive it needs to be done, to keep the datatracker listing of wg document status in accord with reality.
> 	• Are we right in presuming that, in your judgment, working group consensus has been achieved?   Since the authors have received no indicaton of difficulties, one would normally assume so.  However, the fact that the document is still in "I-D exists" makes things confusing and uncertain.  We need to get a quick clarification about the document status.
> 	• Unfortunately, despite your indication that you would shpherd the document forward, according to the data tracker, there is no current shepherd assigned which is apparently in conflict with your statement to Chuck about proceeding to shepherd this document forward.  Again, we need clarification as to the status of this document.  Since the datatracker info is often unreliable, we need to get clarity on this point, to be sure if work on shepherding this document is proceeding and what we can expect in terms of schdule.
> Authors and the rest of the working group need a realiable source of information about the status of documents once thet are ready for working group last call and the data tracker currently is not fulfilliing that function. I'd like to make a couple of suggestions to improve the situation in the future:
> 	• The WG status for documents needs to be updated in the data tracker whenever the status changes.   I realize that this kind of update might strike one as excessive and I agree that it can be annoying.  However, as the datatacker is the one available means to commmunicate this information to the working group members (and others), it makes sense to keep it accurate.
> 	• Given that we have target dates for many of our active documents, these should be noted on the data tracker.
> 	• When there is a substantial delay in proceeding to the next step of document processing (over a week), I suggest that there is a need to properly set expectations with the document authors (and the working group as a whole, if you so choose).
> With regard to this specific document, I think it makes sense for you to decide on a realistic plan to submit it for IESG consideration and share that with the working group.
> 	
> Reply
> Forward
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

--
Chuck Lever
[email-masked]