Subject: [NFVCON] a side meeting @ IETF 89

From: "Songhaibin (A)" <[email-masked]>
Date: Thu, 20 Feb 2014 09:00:23 +0000

I wonder if there are a small group of people who are interested in getting together for a side meeting at the upcoming IETF. We can discuss the use cases and scope that people would like to work on for NFV configuration & data model, but which may not be limited to NFV. NFV itself is not mature at this stage, but VNF configuration and data model are similar to that of some other cloud based applications.

Please reply to me or the list if you are interested, and with your available time. For me, I am available all the evenings except Tuesday.

Best Regards!
-Haibin

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 20 Feb 2014 09:01:58 -0500

Let me suggest you consider coming to the Ops Area, NetMod and NetConf to discuss configuration issues and related data models. *)

	--Tom

On Feb 20, 2014:4:00 AM, at 4:00 AM, Songhaibin (A) <[email-masked]> wrote:

> _______________________________________________
> NFVCON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfvcon
>

---

From: Melinda Shore <[email-masked]>
Date: Thu, 20 Feb 2014 06:24:47 -0900

On 2/20/14 5:01 AM, Thomas Nadeau wrote:
> Let me suggest you consider coming to the Ops Area, NetMod and
> NetConf to discuss configuration issues and related data models. *)

This work got time on the agenda at opsawg at IETF 88 and there's
been little discussion since.  I do think that it's possible to make
substantial progress without meeting in person, and that it would
be worthwhile to take some time before the meeting to identify
an issues that need resolution or that would benefit from face-to-
face discussion.

Melinda

---

From: "Songhaibin (A)" <[email-masked]>
Date: Fri, 21 Feb 2014 02:39:36 +0000

Hi Tom and Melinda,

Thank you for the advice. Substantial progress is most important, and for IETF, it mostly means drafts. Let's see whether we can put some substantial drafts on the table soon after the upcoming IETF meeting.

And yes, identifying a issue is indeed needed. NFV Configuration covers a wide range. But if we look at the requirements for provisioning a VNF service, or a VNF graph service , that should be narrow.

Best Regards!
-Haibin

> -----Original Message-----
> From: NFVCON [mailto:[email-masked]] On Behalf Of Melinda Shore
> Sent: Thursday, February 20, 2014 11:25 PM
> To: [email-masked]
> Subject: Re: [NFVCON] a side meeting @ IETF 89
> 
> > Let me suggest you consider coming to the Ops Area, NetMod and NetConf
> > to discuss configuration issues and related data models. *)
> 
> This work got time on the agenda at opsawg at IETF 88 and there's been little
> discussion since.  I do think that it's possible to make substantial progress
> without meeting in person, and that it would be worthwhile to take some time
> before the meeting to identify an issues that need resolution or that would
> benefit from face-to- face discussion.
> 
> Melinda
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 22 Feb 2014 23:40:57 +0000

Hi,

You know I was skeptical about this initiative, but I must say I am starting to see some potential areas of application of specific NFV configuration aspects, at least in what relates to defining properties of the VNF Forwarding Graph (what has some interesting challenges regarding how you deal with dynamic graphs in the interaction of the VNFs with the infrastructure) and the attachment points of a virtualized service. Furthermore, if we could move in the direction of prescribing a single method for dealing with function configuration (NETCONF based, I'd say) it would be a great step.

I guess one of the key things we need to decide is what are the reference points to be addressed in the NFV architectural framework.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 23 Feb 2014 15:05:17 +0000

Dear Diego, All,

NETCONF is well-prepared for addressing function configuration on diverse reference points of the NFV architecture.
The new interface descriptions in ETSI NFV use a producer/consumer paradigm and the interface can be re-exposed practically by any entity.
RESTCONF would be perfect in such an environment as it can support HTML-based REST-like configuration.

Haibin: I would be available through the week, except on Monday.

Cheers, 
Mehmet 

> From: NFVCON [mailto:[email-masked]] On Behalf Of ext Diego R.
> Lopez
> Sent: Sunday, February 23, 2014 12:41 AM
> To: Songhaibin (A)
> Cc: Melinda Shore; [email-masked]
> You know I was skeptical about this initiative, but I must say I am
> starting to see some potential areas of application of specific NFV
> configuration aspects, at least in what relates to defining properties
> of the VNF Forwarding Graph (what has some interesting challenges
> regarding how you deal with dynamic graphs in the interaction of the
> VNFs with the infrastructure) and the attachment points of a
> virtualized service. Furthermore, if we could move in the direction of
> prescribing a single method for dealing with function configuration
> (NETCONF based, I'd say) it would be a great step.
> 
> I guess one of the key things we need to decide is what are the
> reference points to be addressed in the NFV architectural framework.
> 
> Be goode,
> 
> > Thank you for the advice. Substantial progress is most important, and
> for IETF, it mostly means drafts. Let's see whether we can put some
> substantial drafts on the table soon after the upcoming IETF meeting.
> >
> > And yes, identifying a issue is indeed needed. NFV Configuration
> covers a wide range. But if we look at the requirements for
> provisioning a VNF service, or a VNF graph service , that should be
> narrow.
> >
> > Best Regards!
> > -Haibin
> >
> >
> NetConf
> been little
> Este mensaje se dirige exclusivamente a su destinatario. Puede
> consultar nuestra política de envío y recepción de correo electrónico
> en el enlace situado más abajo.
> This message is intended exclusively for its addressee. We only send
> and receive email on the basis of the terms set out at:

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 23 Feb 2014 17:41:46 +0100

> HTML-based REST-like configuration.

What is heck is "HTML-based REST-like configuration"? And who says
this is useful or desirable?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 23 Feb 2014 19:32:30 +0000

Juergen,

the result of the discussion was that RESTCONF is a protocol almost similar to NETCONF in terms of capabilities, to access YANG modules over HTTP, with REST characteristics but not RESTful. That said you can use it for configuration management.

> And who says this is useful or desirable?
I don't know what you are referring to.

Cheers, 
Mehmet 

> From: ext Juergen Schoenwaelder [mailto:j.schoenwaelder@jacobs-
> university.de]
> Sent: Sunday, February 23, 2014 5:42 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: [email-masked]

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 24 Feb 2014 09:15:09 -0500

> RESTCONF would be perfect in such an environment as it can support HTML-based REST-like configuration.

	Take a look at opendaylight.org. We already have a working implementation of a RestConf interface working on the controller as part of the first release (hydrogen) that talks to a variety of routers and switches (real and virtual). 

	--Tom

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 24 Feb 2014 15:50:26 +0000

> OpenDaylight is the existence proof that RESTCONF/YANG will work great as a starting point for I2RS.

This is exactly what I believe.

Cheers,
Mehmet

From: ext Andy Bierman [mailto:[email-masked]]
Sent: Monday, February 24, 2014 4:29 PM
To: Thomas Nadeau
Cc: Ersue, Mehmet (NSN - DE/Munich); ext Diego R. Lopez; Songhaibin (A); Melinda Shore; [email-masked]
Subject: Re: [NFVCON] a side meeting @ IETF 89

On Mon, Feb 24, 2014 at 6:15 AM, Thomas Nadeau <[email-masked]<mailto:[email-masked]>> wrote:

> RESTCONF would be perfect in such an environment as it can support HTML-based REST-like configuration.

        Take a look at opendaylight.org<http://opendaylight.org>. We already have a working implementation of a RestConf interface working on the controller as part of the first release (hydrogen) that talks to a variety of routers and switches (real and virtual).

+1

I've seen the YANG modules (I hear from the developers every time
yangcli-pro does something wrong with those modules ;-) Very impressive
amount of work done already.

OpenDaylight is the existence proof that RESTCONF/YANG
will work great as a starting point for I2RS.

        --Tom

Andy

>> From: NFVCON [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of ext Diego R.
>> Lopez
>> Cc: Melinda Shore; [email-masked]<mailto:[email-masked]>
>> On 21 Feb 2014, at 03:39 , Songhaibin (A) <[email-masked]<mailto:[email-masked]>>
>> wrote:
>>
>>> Hi Tom and Melinda,
>>>
>>>> From: NFVCON [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Melinda
>> Shore
>>>> To: [email-masked]<mailto:[email-masked]>
>>>> [email-masked]<mailto:[email-masked]>
>>> [email-masked]<mailto:[email-masked]>
>> e-mail: [email-masked]<mailto:[email-masked]>
>> Tel:    +34 913 129 041
>> Mobile: +34 682 051 091
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 24 Feb 2014 11:16:32 -0500

a) I would hope that a discussion of what will work great for I2RS would 
occur on the I2RS list.

b) Rather than "it runs in with this controller", I would really like to 
see an analysis (for it and the other choices) of how the proposal 
actually stacks up against the WG requirements.   While the fact that it 
runs is important, the current ODL (or other running SDN environments) 
simply do not stress many of the stated requirements.

c) Note that the above is as far as I can tell orthogonal to the 
question of how we will configure NFV virtual servers or service chain 
forwarding.

Yours,
Joel

On 2/24/14, 10:50 AM, Ersue, Mehmet (NSN - DE/Munich) wrote:
> *From:*ext Andy Bierman [mailto:[email-masked]]
> *Sent:* Monday, February 24, 2014 4:29 PM
> *To:* Thomas Nadeau
> *Cc:* Ersue, Mehmet (NSN - DE/Munich); ext Diego R. Lopez; Songhaibin
> (A); Melinda Shore; [email-masked]
> *Subject:* Re: [NFVCON] a side meeting @ IETF 89
>
> On Feb 23, 2014:10:05 AM, at 10:05 AM, Ersue, Mehmet (NSN - DE/Munich)
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>  > Dear Diego, All,
>  >
>  > NETCONF is well-prepared for addressing function configuration on
> diverse reference points of the NFV architecture.
>  > The new interface descriptions in ETSI NFV use a producer/consumer
> paradigm and the interface can be re-exposed practically by any entity.
>          Take a look at opendaylight.org <http://opendaylight.org>. We
> already have a working implementation of a RestConf interface working on
> the controller as part of the first release (hydrogen) that talks to a
> variety of routers and switches (real and virtual).
>
> +1
>
>      >> From: NFVCON [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of ext Diego R.
>      >> Lopez
>      >> Cc: Melinda Shore; [email-masked] <mailto:[email-masked]>
>      >> On 21 Feb 2014, at 03:39 , Songhaibin (A)
>     <[email-masked] <mailto:[email-masked]>>
>      >> wrote:
>      >>
>      >>> Hi Tom and Melinda,
>      >>>
>      >>>> From: NFVCON [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Melinda
>      >> Shore
>      >>>> To: [email-masked] <mailto:[email-masked]>
>      >>>> discussion since.  I do think that it's possible to make
>     substantial
>      >> progress
>      >>>> [email-masked] <mailto:[email-masked]>
>      >>> [email-masked] <mailto:[email-masked]>
>      >> e-mail: [email-masked] <mailto:[email-masked]>
>      >> Tel:    +34 913 129 041
>      >> Mobile: +34 682 051 091
>      >> [email-masked] <mailto:[email-masked]>
>      > [email-masked] <mailto:[email-masked]>

---

From: Carl Moberg <[email-masked]>
Date: Mon, 24 Feb 2014 17:28:53 +0100

> 	Take a look at opendaylight.org. We already have a working implementation of a RestConf interface working on the controller as part of the first release (hydrogen) that talks to a variety of route…

 That’s strange. I didn’t even know we had a WG draft for RESTCONF yet?

--
Carl Moberg
VP Technology
twitter: @cmoberg
http://www.tail-f.com/

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 24 Feb 2014 16:56:37 +0000

Carl,

you should come to IETF again. Then you will see what we are doing ;-).

Cheers, 
Mehmet 

> From: ext Carl Moberg [mailto:[email-masked]]
> Sent: Monday, February 24, 2014 5:29 PM
> To: Thomas Nadeau
> Cc: Ersue, Mehmet (NSN - DE/Munich); Songhaibin (A); ext Diego R.
> Lopez; [email-masked]; Melinda Shore; ext Andy Bierman
> > 	Take a look at opendaylight.org. We already have a working
> implementation of a RestConf interface working on the controller as
> part of the first release (hydrogen) that talks to a variety of routers
> and switches (real and virtual).
> >
> > 	--Tom
> 
>  That's strange. I didn't even know we had a WG draft for RESTCONF yet?
> 
> --
> Carl Moberg
> VP Technology
> twitter: @cmoberg
> http://www.tail-f.com/

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 24 Feb 2014 13:19:37 -0500

On Feb 24, 2014:11:28 AM, at 11:28 AM, Andy Bierman <[email-masked]> wrote:

> Hi Loel,
> 
> Sorry.  I mixed this thread up with another one in my Inbox
> about I2RS.
> 
> But to your valid comments -- Implementing a complex data model
> is hard.  IMO, the OpenDaylight data models can serve as
> some measure of complexity that has been created by
> domain experts, not YANG experts.
> 
> The NFV configuration requirements should be comparable
> in complexity to those in OpenDaylight.

	That is what I am hoping. 

	--Tom

> 
> 
> Andy
> 
> On Mon, Feb 24, 2014 at 8:16 AM, Joel M. Halpern <[email-masked]> wrote:
> a) I would hope that a discussion of what will work great for I2RS would occur on the I2RS list.
> 
> b) Rather than "it runs in with this controller", I would really like to see an analysis (for it and the other choices) of how the proposal actually stacks up against the WG requirements.   While the fact that it runs is important, the current ODL (or other running SDN environments) simply do not stress many of the stated requirements.
> 
> c) Note that the above is as far as I can tell orthogonal to the question of how we will configure NFV virtual servers or service chain forwarding.
> 
> Yours,
> Joel
>

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 24 Feb 2014 13:20:12 -0500

> That’s strange. I didn’t even know we had a WG draft for RESTCONF yet?

	Maybe that is the whole point? - implementation first. *)

	--Tom

---

From: Carl Moberg <[email-masked]>
Date: Tue, 25 Feb 2014 08:22:36 +0100

> 	Maybe that is the whole point? - implementation first. *)

 Oh, I don’t worry too much about that, I know of a RESTCONF implementation that have been in production with some of the largest networks in the industry ;-) I worry more about the applicability of RESTCONF to the configuration interfaces of the distributed networking functions vs. as an NB API on controllers.

--
Carl Moberg
VP Technology
twitter: @cmoberg
http://www.tail-f.com/

---

From: Carl Moberg <[email-masked]>
Date: Tue, 25 Feb 2014 08:24:59 +0100

Not exactly sure if by “you should come to IETF again” mean the next meeting in London? Otherwise I’m always interested in swing what you’re doing, Mehmet :-)

--
Carl Moberg
VP Technology
twitter: @cmoberg
http://www.tail-f.com/

---

From: Carl Moberg <[email-masked]>
Date: Tue, 25 Feb 2014 08:34:54 +0100

That would be “seeing”, of course.

--
Carl Moberg
VP Technology
twitter: @cmoberg
http://www.tail-f.com/