Subject: [NFVCON] virtualization of network functions makes the management different

From: "Songhaibin (A)" <[email-masked]>
Date: Fri, 23 May 2014 03:02:15 +0000

Hi guys,

I'm thinking the virtualization of network functions makes the management different from the conventional network appliances, for example, when compared with hard appliances, virtual network functions are easy to install/update/delete, or migrate from one place to another (for something like virtual residential gateway). And virtual network functions can also be open to the network function consumers. What are other differences in your opinion?

Best Regards!
-Haibin

---

From: <[email-masked]>
Date: Mon, 26 May 2014 05:17:15 +0000

Hi Haibin,

Yes I agree with you! 
In particular, the dynamic lifecycle management of the virtual network functions (e.g., deploy, provision, operation and runtime management, disposal)  is very different from the (almost) static configuration of conventional network appliances. 

Best regards,
Georgios

________________________________________
Van: NFVCON [[email-masked]] namens Songhaibin (A) [[email-masked]]
Verzonden: vrijdag 23 mei 2014 5:02
Aan: [email-masked]
Onderwerp: [NFVCON] virtualization of network functions makes the management    different

Hi guys,

Best Regards!
-Haibin

_______________________________________________
NFVCON mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfvcon

---

From: Barbara Martini <[email-masked]>
Date: Mon, 26 May 2014 14:38:24 +0200

Hi Haibin, Georgios,

I do agree with you. Also, I think that the fact we can have agile 
runtime management and disposal of virtual network functions provide the 
capability of performing much more effective optimizations while 
addressing different management targets. For instance, the virtual 
network functions can be initially disposed according to a specified 
optimization targets, then easily rearranged based on changing 
conditions or modified targets. The optimization targets may be for 
example the minimization of used physical server hosting virtual network 
functions or, on the contrary, the balancing of used physical servers.

Moreover, the instances of virtual network function can be dynamically 
scaled up/down in a agile way in order to assure the required 
capabilities while avoiding overprovisioning. Finally, in combination 
with software-defined networking the traffic can be dynamically steered 
across virtual network functions on per-service basis or even on 
per-tenant basis thanks to high level of programmability of network nodes.

Best regards,

Barbara

---

From: "Songhaibin (A)" <[email-masked]>
Date: Tue, 27 May 2014 08:38:25 +0000

Hi Georgios,

Thank you for the reply. Right, that's why we target the virtualization characteristics of VNF. Implementation of virtual network functions gradually get deployed in the real world. If you have multiple vendors and consumers for the VNF, you need a standard protocol for this platform. And we will explain them more in a use case draft for NFV configuration.

Best Regards!
-Haibin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, May 26, 2014 1:17 PM
> To: Songhaibin (A); [email-masked]
> Subject: RE: [NFVCON] virtualization of network functions makes the
> management different
> 
> Hi Haibin,
> 
> Yes I agree with you!
> In particular, the dynamic lifecycle management of the virtual network
> functions (e.g., deploy, provision, operation and runtime management, disposal)
> is very different from the (almost) static configuration of conventional network
> appliances.
> 
> Best regards,
> Georgios
> 
> 
> I'm thinking the virtualization of network functions makes the management
> different from the conventional network appliances, for example, when
> compared with hard appliances, virtual network functions are easy to
> install/update/delete, or migrate from one place to another (for something like
> virtual residential gateway). And virtual network functions can also be open to
> the network function consumers. What are other differences in your opinion?
> 
> Best Regards!
> -Haibin
>

---

From: "Songhaibin (A)" <[email-masked]>
Date: Tue, 27 May 2014 09:00:50 +0000

Hi Barbara,

Best Regards!
-Haibin

> From: Barbara Martini [mailto:[email-masked]]
> Sent: Monday, May 26, 2014 8:38 PM
> To: [email-masked]; [email-masked]; Songhaibin (A)
> Subject: Re: [NFVCON] virtualization of network functions makes the
> management different
> 
> Hi Haibin, Georgios,
> 
> I do agree with you. Also, I think that the fact we can have agile runtime
> management and disposal of virtual network functions provide the capability of
> performing much more effective optimizations while addressing different
> management targets. For instance, the virtual network functions can be
> initially disposed according to a specified optimization targets, then easily
> rearranged based on changing conditions or modified targets. The optimization
> targets may be for example the minimization of used physical server hosting
> virtual network functions or, on the contrary, the balancing of used physical
> servers.

[Haibin] This example is very interesting. I think we can get some very useful requirements from agile runtime management, especially from the NFV consumer perspective. The policies at least include load-balancing policy, automatic scale-out/in policy, and etc. I'm very interested in the NFV management and orchestration plane north bound interactions with VNF providers and consumers. But in the south-bound to the specific infrastructure devices, the management and orchestration plane has to translate those requirements into detailed configuration commands/protocol interactions that have been supported by the existing devices, which is more about implementation issue IMO.

> Moreover, the instances of virtual network function can be dynamically scaled
> up/down in a agile way in order to assure the required capabilities while
> avoiding overprovisioning. 

[Haibin] Fully agree.

>Finally, in combination with software-defined
> networking the traffic can be dynamically steered across virtual network
> functions on per-service basis or even on per-tenant basis thanks to high level
> of programmability of network nodes.
> 
[Haibin] Definitely this kind of combination with SDN is very attractive. One use case that I know is when you add a new VNF instance that's agnostic to the applications, you need to send a command to its neighbor switch, so as to make it split a portion of the traffic to the new VNF instance, based on some policies.

Regards!
-Haibin

---

From: <[email-masked]>
Date: Thu, 29 May 2014 09:36:59 +0000

Hi Haibin,

Yes, I think that a use case draft for NFV configuration will be useful!

I also agree with Diego that it is important to focus on the configuration protocol solution needed  for the support of the EMS-NFV interface associated with the NFV architecture framework.

Best regards,
Georgios

________________________________________
Van: Songhaibin (A) [[email-masked]]
Verzonden: dinsdag 27 mei 2014 10:38
Aan: Karagiannis, G. (EWI); [email-masked]
Onderwerp: RE: [NFVCON] virtualization of network functions makes the management        different

Hi Georgios,

Best Regards!
-Haibin