Subject: Re: [Nfvrg] near-term charter for NFVRG

From: ramki Krishnan <[email-masked]>
Date: Sun, 17 Aug 2014 22:22:52 -0700

Dear All,

During IETF, there was substantial interest in interim meetings before the next IETF meeting at Hawaii. On that front, we would like to arrange interim meetings in the following three locations a) San Francisco Bay Area, USA b) Europe (location to be finalized) c) Bangalore, India with the following goals

-        Deep dive into one or more of the topics in the near term charter (see below and also http://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg).

-        Encourage free-flowing face-to-face discussions which can lead to further discussions over email.

-        Remote participation will be available, but not the preferred option.

We would like to kick this off with a meeting in San Francisco Bay Area  (in the Brocade campus in 237) in the next 2-3 weeks. Please find link to doodle poll - https://doodle.com/nfwrfwqz7ecamef3ipnvnf23/admin#table. Would appreciate your response at your earliest convenience.

Thanks,
Ramki on behalf of the co-chairs

From: Nfvrg [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: Monday, August 11, 2014 9:47 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Alberto Leon-Garcia ([email-masked]<mailto:[email-masked]>); DIEGO LOPEZ GARCIA ([email-masked]<mailto:[email-masked]>); Hesham ElBakoury ([email-masked]<mailto:[email-masked]>); 'Anoop Ghanwani <[email-masked]<mailto:[email-masked]>> ([email-masked]<mailto:[email-masked]>)'; [email-masked]<mailto:[email-masked]>; Shishir Nagaraja <[email-masked]<mailto:[email-masked]>> ([email-masked]<mailto:[email-masked]>)
Subject: [Nfvrg] near-term charter for NFVRG

Dear All,

For NFVRG, we are looking forward to IRTF draft contributions. To facilitate this process, we would like to hone our near-term (at least next 1 year) charter to a few specific areas. Some suggestions for areas are below. For each of the areas, we would suggest exploring system architecture and optimization with open interfaces across components and explore research through simulations and/or real-world implementations. Would love your comments and suggestions !

Would like to thank Steve, Shishir, Alberto, Anoop and Hesham for the discussions so far.

Policy based Resource Management
NFV DCs are often constrained in compute and storage capacity. Since practically all NFV DCs are foreseen to be  distributed, inter-DC network capacity is also a constraint. Additionally, energy is also a constraint, both as a general concern for NFV operators, and for specific-purpose NFV DCs such as those in mobile base stations that often have power limitations. Hence, optimal resource management and workload distribution based on policy is a relevant area to focus on.

Below are some examples of research work in progress in the area of resource management
IRTF drafts
-        - http://tools.ietf.org/html/draft-krishnan-nfvrg-open-nfv-virality-00
ETSI NFV PoCs
-        - http://nfvwiki.etsi.org/index.php?title=Virality_based_content_caching_in_NFV_framework

Security and Service Verification
NFV configuration is expected to be dynamic especially in the edge NFV DCs where capacity is limited; a very good example is handling a viral event such as mobile gaming application. While autonomic networking techniques could be used to automate the configuration process including modular updates, it is important to take into account that incomplete and/or inconsistent configuration may lead to security issues. Additionally, events such as distributed denial of service (DDoS) attacks could be an additional source of compromise. Hence, service verification including logging and analysis in near real-time is a relevant area to focus on.

Analytics for Visibility and Orchestration
Network functions should be supportable on general purpose commodity hardware. Real-time analytics providing insight into various components such as compute (e.g. dynamic CPU utilization), storage (e.g. dynamic capacity usage), network (e.g. dynamic bandwidth utilization), energy (e.g. dynamic power consumption) is key to not only providing visibility into the NFV infrastructure but also optimizing resource usage for the purposes of orchestration. This is a relevant area to focus on.

Virtual Network Function (VNF) Performance Modelling to facilitate transition to NFV
While migrating from hardware network appliances, which are typically custom and monolithic, to virtualized software appliances running on commodity hardware a challenge which is often faced is to come up with an equivalence model especially in terms of performance. This is a relevant area to focus on.

Thanks,
Ramki on behalf of the co-chairs

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 18 Aug 2014 05:54:02 +0000

Ramki

Can you please clarify the context a bit.

1)      From the doodle this seems to be a 1-day meeting.

For some of us it would be hard to justify 2 days travel for a 1-day meeting.

2)      Will there be good facilities for remote participation (e.g., WebEx, Meetecho), or one-way audio and jabber ?

I have participated in the latter type (and meetings based on Skype) and it is highly frustrating.

3)      Is the purpose nailing down a charter, or more like an academic conference ?

Thanks,

Y(J)S

From: Nfvrg [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: 18 August, 2014 08:23
To: [email-masked]
Cc: DIEGO LOPEZ GARCIA ([email-masked]); [email-masked]
Subject: Re: [Nfvrg] near-term charter for NFVRG

Dear All,

Thanks,

Dear All,

Thanks,

---

From: ramki Krishnan <[email-masked]>
Date: Sun, 17 Aug 2014 23:40:56 -0700

Hi Yaakov,

Please find inline.

Thanks,
Ramki

From: Yaakov Stein [mailto:[email-masked]]
Sent: Sunday, August 17, 2014 10:54 PM
To: ramki Krishnan; [email-masked]
Cc: DIEGO LOPEZ GARCIA ([email-masked]); [email-masked]
Subject: RE: [Nfvrg] near-term charter for NFVRG

Ramki

Ramki: The meeting is for 3 hours. We have proposed six, 3 hour time slots in doodle; the ones with a lunch overlap have an extra hour. Please pick the one(s) which are convenient to you.

Ramki: We will use Microsoft Lync which has local numbers for dial-in.

3)      Is the purpose nailing down a charter, or more like an academic conference ?
Ramki: The purpose is to deep dive into one or more of the topics in the near term charter and also refine the near term charter as needed.

Thanks,

Y(J)S

Cc: DIEGO LOPEZ GARCIA ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>

Dear All,

Thanks,

Dear All,

Thanks,

---

From: ramki Krishnan <[email-masked]>
Date: Mon, 18 Aug 2014 08:31:36 -0700

Dear All,

Many thanks for the responses so far. If you could please let me know whether you would be participating in person or remotely (through the doodle poll comments or an email to me) it would be much appreciated; this would help me plan the meeting better.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: Sunday, August 17, 2014 10:23 PM
To: [email-masked]
Cc: DIEGO LOPEZ GARCIA ([email-masked]); [email-masked]
Subject: Re: [Nfvrg] near-term charter for NFVRG

Dear All,

Thanks,

Dear All,

Thanks,