Subject: Re: [Nfvrg] Looking forward to your feedback on the NFVRG agenda

From: Ramki Krishnan <[email-masked]>
Date: Thu, 4 Dec 2014 07:55:49 +0000

Dear All,

A gentle reminder, any feedback on the agenda before this Friday (12/5) would be much appreciated.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: Thursday, November 27, 2014 7:26 AM
To: [email-masked]
Cc: DIEGO LOPEZ GARCIA ([email-masked]); [email-masked]'
Subject: [Nfvrg] Looking forward to your feedback on the NFVRG agenda

Dear NFVRG Members,

Many thanks for the interest and participation. We are working on transitioning NFVRG to approved state and looking forward to your feedback at the earliest on the agenda. The agenda is inline and also attached in a word document; this text is predominantly what we discussed in the meetings so far and in the NFVRG wiki page (https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg) with minor edits.
Thanks,
Ramki on behalf of the co-chairs

Network Function Virtualization Research Group (NFVRG)

Background
Network Function Virtualization is a key emerging area for network operators, hardware and software vendors, cloud service providers, and in general network practitioners and researchers. This area requires exploring new directions and working collaboratively on how to create network services that utilize a virtualized infrastructure. Network functions that are traditionally implemented in dedicated hardware appliances will need to be decomposed and executed in software elements running on cloud-based infrastructures. One essential goal of this new approach is to reduce capital and operating expenditures for future deployments for networks and associated services. Another important goal is for the network operators to be able to offer value added cloud services to their customers. Finally, new business models will open for the provision of network services.

The technologies enabling the virtualization of network functions are currently in an early stage, and they need researchers to develop new architectures, systems, and software, and to explore tradeoffs and possibilities for leveraging virtualized infrastructure to provide support for network functions. The Network Functions Virtualization Research Group (NFVRG) will bring together researchers and grow the community around the world in both academia and industry to explore this new research area. Beyond the direct activity through the IRTF collaboration tools it will organize research group meetings and workshops at premier conferences (such as IEEE ICC, IEEE Globecom) and inviting special issues in well-known journals.

The NFVRG will focus on research problems associated with NFV-related topics and on bringing a research community together that can jointly address them, concentrating on problems that relate not just to networking but also to computing and storage constraints in such environments. It is also hoped that the outcome of the research will benefit standardization efforts that can get spawned via IRTF & IETF BoF meetings and/or provide useful input to other related standards efforts in ETSI or other standards bodies.

Areas of Interest
* New network architectures based on virtualized network functions
* Network and service function chaining: architecture and implementation (e.g. automation of service chain building)
* Autonomous service orchestration and optimization
* New operational aspects of network and service virtualization, as well as new operational models required by virtualization
* Infrastructure and service function description and programming (languages, APIs, frameworks for combined processing, network and storage programming)
* Coexistence with non-virtualized infrastructure and services
* Virtualized network economics and business modeling
* Security, trust and service verification
* Real-time big data analytics and data-centric management of virtualized infrastructure
* New application domains enabled by virtualized infrastructure and services
* System wide optimization of compute, storage, network and energy efficiency
* Explore infrastructure and service abstractions enabled by virtualization
* Autonomic and real-time orchestration enabled by network function virtualization
The group will report progress through its wiki and presentations at IETF and IRTF meetings. Relevant information and research developed by the research group will be submitted for publication as Experimental or Informational RFCs.

Near Term Work Items
The group shall focus on a concrete list of near-term work items. For each of the items mentioned below, the goal is to explore system architecture, optimization, and open interfaces across components, through simulations and/or real-world implementations.

Policy based Resource Management:
NFV Point of Presence (PoP) will be likely constrained in compute and storage capacity. Since practically all NFV PoPs are foreseen to be distributed, inter-datacenter network capacity is also a constraint. Additionally, energy is also a constraint, both as a general concern for NFV operators, and in particular for specific-purpose NFV PoPs such as those in mobile base stations. This work item will focus on optimized resource management and workload distribution based on policy.

Analytics for Visibility and Orchestration:
Network functions should be supportable on general purpose commodity hardware. Real-time analytics providing insight into various components such as compute (e.g. dynamic CPU utilization), storage (e.g. dynamic capacity usage), network (e.g. dynamic bandwidth utilization), energy (e.g. dynamic power consumption) are key to not only providing visibility into the NFV infrastructure but also optimizing resource usage for the purposes of orchestration. This work item will contemplate techniques for the applicability of real-time analytics.

Virtual Network Function (VNF) Performance Modeling to facilitate transition to NFV:
While migrating from hardware network appliances, which are typically custom and monolithic, to virtualized software implementations running on commodity hardware a challenge which is often faced is to come up with an equivalence model especially in terms of performance. The work item will consider this modeling.

Security and Service Verification:
NFV configuration is expected to be dynamic especially in the edge NFV PoP where capacity is limited; a very good example is handling a viral event such as mobile gaming application. While autonomic networking techniques could be used to automate the configuration process including modular updates, it is important to take into account that incomplete and/or inconsistent configuration may lead to security issues. Additionally, events such as distributed denial of service (DDoS) attacks could be an additional source of compromise with additional implications due to the dependency of NFV on a distributed infrastructure. Finally, elasticity of VNFs entails dynamic scale up/down/out with awareness of the resiliency considerations, completely different with the approach of monolithic implementations. Security issues and relevant solutions related to the elastic nature of VNFs are the objectives of this work item.

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Tue, 9 Dec 2014 07:44:08 +0000

Hi,

Just for you to know, NFVRG is still under the status of "proposed RG" in the IRTF. To move into a stable RG status we need to agree in a charter, and to do so the IRTF requires us to collect explicit feedback from the community.

So please review the text included below (predominantly what we discussed in the meetings so far and in the NFVRG wiki page https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg with minor edits) and make your comments and/or express your explicit support (the usual "+1" would be enough)

Be goode,

8<--

Background

Areas of Interest
• New network architectures based on virtualized network functions
• Network and service function chaining: architecture and implementation (e.g. automation of service chain building)
• Autonomous service orchestration and optimization
• New operational aspects of network and service virtualization, as well as new operational models required by virtualization
• Infrastructure and service function description and programming (languages, APIs, frameworks for combined processing, network and storage programming)
• Coexistence with non-virtualized infrastructure and services
• Virtualized network economics and business modeling
• Security, trust and service verification
• Real-time big data analytics and data-centric management of virtualized infrastructure
• New application domains enabled by virtualized infrastructure and services
• System wide optimization of compute, storage, network and energy efficiency
• Explore infrastructure and service abstractions enabled by virtualization
• Autonomic and real-time orchestration enabled by network function virtualization
The group will report progress through its wiki and presentations at IETF and IRTF meetings. Relevant information and research developed by the research group will be submitted for publication as Experimental or Informational RFCs.

Near Term Work Items

--
PLEASE NOTE MY NEW EMAIL ADDRESS
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Tue, 09 Dec 2014 09:21:34 +0100

Hi Diego,

I support the current charter proposal.

As a suggestion/comment from my side, I'm wondering if we could add to
the areas of interest the following:

· NFV mobility (intra and inter-cloud mobility of VNFs).

Thanks,

Carlos

On Tue, 2014-12-09 at 07:44 +0000, DIEGO LOPEZ GARCIA wrote:
> Hi, 
> 
> 
> Just for you to know, NFVRG is still under the status of "proposed RG"
> in the IRTF. To move into a stable RG status we need to agree in a
> charter, and to do so the IRTF requires us to collect explicit
> feedback from the community. 
> 
> 
> So please review the text included below (predominantly what we
> discussed in the meetings so far and in the NFVRG wiki page
> https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg with minor
> edits) and make your comments and/or express your explicit support
> (the usual "+1" would be enough)
> 
> 
> Be goode,
> 
> 
> 8<--
> 
> Network Function Virtualization is a key emerging area for network
> operators, hardware and software vendors, cloud service providers, and
> in general network practitioners and researchers. This area requires
> exploring new directions and working collaboratively on how to create
> network services that utilize a virtualized infrastructure. Network
> functions that are traditionally implemented in dedicated hardware
> appliances will need to be decomposed and executed in software
> elements running on cloud-based infrastructures. One essential goal of
> this new approach is to reduce capital and operating expenditures for
> future deployments for networks and associated services. Another
> important goal is for the network operators to be able to offer value
> added cloud services to their customers. Finally, new business models
> will open for the provision of network services.
>  
> The technologies enabling the virtualization of network functions are
> currently in an early stage, and they need researchers to develop new
> architectures, systems, and software, and to explore tradeoffs and
> possibilities for leveraging virtualized infrastructure to provide
> support for network functions. The Network Functions Virtualization
> Research Group (NFVRG) will bring together researchers and grow the
> community around the world in both academia and industry to explore
> this new research area. Beyond the direct activity through the IRTF
> collaboration tools it will organize research group meetings and
> workshops at premier conferences (such as IEEE ICC, IEEE Globecom) and
> inviting special issues in well-known journals. 
>  
> The NFVRG will focus on research problems associated with NFV-related
> topics and on bringing a research community together that can jointly
> address them, concentrating on problems that relate not just to
> networking but also to computing and storage constraints in such
> environments. It is also hoped that the outcome of the research will
> benefit standardization efforts that can get spawned via IRTF & IETF
> BoF meetings and/or provide useful input to other related standards
> efforts in ETSI or other standards bodies.
>  
> Areas of Interest
> • Network and service function chaining: architecture and
> implementation (e.g. automation of service chain building)
> • New operational aspects of network and service virtualization, as
> well as new operational models required by virtualization
> • Infrastructure and service function description and programming
> (languages, APIs, frameworks for combined processing, network and
> storage programming)
> The group will report progress through its wiki and presentations at
> IETF and IRTF meetings. Relevant information and research developed by
> the research group will be submitted for publication as Experimental
> or Informational RFCs.
>  
> Near Term Work Items
> The group shall focus on a concrete list of near-term work items. For
> each of the items mentioned below, the goal is to explore system
> architecture, optimization, and open interfaces across components,
> through simulations and/or real-world implementations.
>  
> NFV Point of Presence (PoP) will be likely constrained in compute and
> storage capacity. Since practically all NFV PoPs are foreseen to be
> distributed, inter-datacenter network capacity is also a constraint.
> Additionally, energy is also a constraint, both as a general concern
> for NFV operators, and in particular for specific-purpose
> NFV PoPs such as those in mobile base stations. This work item will
> focus on optimized resource management and workload distribution based
> on policy.
>  
> Network functions should be supportable on general purpose commodity
> hardware. Real-time analytics providing insight into various
> components such as compute (e.g. dynamic CPU utilization), storage
> (e.g. dynamic capacity usage), network (e.g. dynamic bandwidth
> utilization), energy (e.g. dynamic power consumption) are key to not
> only providing visibility into the NFV infrastructure but also
> optimizing resource usage for the purposes of orchestration. This work
> item will contemplate techniques for the applicability of real-time
> analytics.
>  
> While migrating from hardware network appliances, which are typically
> custom and monolithic, to virtualized software implementations running
> on commodity hardware a challenge which is often faced is to come up
> with an equivalence model especially in terms of performance. The work
> item will consider this modeling.
>  
> NFV configuration is expected to be dynamic especially in the edge
> NFV PoP where capacity is limited; a very good example is handling a
> viral event such as mobile gaming application. While autonomic
> networking techniques could be used to automate the configuration
> process including modular updates, it is important to take into
> account that incomplete and/or inconsistent configuration may lead to
> security issues. Additionally, events such as distributed denial of
> service (DDoS) attacks could be an additional source of compromise
> with additional implications due to the dependency of NFV on a
> distributed infrastructure. Finally, elasticity of VNFs entails
> dynamic scale up/down/out with awareness of the resiliency
> considerations, completely different with the approach of monolithic
> implementations. Security issues and relevant solutions related to the
> elastic nature of VNFs are the objectives of this work item.
> 
> --
> ______________________________________________________________________
> 
> Este mensaje y sus adjuntos se dirigen exclusivamente a su
> destinatario, puede contener información privilegiada o confidencial y
> es para uso exclusivo de la persona o entidad de destino. Si no es
> usted. el destinatario indicado, queda notificado de que la lectura,
> utilización, divulgación y/o copia sin autorización puede estar
> prohibida en virtud de la legislación vigente. Si ha recibido este
> mensaje por error, le rogamos que nos lo comunique inmediatamente por
> esta misma vía y proceda a su destrucción.
> 
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual
> or entity named above. If the reader of this message is not the
> intended recipient, you are hereby notified that any dissemination,
> distribution or copying of this communication is strictly prohibited.
> If you have received this transmission in error, do not read it.
> Please immediately reply to the sender that you have received this
> communication in error and then delete it.
> 
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida
> em virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição
> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 9 Dec 2014 20:17:47 +0000

Hi,

   It looks good +1. I hope it is not too late now but I have added some comments/suggestions (see attached). Not sure if some of those were already discussed/decided upon.

Best regards,

Meral

Ericsson research

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Monday, December 08, 2014 11:44 PM
To: [email-masked]
Subject: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

  _____

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 9 Dec 2014 22:11:21 +0000

Diego,

It is a good charter proposal. I support it.

Your second bullet is about Service Chaining. Is it something that is covered by SFC WG or beyond what SFC is currently chartered to do?

Thanks, Linda

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Tuesday, December 09, 2014 1:44 AM
To: [email-masked]
Subject: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

---

From: 이승익 <[email-masked]>
Date: Wed, 10 Dec 2014 00:03:53 +0000

Diego,

+1.
It looks good as it is.

Seung-Ik

2014. 12. 9., 오후 4:44, DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>> 작성:

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

---

From: XILOURIS George <[email-masked]>
Date: Tue, 9 Dec 2014 18:12:34 -0600

Dear Diego, 

The text seems fine to me, +1 :-) 

George.

--
Georgios K. Xilouris
Research Associate
Institute of Informatics and Telecommunications,
N.C.S.R  "Demokritos", Digital Communications Lab.
15310, Agia Paraskevi, Greece

phone: + (30) 210 650 31 08
fax:     + (30) 210 653 21 75
http://medianetlab.gr/~xilouris <http://dtlab.iit.demokritos.gr/~xilouris>

> On Dec 9, 2014, at 6:03 PM, 이승익 <[email-masked]> wrote:
> 
> Diego,
> 
> +1.
> It looks good as it is.
> 
> Seung-Ik
> 
> 
>> 2014. 12. 9., 오후 4:44, DIEGO LOPEZ GARCIA <[email-masked] <mailto:[email-masked]>> 작성:
>> 
>> Hi,
>> 
>> So please review the text included below (predominantly what we discussed in the meetings so far and in the NFVRG wiki pagehttps://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg <https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg> with minor edits) and make your comments and/or express your explicit support (the usual "+1" would be enough)
>> 
>> Be goode,
>> 
>> 8<--
>> 
>> http://people.tid.es/diego.lopez/ <http://people.tid.es/diego.lopez/>
>> 
>> e-mail: [email-masked] <mailto:[email-masked]>
>> Tel:    +34 913 129 041
>> Mobile: +34 682 051 091
>> [email-masked] <mailto:[email-masked]>

---

From: Ramki Krishnan <[email-masked]>
Date: Wed, 10 Dec 2014 05:37:49 +0000

Hi Linda,

Good question. NFVRG would be examining service chaining at an orchestration level whereas the SFC work is at the controller level.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Tuesday, December 09, 2014 2:11 PM
To: DIEGO LOPEZ GARCIA; [email-masked]
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Diego,

Thanks, Linda

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Tuesday, December 09, 2014 1:44 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

---

From: "Saurabh Chattopadhyay - ERS, HCL Tech" <[email-masked]>
Date: Wed, 10 Dec 2014 06:19:26 +0000

+1

Regards,
Saurabh

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Tuesday, December 09, 2014 1:14 PM
To: [email-masked]
Subject: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

::DISCLAIMER::
----------------------------------------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
E-mail transmission is not guaranteed to be secure or error-free as information could be intercepted, corrupted,
lost, destroyed, arrive late or incomplete, or may contain viruses in transmission. The e mail and its contents
(with or without referred errors) shall therefore not attach any liability on the originator or HCL or its affiliates.
Views or opinions, if any, presented in this email are solely those of the author and may not necessarily reflect the
views or opinions of HCL or its affiliates. Any form of reproduction, dissemination, copying, disclosure, modification,
distribution and / or publication of this message without the prior written consent of authorized representative of
HCL is strictly prohibited. If you have received this email in error please delete it and notify the sender immediately.
Before opening any email and/or attachments, please check them for viruses and other defects.

----------------------------------------------------------------------------------------------------------------------------------------------------

---

From: "King, Daniel" <[email-masked]>
Date: Wed, 10 Dec 2014 12:28:31 +0000

Hi Diego, all. 

Overall, a good set of objectives for the NFV RG research charter. However, there seems to be a lack of charter text identifying that future NFV-based networks and services will need to be "reliable".  Ensuring resilient services, and therefore  functions (Virtual network Functions - VNFs), should be a key design goal. In the event of failure within NFV-based network environments there should be minimal, or no, effect on service availability and functionality. Reliable NFV design goals and potential solutions will require research and investigation as they impact NFV architecture, components, optimization, and interfaces. To be fair, "resiliency" is mentioned in the sub-section pertaining to "Security and Service Verification":

"Finally, elasticity of VNFs entails dynamic scale up/down/out with awareness of the resiliency considerations, completely different with the approach of monolithic implementations."

Nevertheless, I do not think this outlines the importance and potential challenges associated with building and operating reliable NFV-based networks and services. My suggestion would be to augment the current charter text with:

1. An additional bullet appended to "Areas of Interest"

o Requirements and mechanisms to ensure reliable virtual network functions and services

2. Adding a reliability objective to "Near Term Work items":

Reliability and Redundancy 
 
Virtual network functions will be used to host network infrastructure and services; this introduces additional challenges to ensure this new network supports carrier grade reliability with suitable redundancy mechanisms. In the event of network and/or service degradation or failure, there must be suitable coordination, fail-over, and recovery. Notification and interaction may also need to occur between VNFs and the VNF orchestrator, the general purpose hardware hosting VNFs, and underlying network protection mechanisms. These reliable NFV mechanisms will also need tools and mechanisms to deploy and manage capability, and close coordination with NFV resource management and performance analytics is also expected.

BR, Dan.

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: 09 December 2014 07:44
To: [email-masked]
Subject: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi, 

Be goode,

8<--

Background

 
Areas of Interest
. New network architectures based on virtualized network functions
. Network and service function chaining: architecture and implementation (e.g. automation of service chain building)
. Autonomous service orchestration and optimization
. New operational aspects of network and service virtualization, as well as new operational models required by virtualization
. Infrastructure and service function description and programming (languages, APIs, frameworks for combined processing, network and storage programming)
. Coexistence with non-virtualized infrastructure and services
. Virtualized network economics and business modeling
. Security, trust and service verification
. Real-time big data analytics and data-centric management of virtualized infrastructure
. New application domains enabled by virtualized infrastructure and services
. System wide optimization of compute, storage, network and energy efficiency
. Explore infrastructure and service abstractions enabled by virtualization
. Autonomic and real-time orchestration enabled by network function virtualization
The group will report progress through its wiki and presentations at IETF and IRTF meetings. Relevant information and research developed by the research group will be submitted for publication as Experimental or Informational RFCs.
 
Near Term Work Items

 

Dr Diego R. Lopez
Telefonica I+D

________________________________________

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 10 Dec 2014 08:31:09 -0500

Hi Dan,

Any Reliability/Resiliency work in NFVRG would need to be coordinated
with efforts completing and "re-chartered to do more" in ETSI NFV.
For example, if the REL wg has identified an area for research,
it could be a specific item here (if there is support). At least,
the REL phase 1 output doc is available to all.

regards,
Al

> -----Original Message-----
> From: Nfvrg [mailto:[email-masked]] On Behalf Of King, Daniel
> Sent: Wednesday, December 10, 2014 7:29 AM
> To: DIEGO LOPEZ GARCIA
> Cc: [email-masked]
> Overall, a good set of objectives for the NFV RG research charter.
> However, there seems to be a lack of charter text identifying that future
> NFV-based networks and services will need to be "reliable".  Ensuring
> resilient services, and therefore  functions (Virtual network Functions -
> VNFs), should be a key design goal. In the event of failure within NFV-
> based network environments there should be minimal, or no, effect on
> service availability and functionality. Reliable NFV design goals and
> potential solutions will require research and investigation as they impact
> NFV architecture, components, optimization, and interfaces. To be fair,
> "resiliency" is mentioned in the sub-section pertaining to "Security and
> Service Verification":
> 
> "Finally, elasticity of VNFs entails dynamic scale up/down/out with
> awareness of the resiliency considerations, completely different with the
> approach of monolithic implementations."
> 
> Nevertheless, I do not think this outlines the importance and potential
> challenges associated with building and operating reliable NFV-based
> networks and services. My suggestion would be to augment the current
> charter text with:
> 
> Virtual network functions will be used to host network infrastructure and
> services; this introduces additional challenges to ensure this new network
> supports carrier grade reliability with suitable redundancy mechanisms. In
> the event of network and/or service degradation or failure, there must be
> suitable coordination, fail-over, and recovery. Notification and
> interaction may also need to occur between VNFs and the VNF orchestrator,
> the general purpose hardware hosting VNFs, and underlying network
> protection mechanisms. These reliable NFV mechanisms will also need tools
> and mechanisms to deploy and manage capability, and close coordination
> with NFV resource management and performance analytics is also expected.
> 
> BR, Dan.
> 
> Just for you to know, NFVRG is still under the status of "proposed RG" in
> the IRTF. To move into a stable RG status we need to agree in a charter,
> and to do so the IRTF requires us to collect explicit feedback from the
> community.
> 
> So please review the text included below (predominantly what we discussed
> in the meetings so far and in the NFVRG wiki page
> https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg with minor edits)
> and make your comments and/or express your explicit support (the usual
> "+1" would be enough)
> 
> Be goode,
> 
> 8<--
> 
> operators, hardware and software vendors, cloud service providers, and in
> general network practitioners and researchers. This area requires
> appliances will need to be decomposed and executed in software elements
> running on cloud-based infrastructures. One essential goal of this new
> approach is to reduce capital and operating expenditures for future
> deployments for networks and associated services. Another important goal
> is for the network operators to be able to offer value added cloud
> services to their customers. Finally, new business models will open for
> the provision of network services.
> 
> possibilities for leveraging virtualized infrastructure to provide support
> for network functions. The Network Functions Virtualization Research Group
> (NFVRG) will bring together researchers and grow the community around the
> world in both academia and industry to explore this new research area.
> Beyond the direct activity through the IRTF collaboration tools it will
> organize research group meetings and workshops at premier conferences
> (such as IEEE ICC, IEEE Globecom) and inviting special issues in well-
> known journals.
> 
> address them, concentrating on problems that relate not just to networking
> but also to computing and storage constraints in such environments. It is
> also hoped that the outcome of the research will benefit standardization
> efforts that can get spawned via IRTF & IETF BoF meetings and/or provide
> useful input to other related standards efforts in ETSI or other standards
> bodies.
> 
> Areas of Interest
> . Network and service function chaining: architecture and implementation
> (e.g. automation of service chain building)
> . New operational aspects of network and service virtualization, as well
> as new operational models required by virtualization
> . Infrastructure and service function description and programming
> (languages, APIs, frameworks for combined processing, network and storage
> programming)
> The group will report progress through its wiki and presentations at IETF
> and IRTF meetings. Relevant information and research developed by the
> research group will be submitted for publication as Experimental or
> Informational RFCs.
> 
> Near Term Work Items
> The group shall focus on a concrete list of near-term work items. For each
> of the items mentioned below, the goal is to explore system architecture,
> optimization, and open interfaces across components, through simulations
> and/or real-world implementations.
> 
> Additionally, energy is also a constraint, both as a general concern for
> NFV operators, and in particular for specific-purpose NFV PoPs such as
> those in mobile base stations. This work item will focus on optimized
> resource management and workload distribution based on policy.
> 
> hardware. Real-time analytics providing insight into various components
> such as compute (e.g. dynamic CPU utilization), storage (e.g. dynamic
> capacity usage), network (e.g. dynamic bandwidth utilization), energy
> (e.g. dynamic power consumption) are key to not only providing visibility
> into the NFV infrastructure but also optimizing resource usage for the
> purposes of orchestration. This work item will contemplate techniques for
> the applicability of real-time analytics.
> 
> custom and monolithic, to virtualized software implementations running on
> commodity hardware a challenge which is often faced is to come up with an
> equivalence model especially in terms of performance. The work item will
> consider this modeling.
> 
> NFV PoP where capacity is limited; a very good example is handling a viral
> event such as mobile gaming application. While autonomic networking
> techniques could be used to automate the configuration process including
> modular updates, it is important to take into account that incomplete
> and/or inconsistent configuration may lead to security issues.
> Additionally, events such as distributed denial of service (DDoS) attacks
> could be an additional source of compromise with additional implications
> due to the dependency of NFV on a distributed infrastructure. Finally,
> elasticity of VNFs entails dynamic scale up/down/out with awareness of the
> resiliency considerations, completely different with the approach of
> monolithic implementations. Security issues and relevant solutions related
> to the elastic nature of VNFs are the objectives of this work item.
> 
> --
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
> 
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to
> the sender that you have received this communication in error and then
> delete it.
> 
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação
> vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o
> comunique imediatamente por esta mesma via e proceda a sua destruição
>

---

From: "King, Daniel" <[email-masked]>
Date: Wed, 10 Dec 2014 13:55:10 +0000

Hi Al, 

Agree. It's good to have research objectives, use cases and requirements resulting from documents and discussion from other SDOs, especially (but not limited to) ETSI for NFV. Indeed research and development would benefit from being synchronized. It might also be useful to underline this relationship with the ETSI NFV Industry Steering Group (ISG) in the NFV RG charter text, or it might be enough to cite the ETSI ISG or specific ETSI ISG documents in any subsequent IRTF I-Ds. 

However, we are not stating that IRTF NFV research be solely dependent on ETSI? There are already a number of ETSI documents available that identify reliability/resiliency/continuity/redundancy objectives and requirements, and these are available to all. Unfortunately other key documents are not (unless you are an ETSI member or ETSI ISG participant) accessible until they reach sufficient maturity and/or "released" to the wider industry. 

BR, Dan. 

-----Original Message-----
From: Nfvrg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: 10 December 2014 13:31
To: King, Daniel; DIEGO LOPEZ GARCIA
Cc: [email-masked]
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi Dan,

Any Reliability/Resiliency work in NFVRG would need to be coordinated with efforts completing and "re-chartered to do more" in ETSI NFV.
For example, if the REL wg has identified an area for research, it could be a specific item here (if there is support). At least, the REL phase 1 output doc is available to all.

regards,
Al

> However, there seems to be a lack of charter text identifying that 
> future NFV-based networks and services will need to be "reliable".  
> Ensuring resilient services, and therefore  functions (Virtual network 
> Functions - VNFs), should be a key design goal. In the event of 
> failure within NFV- based network environments there should be 
> minimal, or no, effect on service availability and functionality. 
> Reliable NFV design goals and potential solutions will require 
> research and investigation as they impact NFV architecture, 
> components, optimization, and interfaces. To be fair, "resiliency" is 
> mentioned in the sub-section pertaining to "Security and Service Verification":
> 
> awareness of the resiliency considerations, completely different with 
> the approach of monolithic implementations."
> 
> Nevertheless, I do not think this outlines the importance and 
> potential challenges associated with building and operating reliable 
> NFV-based networks and services. My suggestion would be to augment the 
> current charter text with:
> 
> Virtual network functions will be used to host network infrastructure 
> and services; this introduces additional challenges to ensure this new 
> network supports carrier grade reliability with suitable redundancy 
> mechanisms. In the event of network and/or service degradation or 
> failure, there must be suitable coordination, fail-over, and recovery. 
> Notification and interaction may also need to occur between VNFs and 
> the VNF orchestrator, the general purpose hardware hosting VNFs, and 
> underlying network protection mechanisms. These reliable NFV 
> mechanisms will also need tools and mechanisms to deploy and manage 
> capability, and close coordination with NFV resource management and performance analytics is also expected.
> 
> BR, Dan.
> 
> Research Group
> (NFVRG) will bring together researchers and grow the community around 
> the world in both academia and industry to explore this new research area.
> Beyond the direct activity through the IRTF collaboration tools it 
> will organize research group meetings and workshops at premier 
> conferences (such as IEEE ICC, IEEE Globecom) and inviting special 
> issues in well- known journals.
> 
> . New network architectures based on virtualized network functions . 
> Network and service function chaining: architecture and implementation 
> (e.g. automation of service chain building) . Autonomous service 
> orchestration and optimization . New operational aspects of network 
> and service virtualization, as well as new operational models required 
> by virtualization . Infrastructure and service function description 
> and programming (languages, APIs, frameworks for combined processing, 
> network and storage
> programming)
> . Coexistence with non-virtualized infrastructure and services . 
> Virtualized network economics and business modeling . Security, trust 
> and service verification . Real-time big data analytics and 
> data-centric management of virtualized infrastructure . New 
> application domains enabled by virtualized infrastructure and services 
> . System wide optimization of compute, storage, network and energy 
> efficiency . Explore infrastructure and service abstractions enabled 
> by virtualization . Autonomic and real-time orchestration enabled by 
> network function virtualization The group will report progress through 
> its wiki and presentations at IETF and IRTF meetings. Relevant 
> information and research developed by the research group will be 
> submitted for publication as Experimental or Informational RFCs.
> 
> Near Term Work Items
> for NFV operators, and in particular for specific-purpose NFV PoPs 
> such as those in mobile base stations. This work item will focus on 
> optimized resource management and workload distribution based on policy.
> 
> item will contemplate techniques for the applicability of real-time analytics.
> 
> NFV configuration is expected to be dynamic especially in the edge NFV 
> PoP where capacity is limited; a very good example is handling a viral 
> techniques could be used to automate the configuration process 
> including modular updates, it is important to take into account that 
> incomplete and/or inconsistent configuration may lead to security issues.
> Additionally, events such as distributed denial of service (DDoS) 
> attacks could be an additional source of compromise with additional 
> implications due to the dependency of NFV on a distributed 
> infrastructure. Finally, elasticity of VNFs entails dynamic scale 
> up/down/out with awareness of the resiliency considerations, 
> completely different with the approach of monolithic implementations. 
> Security issues and relevant solutions related to the elastic nature of VNFs are the objectives of this work item.
> 
> --

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 10 Dec 2014 09:01:56 -0500

...
> and these are available to all. Unfortunately other key documents are not
> (unless you are an ETSI member or ETSI ISG participant) accessible until
> they reach sufficient maturity and/or "released" to the wider industry.
>
> BR, Dan.

Since it's the "Dawn of Phase 2", all that's missing from planning here are
the terms of reference for the new REL and other WGs. Perhaps that can be
fixed by liaison if needed, since the terms of reference are now approved, AFAIK.

Al

> From: King, Daniel [mailto:[email-masked]]
> Sent: Wednesday, December 10, 2014 8:55 AM
> To: MORTON, ALFRED C (AL); DIEGO LOPEZ GARCIA
> Cc: [email-masked]
> Subject: RE: We need your feedback on the NFVRG proposed charter
>
> Hi Al,
>
> Agree. It's good to have research objectives, use cases and requirements
> resulting from documents and discussion from other SDOs, especially (but
> not limited to) ETSI for NFV. Indeed research and development would
> benefit from being synchronized. It might also be useful to underline this
> relationship with the ETSI NFV Industry Steering Group (ISG) in the NFV RG
> charter text, or it might be enough to cite the ETSI ISG or specific ETSI
> ISG documents in any subsequent IRTF I-Ds.
>
> However, we are not stating that IRTF NFV research be solely dependent on
> ETSI? There are already a number of ETSI documents available that identify
> reliability/resiliency/continuity/redundancy objectives and requirements,
> and these are available to all. Unfortunately other key documents are not
> (unless you are an ETSI member or ETSI ISG participant) accessible until
> they reach sufficient maturity and/or "released" to the wider industry.
>
> BR, Dan.
>
> Any Reliability/Resiliency work in NFVRG would need to be coordinated with
> efforts completing and "re-chartered to do more" in ETSI NFV.
> For example, if the REL wg has identified an area for research, it could
> be a specific item here (if there is support). At least, the REL phase 1
> output doc is available to all.
>
> regards,
> Al
>
> > Security issues and relevant solutions related to the elastic nature of
> VNFs are the objectives of this work item.
> >
> > --

---

From: <[email-masked]>
Date: Wed, 10 Dec 2014 14:21:34 +0000

w.r.t reliability, I think we need to be a bit more specific about the aspects on which NFVRG is expected to bring value.  NFVRG should focus on aspects that are not already on the specification work plan of ETSI or another standardization body.

For example, rather than adding " Reliability and Redundancy" as a general item, we could add "Failure characterization/representation and impact on reliability and availability".

I'll provide a couple of additional comments by the end of this week.

Bruno 

> -----Message d'origine-----
> De : Nfvrg [mailto:[email-masked]] De la part de King, Daniel
> Envoyé : mercredi 10 décembre 2014 14:55
> À : MORTON, ALFRED C (AL); DIEGO LOPEZ GARCIA
> Cc : [email-masked]
> Objet : Re: [Nfvrg] We need your feedback on the NFVRG proposed charter
> 
> Hi Al,
> 
> resulting from documents and discussion from other SDOs, especially (but not
> limited to) ETSI for NFV. Indeed research and development would benefit from
> being synchronized. It might also be useful to underline this relationship with the
> ETSI NFV Industry Steering Group (ISG) in the NFV RG charter text, or it might be
> enough to cite the ETSI ISG or specific ETSI ISG documents in any subsequent
> IRTF I-Ds.
> 
> reliability/resiliency/continuity/redundancy objectives and requirements, and
> these are available to all. Unfortunately other key documents are not (unless
> you are an ETSI member or ETSI ISG participant) accessible until they reach
> sufficient maturity and/or "released" to the wider industry.
> 
> BR, Dan.
> 
> For example, if the REL wg has identified an area for research, it could be a
> specific item here (if there is support). At least, the REL phase 1 output doc is
> available to all.
> 
> regards,
> Al
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: XILOURIS George <[email-masked]>
Date: Wed, 10 Dec 2014 11:44:31 -0600

Dear Ramki, 

In to my mind the term SFC does make sense at the Orchestration level where the actual Service context is known by the Orchestrator. In the controller level however SFC seems to be more specific to the methods to establish the chaining at the network and service function level. What essentially is done at the controller level is to steer traffic according to the policies established by the SFC @ Orchestration. The exact context or purpose or essentially the Service that is realised by the applied traffic redirections/tunneling etc might not be known to the controller. 

A good idea would be to use an  explicit term to differentiate among SFC at different layers. It seems that our boundaries with SFC WG are the from the 5th point (Manageability) of its charter description and beyond. 

Then again chances are that I have  gaps in my view. :-) 

Best Regards 
George

> On Dec 9, 2014, at 11:37 PM, Ramki Krishnan <[email-masked]> wrote:
> 
> Hi Linda,
>  
> From: Nfvrg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Linda Dunbar
> To: DIEGO LOPEZ GARCIA; [email-masked] <mailto:[email-masked]>
> From: Nfvrg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of DIEGO LOPEZ GARCIA
> To: [email-masked] <mailto:[email-masked]>
> So please review the text included below (predominantly what we discussed in the meetings so far and in the NFVRG wiki page https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg <https://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg> with minor edits) and make your comments and/or express your explicit support (the usual "+1" would be enough)
>  
> Be goode,
>  
> 8<--
>  
> https://www.irtf.org/mailman/listinfo/nfvrg <https://www.irtf.org/mailman/listinfo/nfvrg>

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 11 Dec 2014 04:03:00 +0000

Hi Bruno,
I'd note that defect characterization and defect correlation, at least in part of related informational model(s), is, as I believe, in scope of the LIME WG. Input from NFVRG on that subject and broader role of defect detection, localization will be helpful as LIME WG recently formed the Design Team with the first item of charter as:
	- YANG data model(s) for generic layer-independent and technology-independent configuration, reporting and presentation for OAM mechanisms.

	Regards,
		Greg

-----Original Message-----
From: Nfvrg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 10, 2014 10:22 PM
To: King, Daniel; MORTON, ALFRED C (AL); DIEGO LOPEZ GARCIA
Cc: [email-masked]
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Bruno 

> Envoyé : mercredi 10 décembre 2014 14:55 À : MORTON, ALFRED C (AL); 
> DIEGO LOPEZ GARCIA Cc : [email-masked] Objet : Re: [Nfvrg] We need 
> your feedback on the NFVRG proposed charter
> 
> Hi Al,
> 
> Agree. It's good to have research objectives, use cases and 
> requirements resulting from documents and discussion from other SDOs, 
> especially (but not limited to) ETSI for NFV. Indeed research and 
> development would benefit from being synchronized. It might also be 
> useful to underline this relationship with the ETSI NFV Industry 
> Steering Group (ISG) in the NFV RG charter text, or it might be enough 
> to cite the ETSI ISG or specific ETSI ISG documents in any subsequent IRTF I-Ds.
> 
> However, we are not stating that IRTF NFV research be solely dependent 
> on ETSI? There are already a number of ETSI documents available that 
> identify reliability/resiliency/continuity/redundancy objectives and 
> requirements, and these are available to all. Unfortunately other key 
> documents are not (unless you are an ETSI member or ETSI ISG 
> participant) accessible until they reach sufficient maturity and/or "released" to the wider industry.
> 
> BR, Dan.
> 
> From: Nfvrg [mailto:[email-masked]] On Behalf Of MORTON, 
> ALFRED C
> (AL)
> For example, if the REL wg has identified an area for research, it 
> could be a specific item here (if there is support). At least, the REL 
> phase 1 output doc is available to all.
> 
> regards,
> Al
> 
> > Ensuring resilient services, and therefore  functions (Virtual 
> > network Functions - VNFs), should be a key design goal. In the event 
> > of failure within NFV- based network environments there should be 
> > components, optimization, and interfaces. To be fair, "resiliency" 
> > is mentioned in the sub-section pertaining to "Security and Service Verification":
> >
> > awareness of the resiliency considerations, completely different 
> > with the approach of monolithic implementations."
> >
> > NFV-based networks and services. My suggestion would be to augment 
> > the current charter text with:
> >
> > Virtual network functions will be used to host network 
> > infrastructure and services; this introduces additional challenges 
> > to ensure this new network supports carrier grade reliability with 
> > suitable redundancy mechanisms. In the event of network and/or 
> > service degradation or failure, there must be suitable coordination, fail-over, and recovery.
> > operators, hardware and software vendors, cloud service providers, 
> > and in general network practitioners and researchers. This area 
> > requires exploring new directions and working collaboratively on how 
> > to create network services that utilize a virtualized 
> > infrastructure. Network functions that are traditionally implemented 
> > in dedicated hardware appliances will need to be decomposed and 
> > executed in software elements running on cloud-based 
> > infrastructures. One essential goal of this new approach is to 
> > reduce capital and operating expenditures for future deployments for 
> > networks and associated services. Another important goal is for the 
> > network operators to be able to offer value added cloud services to 
> > their customers. Finally, new business models will open for the provision of network services.
> >
> > The technologies enabling the virtualization of network functions 
> > are currently in an early stage, and they need researchers to 
> > develop new architectures, systems, and software, and to explore 
> > tradeoffs and possibilities for leveraging virtualized 
> > infrastructure to provide support for network functions. The Network 
> > Functions Virtualization Research Group
> > (NFVRG) will bring together researchers and grow the community 
> > around the world in both academia and industry to explore this new research area.
> > The NFVRG will focus on research problems associated with 
> > NFV-related topics and on bringing a research community together 
> > that can jointly address them, concentrating on problems that relate 
> > not just to networking but also to computing and storage constraints 
> > in such environments. It is also hoped that the outcome of the 
> > research will benefit standardization efforts that can get spawned 
> > via IRTF & IETF BoF meetings and/or provide useful input to other 
> > related standards efforts in ETSI or other standards bodies.
> >
> > Areas of Interest
> > Network and service function chaining: architecture and 
> > implementation (e.g. automation of service chain building) . 
> > Autonomous service orchestration and optimization . New operational 
> > aspects of network and service virtualization, as well as new 
> > operational models required by virtualization . Infrastructure and 
> > service function description and programming (languages, APIs, 
> > frameworks for combined processing, network and storage
> > programming)
> > Virtualized network economics and business modeling . Security, 
> > trust and service verification . Real-time big data analytics and 
> > application domains enabled by virtualized infrastructure and 
> > services . System wide optimization of compute, storage, network and 
> > energy efficiency . Explore infrastructure and service abstractions 
> > enabled by virtualization . Autonomic and real-time orchestration 
> > enabled by network function virtualization The group will report 
> > progress through its wiki and presentations at IETF and IRTF 
> > meetings. Relevant information and research developed by the 
> > research group will be submitted for publication as Experimental or Informational RFCs.
> >
> > Near Term Work Items
> > The group shall focus on a concrete list of near-term work items. 
> > For each of the items mentioned below, the goal is to explore system 
> > NFV Point of Presence (PoP) will be likely constrained in compute 
> > and storage capacity. Since practically all NFV PoPs are foreseen to 
> > be distributed, inter-datacenter network capacity is also a constraint.
> > optimizing resource usage for the purposes of orchestration. This 
> > work item will contemplate techniques for the applicability of real-time analytics.
> >
> > While migrating from hardware network appliances, which are 
> > typically custom and monolithic, to virtualized software 
> > implementations running on commodity hardware a challenge which is 
> > often faced is to come up with an equivalence model especially in 
> > terms of performance. The work item will consider this modeling.
> >
> > account that incomplete and/or inconsistent configuration may lead to security issues.
> > Security issues and relevant solutions related to the elastic nature 
> > of VNFs are
> the objectives of this work item.
> >
> > --
> > destinatario, puede contener información privilegiada o confidencial 
> > y es para uso exclusivo de la persona o entidad de destino. Si no es 
> > mensaje por error, le rogamos que nos lo comunique inmediatamente 
> > por esta misma vía y proceda a su destrucción.
> >
> > destinatário, pode conter informação privilegiada ou confidencial e 
> > é para uso exclusivo da pessoa ou entidade de destino. Se não é 
> > vossa senhoria o destinatário indicado, fica notificado de que a 
> > leitura, utilização, divulgação e/ou cópia sem autorização pode 
> > estar proibida em virtude da legislação vigente. Se recebeu esta 
> > mensagem por erro, rogamos-lhe que nos o comunique imediatamente por 
> > esta mesma via e proceda a sua destruição
> >

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 12 Dec 2014 17:07:48 +0000

+1Overall, I support the charter but have a couple of comments:

1/ In areas of Interest,

- add "performance modelling"
- I'm not convinced "Coexistence with non-virtualized infrastructure and services" is an area of interest for a Research Group?
- It is unclear whether different words "autonomous" and "autonomic" were used on purpose for the 3rd and last item.
- In the last item, it is unclear whether we are referring to service orchestration or not. If yes, the difference with the 3rd item is unclear.

2/ The "Security and Service Verification" work item could be extended to cover some reliability challenges (see attachment)

BC

De : Nfvrg [mailto:[email-masked]] De la part de Meral Shirazipour
Envoyé : mardi 9 décembre 2014 21:18
À : [email-masked]
Cc : DIEGO LOPEZ GARCIA
Objet : Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Hi,

Best regards,
Meral
Ericsson research

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

---

From: Ramki Krishnan <[email-masked]>
Date: Sat, 13 Dec 2014 05:05:33 +0000

Dear George,

Great discussion points, please find inline.

Thanks,
Ramki

From: XILOURIS George [mailto:[email-masked]]
Sent: Wednesday, December 10, 2014 9:45 AM
To: Ramki Krishnan
Cc: Linda Dunbar; DIEGO LOPEZ GARCIA; [email-masked]
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Dear Ramki,

>>In to my mind the term SFC does make sense at the Orchestration level where the actual Service context is known by the Orchestrator. In the controller level however SFC seems to be more specific to…

Yes mostly. What we have to keep in mind is that there could be policies in the network controller level and orchestration level. The network controller level policies would be of network scope. For example, a controller level policy could say connect VNFs A,B and C; this policy could be realized by multiple possible overlay/transport technologies. An orchestration level policy is applicable to multiple sub-systems such as compute, network, storage etc.. For example, an orchestration policy could specify that a customer X should be given gold treatment for a given ordered service chain comprising of a set of VNFs. This could map to different policies (thus resultant configurations) in different sub-systems, for example specific server types, HW acceleration etc..

You may have seen a related draft and presentation on the SFC topic “Resource Management for Dynamic Service Chain Adaption” in IETF 91 from Lee, also copying him.
Presentation Link: http://www.ietf.org/proceedings/91/slides/slides-91-nfvrg-0.pptx
Draft Link: https://datatracker.ietf.org/doc/draft-lee-nfvrg-resource-managementservice-chain/

With regard to policy, we have a draft -- https://datatracker.ietf.org/doc/draft-norival-nfvrg-nfv-policy-arch/?include_text=1.

It would be great to continue discussions on these topics.

>>A good idea would be to use an  explicit term to differentiate among SFC at different layers. It seems that our boundaries with SFC WG are the from the 5th point (Manageability) of its charter desc…

Completely agree.

Best Regards
George

On Dec 9, 2014, at 11:37 PM, Ramki Krishnan <[email-masked]<mailto:[email-masked]>> wrote:

Hi Linda,

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Tuesday, December 09, 2014 2:11 PM
To: DIEGO LOPEZ GARCIA; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Diego,

Thanks, Linda

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

---

From: Ramki Krishnan <[email-masked]>
Date: Sat, 13 Dec 2014 05:07:09 +0000

Adding Norival for the policy aspects.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of Ramki Krishnan
Sent: Friday, December 12, 2014 9:06 PM
To: XILOURIS George; 이승익 ([email-masked])
Cc: [email-masked]; DIEGO LOPEZ GARCIA; Linda Dunbar
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Dear George,

Thanks,
Ramki

From: XILOURIS George [mailto:[email-masked]]
Sent: Wednesday, December 10, 2014 9:45 AM
To: Ramki Krishnan
Cc: Linda Dunbar; DIEGO LOPEZ GARCIA; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] We need your feedback on the NFVRG proposed charter

Dear Ramki,

Completely agree.

Best Regards
George

Hi Linda,

Thanks,
Ramki

Diego,

Thanks, Linda

Hi,

Be goode,

8<--

Background

Areas of Interest

Near Term Work Items

Dr Diego R. Lopez
Telefonica I+D

---

From: XILOURIS George <[email-masked]>
Date: Tue, 16 Dec 2014 03:54:14 +0200

Dear Diego, 

Some last minutes proposals and additions for the proposed charter (if not too late): 

1/ Areas of Interest 

The following bullet could be added, (I am aware of at least on project that will work on SDN/NFV over Satellites, as well as there are discussions in EC to push towards this topic in the future calls for research projects) 

- NFV use cases across heterogeneous infrastructures (wired, optical, cellular, satellite)

2/ Near Term Work Items 

I propose to add at the end of the “Security and Service Verification” item the following.This will cover Marketplace aspects strongly related to this particular Work Item. 

"In addition, the envisaged deployment of arbitrary third-party VNF applications on the network infrastructure of the Service Provider raises significant security concerns and poses challenges for VNF verification in terms of functionality, security and stability under well-defined procedures, probably much stricter than the ones involved in the verification of mobile applications published in "App Stores”

Best Regards 
G. 

--
Georgios K. Xilouris
Research Associate
Institute of Informatics and Telecommunications,
N.C.S.R  "Demokritos", MediaNet Lab.
15310, Agia Paraskevi, Greece

> On Dec 10, 2014, at 2:12 AM, XILOURIS George <[email-masked]> wrote:
> 
> Dear Diego, 
> 
>> On Dec 9, 2014, at 6:03 PM, 이승익 <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Diego,
>> 
>> +1.
>> It looks good as it is.
>> 
>> Seung-Ik
>> 
>>